Subject: [COSE] Two nits on cert "compression"

From: Carsten Bormann <[email-masked]>
Date: Mon, 16 Nov 2020 08:09:50 +0100

(1) I hope when we adopt this we can get rid of the “compress” in the file name.

(2) While bignum support is not universal, support for DER-encoded large integers is even less so.  What you want is ~biguint, which is an unwrapped unsigned (non-negative) integer represented as a byte string.  (So not a lot of change, except no weird encoding exceptions for DER sign bits.)

Grüße, Carsten

---

From: John Mattsson <[email-masked]>
Date: Mon, 16 Nov 2020 07:25:17 +0000

(1) Agree, we should change that as well. We just changed the title, let's change the file name in the future.

(2). That sounds like a good idea. If I understand you correctly, this would only be a change to the CDDL. My understanding is that we are otherwise already doing "unwrapped biguint ~biguint" without DER sign bits. 

John

-----Original Message-----
From: COSE <[email-masked]> on behalf of Carsten Bormann <[email-masked]>
Date: Monday, 16 November 2020 at 08:10
To: cose <[email-masked]>
Subject: [COSE] Two nits on cert "compression"

Grüße, Carsten

_______________________________________________
COSE mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cose