Subject: Re: [COSE] Proposed charter update

From: Göran Selander <[email-masked]>
Date: Wed, 16 Dec 2020 17:28:58 +0000

All,

Here is a PR reflecting the change proposed below:
https://github.com/cose-wg/Charter/pull/7

The changes are in the two first sentences, and “native COSE certificate encoding” is changed to “natively signed CBOR certificate encoding”

OLD

A CBOR encoding of the compressed certificate profile defined in RFC 7925. It is expected that the compression works with a large subset of RFC 7925 and takes into consideration any updates in draft-ietf-uta-tls13-iot-profile-00. The compression may also include other important IoT certificate profiles like IEEE 802.1AR. The main objective is to define a method of compressing current X.509 certificates that meet a specific profile into a smaller format. This compression algorithm is loss-less so they can be expanded and normal X.509 certificate processing used. The data structures used to encode such compressed X.509 certificates are expected to produce a compact encoding for certificate information, and are not necessarily tied specifically to X.509 certificates. Accordingly, a secondary objective is to reuse these data structures to produce a native COSE certificate encoding; such a structure is relevant in situations where DER parsing and the compression/decompression machinery to convert between CBOR and DER encodings are unnecessary overhead, such as embedded implementations. The possibility of a joint certificate artifact, conveyed in CBOR encoding but including signatures over both the CBOR and DER encodings, may be explored. This work will be based on draft-mattsson-cose-cbor-cert-compress. The working group will collaborate and coordinate with other IETF WGs such as TLS, UTA, LAKE to understand and validate the requirements and solution.

NEW

A CBOR encoding of the certificate profile defined in RFC 5280. It is expected that the compression works with RFC 7925 and takes into consideration any updates in draft-ietf-uta-tls13-iot-profile-00. The compression may also include other important IoT certificate profiles like IEEE 802.1AR. The main objective is to define a method of compressing current X.509 certificates that meet a specific profile into a smaller format. This compression algorithm is loss-less so they can be expanded and normal X.509 certificate processing used. The data structures used to encode such compressed X.509 certificates are expected to produce a compact encoding for certificate information, and are not necessarily tied specifically to X.509 certificates. Accordingly, a secondary objective is to reuse these data structures to produce a natively signed CBOR certificate encoding; such a structure is relevant in situations where DER parsing and the compression/decompression machinery to convert between CBOR and DER encodings are unnecessary overhead, such as embedded implementations. The possibility of a joint certificate artifact, conveyed in CBOR encoding but including signatures over both the CBOR and DER encodings, may be explored. This work will be based on draft-mattsson-cose-cbor-cert-compress. The working group will collaborate and coordinate with other IETF WGs such as TLS, UTA, LAKE to understand and validate the requirements and solution.

Göran

---

From: Russ Housley <[email-masked]>
Date: Wed, 16 Dec 2020 13:09:19 -0500

Seems reasonable to me.

Russ

> On Dec 16, 2020, at 12:28 PM, Göran Selander <goran.selander=[email-masked]> wrote:
> 
> All,
> 
> https://github.com/cose-wg/Charter/pull/7 <https://github.com/cose-wg/Charter/pull/7>
> 
> _______________________________________________
> COSE mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/cose <https://www.ietf.org/mailman/listinfo/cose>