Subject: [COSE] COSE content-type (generic header 3)

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Feb 2021 22:11:57 +0100

draft-ietf-cose-rfc8152bis-struct-15.txt defines a generic header 3, which is either a media-type-name [1] or a content-format number.
Table 3 on page 17 says this is text string or unsigned integer.
The CDDL snippet following the table at the start of page 18 says

       ? 3 => tstr / int,  ; content type

I think this should be uint, not int.

I also would like to be able to use Content-Type [1] or preferably even Content—Format-String [2] for the text string (we already can use Content-Format numbers for the uint).

Is this a clarification we can/should do at this stage?

Grüße, Carsten

[1]: https://www.ietf.org/archive/id/draft-bormann-core-media-content-type-format-02.html#name-content-type
[2]: https://www.ietf.org/archive/id/draft-bormann-core-media-content-type-format-02.html#name-content-format

BTW, the plan for this draft is to update and resubmit it before IETF110 and then ask for DISPATCH.

---

From: Laurence Lundblade <[email-masked]>
Date: Thu, 18 Feb 2021 10:10:54 -0700

This is a CoAP content ID, right? Seems like RFC 7252 restricts these to 0-65535, so yes, uint.

LL

> On Feb 17, 2021, at 2:11 PM, Carsten Bormann <[email-masked]> wrote:
> 
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose