Subject: [COSE] [Editorial Errata Reported] RFC8152 (6487)

From: RFC Errata System <[email-masked]>
Date: Thu, 18 Mar 2021 07:31:11 -0700 (PDT)

The following errata report has been submitted for RFC8152,
"CBOR Object Signing and Encryption (COSE)".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6487

--------------------------------------
Type: Editorial
Reported by: Thomas Fossati <[email-masked]>

Section: C.7

Original Text
-------------
In order the keys are:

   o  An EC key with a kid of "[email-masked]"

   o  An EC key with a kid of "[email-masked]"

   o  An EC key with a kid of "[email-masked]"

   o  An EC key with a kid of "11"

Corrected Text
--------------
In order the keys are:

   o  An EC key with a kid of "[email-masked]"

   o  An EC key with a kid of "11"

   o  An EC key with a kid of "[email-masked]"

   o  An EC key with a kid of "[email-masked]"

Notes
-----
That, or maybe leave the list as is and remove "In order".

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8152 (draft-ietf-cose-msg-24)
--------------------------------------
Title               : CBOR Object Signing and Encryption (COSE)
Publication Date    : July 2017
Author(s)           : J. Schaad
Category            : PROPOSED STANDARD
Source              : CBOR Object Signing and Encryption
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 18 Mar 2021 07:36:30 -0700

Thanks Thomas.

RFC Editor, please note that this also applies to
draft-ietf-cose-rfc8152bis-struct, in your queue.

-Ben

---

From: Chris Smiley <[email-masked]>
Date: Thu, 18 Mar 2021 14:27:02 -0700

Hi Ben,

Thank you for the information.  We have reordered the keys as described below in
draft-ietf-cose-rfc8152bis-struct.

Thank you,
RFC Editor/cs

> On Mar 18, 2021, at 7:36 AM, Benjamin Kaduk <[email-masked]> wrote:
> 
> Thanks Thomas.
>