Subject: Re: [COSE] [Lake] COSE IANA registrations in EDHOC (Was: New Version Notification for draft-ietf-lake-edhoc-09.txt)

From: Francesca Palombini <[email-masked]>
Date: Wed, 1 Sep 2021 13:09:33 +0000

Hi,

Haven't followed this discussion in detail, but if the change wanted is only to the IANA registry, and given how the "Updates" tag is very undefined, this wouldn't have to update 8152bis strictly speaking: this could provide a different definition and update the registry (including reference) accordingly. Maybe not the prettiest solution, but might save complications.

Also, this made me take a look at the status of 8152bis, which is in AUTH48: if there was enough community consensus around this change, this change could be done directly in the 8152bis with the appropriate amount of last calls and community feedback etc. Yes, this would delay publication of that document, but given how it's been in AUTH48 for 1.5 months, maybe it could be reasonable to wait the additional weeks, if that's what the community wants and the changes are minor. Food for thoughts.

Francesca

On 01/09/2021, 06:19, "Lake on behalf of Benjamin Kaduk" <[email-masked] on behalf of [email-masked]> wrote:

    On Tue, Aug 24, 2021 at 11:43:42AM +0000, Göran Selander wrote:
    > 
    > 
    > > On 2021-08-24, 10:05, "Lake on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:
    > >
    > >    I see.
    > >
    > >    So, you are saying, this will be a “using EDHOC in COSE” specification, 
    > 
    > Well, others may also have use of the COSE header for CWT/UCCS, and the int value type of 'kid'.
    > 
    > >  still normative, but referenced from EDHOC as informative as 
    > >   EDHOC works without COSE.
    > 
    > Well, EDHOC is definitely dependent on COSE, but does not require these particular credentials or identifiers.
    > 
    > >   Yes, it is always hard to position a “using X in Y” draft between the X and Y working groups — after all, the two ends of this draft need 
    > >   to fit X and Y, respectively.  If the EDHOC specification truly doesn’t need the contents of this specification, then I can see moving them
    > >   into a COSE document.  But I think it is as expedient to keep them together in one document.  The only strong reason to split the 
    > >  document would be to avoid a long wait while COSE is deciding on some controversial content of the extracted spec.  Do we foresee such 
    > >  a delay?
    > 
    > Not that I am aware of. Previous discussion in COSE has not indicated that this is contentious. The main thing we haven't discussed is that EDHOC would be updating rfc8152bis-struct.

    I think it would invite questions of charter scope if a document from LAKE
    attempted to update rfc8152bis-struct; keeping that work in COSE seems
    likely to have an easier path, process-wise.

    -Ben

    -- 
    Lake mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/lake

---

From: John Mattsson <[email-masked]>
Date: Sat, 4 Sep 2021 08:14:52 +0000

From: Lake <[email-masked]> on behalf of Francesca Palombini <francesca.palombini=[email-masked]>
Date: Wednesday, 1 September 2021 at 15:10
To: Benjamin Kaduk <[email-masked]>, Göran Selander <goran.selander=[email-masked]>
Cc: Michael Richardson <[email-masked]>, Carsten Bormann <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [Lake] COSE IANA registrations in EDHOC (Was: New Version Notification for draft-ietf-lake-edhoc-09.txt)
Hi,

John: Skipping “Updates” seems like bad solution in general. “Updates” gives people a chance to see that there is an update. Without “Updates” nobody will notice that there was a change.

John: I think that is a very good idea worth doing.

Francesca

    -Ben

---

From: John Mattsson <[email-masked]>
Date: Sat, 4 Sep 2021 08:36:37 +0000

The ID_CRED_x fields are just COSE header maps. The only thing EDHOC adds is how to format CRED_x. I think a separate COSE draft defining ‘cwt’ and ‘ucss’ header parameters should at least be considered. There are supposed to be useful also in other uses of COSE outside of EHDOC which might have different security consideration. At a minimum COSE should be involved to make sure that ‘cwt’ and ‘ucss’ are useful and secure also in non-EDHOC uses of COSE. If there are not a lot of additional things that need to be said regarding non-EHOC use of ‘cwt’ and ‘ucss’, I agree that keeping them in the EHDOC draft is the easier and fastest option.

John

From: Lake <[email-masked]> on behalf of Carsten Bormann <[email-masked]>
Date: Tuesday, 24 August 2021 at 10:05
To: Göran Selander <goran.selander=[email-masked]>
Cc: [email-masked] <[email-masked]>, Michael Richardson <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [Lake] COSE IANA registrations in EDHOC (Was: New Version Notification for draft-ietf-lake-edhoc-09.txt)
I see.

So, you are saying, this will be a “using EDHOC in COSE” specification, still normative, but referenced from EDHOC as informative as EDHOC works without COSE.

Yes, it is always hard to position a “using X in Y” draft between the X and Y working groups — after all, the two ends of this draft need to fit X and Y, respectively.  If the EDHOC specification truly doesn’t need the contents of this specification, then I can see moving them into a COSE document.  But I think it is as expedient to keep them together in one document.  The only strong reason to split the document would be to avoid a long wait while COSE is deciding on some controversial content of the extracted spec.  Do we foresee such a delay?

Grüße, Carsten

> On 2021-08-24, at 09:35, Göran Selander <goran.selander=[email-masked]> wrote:
>
> Combining the responses from Carsten and Michael, and including COSE.
>
>> On 2021-08-23, 19:17, "Michael Richardson" <[email-masked]> wrote:
>>
>>   Göran Selander wrote:
>>> * The key identifier ‘kid’ is extended to also support CBOR ints,
>>> making ‘kid2’ introduced in -08 redundant. This change was based on
>>> feedback from the COSE WG [1]. One potential next step is to move all
>>> COSE-related IANA registrations from this draft to a separate COSE
>>> draft and make an informative reference.
>>
>>> [1] https://mailarchive.ietf.org/arch/msg/cose/qGngdte4s3SEZEKM-xBEoXYUgKc/
>>
>>   I understanding splitting the document so that it is easier to update,
>>   but I think that the reference should be normative.
>>
>>   I think we want to publish the documents together.
>
>
> > On 2021-08-23, 21:42, "Carsten Bormann" <[email-masked]> wrote:
>>
>>> One potential next step is to move all COSE-related IANA registrations from this draft
>> to a separate COSE draft and make an informative reference.
>>
>>   Why?
>>
>
>
> The registrations in question are in section 8.5 -  8.7 of draft-ietf-lake-edhoc-09: The extension of 'kid' to int (both as a reference and in the referenced object) and the registration of 'cwt' to signify that the value is a CWT or UCCS.
>
> A few reasons have been mentioned for moving this from EDHOC to a COSE draft, I don't know what is most relevant, if anything:
>
> * In case of 'kid', these registrations would make EDHOC an update of draft-ietf-cose-rfc8152bis-struct (RFC-to-be 9052). I don't know if LAKE or COSE wants that.
>
> * These registrations are independent of the base EDHOC protocol, but enables the use of CWT and UCCS as credentials, and more compact identification of credentials. Therefore they could instead be referenced from EDHOC. I don't see why the reference needs to be normative.
>
> * These registrations belong to the COSE domain and may gain better awareness and reviews if put into a COSE draft.
>
>
> Göran
>
>
>
>
>
>
>
>
> --
> Lake mailing list
> [email-masked]

---

From: Göran Selander <[email-masked]>
Date: Mon, 6 Sep 2021 08:48:23 +0000

From: John Mattsson <john.mattsson=[email-masked]>
Date: Saturday, 4 September 2021 at 10:15

Hi,

[GS:] Considering Ben's comment (below) that this is process-wise easiest to in COSE, I agree making the change in 8152bis makes more sense than writing a separate draft which does the same thing.

Göran

    -Ben

---

From: Göran Selander <[email-masked]>
Date: Mon, 13 Sep 2021 14:46:15 +0000

Hi,

Here is a small PR which extends 'kid' to ints:

https://github.com/cose-wg/cose-rfc8152bis/pull/34

Göran

From: John Mattsson <john.mattsson=[email-masked]>
Date: Saturday, 4 September 2021 at 10:15
To: Francesca Palombini <[email-masked]>, Benjamin Kaduk <[email-masked]>, Göran Selander <[email-masked]>
Cc: Michael Richardson <[email-masked]>, Carsten Bormann <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Lake] COSE IANA registrations in EDHOC (Was: New Version Notification for draft-ietf-lake-edhoc-09.txt)

Francesca

    -Ben