Subject: Re: [COSE] HPKE for COSE

From: John Mattsson <[email-masked]>
Date: Mon, 8 Nov 2021 16:25:37 +0000

Göran Selander [email-masked]<mailto:[email-masked]> wrote:

>We could e.g. define a COSE Header Parameter (say 'hpke-alg'; label 11)
>signifying that this is an HPKE algorithm, in which case e.g. {11 : 17} would
>indicate DHKEM(P-384, HKDF-SHA384).

A new 'hpke-alg' parameter with values from the “HPKE KEM Identifiers” IANA registry seems like a very good solution. I think this makes a lot of sense in this case. All future HPKE KEMs would then automatically be usable in COSE and we would avoid COSE WG work registering new HPKE KEMs.

If COSE adopt this draft, we should discuss if COSE WG sees HPKE as the main way to use KEMs in COSE in the future. Note that all the current ECDH-ES algorithms are KEMs. A general HPKE mechanism would mean COSE can automatically use any HPKE PQC KEMs, but nothing would stop COSE from registering more optimized PQC KEMs if needed.

Cheers,
John

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 9 Nov 2021 07:01:33 +0000

Hi Jon, Hi Goeran,

Thanks for bringing this issue up.

I had noticed that HPKE defines its own registry and re-using that registry would be beneficial. I then thought that the group would not be happy to define an extra parameter given that there is already an algorithm registry. This lead me to the current design.

I do, however, agree that the cleaner way is to define a new parameter, as you suggested, and then re-use the HPKE registry. By doing this we also make sure that the two registries do not get out of sync.
So, unless there is an objection I would go head and make the chance to the draft.

Ciao
Hannes

From: COSE <[email-masked]> On Behalf Of John Mattsson
Sent: Monday, November 8, 2021 5:26 PM
To: [email-masked]
Subject: Re: [COSE] HPKE for COSE

>indicate DHKEM(P-384, HKDF-SHA384).

A new 'hpke-alg' parameter with values from the "HPKE KEM Identifiers" IANA registry seems like a very good solution. I think this makes a lot of sense in this case. All future HPKE KEMs would then automatically be usable in COSE and we would avoid COSE WG work registering new HPKE KEMs.

Cheers,
John

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.