Subject: Re: [COSE] Call for adoption of draft-tschofenig-cose-hpke-00

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 3 Dec 2021 13:07:39 +0000

As a co-author of the draft I am obviously in favor of it.
It is a document we need for the SUIT working group to complete its work on firmware encryption.

From: COSE <[email-masked]> On Behalf Of Mike Jones
Sent: Tuesday, November 23, 2021 4:56 PM
To: [email-masked]
Subject: [COSE] Call for adoption of draft-tschofenig-cose-hpke-00

During IETF 112, we decided to issue a call for adoption for "Use of Hybrid Public-Key Encryption (HPKE) with CBOR Object Signing and Encryption (COSE)", as recorded in the minutes at https://datatracker.ietf.org/doc/minutes-112-cose/.

Please reply to this message within the next two weeks (by Tuesday, December 7, 2021) indicating either support for its adoption or stating why you oppose its adoption.

                                                       Thank you,
                                                      -- Mike (writing as COSE co-chair)

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Mike Jones <[email-masked]>
Date: Tue, 7 Dec 2021 15:47:46 +0000

We've had only two people respond to the call for adoption - both authors.  Ivo and I decided today to give working group members another week to respond.

If you care whether this is adopted, please respond now when you read this note.

                                                       Thank you,
                                                       -- Mike & Ivo

From: COSE <[email-masked]> On Behalf Of Mike Jones
Sent: Tuesday, November 23, 2021 7:56 AM
To: [email-masked]
Subject: [COSE] Call for adoption of draft-tschofenig-cose-hpke-00

                                                       Thank you,

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 7 Dec 2021 16:51:02 +0000

Hiya,

I had a quick scan:

- I support adoption from the POV of liking to see HPKE
   be re-used(*) and this seems like a fine start
- I'm not sure if having the plaintext always be a CEK
   is the best plan (could be fixed after adoption if/as
   needed) - might be better if pt can be application data
   and exporters are used if needed (not sure)
- be good if the IANA section showed that there exists
   a good mapping from COSE codepoints to HPKE ones just
   to be sure no new HPKE codepoints are needed (and hence
   that existing implementations should work ok)

Cheers,
S.

(*) To be open: my angle here is that I've got an HPKE
implementation [1] and have recently submitted a PR [2]
to try get that included in a future OpenSSL release.
(If anyone has comments on that PR or it's discussion
please do feel free add to the chat at [2], esp if you
have an opinion on when you'd like to see HPKE supported
in an OpenSSL release.)

[1] https://github.com/sftcd/happykey
[2] https://github.com/openssl/openssl/pull/17172

On 07/12/2021 15:47, Mike Jones wrote:
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose
>

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 10 Dec 2021 13:32:16 +0100

+1

I've skimmed the document and well, it's HPKE with COSE. I'm happy to 
see that you are taking on that work Hannes!

(I know that the deadline was 3 days ago, please take this as an 
informational comment)

Viele Grüße,

Henk

On 23.11.21 16:55, Mike Jones wrote:
> During IETF 112, we decided to issue a call for adoption for “Use of 
> Hybrid Public-Key Encryption (HPKE) with CBOR Object Signing and 
> Encryption (COSE)”, as recorded in the minutes at 
> https://datatracker.ietf.org/doc/minutes-112-cose/ 
> <https://datatracker.ietf.org/doc/minutes-112-cose/>.
> 
> Please reply to this message within the next two weeks (by Tuesday, 
> December 7, 2021) indicating either support for its adoption or stating 
> why you oppose its adoption.
> 
>                                                         Thank you,
> 
>                                                        -- Mike (writing 
> as COSE co-chair)
> 
>

---

From: Russ Housley <[email-masked]>
Date: Wed, 29 Dec 2021 01:41:36 -0500

Mike:

Several people (not just authors) have stated support for adoption.  I have not seen anyone speak against.  Can we close the call now?

Russ

> On Dec 7, 2021, at 10:47 AM, Mike Jones <Michael.Jones=[email-masked]> wrote:
> 
> We’ve had only two people respond to the call for adoption – both authors.  Ivo and I decided today to give working group members another week to respond.
>  
> From: COSE <[email-masked] <mailto:[email-masked]>> On Behalf Of Mike Jones
> To: [email-masked] <mailto:[email-masked]>
> During IETF 112, we decided to issue a call for adoption for “Use of Hybrid Public-Key Encryption (HPKE) with CBOR Object Signing and Encryption (COSE)”, as recorded in the minutes athttps://datatracker.ietf.org/doc/minutes-112-cose/ <https://datatracker.ietf.org/doc/minutes-112-cose/>.
>