Subject: Re: [COSE] Call for adoption of draft-tschofenig-cose-hpke-00

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Tue, 7 Dec 2021 15:59:44 +0000

I support adoption. 

Mainly, because I want to see more CBOR in the protocols.

--

Regards,

Uri

There are two ways to design a system. One is to make it so simple there are obviously no deficiencies.

The other is to make it so complex there are no obvious deficiencies.

                                                                                                                                     -  C. A. R. Hoare

From: COSE <[email-masked]> on behalf of Mike Jones <Michael.Jones=[email-masked]>
Date: Tuesday, December 7, 2021 at 10:49
To: "[email-masked]" <[email-masked]>
Subject: Re: [COSE] Call for adoption of draft-tschofenig-cose-hpke-00

We’ve had only two people respond to the call for adoption – both authors.  Ivo and I decided today to give working group members another week to respond.

If you care whether this is adopted, please respond now when you read this note.

                                                       Thank you,

                                                       -- Mike & Ivo

From: COSE <[email-masked]> On Behalf Of Mike Jones
Sent: Tuesday, November 23, 2021 7:56 AM
To: [email-masked]
Subject: [COSE] Call for adoption of draft-tschofenig-cose-hpke-00

During IETF 112, we decided to issue a call for adoption for “Use of Hybrid Public-Key Encryption (HPKE) with CBOR Object Signing and Encryption (COSE)”, as recorded in the minutes at https://datatracker.ietf.org/doc/minutes-112-cose/.

Please reply to this message within the next two weeks (by Tuesday, December 7, 2021) indicating either support for its adoption or stating why you oppose its adoption.

                                                       Thank you,

                                                      -- Mike (writing as COSE co-chair)

---

From: John Mattsson <[email-masked]>
Date: Fri, 10 Dec 2021 11:46:13 +0000

Hi,

I support adoption. I think reuse of HPKE is a good thing. HPKE might even be the default key exchange method for PQC algorithms in COSE. There are several things left to discuss, but I think the current document is a good start.

Cheers,
John

---

From: Mike Jones <[email-masked]>
Date: Thu, 30 Dec 2021 03:15:40 +0000

Consider the document adopted.  Please submit a working group -00 document.

                                                       Best wishes,
                                                       -- Mike

From: Russ Housley <[email-masked]>
Sent: Tuesday, December 28, 2021 10:42 PM
To: Mike Jones <[email-masked]>
Cc: [email-masked]
Subject: [EXTERNAL] Re: [COSE] Call for adoption of draft-tschofenig-cose-hpke-00

Mike:

Several people (not just authors) have stated support for adoption.  I have not seen anyone speak against.  Can we close the call now?

Russ

On Dec 7, 2021, at 10:47 AM, Mike Jones <Michael.Jones=[email-masked]<mailto:Michael.Jones=[email-masked]>> wrote:

                                                       Thank you,
                                                       -- Mike & Ivo

From: COSE <[email-masked]<mailto:[email-masked]>> On Behalf Of Mike Jones
Sent: Tuesday, November 23, 2021 7:56 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [COSE] Call for adoption of draft-tschofenig-cose-hpke-00

During IETF 112, we decided to issue a call for adoption for “Use of Hybrid Public-Key Encryption (HPKE) with CBOR Object Signing and Encryption (COSE)”, as recorded in the minutes athttps://datatracker.ietf.org/doc/minutes-112-cose/.

                                                       Thank you,