Subject: Re: [COSE] Call for COSE Agenda Items for IETF 113 in Vienna

From: Mike Jones <[email-masked]>
Date: Thu, 3 Mar 2022 16:58:11 +0000

We have yet to receive proposed agenda items for our session in Vienna.  What would people like to talk about?

                                                       -- Mike

From: Mike Jones
Sent: Tuesday, February 22, 2022 9:59 AM
To: [email-masked]
Cc: Ivaylo Petrov <[email-masked]>
Subject: Call for COSE Agenda Items for IETF 113 in Vienna

Dear COSE working group members,

Do you have proposed agenda items for our session at IETF 113 in Vienna?  If so, please reply-all to this note.  Include a title, the presenter(s), and proposed amount of time you'd like.

We have a slot for 13:00-14:00 on Monday Afternoon.

I'm looking forward to seeing many of you in Vienna!

                                         -- Mike, for the COSE Working Group Chairs

---

From: Mike Jones <[email-masked]>
Date: Sun, 6 Mar 2022 02:33:22 +0000

Hi Ivo,

I'm writing as an individual (not a chair) to request agenda time to discuss two new cose-related Internet Drafts that Tobias Looker and I have written.  The two slots I'm requesting are:

  *   Barreto-Lynn-Scott Elliptic Curve Key Representations for JOSE and COSE - draft-looker-cose-bls-key-representations-00 - Mike Jones - 10 minutes
  *   CBOR Web Token (CWT) Claims in COSE Headers - draft-looker-cose-cwt-claims-in-headers-00 - Mike Jones - 10 minutes

                                                       -- Mike

P.S.  I just wrote about these drafts at https://self-issued.info/?p=2260 and https://twitter.com/selfissued/status/1500295357082718208.

From: Mike Jones
Sent: Thursday, March 3, 2022 8:58 AM
To: [email-masked]' <[email-masked]>
Cc: Ivaylo Petrov <[email-masked]>
Subject: RE: Call for COSE Agenda Items for IETF 113 in Vienna

                                                       -- Mike

From: Mike Jones
Sent: Tuesday, February 22, 2022 9:59 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Ivaylo Petrov <[email-masked]<mailto:[email-masked]>>
Subject: Call for COSE Agenda Items for IETF 113 in Vienna

---

From: Anders Rundgren <[email-masked]>
Date: Sun, 6 Mar 2022 08:59:39 +0100

On 2022-03-06 3:33, Mike Jones wro

> Do you have proposed agenda items for our session at IETF 113 in Vienna?  If so, please reply-all to this note.  Include a title, the presenter(s), and proposed amount of time you’d like.
> 
> I’m looking forward to seeing many of you in Vienna!

I don't yet have an I-D but if you want I could talk 15 minutes about a work item that combines COSE algorithms, FIDO/CTAP2, and a new CBOR based signature container.  The target is primarily payment authorizations.

An existing solution featured in Chrome and Edge browsers uses a JSON based scheme:
https://w3c.github.io/secure-payment-confirmation/#dictdef-collectedclientadditionalpaymentdata

I'm proposing using a CBOR based solution:
https://fido-web-pay.github.io/specification/crypto.html#4.3
Since COSE isn't compatible with FIDO signatures, a CBOR based signature solution needs to either enhance COSE or start-off from scratch.  I opted for the latter approach (which later this evolved into a an alternative to COSE for "regular" applications as well).

Thanx,
Anders

> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 8 Mar 2022 14:44:03 +0000

Hi Mike, Hi Ivo,

We would like to talk about the updated draft of COSE-HPKE and the open issues (one posted on the list and a few others are open from the interim meeting).

Ciao
Hannes

From: COSE <[email-masked]> On Behalf Of Mike Jones
Sent: Thursday, March 3, 2022 5:58 PM
To: [email-masked]
Cc: Ivaylo Petrov <[email-masked]>
Subject: Re: [COSE] Call for COSE Agenda Items for IETF 113 in Vienna

                                                       -- Mike

From: Mike Jones

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Göran Selander <[email-masked]>
Date: Thu, 10 Mar 2022 11:04:37 +0000

Hi COSE chairs,

We would like the WG to adopt this short draft about extending kid to int:

https://datatracker.ietf.org/doc/draft-selander-cose-kid-int/

There was a thread on this topic in the COSE mailing list [1] between IETF 111 and 112 and it was also discussed at IETF 112. I can present, 5 minutes is enough.

Göran

[1] https://mailarchive.ietf.org/arch/msg/cose/qGngdte4s3SEZEKM-xBEoXYUgKc/

From: COSE <[email-masked]> on behalf of Mike Jones <Michael.Jones=[email-masked]>
Date: Tuesday, 22 February 2022 at 18:59
To: [email-masked] <[email-masked]>
Cc: Ivaylo Petrov <[email-masked]>
Subject: [COSE] Call for COSE Agenda Items for IETF 113 in Vienna