Subject: [COSE] Newly Submitted Draft - Barreto-Lynn-Scott Elliptic Curve Key Representations for JOSE and COSE

From: Tobias Looker <[email-masked]>
Date: Wed, 2 Mar 2022 04:21:50 +0000

Hi All,

This is an email to introduce the newly submitted draft titled "Barreto-Lynn-Scott Elliptic Curve Key Representations for JOSE and COSE", the current abstract is as follows.

"This specification defines how to represent cryptographic keys for the pairing-friendly elliptic curves known as Barreto-Lynn-Scott (BLS), for use with the key representation formats of JSON Web Key (JWK) and COSE (COSE_Key)."

The primary rational for this draft (elaborated on in the introduction section) is that there continues to be industry adoption of algorithms that make use of pairing based cryptography, and the "Barreto-Lyn-Scott" curves are an increasingly popular choice for implementations. Therefore we see immense value in standardizing the representation of the cryptographic keys in the popular formats of JWK and COSE_Key.

Thanks,

[Mattr website]<https://aus01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fscanmail.trustwave.com%2F%3Fc%3D15517%26d%3Dw46s4eMXULV_ns1ZfAKYLbVKcqey_PHiW1WeN4boYw%26u%3Dhttps%253a%252f%252fmattr.global%252f&data=04%7C01%7CSteve.Lowes%40mbie.govt.nz%7C5a65fe33c70b41fd8ba908d976f3a2f1%7C78b2bd11e42b47eab0112e04c3af5ec1%7C0%7C0%7C637671611076709977%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=tKqCMzLUQNCeORd908YqfqZoT7tCy%2FMVwXdjpch1sDY%3D&reserved=0>

Tobias Looker

MATTR
CTO

+64 (0) 27 378 0461
[email-masked]<mailto:[email-masked]>

[Mattr website]<https://aus01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fscanmail.trustwave.com%2F%3Fc%3D15517%26d%3Dw46s4eMXULV_ns1ZfAKYLbVKcqey_PHiW1WeN4boYw%26u%3Dhttps%253a%252f%252fmattr.global%252f&data=04%7C01%7CSteve.Lowes%40mbie.govt.nz%7C5a65fe33c70b41fd8ba908d976f3a2f1%7C78b2bd11e42b47eab0112e04c3af5ec1%7C0%7C0%7C637671611076709977%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=tKqCMzLUQNCeORd908YqfqZoT7tCy%2FMVwXdjpch1sDY%3D&reserved=0>

[Mattr on LinkedIn]<https://aus01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fscanmail.trustwave.com%2F%3Fc%3D15517%26d%3Dw46s4eMXULV_ns1ZfAKYLbVKcqey_PHiW1SbN9fvNg%26u%3Dhttps%253a%252f%252fwww.linkedin.com%252fcompany%252fmattrglobal&data=04%7C01%7CSteve.Lowes%40mbie.govt.nz%7C5a65fe33c70b41fd8ba908d976f3a2f1%7C78b2bd11e42b47eab0112e04c3af5ec1%7C0%7C0%7C637671611076719975%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=t%2BidOI32oaKuTJf1AkcG%2B%2FirIJwbrgzXVZnjOAC52Hs%3D&reserved=0>

[Mattr on Twitter]<https://aus01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fscanmail.trustwave.com%2F%3Fc%3D15517%26d%3Dw46s4eMXULV_ns1ZfAKYLbVKcqey_PHiW1WdMte6ZA%26u%3Dhttps%253a%252f%252ftwitter.com%252fmattrglobal&data=04%7C01%7CSteve.Lowes%40mbie.govt.nz%7C5a65fe33c70b41fd8ba908d976f3a2f1%7C78b2bd11e42b47eab0112e04c3af5ec1%7C0%7C0%7C637671611076729970%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=BD9WWyXEjVGlbpbCja93yW%2FzLJZpe%2Ff8lGooe8V6i7w%3D&reserved=0>

[Mattr on Github]<https://aus01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fscanmail.trustwave.com%2F%3Fc%3D15517%26d%3Dw46s4eMXULV_ns1ZfAKYLbVKcqey_PHiWwGdMoDtMw%26u%3Dhttps%253a%252f%252fgithub.com%252fmattrglobal&data=04%7C01%7CSteve.Lowes%40mbie.govt.nz%7C5a65fe33c70b41fd8ba908d976f3a2f1%7C78b2bd11e42b47eab0112e04c3af5ec1%7C0%7C0%7C637671611076729970%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=4AhRuXZCnU5i3hcngo4H3UiNayYUtXpRcImV4slS1mw%3D&reserved=0>

This communication, including any attachments, is confidential. If you are not the intended recipient, you should not read it - please contact me immediately, destroy it, and do not copy or use any part of this communication or disclose anything about it. Thank you. Please note that this communication does not designate an information system for the purposes of the Electronic Transactions Act 2002.

---

From: Tobias Looker <[email-masked]>
Date: Wed, 2 Mar 2022 04:24:44 +0000

Apologies I forgot to provide a link to this draft in the previous email https://datatracker.ietf.org/doc/draft-looker-cose-bls-key-representations/

Thanks,

Tobias Looker

MATTR
CTO

+64 (0) 27 378 0461

________________________________
From: Tobias Looker
Sent: 02 March 2022 17:21
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Newly Submitted Draft - Barreto-Lynn-Scott Elliptic Curve Key Representations for JOSE and COSE

Hi All,

Thanks,

Tobias Looker

MATTR
CTO

+64 (0) 27 378 0461

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 1 Mar 2022 20:29:19 -0800

With apologies for putting a damper on enthusiasm, I have to note that the
COSE WG charter (https://datatracker.ietf.org/wg/cose/about/) limits our
consideration of work items to algorithms "that have been evaluated by
the CFRG and algorithms which have gone through a public review and
evaluation process such as was done for the NIST SHA-3 algorithms."

The restriction on what we can adopt as WG work items does not mean that we
can't talk about the algorithms, though.

I seem to recall that CFRG has had some discussion of BLS previously, but
forget the details; perhaps you recall that history better than I do.

Thanks,

Ben

> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose

---

From: Tobias Looker <[email-masked]>
Date: Wed, 2 Mar 2022 04:51:58 +0000

Hi Benjamin,

Thanks for the quick feedback.

The CFRG has multiple work items in this area, notably:

https://www.ietf.org/archive/id/draft-irtf-cfrg-pairing-friendly-curves-10.html

Which formally defines the "Barreto-Lynn-Scott" curves referred to by this draft, see section 2.4.

In regards to algorithms using this curve there is the "BLS Signatures" draft

https://datatracker.ietf.org/doc/html/draft-irtf-cfrg-bls-signature-04

Do these drafts meet the criteria in the COSE working group charter for CFRG review?

Depending upon the answer to this question, what do you see the next steps as being?

Thanks,

Tobias Looker

MATTR
CTO

+64 (0) 27 378 0461

________________________________
From: Benjamin Kaduk <[email-masked]>
Sent: 02 March 2022 17:29
To: Tobias Looker <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [COSE] Newly Submitted Draft - Barreto-Lynn-Scott Elliptic Curve Key Representations for JOSE and COSE

EXTERNAL EMAIL: This email originated outside of our organisation. Do not click links or open attachments unless you recognise the sender and know the content is safe.

Thanks,

Ben

---

From: Mike Jones <[email-masked]>
Date: Thu, 3 Mar 2022 17:04:41 +0000

Ben or others - do you have any suggestions as to what our next steps should be for registering the pairing-friendly curve algorithm identifiers?  In particular, see Tobias' notes below about the CFRG drafts that these algorithms are based on.

                                                       Thanks all,
                                                       -- Mike

From: Tobias Looker <[email-masked]>
Sent: Tuesday, March 1, 2022 8:52 PM
To: Benjamin Kaduk <[email-masked]>
Cc: [email-masked]; Mike Jones <[email-masked]>
Subject: [EXTERNAL] Re: [COSE] Newly Submitted Draft - Barreto-Lynn-Scott Elliptic Curve Key Representations for JOSE and COSE

Hi Benjamin,

Thanks,

Tobias Looker

MATTR
CTO

+64 (0) 27 378 0461

________________________________
From: Benjamin Kaduk <[email-masked]<mailto:[email-masked]>>
Sent: 02 March 2022 17:29
To: Tobias Looker <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [COSE] Newly Submitted Draft - Barreto-Lynn-Scott Elliptic Curve Key Representations for JOSE and COSE

Thanks,

Ben

On Wed, Mar 02, 2022 at 04:24:44AM +0000, Tobias Looker wrote:
> [email-masked]<mailto:[email-masked]<mailto:[email-masked]%3cmailto:[email-masked]>>
>
> To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
> Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
> [email-masked]<mailto:[email-masked]<mailto:[email-masked]%3cmailto:[email-masked]>>
>

> [email-masked]<mailto:[email-masked]>