Subject: [Ietf-not43] IRIS Open Issues

From: shollenbeck at verisign.com (Hollenbeck, Scott)
Date: Thu Nov 13 12:47:44 2003

Dave,

> >      - Or simply specify that only one type of status 
> element be used
> > (must be expressed in words... not possible in XML Schema).
> 
> To be clear, the way you represent an "unordered set" in 
> XMLSchema is to 
> create a sequence of choices.  When you do that, you make it 
> impossible to 
> enforce the property of uniqueness.  So you could have:
> 
>   <dreg:status>
>      <dreg:active>some date</dreg:active>
>      <dreg:registrarHold>some date</dreg:registrarHold>
>      <dreg:active>some other date</dreg:active>
>   </dreg:status>

I think an unordered set is better represented using the "all" model group
than a sequence of choices.  According to the schema primer description of
an "all" group: "All the elements in the group may appear once or not at
all, and they may appear in any order".

Note the "once or not at all" part.

-Scott-

---

From: andy at hxr.us (Andrew Newton)
Date: Thu Nov 13 17:11:51 2003

> Note the "once or not at all" part.

And the "may".  I'm not sure why I overlooked this.

-andy