Subject: [Curdle] Does anyone have the one true OID for SHA3 with RSA Encryption?

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 10 Dec 2015 11:46:24 -0500

Was just rejigging some OID management stuff in a library and noticed that
I hadn't put them in yet.

While I don't expect to make much use of SHA3 with RSA, that is all I have
that is testable at present. I don't think the CFRG process is at the stage
where we would want to cut OIDs.

---

From: Yoav Nir <[email-masked]>
Date: Thu, 10 Dec 2015 19:49:01 +0200

> On 10 Dec 2015, at 6:46 PM, Phillip Hallam-Baker <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Was just rejigging some OID management stuff in a library and noticed that I hadn't put them in yet. 
> 
> While I don't expect to make much use of SHA3 with RSA, that is all I have that is testable at present. I don't think the CFRG process is at the stage where we would want to cut OIDs.

Looking in oid-info.com <http://oid-info.com/>, I see this: http://oid-info.com/get/1.2.840.113549.1.1 <http://oid-info.com/get/1.2.840.113549.1.1>

No one has bothered to register SHA-3 here, which I take as further evidence that people don’t care about SHA-3.

Yoav

---

From: Sean Turner <[email-masked]>
Date: Wed, 16 Dec 2015 11:54:06 -0500

On Dec 10, 2015, at 12:49, Yoav Nir <[email-masked]> wrote:
> 
> 
>> On 10 Dec 2015, at 6:46 PM, Phillip Hallam-Baker <[email-masked]> wrote:
>> 
> Looking in oid-info.com, I see this: http://oid-info.com/get/1.2.840.113549.1.1
> 

I haven’t seen any OIDs for SHA-3 with RSA but the standalone SHA-3 OIDs can be found here:

http://csrc.nist.gov/groups/ST/crypto_apps_infra/csor/algorithms.html

spt

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 16 Dec 2015 12:31:08 -0500

> http://csrc.nist.gov/groups/ST/crypto_apps_infra/csor/algorithms.html

I saw those.

What I want to know is if anyone has cut some OIDs for RSA and if so
what they are. Otherwise I would like some cut on the IETF arc because
I want to be able to use SHA3-512 as my backup digest scheme to
SHA2-512.

But I do not want the IETF to cut any if there are plans to do that elsewhere.

A draft should be very short, basically, do exactly what you would for
SHA2 with SHA3 instead.

---

From: "Dang, Quynh" <[email-masked]>
Date: Wed, 16 Dec 2015 17:44:12 +0000

Hi Sean,

On our website at http://csrc.nist.gov/groups/ST/toolkit/secure_hashing.html, we stated that "The XOFs can be specialized to hash functions, subject to additional security considerations. Guideline for using the XOFs will be provided in the future."

The XOFs are the SHAKE128 and SHAKE256. We are working on a guideline for the SHAKEs when being used as hash functions. 

Quynh. 

________________________________________
From: Curdle <[email-masked]> on behalf of Sean Turner <[email-masked]>
Sent: Wednesday, December 16, 2015 11:54 AM
To: [email-masked]
Subject: Re: [Curdle] Does anyone have the one true OID for SHA3 with RSA Encryption?

spt

_______________________________________________
Curdle mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/curdle

---

From: "Jim Schaad" <[email-masked]>
Date: Wed, 16 Dec 2015 12:00:27 -0800

> -----Original Message-----
> From: Curdle [mailto:[email-masked]] On Behalf Of Phillip Hallam-
> Baker
> Sent: Wednesday, December 16, 2015 9:31 AM
> To: Sean Turner <[email-masked]>
> Cc: [email-masked]
> that is testable at present. I don't think the CFRG process is at the stage where
> we would want to cut OIDs.
> >>
> >> Looking in oid-info.com, I see this:
> >> http://oid-info.com/get/1.2.840.113549.1.1
> >>
> What I want to know is if anyone has cut some OIDs for RSA and if so what they
> are. Otherwise I would like some cut on the IETF arc because I want to be able
> to use SHA3-512 as my backup digest scheme to SHA2-512.

Why would one every need to cut any RSA OIDs.  They are not needed for PSS and we should not be using SHA3 with v1.5 signatures.

Jim

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 16 Dec 2015 15:39:17 -0500

On Wed, Dec 16, 2015 at 3:00 PM, Jim Schaad <[email-masked]> wrote:
>> From: Curdle [mailto:[email-masked]] On Behalf Of Phillip

Ah right, RSASSA-PSS-params has the slot for the digest algorithm so
the combo OIDs are no longer needed!

That simplifies things.