Subject: Re: [Curdle] Fwd: I-D Action: draft-ietf-curdle-dnskey-eddsa-00.txt

From: Simon Josefsson <[email-masked]>
Date: Fri, 06 May 2016 09:32:31 +0200

Ondřej Surý <[email-masked]> writes:

> Dear colleagues,
>
> a new EdDSA for DNSSEC draft has been posted in CURDLE WG and is in
> need of more reviewers ;).
>
> I merged Ed25519 and Ed448 drafts into one, removed reasoning why
> EdDSA is superior for RFC and I-D in Normative references (thanks goes
> to Paul Hoffman's review), and introduced using Signature Context[1]
> in the signatures (thanks dkg for introducing me this idea) <-- this
> one needs more work, because using Context is defined just for Ed448
> and we want to have it also for Ed25519.

Thank you for this work!

I suggest to add text repeating the established best practice to not
re-use keys for different purposes -- that solves the
cross-protocol/domain problem better than contexts in my opinion.  There
may not be harm of using Ed448's contexts in your draft, but it sets an
example that doing so is good enough to protect against that generic
class of attacks when it isn't (see DJB's post on CFRG explaining how it
isn't sufficient).

/Simon

---

From: Ondřej Surý <[email-masked]>
Date: Wed, 25 May 2016 09:43:58 +0200 (CEST)

Dear WG members,

I would like to proceed with the draft and we got sort-of stuck because of the Context.

So here I would like to ask the WG, if they have any opinion on how should we push this forward.  There are several options we might take:

1. drop the Contexts
2. drop the Contexts from ed25519 and keep it for ed448 (sort of useless since ed25519 is the one we expect everybody will use)
3. keep the Contexts and clarify the usage for ed25519
4. wait for Simon's eddsa draft to specify ed25519ctx (and ed448ctx)

Thoughts?  Opinions?

Cheers,
--
 Ondřej Surý -- Technical Fellow
 --------------------------------------------
 CZ.NIC, z.s.p.o.    --     Laboratoře CZ.NIC
 Milesovska 5, 130 00 Praha 3, Czech Republic
 mailto:[email-masked]    https://nic.cz/
 --------------------------------------------

----- Original Message -----
> From: [email-masked]
> To: [email-masked]
> Cc: [email-masked]
> Sent: Monday, April 18, 2016 9:40:50 PM
> Subject: [Curdle] I-D Action: draft-ietf-curdle-dnskey-eddsa-00.txt

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the CURves, Deprecating and a Little more
> Encryption of the IETF.
> 
>        Title           : EdDSA for DNSSEC
>        Authors         : Ondrej Sury
>                          Robert Edmonds
>	Filename        : draft-ietf-curdle-dnskey-eddsa-00.txt
>	Pages           : 8
>	Date            : 2016-04-18
> 
> Abstract:
>   This document describes how to specify EdDSA keys and signatures in
>   DNS Security (DNSSEC).  It uses the Edwards-curve Digital Security
>   Algorithm (EdDSA) with the choice of two curves, Ed25519 and Ed448.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-curdle-dnskey-eddsa/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-ietf-curdle-dnskey-eddsa-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle