Subject: Re: [Curdle] Call for Adoption for draft-housley-cms-ecdh-new-curves-00.txt

From: Daniel Migault <[email-masked]>
Date: Wed, 4 May 2016 09:08:20 -0400

Hi,

The draft draft-housley-cms-ecdh-new-curves has been adopted as WG document.

BR,
Rich and Daniel

On Sun, Apr 17, 2016 at 3:57 PM, Jim Schaad <[email-masked]> wrote:

> I have reviewed early drafts of this document and feel that it should be
> adopted by the working group.  I have some issues with some parts of the
> document, but that is normal for documents adopted into a working group.
>
> Jim
>
>
> > -----Original Message-----
> > From: Curdle [mailto:[email-masked]] On Behalf Of Daniel
> Migault
> > Sent: Friday, April 15, 2016 2:52 PM
> > To: Russ Housley <[email-masked]>; [email-masked]
> > Subject: [Curdle] Call for Adoption for
> draft-housley-cms-ecdh-new-curves-
> > 00.txt
> >
> > Hi,
> >
> > As mentioned last week, this is a call for adoption for
> draft-housley-cms-ecdh-
> > new-curves-00.txt.
> >
> > This starts a Call for Adoption for "Use of the Elliptic Curve
> Diffie-Hellman Key
> > Agreement Algorithm with
> >   Curve 25519 and Curve 448 in the Cryptographic Message Syntax (CMS)"
> >
> > The document is available here:
> > https://www.ietf.org/id/draft-housley-cms-ecdh-new-curves-00.txt
> >
> > Please review this draft to see if you think it is suitable for adoption
> by CURLDE,
> > and comment to the list, clearly stating your view.  *Speak Up* if you
> have
> > strong opposition to this work.
> >
> > This call for adoption ends on April 29.
> >
> > BR,
> > Rich and Daniel
> >
> > _______________________________________________
> > Curdle mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/curdle
>
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle
>

---

From: Russ Housley <[email-masked]>
Date: Wed, 4 May 2016 10:13:54 -0400

The current document includes this placeholder …

2.2.  HKDF

   {{{ Should we specify a way to use HKDF from RFC 5869? }}}

      if ukm is provided, then salt = ukm, else salt = zero
      PRK = HKDF-Extract(salt, K)

      KEK = HKDF-Expand(PRK, DER(ECC-CMS-SharedInfo), SizeOf(KEK))

One person said that they would like to see this done.  I have not heard anyone speak against.

If you do not think this is desirable, please speak now.  Otherwise, I will work on this text before posting the WG version of the document.

Russ

On May 4, 2016, at 9:08 AM, Daniel Migault <[email-masked]> wrote:

> > From: Curdle [mailto:[email-masked]] On Behalf Of Daniel Migault
> > Subject: [Curdle] Call for Adoption for draft-housley-cms-ecdh-new-curves-
> > 00.txt
> >
> > Hi,
> >

---

From: Martin Thomson <[email-masked]>
Date: Thu, 5 May 2016 01:00:56 +1000

On 5 May 2016 at 00:13, Russ Housley <[email-masked]> wrote:
> If you do not think this is desirable, please speak now.  Otherwise, I will
> work on this text before posting the WG version of the document.

I agree with that person.  We're using HKDF lots more now.  In
particular, the API is much better than the alternatives that I've
seen.