Subject: [Curdle] Looking for contemporary CMS samples (X25519/Ed25519/AES-GCM)

From: Dmitry Baryshkov <[email-masked]>
Date: Tue, 26 May 2020 22:55:04 +0300

Hello,

While working on CMS support, it was noticed that there are no known
public CMS test vectors covering recent (or not so recent) additions.
In particular we were looking for X25519/Ed25519 and AES-GCM/AES-CCM
examples. Do you have any known-good samples that can be used in open
source projects?

Thank you!

--
With best wishes
Dmitry

---

From: Russ Housley <[email-masked]>
Date: Tue, 26 May 2020 16:59:58 -0400

RFC 8591 has an example of authEnvelopedData with RSA and AES-GCM.

Russ

> On May 26, 2020, at 3:55 PM, Dmitry Baryshkov <[email-masked]> wrote:
> 
> Hello,
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm