Subject: [Curdle] Protocol Action: 'Key Exchange (KEX) Method Updates and Recommendations for Secure Shell (SSH)' to Proposed Standard (draft-ietf-curdle-ssh-kex-sha2-20.txt)

From: The IESG <[email-masked]>
Date: Fri, 10 Sep 2021 09:05:37 -0700

The IESG has approved the following document:
- 'Key Exchange (KEX) Method Updates and Recommendations for Secure Shell
   (SSH)'
  (draft-ietf-curdle-ssh-kex-sha2-20.txt) as Proposed Standard

This document is the product of the CURves, Deprecating and a Little more
Encryption Working Group.

The IESG contact persons are Benjamin Kaduk and Roman Danyliw.

A URL of this Internet Draft is:
https://datatracker.ietf.org/doc/draft-ietf-curdle-ssh-kex-sha2/

Technical Summary

   This document is intended to update the recommended set of key
   exchange methods for use in the Secure Shell (SSH) protocol to meet
   evolving needs for stronger security.  This document updates RFCs
   4250, 4253, 4432, and 4462.

Working Group Summary

The proposed recommendations have been discussed on the mailing
list and in sessions during the IETF in seoul.   Additional changes were
made based on subsequent discussion, including AD and directorate
reviews, but all the changes were amply discussed in the WG.

Document Quality

The document provides recommendations, as such implementations
are mostly related to the new methods defined in curdle. New key 
exchange methods will use the SHA-2 family of hashes and are drawn 
from these ssh-curves from [I-D.ietf-curdle-ssh-curves] and new-modp 
from the [RFC82682] and gss-keyex [I-D.ietf-curdle-gss-keyex-sha2].
All of the key-exchange mechanisms described have multiple implementations.

Personnel

   The document shepherd is Daniel Migault.
   The responsible AD is Benjamin Kaduk

RFC Editor Note

Please remove the duplicated phrase """with the suggested implementation
guidance provided in section 4 "Summary Guidance for Key Exchange Method
Names Implementation" in this document.""" from the IANA considerations.

Please also replace "4000" with the more conventional "4096" in Section 3.2.1

---

From: "Mark Baushke (ietf)" <[email-masked]>
Date: Fri, 10 Sep 2021 10:19:17 -0700

The suggested "RFC Editor Note" changes for IANA and section 3.2.1 are reasonable.

Thank you to everyone who helped to make this document better.

        Be safe, stay healthy,
        -- Mark

PS: I have removed IETF-Announce <[email-masked]> and The IESG <[email-masked]> from this reply to avoid putting the message into a moderation queue.

> On Sep 10, 2021, at 9:05 AM, The IESG <[email-masked]> wrote:
> 
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 10 Sep 2021 17:21:50 +0000

Mark,

Thanks for your patience with the process.  I am sure this is not something you expected to do in retirement.  But if so, then perhaps there is other work we can foist off on you . :)

---

From: Daniel Migault <[email-masked]>
Date: Fri, 10 Sep 2021 16:39:09 -0400

+1 thanks Mark!

Yours,
Daniel

On Fri, Sep 10, 2021 at 1:21 PM Salz, Rich <[email-masked]> wrote:

> Mark,
>
> Thanks for your patience with the process.  I am sure this is not
> something you expected to do in retirement.  But if so, then perhaps there
> is other work we can foist off on you . :)
>
>
>

-- 
Daniel Migault
Ericsson