Subject: Re: [cuss] New REQ: Size of UUI

From: Alan Johnston <[email-masked]>
Date: Wed, 3 Nov 2010 09:37:40 -0500

Keith,

For the ISDN usage of UUI, we definitely need to constrain the size of the
UUI to allow interworking with the PSTN.

For other usages, I don't think we need to put in a fixed constraint.  We
can write some guidelines in the mechanism about size, and point out the
issue with UDP transported responses you mention below.

In my view, the requirement to carry 128 octets or ISDN interworking is
covered by REQ-7 which says the mechanism must interwork with the ISDN
service.

- Alan -

On Fri, Oct 1, 2010 at 5:05 PM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

> I think we need a requirement on size of UUI, although I am not yet sure
> exactly what we will say.
>
> From the perspective of interworking with the ISDN, it needs to say at
> least:
>
>        REQ-X:  The solution MUST provide a mechanism of transporting at
> least 128 octets of user data and a one octet protocol discriminator, i.e.
> 129 octets in total.
>
> It needs to say this as I think we need to provide a mechanism that does at
> least as well as the ISDN.
>
> On the other hand, I would be perfectly happy if we set the limit at
> exactly 129 octets, as I have no use cases to exceed that.
>
> The other criteria we need to think in regard to UUI size, is about what
> happens in responses, where the request was sent UDP. Currently in RFC 3261
> we assume a response will be no more than 200 octets larger that a request,
> so that we do not break the transport mechanism. An unlimited size of UUI in
> the response can easily exceed this.
>
> regards
>
> Keith
> _______________________________________________
> cuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cuss
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 5 Nov 2010 05:13:25 +0100

I would like an explicit requirement. It is possible to interwork in either direction with different maximum sizes, but with the principle that discard occurs.

I still prefer to fix it to the same limitations as the ISDN service, but whatever we should define what mixumum size the solution has to support.

regards

Keith

________________________________

	From: Alan Johnston [mailto:[email-masked]] 
	Sent: Wednesday, November 03, 2010 2:38 PM
	To: DRAGE, Keith (Keith)
	Cc: [email-masked]
	Subject: Re: [cuss] New REQ: Size of UUI

	Keith, 

	For the ISDN usage of UUI, we definitely need to constrain the size of the UUI to allow interworking with the PSTN.

	For other usages, I don't think we need to put in a fixed constraint.  We can write some guidelines in the mechanism about size, and point out the issue with UDP transported responses you mention below.

	In my view, the requirement to carry 128 octets or ISDN interworking is covered by REQ-7 which says the mechanism must interwork with the ISDN service. 

	- Alan -

	On Fri, Oct 1, 2010 at 5:05 PM, DRAGE, Keith (Keith) <[email-masked]> wrote:

		I think we need a requirement on size of UUI, although I am not yet sure exactly what we will say.
		
		From the perspective of interworking with the ISDN, it needs to say at least:
		
		       REQ-X:  The solution MUST provide a mechanism of transporting at least 128 octets of user data and a one octet protocol discriminator, i.e. 129 octets in total.
		
		It needs to say this as I think we need to provide a mechanism that does at least as well as the ISDN.
		
		On the other hand, I would be perfectly happy if we set the limit at exactly 129 octets, as I have no use cases to exceed that.
		
		The other criteria we need to think in regard to UUI size, is about what happens in responses, where the request was sent UDP. Currently in RFC 3261 we assume a response will be no more than 200 octets larger that a request, so that we do not break the transport mechanism. An unlimited size of UUI in the response can easily exceed this.
		
		regards
		
		Keith