Subject: [cuss] Consensus call: Choosing a mechanism

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 03 Jan 2011 09:55:52 -0600

Folks: One output of the Virtual-II meeting was that we need to
converge to a specific mechanism for transporting UUI in order
to move other chartered work ahead.

There are three mechanisms listed in [1]: body, URI parameter and
new header field. We have discussed these options in two interim calls
and in Beijing. [1] favors the new header field approach.

During the CUSS Virtual-II meeting held on Dec-21-2010 (minutes
available at [2]), we further discussed the mechanisms and
there were no objections voiced to moving forward using the header
field mechanism.  In addition, individual folks have expressed
an opinion on the WG mailing list to choose the header field
approach.

So, the chairs would like to formally call for consensus on the
mechanism, specifically:

    Should the working group move ahead with the header field
    approach as the specific mechanism for transporting User-
    to-User Call Control information in SIP?

Please send comments on this consensus call to the list by
Wednesday, January-12-2011.  Please do send a mail to the list,
even if your comment a simple "yes" or "no".

Thank you in advance.

[1] http://tools.ietf.org/html/draft-johnston-cuss-sip-uui-01
[2] http://www.ietf.org/mail-archive/web/cuss/current/msg00132.html

Vijay K. Gurbani and Enrico Marocco
IETF CUSS WG co-chairs

---

From: Leon Portman <[email-masked]>
Date: Mon, 3 Jan 2011 18:19:10 +0200

New header field

Leon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Vijay K. Gurbani
Sent: Monday, January 03, 2011 5:56 PM
To: [email-masked]
Subject: [cuss] Consensus call: Choosing a mechanism

Thank you in advance.

Vijay K. Gurbani and Enrico Marocco
IETF CUSS WG co-chairs
_______________________________________________
cuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cuss

---

From: Laura Liess <[email-masked]>
Date: Tue, 4 Jan 2011 11:34:52 +0100

New Header Field approach.
Laura

---

From: <[email-masked]>
Date: Tue, 4 Jan 2011 11:43:08 +0100

Hello all and happy new year,

New header 

Regards

Frédérique 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Vijay K. Gurbani
Envoyé : lundi 3 janvier 2011 16:56
À : [email-masked]
Objet : [cuss] Consensus call: Choosing a mechanism

Folks: One output of the Virtual-II meeting was that we need to converge to a specific mechanism for transporting UUI in order to move other chartered work ahead.

There are three mechanisms listed in [1]: body, URI parameter and new header field. We have discussed these options in two interim calls and in Beijing. [1] favors the new header field approach.

During the CUSS Virtual-II meeting held on Dec-21-2010 (minutes available at [2]), we further discussed the mechanisms and there were no objections voiced to moving forward using the header field mechanism.  In addition, individual folks have expressed an opinion on the WG mailing list to choose the header field approach.

So, the chairs would like to formally call for consensus on the mechanism, specifically:

Please send comments on this consensus call to the list by Wednesday, January-12-2011.  Please do send a mail to the list, even if your comment a simple "yes" or "no".

Thank you in advance.

---

From: <[email-masked]>
Date: Tue, 4 Jan 2011 12:13:28 +0100

"yes" for Header approach.

Best Regards

Roland

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] Im
> Auftrag von Vijay K. Gurbani
> Gesendet: Montag, 3. Januar 2011 16:56
> An: [email-masked]
> Betreff: [cuss] Consensus call: Choosing a mechanism
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 4 Jan 2011 12:45:43 +0100

Header field.

Regards,

Christer 

> Sent: 3. tammikuuta 2011 17:56
> To: [email-masked]
> Folks: One output of the Virtual-II meeting was that we need 
> to converge to a specific mechanism for transporting UUI in 
> order to move other chartered work ahead.
> 
> There are three mechanisms listed in [1]: body, URI parameter 
> and new header field. We have discussed these options in two 
> interim calls and in Beijing. [1] favors the new header field 
> approach.
> 
> During the CUSS Virtual-II meeting held on Dec-21-2010 
> (minutes available at [2]), we further discussed the 
> mechanisms and there were no objections voiced to moving 
> forward using the header field mechanism.  In addition, 
> individual folks have expressed an opinion on the WG mailing 
> list to choose the header field approach.
> 
> Wednesday, January-12-2011.  Please do send a mail to the 
> list, even if your comment a simple "yes" or "no".
> 
> Thank you in advance.
>

---

From: "Janet Byron (jbyron)" <[email-masked]>
Date: Tue, 4 Jan 2011 06:18:53 -0600

Yes, header field.

Janet

---

From: "Frank Williams (frwillia)" <[email-masked]>
Date: Tue, 4 Jan 2011 08:18:26 -0600

The new header field approach is the preferred mechanism.

Regards,

Frank Williams

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Vijay K. Gurbani
Sent: Monday, January 03, 2011 10:56 AM
To: [email-masked]
Subject: [cuss] Consensus call: Choosing a mechanism

Thank you in advance.

---

From: James Rafferty <[email-masked]>
Date: Tue, 4 Jan 2011 09:44:55 -0500

New Header Field.  

James

James Rafferty 
Product Line Director, Integrated Media Gateways 
Dialogic, Inc.  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Vijay K. Gurbani
Sent: Monday, January 03, 2011 10:56 AM
To: [email-masked]
Subject: [cuss] Consensus call: Choosing a mechanism

Thank you in advance.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 4 Jan 2011 16:54:53 +0100

I favour the header field approach.

I believe with the body approach, we would still need considerable work in the header part to indicate what the body relates to (when multiple UUI is provided as a result of redirection), and putting the data in the body is just an added complication.

For the URI solution, I fail to see how the UUI relates to a specific URI. Is it an attribute of the sending URI or the receiving URI for example?

regards

Keith

> Sent: Monday, January 03, 2011 3:56 PM
> To: [email-masked]

---

From: Alan Johnston <[email-masked]>
Date: Wed, 5 Jan 2011 14:45:36 -0600

I think we should move forward with the header field mechanism.

- Alan -

---

From: Shida Schubert <[email-masked]>
Date: Thu, 6 Jan 2011 22:21:45 +0800

I favor the header approach as well. 

 Regards
  Shida

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 10 Jan 2011 17:49:25 +0100

> Sent: 03 January 2011 15:56
> To: [email-masked]
[JRE] Yes

John

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 11 Jan 2011 09:53:41 +0100

Pro new header field approach
Christian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext Vijay K. Gurbani
Sent: Monday, January 03, 2011 4:56 PM
To: [email-masked]
Subject: [cuss] Consensus call: Choosing a mechanism

Thank you in advance.