Subject: [cuss] Last Call: <draft-ietf-cuss-sip-uui-10.txt> (A Mechanism for Transporting User to User Call Control Information in SIP) to Proposed Standard

From: The IESG <[email-masked]>
Date: Wed, 15 May 2013 08:57:37 -0700

The IESG has received a request from the Call Control UUI Service for SIP
WG (cuss) to consider the following document:
- 'A Mechanism for Transporting User to User Call Control Information in
   SIP'
  <draft-ietf-cuss-sip-uui-10.txt> as Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action. Please send substantive comments to the
[email-masked] mailing lists by 2013-05-29. Exceptionally, comments may be
sent to [email-masked] instead. In either case, please retain the
beginning of the Subject line to allow automated sorting.

Abstract

   There is a class of applications which benefit from using SIP to
   exchange User to User Information (UUI) data during session
   establishment.  This information, known as call control UUI data, is
   a small piece of data inserted by an application initiating the
   session, and utilized by an application accepting the session.  The
   rules which apply for a specific application are defined by a UUI
   package.  This UUI data is opaque to SIP and its function is
   unrelated to any basic SIP function.  This document defines a new SIP
   header field, User-to-User, to transport UUI data, along with an
   extension mechanism.

The file can be obtained via
http://datatracker.ietf.org/doc/draft-ietf-cuss-sip-uui/

IESG discussion can be tracked via
http://datatracker.ietf.org/doc/draft-ietf-cuss-sip-uui/ballot/

No IPR declarations have been submitted directly on this I-D.

---

From: <[email-masked]>
Date: Thu, 16 May 2013 07:58:24 +0000

Hello,

I look at the new version draft-ietf-cuss-sip-uui-10.txt and I don't understand why "encoding" parameter name has been changed into "content" in section 4.1 (so there is "content" twice). Could you please explain? Is it an editorial mistake? Thank you in advance.
Regards,

Celine Serrut-Valette
Orange Labs

Extract from 4.1.  Syntax for UUI Header Field:

        cont-param   = "content" EQUAL cont-param-value
        cont-param-value = token
        enc-param   = "content" EQUAL enc-param-value
        enc-param-value = token / "hex"

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de The IESG
Envoyé : mercredi 15 mai 2013 17:58
À : IETF-Announce
Cc : [email-masked]
Objet : [cuss] Last Call: <draft-ietf-cuss-sip-uui-10.txt> (A Mechanism for Transporting User to User Call Control Information in SIP) to Proposed Standard

The IESG has received a request from the Call Control UUI Service for SIP WG (cuss) to consider the following document:
- 'A Mechanism for Transporting User to User Call Control Information in
   SIP'
  <draft-ietf-cuss-sip-uui-10.txt> as Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits final comments on this action. Please send substantive comments to the [email-masked] mailing lists by 2013-05-29. Exceptionally, comments may be sent to [email-masked] instead. In either case, please retain the beginning of the Subject line to allow automated sorting.

Abstract

_______________________________________________
cuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cuss

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Alan Johnston <[email-masked]>
Date: Thu, 16 May 2013 11:57:20 -0500

Hi Celine,

Yes, that is a typo.  The line in the ABNF should be:

     enc-param   = "encoding" EQUAL enc-param-value

- Alan -

On Thu, May 16, 2013 at 2:58 AM, <[email-masked]> wrote:

> Hello,
>
> I look at the new version draft-ietf-cuss-sip-uui-10.txt and I don't
> understand why "encoding" parameter name has been changed into "content" in
> section 4.1 (so there is "content" twice). Could you please explain? Is it
> an editorial mistake? Thank you in advance.
> Regards,
>
> Celine Serrut-Valette
> Orange Labs
>
> Objet : [cuss] Last Call: <draft-ietf-cuss-sip-uui-10.txt> (A Mechanism
> for Transporting User to User Call Control Information in SIP) to Proposed
> Standard
>
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> As emails may be altered, France Telecom - Orange is not liable for
> messages that have been modified, changed or falsified.
> Thank you.
>
>

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 16 May 2013 12:11:47 -0500

> enc-param   = "encoding" EQUAL enc-param-value

Alan, Celine: Do you think it is worth spinning a new version or should
we fix this typo during Auth-48?

Let's decide what to do and move ahead since Enrico and I will like to
get the ISDN I-D moving forward now that this one is in motion.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq