Subject: [Cwt-reg-review] [IANA #1158949] Requested review for IANA registration in draft-ietf-ace-oauth-params (cwt - CBOR Web Token Claims)

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Tue, 04 Feb 2020 19:31:09 +0000

Hi all,

Resending this request for draft-ietf-ace-oauth-params.

Thanks,

Sabrina Tanamal
Senior IANA Services Specialist

On Sat Dec 21 11:15:05 2019, [email-masked] wrote:
> Hello CWT registry reviewers,
> 
> 
> the IESG-designated experts for the CWT claims registry have asked me to
> send a review request to you about the "rs_cnf" claim registered here:
> 
> https://tools.ietf.org/html/draft-ietf-ace-oauth-params-07#section-9.2
> 
> Thank you in advance for you review comments.
> 
> Regards,
> 
> Ludwig
>

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Tue, 04 Feb 2020 19:32:07 +0000

Hi all,

Resending this request for draft-ietf-ace-oauth-authz.

Thanks,

Sabrina Tanamal

On Sat Dec 21 11:37:11 2019, [email-masked] wrote:
> send a review request to you about the claims registered here:
> 
> https://tools.ietf.org/html/draft-ietf-ace-oauth-authz-29#section-8.13
>

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Tue, 18 Feb 2020 21:05:58 +0000

Hi all, 

Thanks,

Sabrina Tanamal

---

From: Mike Jones <[email-masked]>
Date: Tue, 18 Feb 2020 22:41:32 +0000

I'm mostly OK with these registrations, however, DO NOT assign the value 9 to "scope".   Rather, please put it in the two-byte range - for instance, with the value 41.

				-- Mike

-----Original Message-----
From: Cwt-reg-review <[email-masked]> On Behalf Of Sabrina Tanamal via RT
Sent: Tuesday, February 18, 2020 1:06 PM
Cc: [email-masked]
Subject: [EXTERNAL] [Cwt-reg-review] [IANA #1158953] Requested review for IANA registration in draft-ietf-ace-oauth-authz (cwt - CBOR Web Token Claims)

Hi all, 

Thanks,

Sabrina Tanamal
 
> > the IESG-designated experts for the CWT claims registry have asked 
> > me to send a review request to you about the claims registered here:
> > 
> > https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fto
> > ols.ietf.org%2Fhtml%2Fdraft-ietf-ace-oauth-authz-29%23section-8.13&a
> > mp;data=02%7C01%7CMichael.Jones%40microsoft.com%7Ce23f64ac1ad74269c3
> > c408d7b4b65d45%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C63717656
> > 7656665548&amp;sdata=r01W5Bx0gJh9ZPH8eNS%2BY765CnGq11DkknsHYQ751Dk%3
> > D&amp;reserved=0
> > 

_______________________________________________
Cwt-reg-review mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fcwt-reg-review&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7Ce23f64ac1ad74269c3c408d7b4b65d45%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637176567656675543&amp;sdata=XxBhQmqxGkCRiBxh0PdhX2IJD8TnbwWl%2Feo8VUsHOsg%3D&amp;reserved=0

---

From: Mike Jones <[email-masked]>
Date: Tue, 18 Feb 2020 22:46:44 +0000

This specification is not requesting any CWT claims registrations, so I'm not sure why the expert review request is being made for them.

				-- Mike

-----Original Message-----
From: Cwt-reg-review <[email-masked]> On Behalf Of Sabrina Tanamal via RT
Sent: Tuesday, February 4, 2020 11:31 AM
Cc: [email-masked]
Subject: [EXTERNAL] [Cwt-reg-review] [IANA #1158949] Requested review for IANA registration in draft-ietf-ace-oauth-params (cwt - CBOR Web Token Claims)

Hi all,

Thanks,

Sabrina Tanamal

On Sat Dec 21 11:15:05 2019, [email-masked] wrote:
> the IESG-designated experts for the CWT claims registry have asked me 
> to send a review request to you about the "rs_cnf" claim registered here:
> 
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftool
> s.ietf.org%2Fhtml%2Fdraft-ietf-ace-oauth-params-07%23section-9.2&amp;d
> ata=02%7C01%7CMichael.Jones%40microsoft.com%7C8e006c58015f481625ed08d7
> a9a8cd61%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C6371644147899252
> 54&amp;sdata=cOoRFBs%2F5EEbiHErQE%2BfkX%2F9EIAZwo83LowwQ8nRew8%3D&amp;
> reserved=0
> 

_______________________________________________
Cwt-reg-review mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fcwt-reg-review&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7C8e006c58015f481625ed08d7a9a8cd61%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637164414789925254&amp;sdata=FAzzPtTScAzhAnOKjhZGH%2Bw2Rhoc6L%2F91d0vVljkye8%3D&amp;reserved=0

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Wed, 19 Feb 2020 16:47:17 +0000

Hi Mike, 

It looks like the CWT claim was also removed in the latest version of this document. 

Thanks for checking,

Sabrina

On Tue Feb 18 22:47:24 2020, [email-masked] wrote:
> This specification is not requesting any CWT claims registrations, so
> I'm not sure why the expert review request is being made for them.
> 
> -- Mike
> 
> Subject: [EXTERNAL] [Cwt-reg-review] [IANA #1158949] Requested review
> for IANA registration in draft-ietf-ace-oauth-params (cwt - CBOR Web
> Token Claims)
> 
> Hi all,
> 
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fcwt-
> reg-
> review&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7C8e006c58015f481625ed08d7a9a8cd61%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637164414789925254&amp;sdata=FAzzPtTScAzhAnOKjhZGH%2Bw2Rhoc6L%2F91d0vVljkye8%3D&amp;reserved=0

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Tue, 25 Feb 2020 23:58:39 +0000

Ludwig, Hannes,

Can you confirm that you can make the CBOR Web Token Claim change requested below?

We also have Chuck Mortimore listed as an expert for this registry, but our message to his Salesforce address bounced.

Best regards,

Amanda Baber
Lead IANA Services Specialist

On Tue Feb 18 22:42:22 2020, [email-masked] wrote:
> I'm mostly OK with these registrations, however, DO NOT assign the
> value 9 to "scope".   Rather, please put it in the two-byte range -
> for instance, with the value 41.
> 
> -- Mike
> 
> Subject: [EXTERNAL] [Cwt-reg-review] [IANA #1158953] Requested review
> for IANA registration in draft-ietf-ace-oauth-authz (cwt - CBOR Web
> Token Claims)
> 
> Hi all,
> 
> review&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7Ce23f64ac1ad74269c3c408d7b4b65d45%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637176567656675543&amp;sdata=XxBhQmqxGkCRiBxh0PdhX2IJD8TnbwWl%2Feo8VUsHOsg%3D&amp;reserved=0

---

From: Ludwig Seitz <[email-masked]>
Date: Sat, 29 Feb 2020 15:24:59 +0100

On 2020-02-26 00:58, Amanda Baber via RT wrote:
> We also have Chuck Mortimore listed as an expert for this registry,
> but our message to his Salesforce address bounced.
>
> Best regards,
>
> Amanda Baber Lead IANA Services Specialist
>

I strongly disagree with the assessment that the scope claim should be
pushed into the two-byte range.

The reason we introduced the scope claim is that an ACE RS typically
does not have a direct connection to the AS, and is therefore unable to
retrieve the scope of an access token from other sources than the access
token itself.  I therefore assert that ACE access tokens would often
need to contain this claim in order to inform the RS.
Since one of the major drivers of the ACE work has been to reduce the
authorization overhead (otherwise we could just have used vanilla OAuth
2.0), I find it strange to needlessly add to the overhead by making the
encoding of a frequently used claim longer than necessary.

I am willing to listen to the arguments that have lead the expert
reviewer to denying a value in the one-byte range, and discuss the
reasoning further on list.

Regards,

Ludwig

>> value 9 to "scope".   Rather, please put it in the two-byte range
>> - for instance, with the value 41.
>>
>> -- Mike
>>
>> -----Original Message----- From: Cwt-reg-review
>> <[email-masked]> On Behalf Of Sabrina Tanamal via
>> RT Sent: Tuesday, February 18, 2020 1:06 PM Cc:
>> [email-masked] Subject: [EXTERNAL] [Cwt-reg-review] [IANA
>> #1158953] Requested review for IANA registration in
>> draft-ietf-ace-oauth-authz (cwt - CBOR Web Token Claims)
>>
>> Hi all,
>>
>> Sabrina Tanamal Senior IANA Services Specialist
>>
>>>> the IESG-designated experts for the CWT claims registry have
>>>> asked me to send a review request to you about the claims
>>>> registered here:
>>>>
ols.ietf.org%2Fhtml%2Fdraft-ietf-ace-oauth-authz-29%23section-
>>>> 8.13&a
D&amp;reserved=0
>> _______________________________________________ Cwt-reg-review
>> mailing list [email-masked]
reg-