Subject: Re: [Dart] I-D Action: draft-ietf-dart-dscp-rtp-00.txt

From: Ben Campbell <[email-masked]>
Date: Tue, 5 Aug 2014 14:40:44 -0500

(as individual)

-- General

I concur with the editor's note to reorganize sections. On my first reading, I was going to comment that I thought we needed more focus on what is really likely to happen, e.g. with WebRTC. On a second reading, I think that's mostly okay, but the consolidation of the RTP sections might make it more clear.

-- Section 4, Bullets 3 and 4:

Should STP in bullet 4 be SCTP? If yes, then doesn't this bullet more tightly constrain things than bullet 3, to the point of making bullet 3 redundant? Or am I misreading something?

Thanks!

Ben.

On Jul 31, 2014, at 3:50 PM, Black, David <[email-masked]> wrote:

> As promised, here's the -00 dart WG draft.  I think I incorporated almost
> everything that was discussed in the meeting, but I've surely missed a
> few things - please comment (on list, or send me editorial changes directly).
> 
> I want to call attention to this Editor's Note on draft organization:
> 
>   [Editor's Note: Current section structure skips around topics
>   somewhat.  The editor suggests restructuring to put real-time/RTP
>   material first (new section 2, consisting of current sections 2, 2.1
>   and 3), then DiffServ Background (new section 3, consisting of
>   current sections 2.2, 2.3, 2.6 and 2.7, followed by discussion of
>   interactions (new section 4, consisting of current sections 2.4, 2.5
>   and 5) and guidelines (current section 4, renumbered to new section
>   5).]
> 
> If this change is made, I will submit a version that only contains the
> text rearrangement before making any other changes.  The "game plan" that
> I've discussed w/Ben (WG chair) is to revise the draft over about the next
> week with the resulting version going to WG Last Call, so reading this
> draft sooner rather than later might be a good idea.
> 
> Thanks,
> --David
> 
>> -----Original Message-----
>> From: I-D-Announce [mailto:[email-masked]] On Behalf Of
>> [email-masked]
>> Sent: Thursday, July 31, 2014 3:08 PM
>> To: [email-masked]
>> Cc: [email-masked]
>> Subject: I-D Action: draft-ietf-dart-dscp-rtp-00.txt
>> 
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories.
>> This draft is a work item of the DiffServ Applied to Real-time Transports
>> Working Group of the IETF.
>> 
>>        Title           : Differentiated Services (DiffServ) and Real-time
>> Communication
>>        Authors         : David Black
>>                          Paul Jones
>> 	Filename        : draft-ietf-dart-dscp-rtp-00.txt
>> 	Pages           : 23
>> 	Date            : 2014-07-31
>> 
>> Abstract:
>>   This document describes the interaction between Differentiated
>>   Services (DiffServ) network quality of service (QoS) functionality
>>   and real-time network communication, including communication based on
>>   the Real-time Transport Protocol (RTP).  DiffServ is based on network
>>   nodes applying different forwarding treatments to packets whose IP
>>   headers are marked with different DiffServ Code Points (DSCPs).  As a
>>   result, use of different DSCPs within a single traffic stream may
>>   cause transport protocol interactions (e.g., reordering).  In
>>   addition, DSCP markings may be changed or removed between the traffic
>>   source and destination.  This document covers the implications of
>>   these DiffServ aspects for real-time network communication, including
>>   RTCWEB.
>> 
>> 
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-dart-dscp-rtp/
>> 
>> There's also a htmlized version available at:
>> http://tools.ietf.org/html/draft-ietf-dart-dscp-rtp-00
>> 
>> 
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> _______________________________________________
>> I-D-Announce mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/i-d-announce
>> Internet-Draft directories: http://www.ietf.org/shadow.html
>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> _______________________________________________
> Dart mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dart

---

From: "Black, David" <[email-masked]>
Date: Tue, 5 Aug 2014 19:34:27 -0400

Ben,

Thank you for reviewing this draft.

> I concur with the editor's note to reorganize sections.

Thank you - anyone else care to weigh in?

> Should STP in bullet 4 be SCTP?

Yes, I'd plead gasoline fumes ;-), but I actually missed this in rapid-fire
editing to try to pick up everything from the productive Toronto dart meeting.

> If yes, then doesn't this bullet more tightly
> constrain things than bullet 3, to the point of making bullet 3 redundant? Or
> am I misreading something?

I think that's correct - bullets 3 and 4 should be combined.

Thanks,
--David

> From: Ben Campbell [mailto:[email-masked]]
> Sent: Tuesday, August 05, 2014 3:41 PM
> To: Black, David
> Cc: [email-masked]
> Subject: Re: [Dart] I-D Action: draft-ietf-dart-dscp-rtp-00.txt
> 
> (as individual)
> 
> -- General
> 
> I concur with the editor's note to reorganize sections. On my first reading, I
> was going to comment that I thought we needed more focus on what is really
> likely to happen, e.g. with WebRTC. On a second reading, I think that's mostly
> okay, but the consolidation of the RTP sections might make it more clear.
> 
> Should STP in bullet 4 be SCTP? If yes, then doesn't this bullet more tightly
> constrain things than bullet 3, to the point of making bullet 3 redundant? Or
> am I misreading something?
> 
> Thanks!
> 
> Ben.
>