Subject: [datatracker-rqmts] Slides for the face-to-face BoF next week

From: Paul Hoffman <[email-masked]>
Date: Mon, 1 Nov 2010 15:28:03 -0700

Greetings again. I have uploaded the proposed slides for the BoF to the IETF site; see <http://www.ietf.org/proceedings/79/slides/iddtspec-0.pdf>.

Of course, it would be swell if people wanted to talk about any of the topics in the draft or proposed in the slides before the meeting. :-)

--Paul Hoffman, Director
--VPN Consortium

---

From: SM <[email-masked]>
Date: Tue, 02 Nov 2010 08:04:13 -0700

Hi Paul,
At 15:28 01-11-10, Paul Hoffman wrote:
>Greetings again. I have uploaded the proposed slides for the BoF to 
>the IETF site; see <http://www.ietf.org/proceedings/79/slides/iddtspec-0.pdf>.

On Page 12:

  "Lots of reasons why someone would not
   someone else to know which drafts they are
   following"

Did you forget a word in there?

That page is about "Lists should be able to be private".  Do you 
really want to get into a discussion about privacy?  As the work of 
the IETF is supposed to be open, I suggest letting anyone who is 
"subscribed" to a draft see who else is following it.  Otherwise, 
you'll have to define who should have access to the information.

Regards,
-sm

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 2 Nov 2010 08:36:32 -0700

>Did you forget a word in there?

Yes; "want". Will fix.

>That page is about "Lists should be able to be private".  Do you really want to get into a discussion about privacy?  As the work of the IETF is supposed to be open, I suggest letting anyone who is "subscribed" to a draft see who else is following it.

That seems a tad radical to me. How do others feel about this?

When you say "who else", do you mean "which other lists include this draft" or "which people who created a list which includes this draft"?

>  Otherwise, you'll have to define who should have access to the information.

Correct: there was an implicit definition (that I can make explicit) of "the person who created the list, whomever that person gives access to, and no one else".

--Paul Hoffman, Director
--VPN Consortium

---

From: Fred Baker <[email-masked]>
Date: Tue, 2 Nov 2010 09:15:00 -0700

> Of course, it would be swell if people wanted to talk about any of the topics in the draft or proposed in the slides before the meeting. :-)

Thanks for pointing out the slides.

One of the slides wonders what the rule is for identifying drafts associated with a working group. As I'm sure you know, there has been a convention for a long time in naming: draft-ietf-<wg>-*-nn.txt is a working group draft, and draft-<author>-<wg>-*-nn.txt is an individual submission to a working group. draft monikers that mention no working group are general submissions going nowhere in particular. I'm pretty sure that Henrik's existing tool looks for "draft-ietf-<wg>" and "anything containing <wg>" for the two areas.

I like the convention; I find it useful. I do go a little crazy with the set of people that don't choose to use it, though; I get people posting drafts and then wanting to discuss them for several meetings in my WG but not follow the convention, which means that I have to manually track things. Since a "convention" is not a "rule" (eg, I don't care to be a hard-ass about it), I put in the extra work, but there is a part of me that would like the tool to be able to remember for me in some sense. "documents that follow the convention plus those I add".

Something else the slides note - there could be some pain in various forms regarding personal lists. There might be; I'm not sure why anyone would want to know what drafts I was tracking (it's not like we have drafts about specialized delivery of pornography or etc), but I could imagine someone trying to do corporate intelligence by tracking who is tracking what drafts. A simple solution would be to keep our private lists on our private computers. That might, for example, be a reasonable use of a cookie or some kind of local preferences file. If we're keeping the list on the machine, I would think that per-user lists would not be used in daily processing; they would be compiled into a set of rules of the form "if a draft whose name matches /<regex>/ changes, notify {list}". Individual draft names are an obvious special case, as are /draft-*-<wg>-*.txt/.

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 02 Nov 2010 17:23:24 +0100

Hi,

> you'll have to define who should have access to the information.

No, I think that's turned around.  I think it's as wrong to assume that
personal configuration information is public by default.  With the
possibility to create personal configuration information which resides
on the server (something we haven't really had a lot of on the IETF
servers up till now) the assumption should be that that individual
configuration information is private unless the person chooses to make
it public.

This following isn't an exact parallel, but with email, we have a
situation where list email is public, and the whole purpose of list
emails are to reach people publicly; while emails sent to individual
persons outside of a list are not (and should not be) automatically
assumed to be public.  Thus information is only automatically public
when it's explicitly intended to be so.

When you bookmark web pages in your web browser the information is
private, unless you explicitly publish the information.  When you
subscribe to a feed, that information resides in your feed reader
(or in the Google Reader) and it's not public unless you make it
so.

With the possibility to individually configure services provided by
the IETF servers, we should (I think) respect that people don't
necessarily want others to know what they configure.  If they want
people to know, they are free to make the information public, but
we shouldn't force the information to be public.  That would most
likely make these services less valuable than they could be to a lot
of people, and that seems less than optimal to me.

	Henrik

---

From: "Russ Housley" <[email-masked]>
Date: Tue, 2 Nov 2010 12:36:09 -0400 (EDT)

> Greetings again. I have uploaded the proposed slides for the BoF to the
> IETF site; see <http://www.ietf.org/proceedings/79/slides/iddtspec-0.pdf>.
>
> Of course, it would be swell if people wanted to talk about any of the
> topics in the draft or proposed in the slides before the meeting. :-)

What legal issues do you see if an account-based system is used?  The
community already uses wikis that require an account.  How is this
different?

Russ

---

From: Royer Software and Services <[email-masked]>
Date: Tue, 02 Nov 2010 10:44:53 -0600

> That seems a tad radical to me. How do others feel about this?

Who cares who watches?  And who cares who watches the watchers?

I have seen well meaning people have meetings and make agreements about 
drafts, then forget and
just assume that the idea was part of the consensus on the list.

I would opt for everything as open as possible. The less secrets the 
IETF has the healthier it will remain
as there will be no dark corners that other can assume contain hidden 
agreements or ideas.

--
Doug - Royer Software and Services

http://Project-Contracting.com
(208) 806-1358 / (714) 989-6135

---

From: Royer Software and Services <[email-masked]>
Date: Tue, 02 Nov 2010 10:57:26 -0600

(1) On page 13 it says:

– If someone forgets their list name, they can just create a new one

How about monthly (or whatever) reminder emails? Like the other lists have.

(2) Maybe I missed it. Should the list creator be able to disable/delete 
the list?

--

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 2 Nov 2010 10:01:05 -0700

>community already uses wikis that require an account.  How is this

It is not clear that it is different, but it might be. I don't know of any private information that can be kept on the IETF wikis, but we are talking here about private lists (unless folks agree with SM). If there is private information on the IETF wikis, has anyone asked "the IETF lawyers" about it?

--Paul Hoffman, Director
--VPN Consortium

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 2 Nov 2010 10:04:06 -0700

At 10:44 AM -0600 11/2/10, Royer Software and Services wrote:
>I have seen well meaning people have meetings and make agreements about drafts, then forget and

This as nothing to do with the content of drafts; it is about watching which drafts change over time.

>I would opt for everything as open as possible. The less secrets the IETF has the healthier it will remain
>as there will be no dark corners that other can assume contain hidden agreements or ideas.

I'm deeply confused here. As described in the draft, a list is a personal preference of what to see. There is no "agreement" or "idea" involved. Which part of the draft are you talking about?

--Paul Hoffman, Director
--VPN Consortium

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 2 Nov 2010 10:10:57 -0700

>of people, and that seems less than optimal to me.

My thinking in the early draft was that "making a list" was akin to "bookmarking a lot of drafts". That is, this is what many people do today anyhow, and the IETF can make this easier. Does the fact that it is the IETF making this easier cause the information to have to be exposed to everyone?

--Paul Hoffman, Director
--VPN Consortium

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 2 Nov 2010 10:14:24 -0700

>I like the convention; I find it useful. I do go a little crazy with the set of people that don't choose to use it, though; I get people posting drafts and then wanting to discuss them for several m…

Henrik: I believe that some actual WG drafts do not follow the draft-ietf-wgname rule. Is that true? If so, how does the Datatracker know to show them in the WG charter page? Is that done by hand?

--Paul Hoffman, Director
--VPN Consortium

---

From: Royer Software and Services <[email-masked]>
Date: Tue, 02 Nov 2010 11:16:25 -0600

> I'm deeply confused here. As described in the draft, a list is a personal preference of what to see. There is no "agreement" or "idea" involved. Which part of the draft are you talking about?
I thought this thread was about the PDF file, not a draft submitted.

I read that PDF file section as is who is watching the drafts. I did not 
understand it to mean personal preferences.
--

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 2 Nov 2010 10:18:24 -0700

>Something else the slides note - there could be some pain in various forms regarding personal lists. There might be; I'm not sure why anyone would want to know what drafts I was tracking (it's not l…

This is definitely a possibility for the tool. If people don't want to use the tool's list-making (such as if SM and Doug's proposal is accepted and someone has the concern you give above), the tool could have a mode of "give me your list and your preferences in an HTTP request and I'll give you a display like the one I would have done if you kept the list with me". I don't know how we could handle making an Atom feed or mail stream for those folks.

--Paul Hoffman, Director
--VPN Consortium

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 2 Nov 2010 10:20:45 -0700

At 10:57 AM -0600 11/2/10, Royer Software and Services wrote:
>(1) On page 13 it says:
>
>- If someone forgets their list name, they can just create a new one
>
>
>(2) Maybe I missed it. Should the list creator be able to disable/delete the list?

Both good points. Added.

--Paul Hoffman, Director
--VPN Consortium

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 2 Nov 2010 10:24:43 -0700

At 11:16 AM -0600 11/2/10, Royer Software and Services wrote:
>I read that PDF file section as is who is watching the drafts. I did not understand it to mean personal preferences.

The slides refer to the Internet Draft that is the topic of this BoF listed on slide 2: draft-ietf-genarea-datatracker-community-01.

--Paul Hoffman, Director
--VPN Consortium

---

From: Fred Baker <[email-masked]>
Date: Tue, 2 Nov 2010 10:28:04 -0700

> Henrik: I believe that some actual WG drafts do not follow the draft-ietf-wgname rule. Is that true? If so, how does the Datatracker know to show them in the WG charter page? Is that done by hand?

Drafts that the secretariat understands to be working group drafts follow the convention. To test that assertion, pick a working group and try filing a draft named draft-ietf-<wg>-*.txt. You will find the secretariat contacting the chair for permission to post it.

That doesn't stop chairs from treating individual submissions to the working group as if they were working group drafts. I suspect we all do that; I know I do for small projects that are within charter but have a relatively narrow interest group. Where it gets crazy is people who disregard the convention entirely, as the tools have no organizing handle. A part of me wants to tell them to get their act together.

---

From: SM <[email-masked]>
Date: Tue, 02 Nov 2010 11:54:55 -0700

Hello,
At 08:36 02-11-10, Paul Hoffman wrote:
>When you say "who else", do you mean "which other lists include this 
>draft" or "which people who created a list which includes this draft"?

I meant who are the people who created a list which includes this draft.

>Correct: there was an implicit definition (that I can make explicit) 
>of "the person who created the list, whomever that person gives 
>access to, and no one else".

That sounds fine unless we go down the path where the "following" is 
used as a measure of whether there is interest in a proposal.

At 09:15 02-11-10, Fred Baker wrote:
>Something else the slides note - there could be some pain in various 
>forms regarding personal lists. There might be; I'm not sure why 
>anyone would want to know what drafts I was tracking (it's not like 
>we have drafts about specialized delivery of pornography or etc), 
>but I could imagine someone trying to do corporate intelligence by 
>tracking who is tracking what drafts. A simple solution would be to 
>keep our private lists on our private

Yes.

>configuration information is private unless the person chooses to make

If the information is labeled as "personal configuration", it keeps 
out the privacy discussion.

>when it's explicitly intended to be so.

I, probably incorrectly, drew a parallel between the current mailing 
lists setup and this feature.

>necessarily want others to know what they configure.  If they want

Agreed.

At 10:18 02-11-10, Paul Hoffman wrote:
>This is definitely a possibility for the tool. If people don't want 
>to use the tool's list-making (such as if SM and Doug's proposal is 
>accepted and someone has the concern you give above), the tool could 
>have a mode of "give me your list and your preferences in an HTTP 
>request and I'll give you a display like the one I would have done 
>if you kept the list with me". I don't know how we could handle 
>making an Atom feed or mail stream for those folks.

You could remind people that this tool is about letting "people keep 
track of changes in Internet Drafts".  Shared (public) lists could 
then be about tagging drafts by field of interest, e.g WG, drafts on 
v6 transition, etc. and sharing the list for reasons stated on Page 14.

Regards,
-sm

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 03 Nov 2010 09:28:48 +0200

Reiterating and possibly clarifying what others have said in the past:

I think about 80% of this project is a waste of IETF resources.

I suggest that we concentrate ONLY on providing very granular Atom feeds 
for draft status changes, Then, we can leave everything else (graphic 
presentation, update periods, privacy, sharing) to the users. People can 
use desktop RSS readers, or the easier but more limited Web-based 
alternatives, e.g. Google Reader.

With the proposal on the table, what we're getting ourselves into is yet 
another enterprise-level Web application, with all that that involves. 
Yes, even Web application security.

Thanks,
	Yaron

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 03 Nov 2010 11:26:37 +0100

> At 5:23 PM +0100 11/2/10, Henrik Levkowetz wrote:

...

>> With the possibility to individually configure services provided
>> by the IETF servers, we should (I think) respect that people don't 
>> likely make these services less valuable than they could be to a
>> lot of people, and that seems less than optimal to me.
> 
> My thinking in the early draft was that "making a list" was akin to
> "bookmarking a lot of drafts". That is, this is what many people do
> today anyhow, and the IETF can make this easier. Does the fact that
> it is the IETF making this easier cause the information to have to be
> exposed to everyone?

My thinking is that it does not -- we should not have to expose this
to everyone.  If that wasn't clear from my lengthier exposition...

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 03 Nov 2010 11:29:52 +0100

Hi Paul,

On 2010-11-02 18:14 Paul Hoffman said:
>> One of the slides wonders what the rule is for identifying drafts
>> associated with a working group. As I'm sure you know, there has
>> been a convention for a long time in naming:
>> draft-ietf-<wg>-*-nn.txt is a working group draft, and
>> draft-<author>-<wg>-*-nn.txt is an individual submission to a
>> working group. draft monikers that mention no working group are
>> general submissions going nowhere in particular. I'm pretty sure
>> that Henrik's existing tool looks for "draft-ietf-<wg>" and
>> "anything containing <wg>" for the two areas.
>> 
>> I like the convention; I find it useful. I do go a little crazy
>> with the set of people that don't choose to use it, though; I get
>> people posting drafts and then wanting to discuss them for several
>> meetings in my WG but not follow the convention, which means that I
>> have to manually track things. Since a "convention" is not a "rule"
>> (eg, I don't care to be a hard-ass about it), I put in the extra
>> work, but there is a part of me that would like the tool to be able
>> to remember for me in some sense. "documents that follow the
>> convention plus those I add".
> 
> Henrik: I believe that some actual WG drafts do not follow the
> draft-ietf-wgname rule. Is that true? If so, how does the Datatracker
> know to show them in the WG charter page? Is that done by hand?

For WG drafts, the database has explicit data which identifies a draft
as belonging to the WG.  This is independent of the naming convention.
For individual drafts, there is currently no explicit tagging in the
database which tells us that a particular draft is 'related to' a
certain WG.

Best,

	Henrik

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 3 Nov 2010 06:57:51 -0700

At 9:28 AM +0200 11/3/10, Yaron Sheffer wrote:
>I suggest that we concentrate ONLY on providing very granular Atom feeds for draft status changes, Then, we can leave everything else (graphic presentation, update periods, privacy, sharing) to the users. People can use desktop RSS readers, or the easier but more limited Web-based alternatives, e.g. Google Reader.
>
>With the proposal on the table, what we're getting ourselves into is yet another enterprise-level Web application, with all that that involves. Yes, even Web application security.

A clarifying question: If we have such granular per-draft Atom feeds (which is not at all difficult to create), are you proposing that the user must subscribe to them one-by-one? That is, you see more cost than benefit to making an IETF-hosted tool that would help them select groups of drafts and to keep those groups up-to-date (such as when a new draft is added to a WG)?

--Paul Hoffman, Director
--VPN Consortium

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 03 Nov 2010 16:09:16 +0200

Hi Paul,

I can see two ways of dealing with this issue, there are probably more:

- Make the Atom feeds not only per-draft, but more sophisticated. 
Example feed templates:

* All drafts authored by X
* All drafts of the Y WG (which we already have, BTW)
* All drafts whose name/title includes the term Z.

- Alternatively, we could publish and maintain OPML files for common 
collections, e.g. one per WG. [I know you dislike OPML, but it works for 
me]. But this in an inferior solution because people would have to 
update the OPML file (list of feeds) manually.

Thanks,
	Yaron

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 3 Nov 2010 07:20:14 -0700

At 4:09 PM +0200 11/3/10, Yaron Sheffer wrote:
>- Make the Atom feeds not only per-draft, but more sophisticated. Example feed templates:
>
>- Alternatively, we could publish and maintain OPML files for common collections, e.g. one per WG. [I know you dislike OPML, but it works for me]. But this in an inferior solution because people would have to update the OPML file (list of feeds) manually.

OK, I'm glad I asked. It sounds like you are in favor of some of the list-creation parts of the draft, but not the "my list is stored on the IETF server" part, and not in favor of "I can see my list displayed on the Datatracker web site" part. Is that a fair summary?

--Paul Hoffman, Director
--VPN Consortium

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 03 Nov 2010 16:59:28 +0200

Sort of. I think Atom feeds should be the only primitive provided, and 
the user should take it from there. It can be as easy as using Google 
Reader, or you can use a much fancier reader application.

The server should have no notion of lists who are owned by somebody, 
only of anonymous feeds. The draft mentions that feeds should be based 
on lists, but I see no reason to have lists in the first place.

One drawback of this direction is that there will be overlaps (e.g. 
between "documents of the IPsecME WG" and "Documents that have 'ipsec' 
in their title"). Perhaps some feed readers can de-duplicate such cases, 
I haven't seen any that do. Alternatively, we may have a powerful enough 
feed creation mechanism, so that you can specify the union of these two 
feeds as a single feed. Then you can sort/filter the resulting feed on 
the client side if necessary.

Thanks,
	Yaron

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 3 Nov 2010 09:09:37 -0700

Drilling down a bit more.

>I meant who are the people who created a list which includes this draft.

Attempt at summarizing: you want people who use the new tool to have to be authenticated, and anyone can see which of the authenticated people created a list that refers to a draft. Yes?

>That sounds fine unless we go down the path where the "following" is used as a measure of whether there is interest in a proposal.

If we don't go down that path (such as I explicitly say in this draft that it cannot be used for such measurements), do you still want the requirement above?

--Paul Hoffman, Director
--VPN Consortium

---

From: Barry Leiba <[email-masked]>
Date: Thu, 4 Nov 2010 20:45:42 +0800

> Attempt at summarizing: you want people who use the new tool to have
> to be authenticated, and anyone can see which of the authenticated people
> created a list that refers to a draft. Yes?

I'll make it simple here: if it should work this way, I will not use
it.  I'll just keep my own list, and check it twice.

Barry

---

From: SM <[email-masked]>
Date: Fri, 05 Nov 2010 01:16:36 -0700

Hi Paul,
At 09:09 03-11-10, Paul Hoffman wrote:
>to be authenticated, and anyone can see which of the authenticated 
>people created a list that refers to a draft. Yes?

No.  If we go by the arguments put forward by Henrik, this is a 
non-issue.  If these lists works along the same lines as IETF mailing 
list, these lists would have to be open.

>If we don't go down that path (such as I explicitly say in this 
>draft that it cannot be used for such measurements), do you still 
>want the requirement above?

No, I prefer not to use it for such measurements to keep matters simple.

Regards,
-sm

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 6 Nov 2010 06:31:37 -0700

At 1:16 AM -0700 11/5/10, SM wrote:
>No.  If we go by the arguments put forward by Henrik, this is a non-issue.  If these lists works along the same lines as IETF mailing list, these lists would have to be open.

OK, I'll remove this from the presentation then. If you can think of words I can put in the draft to make it clear that these lists-of-drafts are not discussion lists, I can do that.

Of course, if Yaron's preferences are adopted, this will be a non-issue.

--Paul Hoffman, Director
--VPN Consortium

---

From: Yaron Sheffer <[email-masked]>
Date: Sun, 07 Nov 2010 12:28:45 +0200

One more data point regarding the RSS/Atom option: in fact some feed 
readers are able to detect duplicates. At least my favorite reader, 
Liferea, can do it: 
http://liferea.blogspot.com/2007/02/item-duplicate-detection.html.

Thanks,
	Yaron

On 11/03/2010 04:57 PM, Yaron Sheffer wrote:
> feed creation mecha, so that you can specify the union of these two
> feeds as a single feed.
>
> Thanks,
> Yaron
>
>>> collections, e.g. one per WG. [I know you dislike OPML, but it works
>>> for me]. But this in an inferior solution because people would have
>>> to update the OPML file (list of feeds) manually.
>>
>> OK, I'm glad I asked. It sounds like you are in favor of some of the
>> list-creation parts of the draft, but not the "my list is stored on
>> the IETF server" part, and not in favor of "I can see my list
>> displayed on the Datatracker web site" part. Is that a fair summary?
>>
>> --Paul Hoffman, Director
>> --VPN Consortium

---

From: SM <[email-masked]>
Date: Sun, 07 Nov 2010 02:34:30 -0800

Hi Paul,
At 06:31 06-11-10, Paul Hoffman wrote:
>OK, I'll remove this from the presentation then. If you can think of 
>words I can put in the draft to make it clear that these 
>lists-of-drafts are not discussion lists, I can do that.

As there is a BoF for the project, I suggest letting people flush 
this out as the argument may still be brought forward even with a rewording.

>Of course, if Yaron's preferences are adopted, this will be a non-issue.

The problem with building such tools is that there are always some 
feature that are good to have.  Yaron's preferences [1] side step the issues.

Regards,
-sm

1. http://www.ietf.org/mail-archive/web/datatracker-rqmts/current/msg00020.html