Subject: [datatracker-rqmts] New Requirement

From: "Jim Schaad" <[email-masked]>
Date: Mon, 15 Nov 2010 01:17:38 -0800

I believe that there may be situations where one wishes to create lists
based on data that is private.  In this case either the list must not be
able to be made public or it must be restricted based on the same
constraints as the data.

An example of where this might occur is called for.

The ISE might desire to add a field to the data tracker listing the set of
people who either have or have been asked to review a document.  This field
is restricted to the ISE and the IESB.  If these people create a list based
on the existence of a name in this field then it could be considered to be
restricted to a small set of people.

Jim

---

From: Royer Software and Services <[email-masked]>
Date: Mon, 15 Nov 2010 12:17:37 -0700

Why would it be a secret as to who viewed, read, or reviewed public 
documents?

And how would anyone know that 'some-random-list-name' was an official
review directed by the ISE or IESB by X, Y, and  Z @somedomains ?

Royer Software and Services
http://Project-Contracting.com
(208) 806-1358 / (714) 989-6135

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 15 Nov 2010 11:30:45 -0800

At 12:17 PM -0700 11/15/10, Royer Software and Services wrote:
>Why would it be a secret as to who viewed, read, or reviewed public documents?

That's not what Jim said. His example was some private data in the Datatracker.

--Paul Hoffman, Director
--VPN Consortium

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 15 Nov 2010 14:39:02 -0500

> That's not what Jim said. His example was some private data in the Datatracker.

I don't have time for a more detailed comment right now, but do we
really think it a good idea to be adding private data to the
datatracker?  Public systems with private data in them are mostly a
nightmare.

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 15 Nov 2010 11:53:49 -0800

>datatracker?  Public systems with private data in them are mostly a

Henrik can comment more fully about the private data stored in the Datatracker. I'm pretty sure there is a bunch of it for the ISE, for the IESG, and so on.

--Paul Hoffman, Director
--VPN Consortium

---

From: Royer Software and Services <[email-masked]>
Date: Mon, 15 Nov 2010 13:18:01 -0700

I am not trying to be a pain. I just don't see the need for private. And 
the explanation
given in that post does not convince me that anyone could reach any 
dangerous, invasive,
disruptive, or anything else conclusions by knowing that some people are 
looking at something.

Adding private seems like a lot of access control issues that  can 
break, have some misconfiguration,
or software bug, that would not reveal the same information. With the 
terabytes of data posted on the net (daily?),
it would be easier for an employer to just look at the employees 
activities than to write a tool to
see what drafts there employee is looking at. (re: the example in the 
current draft).

I have read the draft. Who could tell what it meant that  someone is 
looking at stuff?

My point is, what's private mean here?

Would it be private that the draft changed? That some status changed? 
That someone is looking
for keyword 'oops'? What would be private? The drafts are not private. 
The status of a draft
is not private.

The name of the ISE is not private. The names of the IESB members is not 
private. They are
going to review the drafts anyway. So, that is not private.

The title of the draft  is :

     Requirements for Draft Tracking by the IETF Community in the 
Datatracker

Not 'Requirement of the IAB, IETF, IESB, ISE, ...'

So that argument posted does not seem on point - in my opinion.

If it is needed, then it is needed. I have just not seen anyone post a 
reason
that convinces me that it is needed.

I have no plans to pound on this issue. I am trying to understand it.

-Doug

---

From: Russ Housley <[email-masked]>
Date: Mon, 15 Nov 2010 15:31:01 -0500

> Henrik can comment more fully about the private data stored in the Datatracker. I'm pretty sure there is a bunch of it for the ISE, for the IESG, and so on.

The IESG has the ability to mark comments as private, but I have not
seen one in the last six years or more.

I think we should avoid non-public data unless it provides high value.
So, the question is whether private lists are sufficiently valuable.

Russ

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 15 Nov 2010 12:36:50 -0800

At 1:18 PM -0700 11/15/10, Royer Software and Services wrote:
>I am not trying to be a pain. I just don't see the need for private.

Private what? Private data that is already in the Datatracker (as Jim pointed out), or private lists (as are defined in the draft)? This is an important distinction.

>And the explanation
>given in that post does not convince me that anyone could reach any dangerous, invasive,
>disruptive, or anything else conclusions by knowing that some people are looking at something.

Again, that is not what Jim said. Let's try again:

>restricted to a small set of people.

There is nothing there about "knowing that some people are looking at something".

>Adding private seems like a lot of access control issues that  can break, have some misconfiguration,
>or software bug, that would not reveal the same information. With the terabytes of data posted on the net (daily?),
>it would be easier for an employer to just look at the employees activities than to write a tool to
>see what drafts there employee is looking at. (re: the example in the current draft).

The example in the current draft is not just about an employer looking. If I were looking for a job at XywCorp and created a list of all drafts written by XyzCorp employees, there are plenty of people I would not want to see my list.

>I have read the draft. Who could tell what it meant that  someone is looking at stuff?

I'm sorry, but I can't parse that question.

>My point is, what's private mean here?

See above.

>Would it be private that the draft changed? That some status changed? That someone is looking
>for keyword 'oops'? What would be private? The drafts are not private. The status of a draft
>is not private.

Correct. In the current draft, the *list of drafts* is private unless its creator makes it public. In the current Datatracker, some data is private.

>The name of the ISE is not private. The names of the IESB members is not private. They are

No one said it was.

>    Requirements for Draft Tracking by the IETF Community in the Datatracker
>

The IAB, IESG, and so on are members of the IETF community.

>If it is needed, then it is needed. I have just not seen anyone post a reason

Please re-read Jim's message again in light of my questions to you about what you mean by "private".

--Paul Hoffman, Director
--VPN Consortium

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 15 Nov 2010 19:53:13 -0800

First, not all drafts that go to the ISE are actually reviewed by just the
IESB.  Many times we will solicit reviewers from the general community.  Now
let's say that <Your favorite evil person> writes a draft and requests the
ISE to publish this document.  We come to you and ask you to review the
document.  You might come back with three different responses:

1.  Sure
2.  Only if my name does not get back to <evil person>
3.  No way.

In cases 2 and 3 we might want to record this information in the data
tracker so that we know who was asked and when they were asked to do
reviews.  This might give me (as a member of the IESB) a clue as to who was
previously asked in the event that somebody does not deliver a review and I
am trying to come up with a replacement.  At present this type of data is so
private it only resides on the ISE's computer and is not available to the
IESB where it might be useful.

Jim

> -----Original Message-----
> From: [email-masked] [mailto:datatracker-rqmts-
> [email-masked]] On Behalf Of Royer Software and Services
> Sent: Monday, November 15, 2010 11:18 AM
> To: [email-masked]
> Subject: Re: [datatracker-rqmts] New Requirement
> 
> 
> > I believe that there may be situations where one wishes to create
> > lists based on data that is private.  In this case either the list
> > must not be able to be made public or it must be restricted based on
> > the same constraints as the data.
> >
> > The ISE might desire to add a field to the data tracker listing the
> > set of people who either have or have been asked to review a document.
> > This field is restricted to the ISE and the IESB.  If these people
> > create a list based on the existence of a name in this field then it
> > could be considered to be restricted to a small set of people.
> >
> > Jim
> _______________________________________________
> datatracker-rqmts mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/datatracker-rqmts

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 21 Nov 2010 20:07:48 -0800

Greetings again. As promised, I have made massive revisions (mostly additions) to the draft based on the input at the BoF in Beijing and follow-up discussion. The new draft can be found at <http://www.ietf.org/internet-drafts/draft-ietf-genarea-datatracker-community-02.txt>.

It might have been silly for me to try to track all the changes in Appendix D, but some of y'all might want to check that I hit all the points given during the BoF.

All input is still welcome. At some point soon, I will start some focused threads, but feel free to start your own.

--Paul Hoffman, Director
--VPN Consortium

---

From: "Jim Schaad" <[email-masked]>
Date: Sun, 21 Nov 2010 23:32:34 -0800

Paul,

Some responses to this document.

1.  Is there perhaps a requirement for some type of mathematics of the
lists?   We currently have unions - i.e. make me a list of lists.  I don't
know that I can think of any good reason to have intersections (i.e. in all
of the following lists), but I can think that the subtraction operation
might be very useful.  I care about everything that this working group does
EXCEPT for the following documents.

2.  In section 2.1.6, I am wondering if I can put a list instead of a
particular RFC or particular draft in some of the locations?  I.e. can I get
a list of all of the drafts/rfcs that are referenced by the drafts/rfcs in
this list?  I can see it as being useful for some type of background
processing.  I.e. I need to figure out which drafts or RFCs I might care
about reading because they relate to the current set of drafts that I am
tracking.

3.  Section 2.2.2 - This section does not match exactly what I remember from
the discussion.  I remember that it should be possible to create an atom
feed that specifies exactly which events are to be sent.  (OK - I see this
in the open issue list.)

4. In Section 2.3.1 - You have a requirement that the display should only
show a single draft once.  Does the same requirement also apply to the atom
and e-mail feeds?

5.  In section 2.3.3 - you talk about having the flag on a draft in a list.
Do you really mean list or view of a list?  What happens if you have
multiple flags because the draft appears in multiple lists?

6.  In appendix B - It might be better to have a set of "pre-defined" lists
that are owned by tools team (or some such group) that contain the set of
good pre-defined lists that people want to see.  Such as: 
  WG - Std track documents
  WG - Non-std track documents
  WG - Agenda documents for next meeting.
  ....

Jim

> [email-masked]] On Behalf Of Paul Hoffman
> Sent: Sunday, November 21, 2010 8:08 PM
> Subject: [datatracker-rqmts] Community Datatracker draft -02
> 
> Greetings again. As promised, I have made massive revisions (mostly
additions)
> to the draft based on the input at the BoF in Beijing and follow-up
discussion.
> The new draft can be found at
<http://www.ietf.org/internet-drafts/draft-ietf-
> genarea-datatracker-community-02.txt>.
> 
> It might have been silly for me to try to track all the changes in
Appendix D, but
> some of y'all might want to check that I hit all the points given during
the BoF.
> 
> All input is still welcome. At some point soon, I will start some focused
threads,
> but feel free to start your own.
> 
> --Paul Hoffman, Director
> --VPN Consortium

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 22 Nov 2010 16:07:28 -0800

>EXCEPT for the following documents.

That seems pretty obscure and would have a difficult interface.

>about reading because they relate to the current set of drafts that I am

That, too, seems pretty obscure. What does "relates to" mean in this context?

>feed that specifies exactly which events are to be sent.  (OK - I see this

Right: it is an open issue for display, Atom, and mailing lists. It seems tractable to me, but I want to hear more from the group before adding it.

>show a single draft once.  Does the same requirement also apply to the atom

Not currently, but it could. Thoughts?

>multiple flags because the draft appears in multiple lists?

Good catch. I think I mean in the view of the list. Otherwise, the user would lose information when they put different dates on the draft and the Datatracker only shows them one of the records.

>  WG - Agenda documents for next meeting.

Not sure where this goes in Appendix B.

--Paul Hoffman, Director
--VPN Consortium

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 22 Nov 2010 18:10:44 -0800

> From: Paul Hoffman [mailto:[email-masked]]
> Sent: Monday, November 22, 2010 4:07 PM
> To: Jim Schaad; [email-masked]
> Subject: Re: [datatracker-rqmts] Community Datatracker draft -02
> 
> >know that I can think of any good reason to have intersections (i.e. in
> >all of the following lists), but I can think that the subtraction
> >operation might be very useful.  I care about everything that this
> >working group does EXCEPT for the following documents.
> 
> >particular RFC or particular draft in some of the locations?  I.e. can
> >I get a list of all of the drafts/rfcs that are referenced by the
> >drafts/rfcs in this list?  I can see it as being useful for some type
> >of background processing.  I.e. I need to figure out which drafts or
> >RFCs I might care about reading because they relate to the current set
> >of drafts that I am tracking.
> 

What I was looking at was starting with the statement

   o  All drafts that are referenced by a particular draft

But what I would like to do is to say
   All drafts that are referenced by any draft on list <XXXX>

> 
> >3.  Section 2.2.2 - This section does not match exactly what I remember
> >from the discussion.  I remember that it should be possible to create
> >an atom feed that specifies exactly which events are to be sent.  (OK -
> >I see this in the open issue list.)
> 
> Right: it is an open issue for display, Atom, and mailing lists. It seems
tractable
> to me, but I want to hear more from the group before adding it.
> 
> >4. In Section 2.3.1 - You have a requirement that the display should
> >only show a single draft once.  Does the same requirement also apply to
> >the atom and e-mail feeds?
> 

I would like not get the same message multiple times on a single document.
I think this would encourage my SPAM filters to think this is a spam sender.

> Good catch. I think I mean in the view of the list. Otherwise, the user
would lose
> information when they put different dates on the draft and the Datatracker
> only shows them one of the records.
> 
> >6.  In appendix B - It might be better to have a set of "pre-defined"
> >lists that are owned by tools team (or some such group) that contain
> >the set of good pre-defined lists that people want to see.  Such as:
> >  WG - Std track documents

Ok - I think that this may not go into appendix B, but would be a part of
2.1.6 except for the last item.  The thing that triggered this in my mind
was the comment on scraping agendas for the last bullet in Appendix B

jim

---

From: Tero Kivinen <[email-masked]>
Date: Tue, 23 Nov 2010 16:01:02 +0200

> > That seems pretty obscure and would have a difficult interface.

I do not think it is going to be any more obscure than having union of
two lists would be. I.e. if you have a way to take list1 and list2 and
generate new list3 which is union of those two lists, I do not really
see that big difference if there is a way to make new list by
substracting list2 from list1.

User interface could simply be:

	List A: [                         ]
	List B: [                         ]
	Operation: ( ) Union ( ) Intersection ( ) Substraction

Where the lists are list ids (or urls or whetever) and operation is
radiobutton.

Those people who really want to get such lists usually do understand
enough to make use of such features.

In some working groups there charter items which I am not that
interested in, and I would like to create list having drafts in that
WG except those relating charter item x (which would mean it would be
nice to have WG chair keeping up list of drafts per charter item). 
-- 
[email-masked]