Subject: [decade] Reviews of the Decade Survey draft

From: "Woundy, Richard" <[email-masked]>
Date: Wed, 15 Dec 2010 20:13:53 +0000

Folks,

We would like to prepare the survey draft, draft-ietf-decade-survey-01<http://datatracker.ietf.org/doc/draft-ietf-decade-survey/>, for working group last call in January.

The chairs are looking for document reviews to be sent to the mailing list by Wednesday December 29. We already have three volunteers from our session in Beijing. Additional draft reviews by the deadline would be timely and greatly appreciated.

After the authors incorporate the feedback from the reviews in a new draft iteration, the chairs expect to take the draft to WGLC.

-- Rich

---

From: "Rahman, Akbar" <[email-masked]>
Date: Wed, 15 Dec 2010 16:42:21 -0500

Hi Rich,

We did a small update to our  DECADE Survey draft to capture the
following main points:

   1) Re-ordered "Informative References" to match order that they

   appear in the text.  Also changed the DECADE Problem Statement and

   Requirements references to the WG documents (from the original

   individual author documents).

   2) Updated text of NDN section (sec 4.6) as per off line comments

   received from Lucy Yong.

   3) Added a new section on NetInf section (sec 4.7) as per off line

   comments received from Borje Ohlman.

So, we would appreciate it if three volunteer reviewers take a look at
the Rev. 02 version of our Survey draft:

http://www.ietf.org/internet-drafts/draft-ietf-decade-survey-02.txt

Sincerely,

Akbar

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Woundy, Richard
Sent: Wednesday, December 15, 2010 3:14 PM
To: [email-masked]'
Subject: [decade] Reviews of the Decade Survey draft

Folks,

We would like to prepare the survey draft, draft-ietf-decade-survey-01
<http://datatracker.ietf.org/doc/draft-ietf-decade-survey/> , for
working group last call in January.

The chairs are looking for document reviews to be sent to the mailing
list by Wednesday December 29. We already have three volunteers from our
session in Beijing. Additional draft reviews by the deadline would be
timely and greatly appreciated.

After the authors incorporate the feedback from the reviews in a new
draft iteration, the chairs expect to take the draft to WGLC.

-- Rich

---

From: "Woundy, Richard" <[email-masked]>
Date: Fri, 17 Dec 2010 23:58:33 +0000

Thanks, Akbar.

Survey draft reviewers, please use draft-ietf-decade-survey-02<http://datatracker.ietf.org/doc/draft-ietf-decade-survey/> as the basis of your review.

-- Rich

From: Rahman, Akbar [mailto:[email-masked]]
Sent: Wednesday, December 15, 2010 4:42 PM
To: Woundy, Richard
Cc: [email-masked]
Subject: RE: [decade] Reviews of the Decade Survey draft

Hi Rich,

We did a small update to our  DECADE Survey draft to capture the following main points:

So, we would appreciate it if three volunteer reviewers take a look at the Rev. 02 version of our Survey draft:

Sincerely,

Akbar

From: [email-masked] [mailto:[email-masked]] On Behalf Of Woundy, Richard
Sent: Wednesday, December 15, 2010 3:14 PM
To: [email-masked]'
Subject: [decade] Reviews of the Decade Survey draft

Folks,

-- Rich

---

From: "zhangyunfei" <[email-masked]>
Date: Mon, 27 Dec 2010 17:33:26 +0800

First of all happy new year to everybody! 

The following is my WG review of draft-ietf-decade-survey-02.
 
Summary:
 
This document surveys thoroughly deployed, experimental and on-research in-network storage and cache systems/ sub-systems 
and describes their applicability for DECADE. It provides rich references for knowing what the existing systems have and 
what they lack of. Therefore the designing space of DECADE is explicated for better understanding. The draft is well written and 
conveys the group's intent well.
The authors are suggested to categorize the surveyed systems/sub-systems as user-controlled (individual) services (in scope of DECADE) 
and network-controlled (mass) services (out of scope of DECADE) to make it more focus on DECADE type services.
 
Specific comments and concerns:
1．  The organization of section 4: In this section the authors survey thoroughly deployed, experimental and on-research in-network storage 
      and cache systems/ sub-systems. However some of them are user-controlled (individual) services like section 4.1, 4.2,4.9,4.10 and 
     part of 4.12, which are in scope of DECADE; others are network controlled(mass) services where the users have no rights to operate
    the in-network storage or caches, which are out of scope of DECADE. The current organization is a little bit messy and it’s suggested 
    to separate the two parts and focus on the DECADE type services.
2．  Difference between cache and storage: In section 4, there are many places to mention in-network caches. In network-controlled 
     caches, it’s hard to introduce DECADE service because some of the operations defined in DECADE like data deletion in DECADE 
     server (if we use the current cache as the DECADE server) may raise confliction with the existing cache update mechanism 
     by Cache operators when dealing with a certain data. In section 4.14 the authors state the possible inapplicability for the cache scenarios 
     in using DECADE mechanism. But to make the draft more clear, it’s better to state explicit the scope of DECADE ahead of this section. 
    And also more discussions on whether and how much degree we need the cache system/subsystem description in this draft are needed in the group.
3.  In section 2, the No.1 effect of DECADE, to my understanding, is to improve P2P application experience in up-band constraint environment like 
    cellular mobile networks. The current draft lacks of this although this is highlighted in the PS.
4.  Data Search Capability described in section 3.3 seems irrelevant to DECADE protocols.
5.  In section 3.8 the authors propose three types of storage modes without explicit description. And the following echoes in section 4 still pose an 
     ambiguous image esp. between file and object oriented mode.
 
Nits
Section 2.2 Line2: to reducing->to reduce

Best regards,

Yunfei

zhangyunfei
2010-12-27

发件人： Woundy, Richard
发送时间： 2010-12-18 07:58:43
收件人： Rahman, Akbar
抄送： [email-masked]
主题： Re: [decade] Reviews of the Decade Survey draft

Thanks, Akbar.
 
Survey draft reviewers, please use draft-ietf-decade-survey-02 as the basis of your review.
 
-- Rich

Hi Rich,

 

 

Sincerely,
 
Akbar

Folks,
 
We would like to prepare the survey draft, draft-ietf-decade-survey-01, for working group last call in January.

 
-- Rich

---

From: "Rahman, Akbar" <[email-masked]>
Date: Wed, 29 Dec 2010 10:21:45 -0500

Hi Yunfei,

Thanks for your comments.  I will work with the other authors and do an update of the draft based on your suggestions by early January. 

Sincerely,

Akbar

From: [email-masked] [mailto:[email-masked]] On Behalf Of zhangyunfei
Sent: Monday, December 27, 2010 4:33 AM
To: [email-masked]
Subject: [decade] WG Reviews of the Decade Survey draft

The following is my WG review of draft-ietf-decade-survey-02 <http://datatracker.ietf.org/doc/draft-ietf-decade-survey/> .

Summary:

Nits

 

Best regards,

Yunfei

________________________________

zhangyunfei

2010-12-27

________________________________

发件人： Woundy, Richard

收件人： Rahman, Akbar

抄送： [email-masked]

Thanks, Akbar.

Survey draft reviewers, please use draft-ietf-decade-survey-02 <http://datatracker.ietf.org/doc/draft-ietf-decade-survey/>  as the basis of your review.

-- Rich

Hi Rich,

   received from Lucy Yong.

 

 

Sincerely,

Akbar

Folks,

We would like to prepare the survey draft, draft-ietf-decade-survey-01 <http://datatracker.ietf.org/doc/draft-ietf-decade-survey/> , for working group last call in January.

-- Rich