Subject: [decade] FW: New Version Notification for draft-ietf-decade-problem-statement-01

From: Songhaibin <[email-masked]>
Date: Mon, 20 Dec 2010 09:42:11 +0000

Dear all,

The problem statement draft has been updated to 01. The authors will give another iteration after receiving the comments from other reviewers. We would like to thank Akbar and Borje for their valuable comments and contribution.

Thanks,
Haibin

> -----Original Message-----
> From: IETF I-D Submission Tool [mailto:[email-masked]]
> Sent: Monday, December 20, 2010 3:51 PM
> To: Songhaibin
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: New Version Notification for draft-ietf-decade-problem-statement-01
> 
> 
> A new version of I-D, draft-ietf-decade-problem-statement-01.txt has been
> successfully submitted by Haibin Song and posted to the IETF repository.
> 
> Filename:	 draft-ietf-decade-problem-statement
> Revision:	 01
> Title:		 DECoupled Application Data Enroute (DECADE) Problem
> Statement
> Creation_date:	 2010-12-18
> WG ID:		 decade
> Number_of_pages: 18
> 
> Abstract:
> Peer-to-peer (P2P) applications have become widely used on the
> Internet today and make up a large portion of the traffic in many
> networks.  In P2P applications, one technique for reducing the total
> amount of P2P traffic is to introduce storage capabilities within the
> network.  Traditional caches (e.g., P2P and Web caches) provide such
> storage, but they are complex (due to explicitly supporting
> individual P2P application protocols) and they do not allow users to
> manage access to content in the cache.  For example, Content
> Providers cannot easily control access and resource usage policies to
> satisfy their own requirements.  This document discusses the
> introduction of in-network storage for P2P applications, shows the
> need for a standard protocol for accessing this storage, and
> identifies the scope of this protocol.  The accessing protocol can
> also be used by other applications with similar requirements.
> 
> 
> 
> The IETF Secretariat.
>

---

From: Roni Even <[email-masked]>
Date: Thu, 23 Dec 2010 12:53:16 +0200

Hi,
In general it looks good.

I have a question about the flow in section 5.4.1. It shows that Sb can
perform IAP operation. I am not sure I noticed that the in network storage
can also perform the DECADE protocol. Now if it can do it than how does B
know when the data is available at Sb in order to get it.

In the security consideration it is not specified but I assume that the
access control is used also to prevent unauthorized user from getting the
content on the in network storage.

Roni Even

---

From: Songhaibin <[email-masked]>
Date: Fri, 24 Dec 2010 02:42:32 +0000

Hi Roni,

Thank you very much for your review. See my reply in line.

> From: Roni Even [mailto:[email-masked]]
> Sent: Thursday, December 23, 2010 6:53 PM
> To: [email-masked]
> Cc: Songhaibin
> Subject: Review of draft-ietf-decade-problem-statement-01
> 
> Hi,

[Haibin] In this scenario, the request is initiated from B to Sb to get the data from Sa. So when Sb gets the data from Sa, Sb will pass the data to B and also save it in Sb. I also think there is another possibility that B indicates Sb not sending the data to B.

> content on the in network storage.

[Haibin] You are right.

Thanks,
Haibin