Subject: [Detnet-dp-dt] protocol signaling vs. net services vs. det services

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sun, 13 Mar 2016 13:31:21 +0000

Dear all:

Following the discussion with Janos, I put some thoughts in a presentation that I placed in the repo:
https://github.com/jounikor/draft-dt-detnet-dp-alt/blob/master/Thoughts%20on%20Det%20vs%20Net.pdf

Bottom line is that protocols provide signaling tools, which in turn can be used by any combination of net, det and app layers, should we either allow for cross layers semantics or duplicate the signaling to accommodate the various layers in a more appropriate fashion. Using those tools, the net layer provides services to the det layer, which provides services to the app layer, all as managed by the control layer.

When I read the latest version of the text I find that though we separated the layers, we still mix the protocol tooling and the  layer services. Maybe this piceture expresses better what I have in mind:

Thoughts?

Pascal

---

From: Jouni Korhonen <[email-masked]>
Date: Sun, 13 Mar 2016 21:36:22 +0800

Hi

Thanks for the new graph. I would still argue that duplicate elimination
can also belong/done at layers above Net.

Jouni

Sent from a smart phone.. Mind the typos..

On Mar 13, 2016, at 9:31 PM, Pascal Thubert (pthubert) <[email-masked]>
wrote:

Dear all:

Following the discussion with Janos, I put some thoughts in a presentation
that I placed in the repo:

Bottom line is that protocols provide signaling tools, which in turn can be
used by any combination of net, det and app layers, should we either allow
for cross layers semantics or duplicate the signaling to accommodate the
various layers in a more appropriate fashion. Using those tools, the net
layer provides services to the det layer, which provides services to the
app layer, all as managed by the control layer.

When I read the latest version of the text I find that though we separated
the layers, we still mix the protocol tooling and the  layer services.
Maybe this piceture expresses better what I have in mind:

Thoughts?

Pascal

_______________________________________________
Detnet-dp-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sun, 13 Mar 2016 14:12:46 +0000

Hello Jouni

The only occurrences I'm familiar with for the elimination thing are HSR/PRP and transports like TCP. We seem to place both at the Det layer in this draft this my initial agreement with you.

Then I figured that multicast and ARQ involved replication at the net layer. Damn, are they Det or Net or is it that replication is net and elimination is Det? Seemed impossible to split because the sequencing tied them together.

To sort that out I found that separating the tools in protocol signaling from the layer services could help. Now we have separated replication and elimination and may move elimination to the Det layer, which I have not done yet but can be done if we agree.

Regards,

Pascal

Le 13 mars 2016 ? 14:36, Jouni Korhonen <[email-masked]<mailto:[email-masked]>> a ?crit :

Hi

Thanks for the new graph. I would still argue that duplicate elimination can also belong/done at layers above Net.

Jouni

On Mar 13, 2016, at 9:31 PM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:

Dear all:

Thoughts?

Pascal

_______________________________________________
Detnet-dp-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Gregory Mirsky <[email-masked]>
Date: Sun, 13 Mar 2016 17:44:16 +0000

Hi Jouni,
though it may be the case that Net, i.e. transport, does provide duplicate elimination I have not seen the example yet. And if the transport provides both replication and duplicate elimination, then how the service layer, the Det knows about that, control it. From the Det layer POV, it can only request the transport to the set of CEs with certain SLA, not specific number of replication points in the Net layer.

                Regards,
                                Greg

From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Jouni Korhonen
Sent: Sunday, March 13, 2016 6:36 AM
To: Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: [Detnet-dp-dt] protocol signaling vs. net services vs. det services

Hi

Jouni

Thoughts?

Pascal

---

From: Jouni Korhonen <[email-masked]>
Date: Sun, 13 Mar 2016 19:06:55 -0700

Greg,

So you agree what I said earlier? Duplicate elimination mainly belonging 
to Det layer.

- Jouni

3/13/2016, 10:44 AM, Gregory Mirsky kirjoitti:
>
> Hi Jouni,
>
> though it may be the case that Net, i.e. transport, does provide 
> duplicate elimination I have not seen the example yet. And if the 
> transport provides both replication and duplicate elimination, then 
> how the service layer, the Det knows about that, control it. From the 
> Det layer POV, it can only request the transport to the set of CEs 
> with certain SLA, not specific number of replication points in the Net 
> layer.
>
> Regards,
>
> Greg
>
> *From:*Detnet-dp-dt [mailto:[email-masked]] *On Behalf 
> Of *Jouni Korhonen
> *Sent:* Sunday, March 13, 2016 6:36 AM
> *To:* Pascal Thubert (pthubert)
> *Cc:* [email-masked]
> *Subject:* Re: [Detnet-dp-dt] protocol signaling vs. net services vs. 
> det services
>
> Hi
>
> Thanks for the new graph. I would still argue that duplicate 
> elimination can also belong/done at layers above Net.
>
> Jouni
>
> On Mar 13, 2016, at 9:31 PM, Pascal Thubert (pthubert) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Dear all:
>
>     Bottom line is that protocols provide signaling tools, which in
>     turn can be used by any combination of net, det and app layers,
>     should we either allow for cross layers semantics or duplicate the
>     signaling to accommodate the various layers in a more appropriate
>     fashion. Using those tools, the net layer provides services to the
>     det layer, which provides services to the app layer, all as
>     managed by the control layer.
>
>     When I read the latest version of the text I find that though we
>     separated the layers, we still mix the protocol tooling and the
>      layer services. Maybe this piceture expresses better what I have
>     in mind:
>
>
>     Thoughts?
>
>     Pascal
>
>     [email-masked] <mailto:[email-masked]>

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 14 Mar 2016 04:28:58 +0000

Hi Jouni,
yes, I agree as I believe that duplicate elimination, whether it is over 1+1 protection or BIER domain, belongs in the Det layer. 

	Regards,
		Greg
PS. Regarding 1+1 protection scheme I should point that PE does not alternate between flows selecting packets but uses working source as long as it is deemed valid. As I understand, DetNet would require very different method, per packet, of duplicate elimination.

-----Original Message-----
From: Jouni Korhonen [mailto:[email-masked]] 
Sent: Sunday, March 13, 2016 7:07 PM
To: Gregory Mirsky; Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: [Detnet-dp-dt] protocol signaling vs. net services vs. det services

Greg,

So you agree what I said earlier? Duplicate elimination mainly belonging to Det layer.

- Jouni