Subject: [Detnet-dp-dt] structuring

From: János Farkas <[email-masked]>
Date: Fri, 11 Mar 2016 15:33:36 +0100

Hi,

As we discussed on the call yesterday, I'd follow the following 
structure in the document:

    4.  Data plane solution alternatives
      4.1 Net Layer technologies
        4.1.1  Native IPv6 transport
        4.1.2.  Native IPv4 transport
        4.1.3.  MPLS
      4.2 Det Layer technologies
        4.2.1.  PseudoWires
        4.2.2.  Generic Routing Encapsulation (GRE)
        4.2.3.  L2TP
        4.2.4. RTP
        4.3.5. TCP
        4.3.6.  VXLAN
        4.3.7.  Bit Indexed Explicit Replication
      4.2 Combination examples for Det + Net layers

I'd just pick a couple of combinations to give a picture, and highlight 
that many other combinations are possible.

In section 4.1, I'd only evaluate the technologies against:
    The criteria for the Net layer:

       #1 Encapsulation and overhead
       #2 Stream identification (Egress ID)
       #4 Explicit routes (network path)
       #5 Packet replication and deletion (for seamless redundancy)
       #6 Operations and management (capabilities)
       #7 Time synchronization (time/phase sync of nodes)
       #8 Class and quality of service capabilities (Net specific)
       #9 Packet traceability (verification purposes)
       #10 Technical maturity

In section 4.2, I'd only evaluate the technologies against:

    The criteria for the Det layer:

       #1 Encapsulation and overhead
       #2 Stream identification (Flow ID part of the DetNet stream)
       #3 Packet sequencing (sequence number)
       #6 Operations and management (capabilities)
       #7 Time synchronization (e.g., time stamping)
       #8 Class and quality of service capabilities (Det specific)
       #10 Technical maturity

(This is the current criteria list, that's why I picked it)

The combination examples could be evaluated against the complete 
criteria list.

Need to take a taxi now to the airport.
See some of you in Macau.

Cheers,
Janos

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sun, 13 Mar 2016 13:20:18 +0000

Hello Janos :)

>From our previsou exchanges it seems to me that BIER (both mcast and TE) belong to the net section.

Do I miss anything?

Pascal

> -----Original Message-----
> From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of
> János Farkas
> Sent: vendredi 11 mars 2016 15:34
> To: [email-masked]
> Subject: [Detnet-dp-dt] structuring
> 
> Hi,
> 
> As we discussed on the call yesterday, I'd follow the following structure in
> the document:
> 
> I'd just pick a couple of combinations to give a picture, and highlight that
> many other combinations are possible.
> 
> The combination examples could be evaluated against the complete criteria
> list.
> 
> 
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: János Farkas <[email-masked]>
Date: Sun, 13 Mar 2016 18:41:45 +0100

Hi Pascal,

I hope you are doing well.

>  From our previsou exchanges it seems to me that BIER (both mcast and TE) belong to the net section.
No. It is just my fault.
Please correct BIER in the draft.

Cheers,
Janos

---

From: Jouni Korhonen <[email-masked]>
Date: Sun, 13 Mar 2016 19:12:29 -0700

Janos,

Regarding restructuring part I am fine with this. Thanks.
For the criterias you probably know my view of having the duplicate 
deletion on the same place where I have my sequencing i.e., on Det layer.

- Jouni

3/11/2016, 6:33 AM, János Farkas kirjoitti:
> I'd just pick a couple of combinations to give a picture, and 
> highlight that many other combinations are possible.
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 14 Mar 2016 07:39:12 +0000

Hello Janos:

The draft on the repo does not have this new structure yet.
I added BIER to the Net layer in the figure

Cheers,

Pascal

From: János Farkas [mailto:[email-masked]]
Sent: dimanche 13 mars 2016 18:42
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Detnet-dp-dt] structuring

Hi Pascal,

Hello Janos :)

Do I miss anything?
No. It is just my fault.

Cheers,
Janos

Pascal

-----Original Message-----

János Farkas

To: [email-masked]<mailto:[email-masked]>

Hi,

the document:

        4.1.3.  MPLS

        4.2.1.  PseudoWires

        4.2.3.  L2TP

        4.2.4. RTP

        4.3.5. TCP

        4.3.6.  VXLAN

       #10 Technical maturity

       #10 Technical maturity

list.

Cheers,

Janos

[email-masked]<mailto:[email-masked]>

---

From: Jouni Korhonen <[email-masked]>
Date: Mon, 14 Mar 2016 15:53:10 +0800

No because i have not done the changes yet ;)

Sent from a smart phone.. Mind the typos..

On Mar 14, 2016, at 3:39 PM, Pascal Thubert (pthubert) <[email-masked]>
wrote:

Hello Janos:

Cheers,

Pascal

*From:* János Farkas [mailto:[email-masked]
<[email-masked]>]
*Sent:* dimanche 13 mars 2016 18:42
*To:* Pascal Thubert (pthubert) <[email-masked]>
*Cc:* [email-masked]
*Subject:* Re: [Detnet-dp-dt] structuring

Hi Pascal,

Hello Janos :)

Do I miss anything?

No. It is just my fault.

Cheers,
Janos

Pascal

-----Original Message-----

From: Detnet-dp-dt [mailto:[email-masked]
<[email-masked]>] On Behalf Of

János Farkas

Hi,

the document:

        4.1.3.  MPLS

        4.2.1.  PseudoWires

        4.2.3.  L2TP

        4.2.4. RTP

        4.3.5. TCP

        4.3.6.  VXLAN

       #10 Technical maturity

       #10 Technical maturity

list.

Cheers,

Janos

[email-masked]