Subject: Re: [Detnet-dp-dt] Overlay OAM DT documents

From: Gregory Mirsky <[email-masked]>
Date: Mon, 16 May 2016 20:30:02 +0000

Dear All,
hope someone read the one or both drafts and will have comments and/or questions.
I think that the discussion would help us in understanding the scope of Det and DetNet layers as presented in the draft-varga-detnet-service-model.

                Regards,
                                Greg

From: Gregory Mirsky
Sent: Wednesday, May 04, 2016 8:50 AM
To: [email-masked]
Subject: Overlay OAM DT documents

Dear All,
the Overlay OAM DT has published two documents:

*         Overlay OAM Requirements<https://tools.ietf.org/html/draft-ooamdt-rtgwg-ooam-requirement-00>

*         OAM for Overlay Networks: Gap Analysis<https://tools.ietf.org/html/draft-ooamdt-rtgwg-oam-gap-analysis-01>

The work been presented and discussed in BA in RTGWG meeting. Slides attached.

Greatly appreciate your comments, questions.

                Regards,
                                Greg

---

From: Jouni Korhonen <[email-masked]>
Date: Tue, 17 May 2016 18:53:10 -0700

Hi,

I read both documents.  Cleared to me within _current_ DetNet data plane 
document the "net" layer time sync should be entirely part of OAM PM ;)

Ot the other aspects I think there is need to have tools that are "det" 
service aware, not just the underlying transport. I would take a 
traceroute with packet replication as an example..

My 0.02 ZWD,
- Jouni

5/16/2016, 1:30 PM, Gregory Mirsky kirjoitti:
> I think that the discussion would help us in understanding the scope of
> Det and DetNet layers as presented in the draft-varga-detnet-service-model.
>
>
>
>                 Regards,
>
>                                 Greg
>
>
>
> *From:*Gregory Mirsky
> *Sent:* Wednesday, May 04, 2016 8:50 AM
> *To:* [email-masked]
> *Subject:* Overlay OAM DT documents
>
>
>
> Dear All,
>
> ·         Overlay OAM Requirements
> <https://tools.ietf.org/html/draft-ooamdt-rtgwg-ooam-requirement-00>
>
> ·         OAM for Overlay Networks: Gap Analysis
> <https://tools.ietf.org/html/draft-ooamdt-rtgwg-oam-gap-analysis-01>
>
>
>
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt
>

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 18 May 2016 02:01:49 +0000

Hi Jouni,
thank you for your review and comments. I believe that if we talk about the clock synchronization, then there are already mechanisms, e.g. IEEE-1588, SyncE, that can do that. What OAM, overlay OAM should do in its PM part, in my view, is to support measurement of latency/jitter to characterize what is experience of the particular data flow being monitored. And for the DetNet, in my opinion, these may require higher precision, e.g. nanoseconds instead of millisecond for other overlays.

	Regards,
		Greg

-----Original Message-----
From: Jouni Korhonen [mailto:[email-masked]] 
Sent: Tuesday, May 17, 2016 6:53 PM
To: Gregory Mirsky; [email-masked]
Subject: Re: [Detnet-dp-dt] Overlay OAM DT documents

Hi,

I read both documents.  Cleared to me within _current_ DetNet data plane document the "net" layer time sync should be entirely part of OAM PM ;)

Ot the other aspects I think there is need to have tools that are "det" 
service aware, not just the underlying transport. I would take a traceroute with packet replication as an example..

My 0.02 ZWD,
- Jouni

5/16/2016, 1:30 PM, Gregory Mirsky kirjoitti:
> I think that the discussion would help us in understanding the scope 
> of Det and DetNet layers as presented in the draft-varga-detnet-service-model.
>
>
>
>                 Regards,
>
>                                 Greg
>
>
>
> *From:*Gregory Mirsky
> *         Overlay OAM Requirements
> *         OAM for Overlay Networks: Gap Analysis

---

From: Jouni Korhonen <[email-masked]>
Date: Tue, 17 May 2016 21:19:36 -0700

> On 17 May 2016, at 19:01, Gregory Mirsky <[email-masked]> wrote:
> 
> Hi Jouni,
> thank you for your review and comments. I believe that if we talk about the clock synchronization, then there are already mechanisms, e.g. IEEE-1588, SyncE, that can do that. What OAM, overlay OAM should do in its PM part, in my view, is to support measurement of 

No, I wasn’t talking about clock/time distribution. More of thinking doing monitoring e.g. for SLA or troubleshooting purposes. In the current draft we have a “time sync” criteria whose placement or content is a bit shady.

- JOuni

> latency/jitter to characterize what is experience of the particular data flow being monitored. And for the DetNet, in my opinion, these may require higher precision, e.g. nanoseconds instead of millisecond for other overlays.

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 18 May 2016 04:28:59 +0000

Hi Jouni,
thank you for the clarification. Should we update the document with the terminology clarification as I believe many will make the same assumption as I've done.
The "monitoring" could be not only latency and jitter measurement but, and that is special for the DetNet, monitoring of clock synchronization quality. AFAIK, ITU-T SG15 Q13 and Q14 are working on Sync OAM and Management, including definition of Clock Synchronization Quality metrics.

	Regards,
		Greg

-----Original Message-----
From: Jouni Korhonen [mailto:[email-masked]] 
Sent: Tuesday, May 17, 2016 9:20 PM
To: Gregory Mirsky
Cc: [email-masked]
Subject: Re: [Detnet-dp-dt] Overlay OAM DT documents

> thank you for your review and comments. I believe that if we talk 
> about the clock synchronization, then there are already mechanisms, 
> e.g. IEEE-1588, SyncE, that can do that. What OAM, overlay OAM should 
> do in its PM part, in my view, is to support measurement of

- JOuni

> I read both documents.  Cleared to me within _current_ DetNet data 
> plane document the "net" layer time sync should be entirely part of 
> OAM PM ;)
>

---

From: Jouni Korhonen <[email-masked]>
Date: Tue, 17 May 2016 21:33:48 -0700

Hi,

> On 17 May 2016, at 21:28, Gregory Mirsky <[email-masked]> wrote:
> 
> Hi Jouni,

Yep. The current criteria is confusing at best.

> The "monitoring" could be not only latency and jitter measurement but, and that is special for the DetNet, monitoring of clock synchronization quality. AFAIK, ITU-T SG15 Q13 and Q14 are working on…

That is definitely interesting. Alas, I have not followed closely what ITU-T does..

- Jouni