Subject: Re: [Detnet-dp-dt] Quick call notes

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 7 Jun 2016 10:03:25 +0000

Hello Jouni:

As promised the cross review on BIER.

1) there was an intro that presented both BIER variations. The text is merged with the classical BIER and the result is a bit awkward, and not delineated from where the discussion on classical BIER starts (line 1300). We could use a forward pointer, or make that a small separated section.

2) BFIR and BFER acronyms are used without introducing first. We can quote the architecture sand say '  A multicast data packet enters a BIER domain at a "Bit-Forwarding   Ingress Router" (BFIR), and leaves the BIER domain at one or more  "Bit-Forwarding Egress Routers" (BFERs).'

3) " The DetNet may be": what do we mean by "the detnet"? same in " Such DetNet may be BFER", " sends DetNet into red "

4) "DetNet node, collocated": are we defining a detnet node? Is it not detnet services, rather?

5)     #4 Explicit routes (M) -> explicit routes is not provided. In TE I say N with the same arguments as the BIER here says M. We need homogeneity...

Cheers,

Pascal

> -----Original Message-----
> From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Jouni
> Korhonen
> Sent: mercredi 25 mai 2016 20:24
> To: [email-masked]
> Subject: [Detnet-dp-dt] Quick call notes
> 
> Folks,
> 
> We had a quick call today. Some notes, mainly APs.
> 
> * AP Pascal: to provide new revision of the BIER-TE text. Done!
> * AP Jouni: to incorporate Pascal's text EOB 5/25/16
> * AP Jouni: separate BIER and BIER-TE texts into different sections.
> * AP Balazs: review all MPLS sections
> * AP Pascal & Greg: cross review BIER sections
> 
> We still need to conclude the service model discussion and reflect that in the
> criteria (number #? currently as far as I understand).
> 
> The goal is to get a publishable version out in two weeks.
> 
> As a reminder, please, review the Overlay OAM DT specs and provide input
> specifically in the context of DetNet!
> 
> - Jouni
> 
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Jouni Korhonen <[email-masked]>
Date: Tue, 7 Jun 2016 07:32:33 -0700

Thanks Pascal,

> 1) there was an intro that presented both BIER variations. The text is merged with the classical BIER and the result is a bit awkward, and not delineated from where the discussion on classical BIER…

Right. I'll check how the forward pointer would work out.

> 2) BFIR and BFER acronyms are used without introducing first. We can quote the architecture sand say '  A multicast data packet enters a BIER domain at a "Bit-Forwarding   Ingress Router" (BFIR), a…

Ack.

> 3) " The DetNet may be": what do we mean by "the detnet"? same in " Such DetNet may be BFER", " sends DetNet into red "

Good questions. I'll Greg answer that since he (AFAIK) wrote the text 
originally.

> 4) "DetNet node, collocated": are we defining a detnet node? Is it not detnet services, rather?

Greg?

> 5)     #4 Explicit routes (M) -> explicit routes is not provided. In TE I say N with the same arguments as the BIER here says M. We need homogeneity...

I tend to think BIER-TE view is more closer to what it should be within 
here.  On the otherhand, since PCE and such exist I would have (W) 
instead of (N) for BIER-TE.

- Jouni