Subject: [Detnet-dp-dt] what does this mean in the dp doc?

From: Lou Berger <[email-masked]>
Date: Thu, 7 Jul 2016 15:08:33 -0400

1st sentence of section:

and Discussion

   #1 Encapsulation and overhead (M)

      The DetNet Service layer encapsulated DetNet flows are assumed to
      be handled natively at layer-3 by IPv6 at the first place.

Thanks,

Lou

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 7 Jul 2016 12:18:14 -0700

My wild guess is that when "native" IPv6 is used as a transport for DetNet
flows.. there should not be tunnels what so ever as a payload for the IPv6.
Meaning, not used for interworking or emulated TSN service scenarios.

- Jouni

On Thu, Jul 7, 2016 at 12:08 PM, Lou Berger <[email-masked]> wrote:

> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt
>

-- 
Jouni Korhonen, Broadcom Ltd.

---

From: Lou Berger <[email-masked]>
Date: Thu, 7 Jul 2016 15:52:26 -0400

I've left it in, but suspect it needs to be fixed/replaced -- I'm almost
done with a general editorial pass.

On 7/7/2016 3:18 PM, Jouni Korhonen wrote:
> My wild guess is that when "native" IPv6 is used as a transport for
> DetNet flows.. there should not be tunnels what so ever as a payload
> for the IPv6. Meaning, not used for interworking or emulated TSN
> service scenarios.
>
> - Jouni
>
> On Thu, Jul 7, 2016 at 12:08 PM, Lou Berger <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     1st sentence of section:
>
>     and Discussion
>
>     [email-masked] <mailto:[email-masked]>

---

From: Janos Farkas <[email-masked]>
Date: Thu, 7 Jul 2016 20:43:46 +0000

Good catch.
It has remained there from an earlier version, before introducing the Service and Transport layers. At that time, the idea was to evaluate the applicability of each technology on its own for the whole DetNet space. 

The approach now is that IPv6 can be used for Transport layer, but it does not have to solve Service layer tasks.

I guess we could update the sentence to:
"The DetNet Service layer encapsulated DetNet flows are transported by IPv6."
Or 
"IPv6 is used to transport the DetNet Service layer encapsulated DetNet flows."
Or sg alike.

Thanks,
Janos

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Thursday, July 07, 2016 9:52 PM
To: Jouni Korhonen <[email-masked]>
Cc: [email-masked]
Subject: Re: [Detnet-dp-dt] what does this mean in the dp doc?

I've left it in, but suspect it needs to be fixed/replaced -- I'm almost done with a general editorial pass.

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 7 Jul 2016 20:47:36 +0000

Sorry not following all the discussions.
I think that with “native” IPv6 DetNet loses explicit routing capability. If we need it, then it could be with Segment Routing which for IPv6 requires IPv6 header extensions.

                Regards,
                                Greg

From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Jouni Korhonen
Sent: Thursday, July 07, 2016 12:18 PM
To: Lou Berger <[email-masked]>
Cc: [email-masked]
Subject: Re: [Detnet-dp-dt] what does this mean in the dp doc?

My wild guess is that when "native" IPv6 is used as a transport for DetNet flows.. there should not be tunnels what so ever as a payload for the IPv6. Meaning, not used for interworking or emulated TSN service scenarios.

- Jouni

On Thu, Jul 7, 2016 at 12:08 PM, Lou Berger <[email-masked]<mailto:[email-masked]>> wrote:
1st sentence of section:

and Discussion

Thanks,

Lou

_______________________________________________
Detnet-dp-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 7 Jul 2016 14:25:30 -0700

That is what the document also states in IPv6 criteria #4 evaluation. So I
think we have covered our bases there.

- Jouni

On Thu, Jul 7, 2016 at 1:47 PM, Gregory Mirsky <[email-masked]>
wrote:

> I think that with “native” IPv6 DetNet loses explicit routing capability.
> If we need it, then it could be with Segment Routing which for IPv6
> requires IPv6 header extensions.
>
>
>
>                 Regards,
>
>                                 Greg
>
>
>
> *From:* Detnet-dp-dt [mailto:[email-masked]] *On Behalf Of
> *Jouni Korhonen
> *Sent:* Thursday, July 07, 2016 12:18 PM
> *To:* Lou Berger <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [Detnet-dp-dt] what does this mean in the dp doc?
>
>
>

---

From: Lou Berger <[email-masked]>
Date: Thu, 7 Jul 2016 17:30:29 -0400

so should this sentence be dropped?

On 7/7/2016 5:25 PM, Jouni Korhonen wrote:
> That is what the document also states in IPv6 criteria #4 evaluation.
> So I think we have covered our bases there.
>
> - Jouni
>
> On Thu, Jul 7, 2016 at 1:47 PM, Gregory Mirsky
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     I think that with “native” IPv6 DetNet loses explicit routing
>     capability. If we need it, then it could be with Segment Routing
>     which for IPv6 requires IPv6 header extensions.
>
>      
>
>                     Regards,
>
>                                     Greg
>
>      
>
>     *From:*Detnet-dp-dt [mailto:[email-masked]
>     <mailto:[email-masked]>] *On Behalf Of *Jouni Korhonen
>     *To:* Lou Berger <[email-masked] <mailto:[email-masked]>>
>     *Cc:* [email-masked] <mailto:[email-masked]>
>     My wild guess is that when "native" IPv6 is used as a transport
>     for DetNet flows.. there should not be tunnels what so ever as a
>     payload for the IPv6. Meaning, not used for interworking or
>     emulated TSN service scenarios.
>
>      
>
>     - Jouni
>
>      
>

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 7 Jul 2016 14:32:36 -0700

Actually already did that.

- Jouni

---

From: Lou Berger <[email-masked]>
Date: Thu, 7 Jul 2016 17:42:57 -0400

;-)

On 7/7/2016 5:32 PM, Jouni Korhonen wrote:
> On Thu, Jul 7, 2016 at 2:30 PM, Lou Berger <[email-masked]
>     > <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>     >
>     <mailto:[email-masked]>
>     >     <mailto:[email-masked]
>     <mailto:[email-masked]>>] *On Behalf Of *Jouni Korhonen
>     >     *To:* Lou Berger <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>     >     On Thu, Jul 7, 2016 at 12:08 PM, Lou Berger
>     <[email-masked] <mailto:[email-masked]>
>     >     <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>     >
>     >         1st sentence of section:
>     >
>     >         and Discussion
>     >
>     <mailto:[email-masked] <mailto:[email-masked]>>

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 7 Jul 2016 14:51:03 -0700

Actually.. now that I also checked what others say about the criteria #1,
they mainly concentrate on the encapsulation part.. not the overhead. In
the same vein having something towards what Janos proposed would be fine, I
think.

For example:
"IPv6 can encapsulate DetNet Service layer headers (and the associated
DetNet flow payload) like any
other upper-layer header indicated by the Next Header."

- Jouni