Subject: [Detnet-dp-dt] Node names

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Wed, 6 Jul 2016 18:27:27 +0000

On the terminology front:

Having settled on relay nodes and transport nodes (I think) I often need a
term in the architecture document for “relay or transport node”.  Note
that “DetNet node” includes end systems, as well.  I propose “intermediate
node”.  Thus:

DetNet node = end system | intermediate node
Intermediate node = relay node | transport node

— Norm

---

From: Lou Berger <[email-masked]>
Date: Wed, 6 Jul 2016 14:32:37 -0400

Sigh.

From
https://github.com/jounikor/draft-dt-detnet-dp-alt/blob/master/draft-dt-detnet-dp-alt-01.txt

I see

     End           Edge          Transit        Relay          End
    System         Node            Node         Node          System

   +---------+                                              +---------+
   |  Appl.  |<--------- End to End DetNet Service -------->|  Appl.  |
   +---------+   +---------+                  +---------+   +---------+
   | Service |<--| Service |--- DetNet flow --| Service |-->| Service |
   +---------+   +---------+    +---------+   +---------+   +---------+
   |Transport|   |Trp| |Trp|    |Transport|   |Transport|   |Transport|
   +-------.-+   +-.-+ +-.-+    +--.---.--+   +--.---.--+   +----.----+
           : Link  :    /  ,-----.  \  : Link    :   :   Link    :
           +.......+    +-[  Sub  ]-+  +.........+   +...........+
                          [Network]
                           `-----'

Did this too change in todays meeting? All but transit node are detnet
aware, and IMO are types of detnet nodes...

Lou

On 7/6/2016 2:27 PM, Norman Finn (nfinn) wrote:
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 6 Jul 2016 11:36:53 -0700

Sounds good. And what about the Edge Node? Is the "Relay with application
knowledge" appropriate? The function we identified was "converting" TSN to
Detnet.

- Jouni

-- 
Jouni Korhonen, Broadcom Ltd.

---

From: "Zhuangyan (Yan)" <[email-masked]>
Date: Thu, 7 Jul 2016 13:18:31 +0000

Hi all,

I have a question about nodes in Figure 1.

Both Edge nodes and Relay node have two transport “legs” and look the same there. But actually, they are different transport layers, right?
The transport legs on Relay node are for Detnet only environment, which are the detnet transport layer discussed in this draft, while the left transport leg on Edge node is to connect .1TSN end system, which should support .1TSN and not the transport layer discussed here. Is that right?  If so, shall we distinguish them in the figure to show the difference between Edge and Relay nodes?

Thanks a lot.

Best Regards,

Yan

发件人: Detnet-dp-dt [mailto:[email-masked]] 代表 Jouni Korhonen
发送时间: 2016年7月7日 2:37
收件人: Norman Finn (nfinn)
抄送: [email-masked]
主题: Re: [Detnet-dp-dt] Node names

Sounds good. And what about the Edge Node? Is the "Relay with application knowledge" appropriate? The function we identified was "converting" TSN to Detnet.

- Jouni

On Wed, Jul 6, 2016 at 11:27 AM, Norman Finn (nfinn) <[email-masked]<mailto:[email-masked]>> wrote:
On the terminology front:

— Norm

_______________________________________________
Detnet-dp-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 7 Jul 2016 07:53:03 -0700

Hi,

See inline.

On Thu, Jul 7, 2016 at 6:18 AM, Zhuangyan (Yan) <[email-masked]

> Both Edge nodes and Relay node have two transport “legs” and look the same
> there. But actually, they are different transport layers, right?
>
> The transport legs on Relay node are for Detnet only environment, which
> are the detnet transport layer discussed in this draft, while the left
> transport leg on Edge node is to
>

​Correct.

> connect .1TSN end system, which should support .1TSN and not the transport
> layer discussed here. Is that right?  If so, shall we distinguish them in
> the figure to show the
>

​Correct.

> difference between Edge and Relay nodes?
>

​I am open for suggestions. The edge node also terminates the service
layer, which is different from relay. I could also try to enhance that part
some how.

​- Jouni​

>
>
> Thanks a lot.
>
>
>
> Best Regards,
>
>
>
> Yan
>
>
>
>
>
> *发件人:* Detnet-dp-dt [mailto:[email-masked]] *代表 *Jouni
> Korhonen
> *发送时间:* 2016年7月7日 2:37
> *收件人:* Norman Finn (nfinn)
> *抄送:* [email-masked]
> *主题:* Re: [Detnet-dp-dt] Node names
>
>
>