Subject: [Detnet-dp-dt] Publishing v06 of architecture draft

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 8 Jul 2016 16:06:03 +0000

<for Norm> I updated archie 06 in the bitbucket based on the below. I’d appreciate if you can check and publish to the IETF today, since this is cutoff. I’ll check later and push myself in the absence of news from you.

Dear Janos and all:

I've also found some differences that may be confusing.

The architecture draft defines:

DetNet intermediate node
           A DetNet relay node or transport node.

DetNet transport node
           A node operating at the DetNet transport layer, that utilizes
           link layer and/or network layer switching across multiple
           links and/or sub-networks to provide paths for DetNet service
           layer functions.  An MPLS LSR is an example of a DetNet
           transport node.

Whereas "transport node" is not used in the data plane draft.
Instead, the data plane draft defines:
Transit Node
A node that provides link layer and network layer switching across
multiple links and/or sub-networks. An MPLS LSR is an example of
a transit node.

Ø  I’m happy to converge from “DetNet transport node” to “DetNet transit node”.

Ø  I’m doing it is 06 but not publishing. Norm, you have the final word.

The architecture draft defines:

   DetNet relay edge node
           An instance of a DetNet relay node that includes a service
           layer (packet sequencing and/or elimination) proxy function
           for one or more end systems, analogous to a Label Edge Router
           (LER).

   DetNet transport edge node
           An instance of a DetNet transport node that includes a
           transport layer (DetNet flow encapsulation, splitting and/or
           merging) proxy function for one or more end systems, for
           example, a Label Edge Router (LER).

Do we have DetNet transport edge node? Isn't each DetNet edge node is a DetNet relay edge node?

Ø    This comes from the old separation of service and transport. Service was whanged to relay. If replication is transport and elimination is relay (service) layer, then we can have one without the other in a given node...

The data plane draft says at the moment:
Edge Node
A relay node with application level knowledge (i.e., basically a
"proxy" node). Egde nodes are needed when interfacing with nodes
or end systems that are not DetNet-enabled.

The data plane draft says:
Transit Node
A node that provides link layer and network layer switching across
multiple links and/or sub-networks. An MPLS LSR is an example of
a transit node.

The architecture draft says:
relay node
           A DetNet service layer function that interconnects different
           DetNet transport layer protocols or networks (instances) to
           perform packet replication and elimination (Section 3.4.  May
           be a router, transit node, bridge, Label Switch Router (LSR),
           firewall, or any other system that participates in the DetNet
           service layer.  A DetNet relay node typically incorporates
           DetNet transport layer functions, as well.

Should be "transit node" and LSR removed from the definition of relay node in the architecture draft?
(My understanding from the call yesterday and from the data plane draft is that a relay node is rather a LER than an LSR.)

Ø  I think we mean that it may be *collocated with* IOW *implemented in a*  transit node such as a router, a switch or a MPLS LSR. Works?

Ø  Proposal I made in 06 :

A DetNet relay node     typically incorporates DetNet transport layer functions as  well, in which case it is collocated with a transit node, such  as a bridge, a router, a Label Switch Router (LSR), a firewall,   or any other system that participates in the DetNet service layer.

Works?

In the data plane draft, the criteria relevant for the Service and dor the Transport layer are collected in Section 4. IT has been discussed a lot and what we have at the moment is:

for the Service layer:
#5 Packet replication and elimination (note: only the packet deletion
for seamless redundancy)

for the Transport layer
#5 Packet replication and elimination (note: only the packet
replication and/or flow merging for seamless redundancy)

The architecture draft says:

DetNet service layer
           The layer at which packet replication and elimination
           (Section 3.4) is performed.

DetNet transport layer
           The layer that splits and merges Detnet flows for packet
           replication and elimination (Section 3.4).

I guess the two drafts could be better synchronized.
One key difference is that packet replication is considered as part of the Service layer in the Architecture draft whereas it is part of the Transport layer in the data plane draft.

Ø  That’s a mistake, the replication is transport.

Ø  I’m updating archie  06 to

DetNet service layer:    The layer at which the elimination part of packet replication and elimination (Section 3.4) is performed.

At the moment, maybe the easiest way to delete these from the architecture draft? (Actually the Service and Transport layers are distinguished for other purposes too.)

The data plane draft said yesterday:
[I-D.finn-detnet-architecture] does not specify the relationship
between layers.
which I've just suggested to update to
[I-D.finn-detnet-architecture] does not specify the relationship
between the DetNet Service and Transport layers used in this document
to investigate data plane options as explained in the following.

In any case, I guess we should get rid of "seamless redundancy" from the data plane draft as the architecture uses "packet replication and elimination" instead.

Ø  Would be good

I guess we should update the data plane draft to

The two referred bullets of Section 4 could be updated to:

for the Service layer:
#5 Packet elimination for packet replication and elimination (see Section 3.4 in Architecture)

Ø  yes

for the Transport layer
#5 Packet replication and splits and merges of DetNet flows for packet replication and elimination (see Section 3.4 in Architecture)

> Yes

nits on the architecture draft

all kinds of nodes are defined as "DetNet xy node" except for "relay node" which has no DetNet in its name but the definition itself begins with DetNet. Maybe it could be renamed to "DetNet relay node" and the definition could be moved next to "DetNet relay edge node" to show the specialty of edge.

 DetNet node
           A DetNet aware end system, transport node, or relay node.
           "DetNet" may be omitted in some text.

Ø    I have generalized it for now. We can simplify later by explaining that it is a language abuse

It may be confusing to have "end system here.
However,, I understand that an end system is a DetNet relay node e.g., the right hand side end system in Fig 1 of data plane.
Unfortunately, I have no resolution at hand.

Ø    We have not fully sorted that out. Let us delay.

Thanks for all Janos!!!!

Regards,
Janos

On 7/6/2016 9:11 PM, Lou Berger wrote:

Norm,

    I think there are still some mismatches between what Jouni is

working on and this document.  Do you have time to discuss today? or

tomorrow am?  What's the best way to get you comments on other sections?

Lou

On 7/6/2016 2:49 PM, Norman Finn (nfinn) wrote:

Uploaded it to bitbucket.  Here’s a link to the text in dropbox.

https://www.dropbox.com/s/9kc1ingqtnwgb49/draft-finn-detnet-architecture-05

.txt?dl=0

Big differences are the simplified stack diagram and terminology revised

to better match dp-alt, in accordance with last two dial-in meetings.

— Norm

_______________________________________________

Detnet-dp-dt mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/detnet-dp-dt

_______________________________________________

Detnet-dp-dt mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Janos Farkas <[email-masked]>
Date: Fri, 8 Jul 2016 17:51:49 +0000

I leave it for u now.
I can't work any more today.
Thanks,
János

Sent from my Android phone using Symantec TouchDown (www.symantec.com)

-----Original Message-----
From: Pascal Thubert (pthubert) [[email-masked]]
Received: péntek, 08 júl. 2016, 18:06
To: Janos Farkas [[email-masked]]; Norman Finn (nfinn) [[email-masked]]
CC: [email-masked] [[email-masked]]
Subject: Publishing v06 of architecture draft

Dear Janos and all:

DetNet intermediate node

DetNet transport node

   DetNet relay edge node

Works?

for the Service layer:

for the Transport layer

DetNet service layer

DetNet transport layer

Ø  Would be good

for the Service layer:

Ø  yes

for the Transport layer

 DetNet node

Thanks for all Janos!!!!

Regards,
Janos

Norm,

Lou

.txt?dl=0

— Norm

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 8 Jul 2016 11:06:15 -0700

Inline..

On Fri, Jul 8, 2016 at 9:06 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> <for Norm> I updated archie 06 in the bitbucket based on the below. I’d
> appreciate if you can check and publish to the IETF today, since this is
> cutoff. I’ll check later and push myself in the absence of news from you.
>
>
>
> Dear Janos and all:
>
>
>
>
>
>
>
>
> Ø    This comes from the old separation of service and transport. Service
> was whanged to relay. If replication is transport and elimination is relay
> (service) layer, then we can have one without the other in a given node...
>
​We got some misalignment here still. Let's sort all this out by the ​Wg
meeting. The agenda will again have a slot for terminology ;)

> multiple links and/or sub-networks. An *MPLS LSR* is an example of
> a transit node.
>
>            be a router, *transit node*, bridge, *Label Switch Router
> (LSR)*,
> (My understanding from the call yesterday and from the data plane draft is
> that a relay node is rather a LER than an LSR.)
>
> Ø  I think we mean that it may be **collocated with** IOW **implemented
> in a**  transit node such as a router, a switch or a MPLS LSR. Works?
>
> A DetNet relay node     typically incorporates DetNet transport layer
> functions as  well, in which case it is collocated with a transit node,
> such  as a bridge, a router, a Label Switch Router (LSR), a firewall,   or
> any other system that participates in the DetNet service layer.
>
> Works?
>
​I though this was given i.e., relay has to have transport layer functions
as well.​

>
>
>
> In the data plane draft, the criteria relevant for the Service and dor the
> Transport layer are collected in Section 4. IT has been discussed a lot and
> what we have at the moment is:
>
> for the Service layer:
> One key difference is that packet replication is considered as part of the
> Service layer in the Architecture draft whereas it is part of the Transport
> layer in the data plane draft.
>
>
>
> DetNet service layer:    The layer at which the elimination part of packet
> replication and elimination (Section 3.4) is performed.
>
>
>
> At the moment, maybe the easiest way to delete these from the architecture
> draft? (Actually the Service and Transport layers are distinguished for
> other purposes too.)
>
> In any case, I guess we should get rid of "seamless redundancy" from the
> data plane draft as the architecture uses "packet replication and
> elimination" instead.
>
>
>
> Ø  Would be good
>
>
>
> #5 Packet replication and splits and merges of DetNet flows for packet
> replication and elimination (see Section 3.4 in Architecture)
>
> > Yes
>

​I did not implement the above two into DP draft like this i.e., references
in parenthesis are not there and the language is bit different. The message
is the same, though.​

​- Jouni​

> all kinds of nodes are defined as "DetNet xy node" except for "relay node"
> which has no DetNet in its name but the definition itself begins with
> DetNet. Maybe it could be renamed to "DetNet relay node" and the definition
> could be moved next to "DetNet relay edge node" to show the specialty of
> edge.
>
>
>  DetNet node
> However,, I understand that an end system is a DetNet relay node e.g., the
> right hand side end system in Fig 1 of data plane.
> [email-masked]
> [email-masked]
> [email-masked]

-- 
Jouni Korhonen, Broadcom Ltd.

---

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Fri, 8 Jul 2016 19:21:24 +0000

I’m all for “transit” instead of “transport”.  Sorry for the confusion.

— Norm

From: Jouni Korhonen <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 8, 2016 at 11:06 AM
To: Pascal Thubert <[email-masked]<mailto:[email-masked]>>
Cc: János Farkas <[email-masked]<mailto:[email-masked]>>, Norman Finn <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet-dp-dt] Publishing v06 of architecture draft

defines

---

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Fri, 8 Jul 2016 19:21:45 +0000

I’ll take care of it.

— Norm

From: János Farkas <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 8, 2016 at 10:51 AM
To: Norman Finn <[email-masked]<mailto:[email-masked]>>, Pascal Thubert <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Publishing v06 of architecture draft

I leave it for u now.

-----Original Message-----
From: Pascal Thubert (pthubert) [[email-masked]<mailto:[email-masked]>]
Received: péntek, 08 júl. 2016, 18:06
To: Janos Farkas [[email-masked]<mailto:[email-masked]>]; Norman Finn (nfinn) [[email-masked]<mailto:[email-masked]>]
CC: [email-masked]<mailto:[email-masked]> [[email-masked]<mailto:[email-masked]>]
Subject: Publishing v06 of architecture draft

Dear Janos and all:

DetNet intermediate node

DetNet transport node

   DetNet relay edge node

Works?

for the Service layer:

for the Transport layer

DetNet service layer

DetNet transport layer

Ø  Would be good

for the Service layer:

Ø  yes

for the Transport layer

 DetNet node

Thanks for all Janos!!!!

Regards,
Janos

Norm,

Lou

.txt?dl=0

— Norm