Subject: [Detnet-dp-dt] where do I find the sequence number

From: Loa Andersson <[email-masked]>
Date: Fri, 13 Jan 2017 12:23:38 +0800

Folks,

I'm thinking about the discussion we had last meeting, to avoid silly
mistakes, one question.

In the case we have the detnet PW running over MPLS, where do we place 
the sequence number.

Is it part of the PW payload?

/Loa
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Balázs Varga A <[email-masked]>
Date: Fri, 13 Jan 2017 06:30:58 +0000

Hi Loa,

For the PW scenario the Control Word is envisioned to provide sequencing services, 
and so the CW would be mandatory for DetNet flows.

We have identified one issue with the CW, namely the size of the sequence number 
in a generic CW is 16 bits. Depending on the link and the DetNet flow speed it may 
be too little.

Cheers
Bala'zs

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Friday, January 13, 2017 5:24 AM
To: [email-masked]
Subject: [Detnet-dp-dt] where do I find the sequence number

Folks,

I'm thinking about the discussion we had last meeting, to avoid silly mistakes, one question.

In the case we have the detnet PW running over MPLS, where do we place the sequence number.

/Loa
-- 

_______________________________________________
Detnet-dp-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Loa Andersson <[email-masked]>
Date: Fri, 13 Jan 2017 17:02:17 +0800

Balázs,

Tnx, OK I'm on the same page :).

Question: If we could use 28 bits would that be enough?

/Loa

--

---

From: Balázs Varga A <[email-masked]>
Date: Fri, 13 Jan 2017 14:26:34 +0000

Hi Loa,
I think yes. We have made just very basic math.
- 100G interface with 64 byte packets results roughly 200 million packets per second.
- 2^28 = 268 million different values
- transport delay difference should be << 1 sec 
So, with 28 bits You are fine even in extreme cases.
Cheers
Bala!zs

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Friday, January 13, 2017 10:02 AM
To: Balázs Varga A <[email-masked]>; [email-masked]
Subject: Re: [Detnet-dp-dt] where do I find the sequence number

Balázs,

/Loa

On 2017-01-13 14:30, Balázs Varga A wrote:
> Hi Loa,
>
> For the PW scenario the Control Word is envisioned to provide 
> sequencing services, and so the CW would be mandatory for DetNet flows.
>
> We have identified one issue with the CW, namely the size of the 
> sequence number in a generic CW is 16 bits. Depending on the link and 
> the DetNet flow speed it may be too little.
>
> Cheers
> Bala'zs
>

--

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 13 Jan 2017 08:44:53 -0800

PW control word.

- Jouni

--
Jouni Korhonen, Broadcom Ltd.
M: +1-408-391-7160

> On Jan 12, 2017, at 8:23 PM, Loa Andersson <[email-masked]> wrote:
> 
> Folks,
>