Subject: [Detnet-dp-dt] thoughts from the 1st DT call

From: Jouni Korhonen <[email-masked]>
Date: Wed, 4 Jan 2017 12:52:05 -0800

We had a well attended call last night: Jouni, Tal, Carlos, Janos, Balazs, Loa, Yuanlong.

First, send me your github account names, so that I can add you to the upcoming repository.

We have calls if we have things to discuss. Jouni will inform about whether the call takes place or not latest during the preceding weekend. We will have a call next week.

After all the management related discussions we managed to scratch the surface on two topics. First, Balazs brought up the topic how much nodes in the network need to understand detnet flows. This was in the context of using PW labels to identify the flow and it can be an issue i.e., the node in the path has to look into the label stack to identify the flow, while the same could be achieved using other methods as well. Is plain outer label-based forwarding OK in some nodes? Second, Jouni brought up a similar topic in the context of FRER. It implies the node doing FRER would need to do quite a bit of work within the label stack, and it needs to be decided whether we aim doing such operations only at the edges of the network/detnet domain or also within the detnet domain.

List of background material to be collected. I would suggest taking a quick look at IEEE 802.1TSN specs (specifically 802.1CB and 802.1CM). Feel free to fill in more documents that you think are essential to understand.

Mailstones - first phase:
* End of Jan - have fundamental decisions of the high level solution directions agreed.
* End of Feb - DT internal -00 publication ready. This can be a rather barebones version, though.

- Jouni

--
Jouni Korhonen, Broadcom Ltd.
M: +1-408-391-7160

---

From: Norman Finn <[email-masked]>
Date: Wed, 4 Jan 2017 13:46:46 -0800

Sorry I missed the meeting.

Github username: nfinn

Good points brought up.  The underlying question is the degree of detail to export to the outside of the packet (not to mention the question of where the outside is).

Suppose, purely on the basis of routing, you would wrap two hundred different Pos with a single outer label, but to get DetNet QoS you need to differentiate specific flows and not just by a few priority levels.  Do you use two hundred outer labels to satisfy DetNet, or does a DetNet-aware node look deeper into the stack?

With regard to FRER, all the use cases I’ve seen assume a single detnet domain, but those were not thinking about MPLS stacks.

To put it another way -- and this may or may not be closer to your question — I haven’t seen a use case that demands you to do FRER manipulations on a sequence number buried 4 layers deep in the stack.

— Norm

> On Jan 4, 2017, at 12:52, Jouni Korhonen <[email-masked]> wrote:
> 
> 
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt