Subject: [Detnet-dp-dt] Data Plane Approach - Synchronization Traffic

From: Tal Mizrahi <[email-masked]>
Date: Thu, 26 Jan 2017 06:44:45 +0000

Hi,

I realize this is a bit off-topic, but one of the things I am wondering about is how synchronization traffic (PTP) is forwarded in the context of the data plane approaches we have been considering.
Is PTP transported as a DETNET flow?
- If the answer is no: does that mean we are assuming that synchronization is achieved at a different layer, possibly requiring dedicated communication between the customer and provider?
- If the answer is yes: not sure replication and elimination makes sense for PTP.

Will be happy to hear your thoughts, and apologies if this has already been discussed elsewhere and I am not aware.

Cheers,
Tal.

---

From: Loa Andersson <[email-masked]>
Date: Thu, 26 Jan 2017 15:01:01 +0800

Tal,

> - If the answer is yes: not sure replication and elimination makes sense for PTP.

Why is that?

/Loa
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Tal Mizrahi <[email-masked]>
Date: Thu, 26 Jan 2017 07:10:12 +0000

Hi Loa,

>> - If the answer is yes: not sure replication and elimination makes sense for PTP.

In order for PTP to work well, PTP packets have to be consistently sent over the same path. If packets are intermittently sent through two different paths (with two different delays) the PTP slave will not be able to synchronize in a stable way.
However, it *does* make sense for PTP to be sent through two different paths *without* elimination at the end. Such path redundancy allows the slave to always receive the sync information through both paths, which actually allows more robust synchronization than over a single path.

So path redundancy is good for PTP, but elimination - not so good. 

Cheers,
Tal.

>-----Original Message-----
>From: Loa Andersson [mailto:[email-masked]]
>Sent: Thursday, January 26, 2017 9:01 AM
>To: Tal Mizrahi; [email-masked]
>Subject: [EXT] Re: [Detnet-dp-dt] Data Plane Approach - Synchronization Traffic
>
>External Email
>
>----------------------------------------------------------------------
>Tal,
>
>> I realize this is a bit off-topic, but one of the things I am wondering about is how
>synchronization traffic (PTP) is forwarded in the context of the data plane
>approaches we have been considering.
>> - If the answer is no: does that mean we are assuming that synchronization is
>achieved at a different layer, possibly requiring dedicated communication
>between the customer and provider?

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 26 Jan 2017 10:39:50 -0800

> On Jan 25, 2017, at 11:10 PM, Tal Mizrahi <[email-masked]> wrote:
> 
> Hi Loa,
> 
> 

In a path redundancy case would the PTP messages on multiple paths be exact copies a single origin PTP message or different PTP messages?

- JOuni

---

From: Tal Mizrahi <[email-masked]>
Date: Fri, 27 Jan 2017 07:36:58 +0000

>In a path redundancy case would the PTP messages on multiple paths be exact
>copies a single origin PTP message or different PTP messages?

They would be two different PTP messages.
This implies that we would not like PTP packets to be subject to replication and elimination.

Tal.

>From: Jouni Korhonen [mailto:[email-masked]]
>Sent: Thursday, January 26, 2017 8:40 PM
>To: Tal Mizrahi
>Cc: Loa Andersson; [email-masked]
>Subject: Re: [Detnet-dp-dt] [EXT] Re: Data Plane Approach - Synchronization
>Traffic
>
>
>
>> In order for PTP to work well, PTP packets have to be consistently sent over the
>same path. If packets are intermittently sent through two different paths (with
>two different delays) the PTP slave will not be able to synchronize in a stable way.
>> However, it *does* make sense for PTP to be sent through two different paths
>*without* elimination at the end. Such path redundancy allows the slave to
>always receive the sync information through both paths, which actually allows
>more robust synchronization than over a single path.
>>
>In a path redundancy case would the PTP messages on multiple paths be exact
>copies a single origin PTP message or different PTP messages?
>
>- JOuni
>
>
>>
>> Cheers,
>> Tal.
>>
>>
>>> synchronization traffic (PTP) is forwarded in the context of the data
>>> plane approaches we have been considering.
>>> achieved at a different layer, possibly requiring dedicated
>>> communication between the customer and provider?
>>>> Will be happy to hear your thoughts, and apologies if this has
>>>> already been
>>> discussed elsewhere and I am not aware.
>>>>
>>>> Cheers,
>>>> Tal.

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 31 Jan 2017 20:13:08 +0000

Hi,
For sync usually we need hop-by-hop forwarding. 
So it is not clear why to consider replication (and elimination) at all?
Cheers
Bala'zs

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Tal Mizrahi
Sent: Friday, January 27, 2017 8:37 AM
To: Jouni Korhonen <[email-masked]>
Cc: [email-masked]; Loa Andersson <[email-masked]>
Subject: Re: [Detnet-dp-dt] [EXT] Re: Data Plane Approach - Synchronization Traffic

>In a path redundancy case would the PTP messages on multiple paths be 
>exact copies a single origin PTP message or different PTP messages?

Tal.

>Subject: Re: [Detnet-dp-dt] [EXT] Re: Data Plane Approach - 
>Synchronization Traffic
>
>
>
>>>> - If the answer is yes: not sure replication and elimination makes 
>>>> sense for
>PTP.
>>>
>>> Why is that?
>>
>same path. If packets are intermittently sent through two different 
>paths (with two different delays) the PTP slave will not be able to synchronize in a stable way.
>*without* elimination at the end. Such path redundancy allows the slave 
>to always receive the sync information through both paths, which 
>actually allows more robust synchronization than over a single path.
>>
>In a path redundancy case would the PTP messages on multiple paths be 
>exact copies a single origin PTP message or different PTP messages?
>
>- JOuni
>
>
>>
>> Cheers,
>> Tal.
>>
>>
>>> --------------------------------------------------------------------
>>> -
>>> -
>>> Tal,
>>>
>>> synchronization traffic (PTP) is forwarded in the context of the 
>>> data plane approaches we have been considering.
>>>> - If the answer is yes: not sure replication and elimination makes 
>>>> sense for
>PTP.
>>>
>>> Why is that?
>>>
>>> /Loa
>>>>

---

From: Jouni Korhonen <[email-masked]>
Date: Tue, 31 Jan 2017 12:25:03 -0800

Indeed. Not all traffic will receive the replication/elimination service. That is based on the configuration.

- Jouni

--
Jouni Korhonen, Broadcom Ltd.
M: +1-408-391-7160

> On Jan 31, 2017, at 12:13 PM, Balázs Varga A <[email-masked]> wrote:
> 
> Hi,

---

From: Norman Finn <[email-masked]>
Date: Tue, 31 Jan 2017 13:10:49 -0800

> On Jan 31, 2017, at 12:25, Jouni Korhonen <[email-masked]> wrote:
>