Subject: [Detnet-dp-dt] DETNET Synchronization Slides

From: Tal Mizrahi <[email-masked]>
Date: Wed, 8 Feb 2017 06:51:32 +0000

Hi,

The slides from today's weekly meeting are attached.
I slightly updated them after the meeting based on the comments.

Cheers,
Tal.

---

From: János Farkas <[email-masked]>
Date: Wed, 8 Feb 2017 08:56:08 +0100

Hi Tal,

Thank you for the slides and for the discussion!
I'd also suggest to find the means to start the discussion on the DetNet 
WG mailing list. I think sync is an important topic, we have not dived 
into it yet and it would great to have the view of the WG and involve 
sync experts as we discussed on the call.

Thanks,
Janos

On 2/8/2017 7:51 AM, Tal Mizrahi wrote:
>
> Hi,
>
> The slides from today’s weekly meeting are attached.
>
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 8 Feb 2017 10:14:52 -0800

Thanks Tal,

Didn’t we also agree adjusting the slide 6 “typical accuracy” numbers:
1) <1ms or hundreds of us
2) <tens of us
3) <1us

- Jouni

--
Jouni Korhonen, Broadcom Ltd.
M: +1-408-391-7160

> On Feb 7, 2017, at 10:51 PM, Tal Mizrahi <[email-masked]> wrote:
> 
> Hi,
>  
> <Synchronization in DETNET.pptx>_______________________________________________

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 9 Feb 2017 06:23:40 +0000

Hi,
Yes, these are the typical numbers we concluded during the meeting.
Cheers
Bala'zs

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Jouni Korhonen
Sent: Wednesday, February 08, 2017 7:15 PM
To: Tal Mizrahi <[email-masked]>
Cc: [email-masked]
Subject: Re: [Detnet-dp-dt] DETNET Synchronization Slides

Thanks Tal,

- Jouni

---

From: Loa Andersson <[email-masked]>
Date: Thu, 9 Feb 2017 14:38:02 +0800

Folks,

A questionon the figures.

For Approach 3 I guess that there are experience.

How did we arrive at the figures for Approach 1 and 2?

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Tal Mizrahi <[email-masked]>
Date: Thu, 9 Feb 2017 07:22:43 +0000

Hi Jouni,

Sorry for not explaining the accuracy numbers on slide 6 further. I made some changes following the discussion, and also added notes saying that the accuracy will depend on the network topology and on the number of hops.

Regarding approach 2, I believe sub-microsecond accuracy can certainly be achieved using transparent clocks in a real network. There are quite a few publications that show this. Here are a couple: 
- For example, China Mobile have revealed in a keynote lecture in ISPCS 2014 that they have measured an accuracy of 266 ns over 30 hops of transparent clocks. Unfortunately, this presentation is not in the public domain, but a short version of it is available  (https://www.ietf.org/mail-archive/web/tictoc/current/pdfp9ceHphbcE.pdf). 
- Another example: http://wwwen.zte.com.cn/endata/magazine/ztecommunications/2010Year/no3/articles/201009/t20100913_191838.html
But again, this entirely depends on the nature of the network.

Regarding approach 1, the accuracy will entirely depend on the network topology (the number of hops, the physical distance, the type of intermediate nodes, the delay variation). Hundreds of microseconds is just an example. Some of the research I took part in showed that in a multi-site public cloud network you can achieve a precision on the order of hundreds of microseconds using PTP without on-path support (https://sites.google.com/site/talmizrahihome/files/TaaSInfocomFinal.pdf?attredirects=0). But again, this entirely depends on the nature of the network.

Please let me know if there are further comments.

Thanks,
Tal.

>From: Jouni Korhonen [mailto:[email-masked]]
>Sent: Wednesday, February 08, 2017 8:15 PM
>To: Tal Mizrahi
>Subject: [EXT] Re: [Detnet-dp-dt] DETNET Synchronization Slides
>
>External Email
>
>----------------------------------------------------------------------
>Thanks Tal,
>
>> <Synchronization in
>DETNET.pptx>_______________________________________________

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 9 Feb 2017 12:35:04 -0800

Tal,

I understood that in 2) the TC function would only be in the PW nodes we define leaving all intermediate “normal” LSRs between PW nodes as a source of higher inaccuracy. If this was not a correct understanding then the value in 2) is likely too high.

- Jouni

> On 08 Feb 2017, at 23:22, Tal Mizrahi <[email-masked]> wrote:
> 
> Hi Jouni,
>

---

From: Tal Mizrahi <[email-masked]>
Date: Mon, 13 Feb 2017 09:01:02 +0000

Hi Jouni, 

That is a fair point. If only the PW nodes function as TCs, then indeed the accuracy will be lower.
I added a clarification about this in slide 6.

The updated slides are attached.

Thanks,
Tal.

>Sent: Thursday, February 09, 2017 10:35 PM
>To: Tal Mizrahi
>Subject: Re: [EXT] [Detnet-dp-dt] DETNET Synchronization Slides
>
>Tal,
>
>I understood that in 2) the TC function would only be in the PW nodes we define
>leaving all intermediate “normal” LSRs between PW nodes as a source of higher
>inaccuracy. If this was not a correct understanding then the value in 2) is likely
>too high.
>
>- Jouni
>
>
>> Sorry for not explaining the accuracy numbers on slide 6 further. I made some
>changes following the discussion, and also added notes saying that the accuracy
>will depend on the network topology and on the number of hops.
>>
>> Regarding approach 2, I believe sub-microsecond accuracy can certainly be
>achieved using transparent clocks in a real network. There are quite a few
>publications that show this. Here are a couple:
>> - For example, China Mobile have revealed in a keynote lecture in ISPCS 2014
>that they have measured an accuracy of 266 ns over 30 hops of transparent
>clocks. Unfortunately, this presentation is not in the public domain, but a short
>version of it is available  (https://www.ietf.org/mail-
>archive/web/tictoc/current/pdfp9ceHphbcE.pdf).
>> - Another example:
>http://wwwen.zte.com.cn/endata/magazine/ztecommunications/2010Year/no3
>/articles/201009/t20100913_191838.html
>> Regarding approach 1, the accuracy will entirely depend on the network
>topology (the number of hops, the physical distance, the type of intermediate
>nodes, the delay variation). Hundreds of microseconds is just an example. Some
>of the research I took part in showed that in a multi-site public cloud network you
>can achieve a precision on the order of hundreds of microseconds using PTP
>without on-path support
>(https://sites.google.com/site/talmizrahihome/files/TaaSInfocomFinal.pdf?attred
>irects=0). But again, this entirely depends on the nature of the network.
>>

---

From: Loa Andersson <[email-masked]>
Date: Mon, 13 Feb 2017 17:48:00 +0800

Tal and Jouni,

I'm trying to make heads and tails of this.

I think we have the three scenarios in the slides + 1 or 2 more.

0.5 - raw,   i.e. running over a network without DetNet cpabilities
1.  - Naive, i.e. running over a DetNet network
1.5 - On-path-support, on a subset of the nodes
2.  - On path support (all nodes)
3.  - Time as a service

Nat that we need to include all this in the list, I just want to have
an understanding that DetNet capabilities improve the things.

/Loa

--

---

From: Tal Mizrahi <[email-masked]>
Date: Mon, 13 Feb 2017 09:54:25 +0000

Hi Loa,

Right, that is my understanding as well.

Thanks,
Tal.

>From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Loa
>Andersson
>Sent: Monday, February 13, 2017 11:48 AM
>To: [email-masked]
>Subject: Re: [Detnet-dp-dt] [EXT] DETNET Synchronization Slides
>
>Tal and Jouni,
>
>1.5 - On-path-support, on a subset of the nodes 2.  - On path support (all nodes)
>3.  - Time as a service
>
>Nat that we need to include all this in the list, I just want to have an
>understanding that DetNet capabilities improve the things.
>
>/Loa
>
>>> I understood that in 2) the TC function would only be in the PW nodes
>>> we define leaving all intermediate "normal" LSRs between PW nodes as
>>> a source of higher inaccuracy. If this was not a correct
>>> understanding then the value in 2) is likely too high.
>>>
>>> - Jouni
>>>
>>>
>>> changes following the discussion, and also added notes saying that
>>> the accuracy will depend on the network topology and on the number of
>hops.
>>>>
>>> achieved using transparent clocks in a real network. There are quite
>>> a few publications that show this. Here are a couple:
>>> that they have measured an accuracy of 266 ns over 30 hops of
>>> transparent clocks. Unfortunately, this presentation is not in the
>>> public domain, but a short version of it is available
>>> (https://www.ietf.org/mail- archive/web/tictoc/current/pdfp9ceHphbcE.pdf).
>>>> - Another example:
>>>
>http://wwwen.zte.com.cn/endata/magazine/ztecommunications/2010Year/no
>>> 3 /articles/201009/t20100913_191838.html
>>> topology (the number of hops, the physical distance, the type of
>>> intermediate nodes, the delay variation). Hundreds of microseconds is
>>> just an example. Some of the research I took part in showed that in a
>>> multi-site public cloud network you can achieve a precision on the
>>> order of hundreds of microseconds using PTP without on-path support
>>> (https://sites.google.com/site/talmizrahihome/files/TaaSInfocomFinal.
>>> pdf?attred irects=0). But again, this entirely depends on the nature
>>> of the network.
>>>>
>>>>> Didn't we also agree adjusting the slide 6 "typical accuracy" numbers:

---

From: Norman Finn <[email-masked]>
Date: Wed, 15 Feb 2017 05:50:20 +0000

Good summary.  Thanks.

-- Norm

________________________________________
From: Detnet-dp-dt [[email-masked]] on behalf of Tal Mizrahi [[email-masked]]
Sent: Monday, February 13, 2017 1:01 AM
To: Jouni Korhonen
Cc: [email-masked]
Subject: Re: [Detnet-dp-dt] [EXT]  DETNET Synchronization Slides

Hi Jouni,

Thanks,
Tal.