Subject: Re: [Detnet-dp-dt] Using MS-PW concept for the d-pw

From: Jiangyuanlong <[email-masked]>
Date: Sun, 26 Feb 2017 02:28:11 +0000

The egress knows that two PWs are mapped to the same elimination module, and in the data plane, packets with these two PW label values are directed to the same elimination module, then packets are eliminated by their sequence number.
Even when only a single common elimination module is available for all detnet, a vLabel can be used internally to identify detnet PWs. that is, two PWs are mapped to the same vLabel, elimination is done based on (vLabel, sequence number).

Cheers,
Yuanlong
发件人：LoaAndersson
收件人：[email-masked]
时间：2017-02-25 18:30:20
主题:Re: [Detnet-dp-dt] Using MS-PW concept for the d-pw

Yuanlong,

On 2017-02-25 18:02, Jiangyuanlong wrote:
> Loa,
>
> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: Saturday, February 25, 2017 3:34 PM
> To: Jiangyuanlong; Jouni Korhonen
> Cc: [email-masked]
> Subject: Re: [Detnet-dp-dt] Using MS-PW concept for the d-pw
>
> Yuanlong,
>
> The L-laabel is ther to make the the intermediate not (S-PE) know what to do whit the packet, the d-pw label was not allocated by the S-PE, so it does not ahve any knowledge what it means.
> [YJ] d-pw can be allocated by the S-PE in MS-PW, just as you would like to allocate the L-labels. Very similarly, I think the same T-LDP protocol can be used.

If you do that the S-PE will swap the d-pw, packets will come in from
two different directions with differnt d-pws to the egress, and there
is no way for the egress to identify packets to eliminate.

/Loa
and the egress will have no way

> [YJ] As I said in the previous email, using PW to trigger FRER will be cleaner

compared with using L-label since CW is inspected.
>
> If you let the S-PEs allocate and swap d-pw's, the next S-PE or a T-PE can't coordinate for the same packet coming in on from tow different nodes.
> [YJ] It's like the 1+1 PW protection case, though the operations of elimination and replication in the S-PE and the T-PE need to be specified.
> [YJ]Take VPLS as an example, several PWs can be directed into the same VSI in a PE and PW packets are processed there (for detnet, the processing is FRER now).
>
> But I feel like we are going in circles, can we agree on the corner stones first?
>
> Do we want all possible/conceivable control mechanism be within scope?
> [YJ] maybe we can take LDP as a first step. It seems the difficulty is how to decide the S-PEs for a detnet flow (a routing protocol may be needed for automatic selection).
> [YJ] if all T-PEs and S-PEs are determined for a detnet flow, it is quite easy to set up PW segments and LSPs respectively with the help of LDP protocol.
> Cheers,
> Yuanlong
>
> /Loa
>
>
> On 2017-02-25 15:18, Jiangyuanlong wrote:
>> I agreed to alternative 2. L-label is not needed, S-PE must look into the PW label (further, extract sequence number in the CW) of a packet, and all FRER semantics can be coupled with the PW label.
>>
>> -----Original Message-----
>> From: Jouni Korhonen [mailto:[email-masked]]
>> Sent: Saturday, February 25, 2017 3:07 PM
>> To: Jiangyuanlong
>> Cc: [email-masked]; Loa Andersson
>> Subject: Re: [Detnet-dp-dt] Using MS-PW concept for the d-pw
>>
>> Hi,
>>
>>> [YJ] I regard the L-Labels and T-labels are the same LSP layer. If we look into the full MPLS label stack of a packet in a PW, normally there is an LSP label at the top (unless PHP is enabled for the last hop).
>>> Not sure what is the L-Label in your picture, is it different from LSP label?
>>
>> L-labels have been so far in the discussion between MS-PW PEs.
>> T-labels are between any LSR. L-labels are not PHPed i.e., even if PHP
>> is enable the L-Label stays and the label above it gets popped (that
>> we have been referring as T-Labels). T- and L-labels are just a naming
>> convention. IF you don’t have “between MS-PW PEs” semantic associated
>> with the L-Label, it is the same as T-Label ;)
>>
>>
>>
>> case L-labels are present.. (alternative 1)
>>
>>                      PHP
>>                    -------->
>> +------------+                  +------------+
>> |  T-labels  |                  |  L-label   |
>> +------------+                  +------------+
>> |  L-label   |                  | d-pw label |
>> +------------+                  +------------+
>> | d-pw label |                  |            |
>> +------------+                  |  Payload   |
>> |            |                  |            |
>> |  Payload   |                  +------------+
>> |            |
>> +------------+
>>
>> case no L-labels.. (alternative 2.. and also alternative 3 if you
>> think T- and L-labels are the same)
>>
>>                      PHP
>>                    -------->
>> +------------+                  +------------+
>> |  T-labels  |                  | d-pw label |
>> +------------+                  +------------+
>> | d-pw label |                  |            |
>> +------------+                  |  Payload   |
>> |            |                  |            |
>> |  Payload   |                  +------------+
>> |            |
>> +------------+
>>
>>
>>
>>
>>
>> - Jouni
>>
>

--

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

_______________________________________________
Detnet-dp-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Loa Andersson <[email-masked]>
Date: Sun, 26 Feb 2017 11:20:09 +0800

Yuanlong,

Either I missed something or something has not been communicated.

On 2017-02-26 10:28, Jiangyuanlong wrote:
> The egress knows that two PWs are mapped

what info does the the eliminating node use to map the PW to the
virtual label? Or for that matter elimination module

to the same elimination module,

I don't think we can mandate how things happen within the box, that
should be implementation specific, what we need is to make sure that
there is enough info to do what we specify.

> and in the data plane, packets with these two PW label values are
> directed to the same elimination module,

what is the means by which this direction is doen
then packets are eliminated by
> their sequence number.

yes - that part is common for all proposals

> Even when only a single common elimination module is available for all
> detnet, a vLabel can be used internally to identify detnet PWs. that is,
> two PWs are mapped to the same vLabel, elimination is done based on
> (vLabel, sequence number).

why is a virtual label better than an L-label??

Would you say that this works with the existing control plane protocols
without changes to these protocols?

/Loa
>
> Cheers,
> Yuanlong
> *发件人：*LoaAndersson
> *收件人：[email-masked]
> *时间：*2017-02-25 18:30:20
> *主题:*Re: [Detnet-dp-dt] Using MS-PW concept for the d-pw
>
> Yuanlong,
>
>

--