Subject: [Detnet-dp-dt] Figure 10 (example of DetNet data plane operation)

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Sat, 11 Mar 2017 17:36:38 +0100

Hi,

I've committed a proposal of Figure 10 for the example in the annex, trying to make it a bit simpler (so we use it with ascii art):

--8-<----8-<----8-<----8-<----8-<----8-<----8-<----8-<----8-<----

T1      ->R1----->DA-S-PE1---->R2---->DA-S-PE2--->R3

L1     /     L1            T2     L2           T3   \    L2

PW1   /      PW1           L2     PW1          L2    \   PW1

#seq  /       #seq          PW1    #seq         PW1    \  #seq

FID1 /        FID1          #seq   FID1         #seq    \ FID1

/                                           FID1     v

E1-->DA-T-PE1                                            DA-T-PE2-->E3

\                                T5     T6           ^

T4 \        L2     L3              L4     L5          /

L2  \       PW1    PW2             PW1    PW2        /

PW1  \      #seq   #seq            #seq   #seq      /

#seq  \     FID1   FID2            FID1   FID2     /

FID1   =>R4------------->DA-S-PE2--------------->R5

/                    ^                       \

/                      \    L9                 \

/                        \   PW2                 \

/                          \  #seq                 \

/                            \ FID2                  v

E2-->DA-T-PE3                         R9<-    T10        DA-T-PE4-->E4

\                     T8         \   L9    T9        ^

T7 \      L6            L7     L7   \  PW2   L8       / L8

L6  \     PW2           PW2    PW2   \ #seq  PW2     /  PW2

PW2  \    #seq          #seq   #seq   \FID2  #seq   /   #seq

#seq  \   FID2          FID2   FID2    \     FID2  /    FID2

FID2   ->R6---->DA-S-PE2---->R7---->DA-S-PE6---->R8

Figure 10: Replication and elimination example

--8-<----8-<----8-<----8-<----8-<----8-<----8-<----8-<----8-<----

Comments? Surely, I've made mistakes...

Carlos

---

From: Loa Andersson <[email-masked]>
Date: Sun, 12 Mar 2017 14:35:24 +0800

Carlos,

There is a

T11
L3
PW2
seq#
FID2

Between DA-T-PE3 and R4, right?

One other thing is that if we do the Figure this way, we miss the
option of showing that there is a possibility to merge L-labels on to
the same T-label.

/Loa

On 2017-03-12 00:36, Carlos Jesús Bernardos Cano wrote:
> Hi,
>
> I've committed a proposal of Figure 10 for the example in the annex,
> trying to make it a bit simpler (so we use it with ascii art):
>
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Sun, 12 Mar 2017 12:02:29 +0100

Hi Loa,

> Between DA-T-PE3 and R4, right?

Yes, I missed that.

> option of showing that there is a possibility to merge L-labels on to

Well, the figure was just meant to be an example in the annex. We can
mention that there are other options (and even also do a figure for
that). I think there is value in including an example to show the label
stack (at least, for me it is quite helpful to understand for what each
 label is used :D).

Thanks,

Carlos