Subject: [Detnet-dp-dt] Presentation on L2/L3 issues

From: Norman Finn <[email-masked]>
Date: Tue, 14 Mar 2017 15:58:44 +0000

Do we have time for, and do you think it would be useful, for me to do a 20 min presentation (10 min for preso, 10 for comments/questions) in Chicago on my opinion of what's needed to link IEEE TSN and IETF DetNet properly?  Of course, a draft would follow for July.  This preso should be after any architecture and data plane presentations.  I see two subjects that could be brought up:

  a) show the need for both L2 tunnel connectivity between bridged islands across the routed network, and apparent routed connectivity (actually a tunnel) between bridged islands.

  b) show the need for applying 802.1 TSN queuing mechanisms to routers / label switches, and an approach (via a YANG model) of applying them without rewriting 802.1Q, where the definitions currently live.

What's your opinion?

-- Norm

---

From: Jouni Korhonen <[email-masked]>
Date: Tue, 14 Mar 2017 11:52:14 -0700

Sounds good to me. I’ll check if this still fits into the agenda once I get to write it down.

- JOuni

-- 
Jouni Korhonen, Broadcom, Core Switching Group
+1-408-391-7160

> On Mar 14, 2017, at 8:58 AM, Norman Finn <[email-masked]> wrote:
> 
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: János Farkas <[email-masked]>
Date: Tue, 14 Mar 2017 20:02:31 +0100

Hi Norm,

I think such discussion would be useful.
We tried to get started with item b): 
https://tools.ietf.org/html/draft-varga-detnet-service-model-01#section-13.
(this draft was chosen to put the text somewhere in lack of a better one 
and to avoid a separate draft for these initial text and figures)

Thanks,
Janos

On 3/14/2017 4:58 PM, Norman Finn wrote:
> Do we have time for, and do you think it would be useful, for me to do 
> a 20 min presentation (10 min for preso, 10 for comments/questions) in 
> Chicago on my opinion of what's needed to link IEEE TSN and IETF 
> DetNet properly?  Of course, a draft would follow for July.  This 
> preso should be after any architecture and data plane presentations.  
> I see two subjects that could be brought up:
>
>   a) show the need for both L2 tunnel connectivity between bridged 
> islands across the routed network, and apparent routed connectivity 
> (actually a tunnel) between bridged islands.
>
>   b) show the need for applying 802.1 TSN queuing mechanisms to 
> routers / label switches, and an approach (via a YANG model) of 
> applying them without rewriting 802.1Q, where the definitions 
> currently live.
>
> What's your opinion?
>
> -- Norm
>
>

---

From: Norman Finn <[email-masked]>
Date: Tue, 14 Mar 2017 19:26:47 +0000

I'll look at that before I write any slides.  Thanks.

-- Norm

________________________________
From: János Farkas [[email-masked]]
Sent: Tuesday, March 14, 2017 12:02 PM
To: Norman Finn
Cc: [email-masked]; Pat Thaler; Lou Berger; DetNet Chairs; [email-masked]
Subject: Re: [Detnet-dp-dt] Presentation on L2/L3 issues

Hi Norm,

I think such discussion would be useful.
We tried to get started with item b): https://tools.ietf.org/html/draft-varga-detnet-service-model-01#section-13.
(this draft was chosen to put the text somewhere in lack of a better one and to avoid a separate draft for these initial text and figures)

Thanks,
Janos

What's your opinion?

-- Norm

_______________________________________________
Detnet-dp-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Norman Finn <[email-masked]>
Date: Tue, 14 Mar 2017 19:27:07 +0000

OK.  I'll put together something, just in case.

-- Norm

________________________________________
From: Jouni Korhonen [[email-masked]]
Sent: Tuesday, March 14, 2017 11:52 AM
To: Norman Finn
Cc: Pat Thaler; Lou Berger <lberger@labn. net>; DetNet Chairs; [email-masked]
Subject: Re: [Detnet-dp-dt] Presentation on L2/L3 issues

- JOuni