Subject: [Detnet-dp-dt] New update of the draft available

From: Jouni Korhonen <[email-masked]>
Date: Fri, 10 Mar 2017 15:25:10 -0800

* Added Loa’s comments on the L-label.
* Added Janos’ comments.
* Added extended forwarder text.
* Added (speculative text.. can be removed) D bit to flow-id word so that we can check in a ring case the direction of the flow (note this does not double history buffer space as claimed.. did not bother to fix that)
* reworked the PW encapsulation pictures.
* Added more content to DA-*-PE descriptions.

- Jouni

-- 
Jouni Korhonen, Broadcom, Core Switching Group
+1-408-391-7160

---

From: Loa Andersson <[email-masked]>
Date: Sat, 11 Mar 2017 10:38:11 +0800

Jouni,

Mostly looks very good, the thing I don't understand is why you still 
say that the L-label is optional, it really isn't.

- we need it to deliver the d-pw label unchanged
- since we can't guarantee that the "P" nodes are not able to do
   DetNet NSP, we can't set up the d-pw label with signaling that
   exposes the "request for DetNet NSP/FRER" to P nodes.
- needed for protection
- the end-to-end tunnel must be the innermost tunnel, carrying
   pw label

There is one case, if two DA-*-PEs are immediately adjacent, there the
L-lable will be an implicit NULL label and not appear in the stack, but
for the control plane it is there.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Jouni Korhonen <[email-masked]>
Date: Sun, 12 Mar 2017 16:44:23 -0700

I think there’s still a bit of confusion what constitutes T and L labels. Say I have a topology below:

          DA-T-PE     P       P       Php      DA-S-PE       Php    DA-T-PE
PW label     200      200     200     200    200 swp 300     300    300
L label
T label          123  swp 124 swp 125 pop                131 pop

Why would I need L-labels in the above case?

          DA-T-PE     P       P       Php      DA-S-PE       Php    DA-T-PE
PW label     200      200     200     200         200        200    200
L label      300      300     300     300    300 swp 400     400    400
T label          123  swp 124 swp 125 pop                131 pop

Here I could use the L-label to bypass DA-S-PE.

Correct me if this is not correct assumption..

- Jouni

> On Mar 10, 2017, at 6:38 PM, Loa Andersson <[email-masked]> wrote:
> 
> Jouni,
> 
> Mostly looks very good, the thing I don't understand is why you still say that the L-label is optional, it really isn't.
> 
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Loa Andersson <[email-masked]>
Date: Mon, 13 Mar 2017 14:03:12 +0800

Jouni,

I'm sorry if I caused the confusion. A PW needs the PSN Tunnel, we have
called L-Label because we use it for overlay also.

> T label          123  swp 124 swp 125 pop                131 pop

Yes - but you don't need the T-label (it is optional), and only tunnel 
part of the way between two DA-*-PEs.

I think this is the case
                        php                     php
         DA-T-PE  P      P     DA-S-PE    P      P    DA-T-PE
PW label    20   20    20    20 swp 30  30     30    terminate
L label     13   14    php     push 40  50     php
T label          <optional>

If you want we can talk about it, if you are online now.

/Loa

--

---

From: Balázs Varga A <[email-masked]>
Date: Mon, 13 Mar 2017 10:09:00 +0000

Hi, mail below seems to be lost in hyperspace. I send it again, sorry for possible duplicates ... Cheers Bala'zs

-----Original Message-----
From: Balázs Varga A 
Sent: Saturday, March 11, 2017 7:54 PM
To: 'Loa Andersson' <[email-masked]>; [email-masked]
Subject: RE: [Detnet-dp-dt] New update of the draft available

Hi Loa,

I think the addition of the DetNet Flow-ID to the "PW Encapsulation header" changed our former discussions. If the DetNet Flow-ID is present, we can change the d-pw label during the transport like in case of a legacy MS-PW.

Also we assume no protection other than PRER for DetNet flows (see also the draft-architecture, section 3.2).
" 3.2. Explicit routes
... DetNet employs
explicit routes, where the path taken by a given DetNet flow does not change, at least immediately, and likely not at all, in response to network topology events. Service protection (Section 3.4 or Section 3.5) over explicit routes provides a high likelihood of continuous connectivity. "

> d-pw label with signaling that exposes the "request for DetNet 
> NSP/FRER" to P nodes
Could You explain it more, I do not see your point. Do You propose that the L-label value would control whether a PW is a DetNet PW with PRER or not?

Thx & Cheers
Bala'zs

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Saturday, March 11, 2017 3:38 AM
To: [email-masked]
Subject: Re: [Detnet-dp-dt] New update of the draft available

Jouni,

There is one case, if two DA-*-PEs are immediately adjacent, there the L-lable will be an implicit NULL label and not appear in the stack, but for the control plane it is there.

/Loa

On 2017-03-11 07:25, Jouni Korhonen wrote:
> * Added (speculative text.. can be removed) D bit to flow-id word so 
> that we can check in a ring case the direction of the flow (note this 
> does not double history buffer space as claimed.. did not bother to 
> fix that)

--

---

From: Loa Andersson <[email-masked]>
Date: Mon, 13 Mar 2017 23:05:05 +0800

Balázs,

I'd not seen this before. I thought that we'd reached consensus on the
need to tunneling across the P routers after the comments from Jouni and
Yuanlong. Please see inline.

> Subject: RE: [Detnet-dp-dt] New update of the draft available
<snip>

> Could You explain it more, I do not see your point. Do You propose that the L-label value would control whether a PW is a DetNet PW with PRER or not?

We discuss the "overlay network" in terms of P and PE nodes. The P node
does not not do PRER, while the PE may do so if we tell them.

However one node by serve as P in one overlay network, and as PE in
another.

Consider:

                 +------+
                 | PE-B1|
                 +------+
                    |
                    v
                 +------+
                 | P-B1 |
                 +------+
                    |
                    v
                 +------+
  +------+       | P-A1 |       +------+       +------+       +------+
  | PE-A1|------>| PE-B2|------>| P-A2 |------>| P-A3 |------>| PE-A2|
  +------+       +------+       +------+       +------+       +------+
                    |
                    v
                 +------+
                 | P-B2 |
                 +------+
                    |
                    v
                 +------+
                 | PE-B3|
                 +------+

Ledgend: PE-A = DA-*-PE, PE node in network A
          P-A  = P node network A
          PE-B = DA-*-PE, PE node in network B
          P-B  = P node network B

Problem is signalling!

If have the PW-Label un-tunneled PE-B will establish the unprotected PW
to PE-B3, requesting PERF of the PERF capable nodes.

Node PE-B2 will do PREF, which is fine, that is what it is supposed to
do. PE-B3 will eliminate duplicates as it is supposed to do.

PE-A1 will also try to set up an un-tunneled PW to PE-A2, PA-2, PA-3 and
PE-A2 will do what they are supposed to do. The problem is that the node
"P-A1" is also "PE-B2" and will understand the request for PERF, which
it is not supposed to do.

Our solution is to use the L-label to tunnel between DA-*-PE.

/Loa

--

---

From: Jouni Korhonen <[email-masked]>
Date: Mon, 13 Mar 2017 08:48:55 -0700

Okay.. seems we are in sync regarding what we want. We just talk past each other terminology and label concept wise. I’ll try to fix this into the draft.

- Jouni

> On Mar 12, 2017, at 11:03 PM, Loa Andersson <[email-masked]> wrote:
> 
> Jouni,
> 
> Yes - but you don't need the T-label (it is optional), and only tunnel part of the way between two DA-*-PEs.
> 
> I think this is the case
>                       php                     php

---

From: Jouni Korhonen <[email-masked]>
Date: Mon, 13 Mar 2017 11:42:06 -0700

Loa,

What I still do not get is.. the picture you have below is the same except I used T-labels and you used L-labels. So what is the real difference? 

I have used T-labels as those that change between P-nodes. And when I need to carry PWs over DA-*-PE unchanged i.e., make a DA-*-PE behave like a P-node, I used L-labels to build my overlay. Still T-labels being there between each P-node.

- Jouni

---

From: Balázs Varga A <[email-masked]>
Date: Sat, 11 Mar 2017 18:54:24 +0000

Hi Loa,

I think the addition of the DetNet Flow-ID to the "PW Encapsulation header" changed 
our former discussions. If the DetNet Flow-ID is present, we can change the d-pw label 
during the transport like in case of a legacy MS-PW.

Also we assume no protection other than PRER for DetNet flows (see also the 
draft-architecture, section 3.2).
" 3.2. Explicit routes
... DetNet employs
explicit routes, where the path taken by a given DetNet flow does not
change, at least immediately, and likely not at all, in response to
network topology events. Service protection (Section 3.4 or
Section 3.5) over explicit routes provides a high likelihood of
continuous connectivity. "

> d-pw label with signaling that exposes the "request for DetNet NSP/FRER" to P nodes
Could You explain it more, I do not see your point. Do You propose that the L-label value
would control whether a PW is a DetNet PW with PRER or not?

Thx & Cheers
Bala'zs

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Saturday, March 11, 2017 3:38 AM
To: [email-masked]
Subject: Re: [Detnet-dp-dt] New update of the draft available

Jouni,

/Loa

--

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 14 Mar 2017 09:11:46 +0000

Hi Loa,

Yes, I am fine with the tunneling, no issues on that. Now I see 
your point better.

Your concern is regarding the control plane and not the data plane.
In my view request for PRER should be (i) PW and (ii) node specific:
- PRER points need proper planning before the setup of the DetNet-PW
(which nodes should be selected for x-PE roles, already established 
overlay tunnel might be considered during the design also, etc.)
- signaling for PW setup should contain the planning results

So in your example, when PE-A1 signals for the PW to PE-A2, the role
of P-A1 should be clear (i.e. no PRER for PW between A1 and A2) and
included in signaling.
Simultaneously PE-B1 should signal explicitly that PE-B2 is a PRER 
point for the PW between PE-B1 and PE-B3.

Cheers
Bala'zs

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Loa Andersson
Sent: Monday, March 13, 2017 4:05 PM
To: Balázs Varga A <[email-masked]>; [email-masked]
Subject: Re: [Detnet-dp-dt] FW: New update of the draft available

Balázs,

I'd not seen this before. I thought that we'd reached consensus on the need to tunneling across the P routers after the comments from Jouni and Yuanlong. Please see inline.

On 2017-03-13 18:09, Balázs Varga A wrote:
> Hi, mail below seems to be lost in hyperspace. I send it again, sorry 
> for possible duplicates ... Cheers Bala'zs
>
<snip>

> Could You explain it more, I do not see your point. Do You propose that the L-label value would control whether a PW is a DetNet PW with PRER or not?

We discuss the "overlay network" in terms of P and PE nodes. The P node does not not do PRER, while the PE may do so if we tell them.

However one node by serve as P in one overlay network, and as PE in another.

Consider:

                 +------+
                 | PE-B1|
                 +------+
                    |
                    v
                 +------+
                 | P-B1 |
                 +------+
                    |
                    v
                 +------+

Problem is signalling!

If have the PW-Label un-tunneled PE-B will establish the unprotected PW to PE-B3, requesting PERF of the PERF capable nodes.

Node PE-B2 will do PREF, which is fine, that is what it is supposed to do. PE-B3 will eliminate duplicates as it is supposed to do.

PE-A1 will also try to set up an un-tunneled PW to PE-A2, PA-2, PA-3 and
PE-A2 will do what they are supposed to do. The problem is that the node "P-A1" is also "PE-B2" and will understand the request for PERF, which it is not supposed to do.

/Loa

--

---

From: Loa Andersson <[email-masked]>
Date: Wed, 15 Mar 2017 15:21:18 +0800

Bala'zs,

OK - I think we are close to consensus here.

In line please.

> Your concern is regarding the control plane and not the data plane.

Well, almost - I'm concerned that for some control planes it is not
possible to distinguish between a node that act as P or PE when setting
up a PW. I it is my gut feeling that if we want to change the control
plane to do this it would be a major change.

> In my view request for PRER
Jouni calls the "Packet Replication and Elimination function (PREF)"
in the draft - should we stay with that terminology??

  should be (i) PW and (ii) node specific:

This a a big bite to bite of for example for LDP if we are talking
about an un-tunneled PW, if we are talking about a MS-PW with a
L-label (PSN tunnel) it is state of the art.

It might be that I misunderstood your earlier comment:

"I think the addition of the DetNet Flow-ID to the "PW Encapsulation
  header" changed our former discussions. If the DetNet Flow-ID is
  present, we can change the d-pw label during the transport like in
  case of a legacy MS-PW."

I took that to mean that we could change he PW label "during transport"
and thought you meant at P nodes also. Reading it more careful and
seeing "like in case of a legacy MS-PW" I think you meant that the
PW-label can be changed at every DA-S-PE node. And pushed/popped at the
DA-T-PE nodes.

If this is the case we are in agreement!

> overlay tunnel might be considered during the design also, etc.)

hmmm  - yes, but setting up an un-tunneled PW through PA-1/PE-B2, will
be non-deterministic, the control plane for one overlay network will
view PA-1/PE-B2 as a P node (un-capable of DetNet NSP and PREF), and
send the TLV/object that request DetNet NSP and PREF that is intended
for PE-A2. Since PA-1/PE-B2 are capable of DetNet NSP and PREF, since
it is a DA-A-PE in the other overlay network, it will try to act on
the  DetNet NSP and PREF (and very likely fail).

> - signaling for PW setup should contain the planning results

yes it does, only that this planning should include the L-label overlay.

> of P-A1 should be clear (i.e. no PRER for PW between A1 and A2) and

Sure - but since PA-1/PE-B2 is capable of DetNet NSP and PREF, it can't
be allowed to see the signalling for PE-A2 or packets that are intended
for PE-A2. One reason we need the L-label.

> point for the PW between PE-B1 and PE-B3.
Yes - in this case the MS-PW label is exposed, it is understood that
NSP and PREF is required, since the signaling is specifically to
PA-1/PE-B2 (e.g. tLDP) and when forwarding the L-label is php'ed or
popped.

/Loa

--

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 15 Mar 2017 08:59:19 -0700

Inline..

> On Mar 15, 2017, at 12:21 AM, Loa Andersson <[email-masked]> wrote:
> 
> Bala'zs,
> 

Yes ;)

> If this is the case we are in agreement!

This is my understanding of “changing PW label during transport”. Only DA-*-PE nodes may swap/push/pop PW label. The text in the draft should already be written this as the design.

> the  DetNet NSP and PREF (and very likely fail).

I think you will always have at least one label in a stack above the PW label (until you reach the DA-*-PE node) during transit.

> PA-1/PE-B2 (e.g. tLDP) and when forwarding the L-label is php'ed or

Ack.

- JOuni