Subject: [Detnet-dp-dt] IPv6 and multicast

From: Jouni Korhonen <[email-masked]>
Date: Wed, 24 May 2017 14:55:00 -0700

Continuing the discussion we had about IPv6, multicast and destination options. In a multicast case only the final receivers of the packets (i.e. the nodes joining to the multicast group as end hosts) would examine the Destination Option. I am not sure if this is the desired behavior? On the other hand a Hop by Hop option would be examined by all intermediate nodes whether they are PREF processing or not. Whcih one you would think is a better approach?

When using unicast and things like segment routing the behavior of the nodes is more straight forward. The processing of the Destination Option is done each time one of the routing option destinations are reached.

- Jouni

-- 
Jouni Korhonen, Broadcom, Core Switching Group
+1-408-391-7160

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 25 May 2017 11:35:02 +0000

Hi,

I would take a pragmatic view on this. The rules of using the extension header options
are defined primarily for "routing" decision purposes of the IP layer. However PREF is 
a detnet service layer function by definition. So, PREF can simple check whatever 
header fields are there in the IP packet to do its own task (namely replicate and 
eliminate) even if the PREF node is not the destination node.

Therefore, destination option is absolutely fine as seq.num. Hop by hop would cause 
unnecessary load for intermediate nodes to examine and process an option that 
contains seq.num which is useless for them. 

Cheers
Bala'zs

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Jouni Korhonen
Sent: 2017. május 24. 23:55
To: [email-masked]
Subject: [Detnet-dp-dt] IPv6 and multicast

- Jouni

_______________________________________________
Detnet-dp-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 25 May 2017 15:02:08 -0700

Hi,

I hear you. However, these kinds of things are issues IETF wise.. protocol purists, you know ;) Also, we have precedence using hop-by-hop options in rfc6621 (see Section 6.1). So I might actually be leaning towards favoring hop-by-hop as a generic solution even if it has an undesired impact for nodes that do not need to look the option up. At least the same solution would then work for both unicast and multicast.

- JOuni

> On May 25, 2017, at 4:35 AM, Balázs Varga A <[email-masked]> wrote:
> 
> Hi,
>