Subject: [Detnet-dp-dt] Updates to dp-sol

From: Norman Finn <[email-masked]>
Date: Fri, 26 May 2017 23:57:58 +0000

I've checked in an updated draft-dt-detnet-dp-sol-01.  Changes:

 - Fixed a few typos/spelling.

 - Expanded introduction to include IPv6 encaps.

 - Edited time section.  It assumed that PTP is normally a DetNet flow, and I claim that that is not the normal case, at all.  Also, the first choice (now the second) needed a little clarification.

 - Added sentence in bidirectional about no special bidirectional feature except for same path.

 - Small edit to Class of Service.

 - Added 7.6 Layer 2 addressing considerations.

 - Added 802.1Q to references.

 - Added myself to authors list.

All of the above are, IMO, covered by what we talked about on Tuesday except maybe the introduction (which should be non-controversial) and the synchronization stuff (which could conceivably be controversial).  Feel free to challenge what you don't like, of course.

-- Norm

---

From: Balázs Varga A <[email-masked]>
Date: Mon, 29 May 2017 12:13:03 +0000

Hi All,

A general observation: we may need a new structure for the draft.

In the first discussions we have concluded to use practically the same encapsulation for the DetNet flows namely PseudoWires.
So we were able to use the MS-PW analogy to describe the DetNet data plane. Practically all statements were valid for both
PSN types (i) IP and (ii) MPLS.

However, in Chicago based on the feedbacks and our discussions we have changed the proposed data plane using (i) native
encapsulation in case of IPv6 and (ii) using PW in case of MPLS. This is something we have to reflect in the text.

There are numerous examples where we refer explicitly to PWs, making confusion with respect to scenarios where PSN = IPv6.
One good example for that is the definition of PREF in the terminology section:
   PREF          A Packet Replication and Elimination Function (PREF)
                 does the replication and elimination processig of
                 DetNet flow packets in DA-T-PE or DA-S-PE nodes.  The
                 replication function is essentially the existing 1+1
                 protection mechanism.  The elimination function reuses
                 and extends the existing [RFC3985] PseudoWire
                 sequencing provided duplicate detection mechanism to
                 operate over multiple (separate) PseudoWires that are
                 sub-flows of a compound DetNet flow.
This text is not valid for IPv6. And there are many similar examples all over in the document. I have found practically problematic
text in each chapter. Including Abstract, Introduction, etc. etc.

So, should we reconsider the structure? Any thoughts?

Cheers
Bala'zs

From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Norman Finn
Sent: 2017. május 27. 1:58
To: [email-masked]
Subject: [Detnet-dp-dt] Updates to dp-sol

-- Norm

---

From: jouni korhonen <[email-masked]>
Date: Mon, 29 May 2017 17:50:36 -0700

I would think some additional clear cut separation in text is needed as you pointed out. Major restructuring.. i do not think so.\

- JOuni

> On May 29, 2017, at 5:13 AM, Balázs Varga A <[email-masked]> wrote:
> 
> Hi All,
>  
> Bala’zs
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 30 May 2017 11:22:59 +0000

Hi,

That is fine. I have meant the new structure within the chapters (see below).

Two practical comments regarding the text upgrade:
1, MS-PW analogy may be reconsidered as for IP there are no PWs. That impacts pretty much the terminology we use. 
I would prefer to define a terminology that is valid for both IP and MPLS based PSN. So in each chapter we could have 
a general description followed by IP and MPLS specific details.
In practice we may consider "segments" only between PREF nodes doing replication and elimination. If a DetNet flow 
does not require PREF, we do not have anything that looks like a MS-PW. We have already defined "Edge Node", 
"Relay Node" and "Transit Node". So referring to them instead of DA-T-PE and DA-S-PE could be the basis for the 
text upgrade. 
I think the most challenging part is chapter 6, describing the PREF functionality from data plane perspective. In the 
general description we could simple speak about "sub-flows of a compound flow" instead of "PW-segments" or 
"PW instance". 

2, chapter 5.1 should be incorporated in current 5.2.1.

Let's discuss this in the call.

See You soon
Bala'zs

-----Original Message-----
From: jouni korhonen [mailto:[email-masked]] 
Sent: 2017. május 30. 2:51
To: Balázs Varga A <[email-masked]>
Cc: Norman Finn <[email-masked]>; [email-masked]
Subject: Re: [Detnet-dp-dt] Updates to dp-sol

- JOuni

> So we were able to use the MS-PW analogy to describe the DetNet data 
> plane. Practically all statements were valid for both PSN types (i) IP and (ii) MPLS.
>  
> However, in Chicago based on the feedbacks and our discussions we have 
> changed the proposed data plane using (i) native encapsulation in case of IPv6 and (ii) using PW in case of MPLS. This is something we have to reflect in the text.
>  
> This text is not valid for IPv6. And there are many similar examples 
> all over in the document. I have found practically problematic text in each chapter. Including Abstract, Introduction, etc. etc.
>