Subject: [Detnet-dp-dt] DP DT solution draft slides for IETF99

From: "Korhonen, Jouni" <[email-masked]>
Date: Wed, 12 Jul 2017 21:29:17 +0000

Hi,

Sorry about this taking so long. Please, have a look and flame on.. There's still time to work on the actual content. However, keep in mind that this is mainly an update from last time.

- Jouni

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 13 Jul 2017 09:54:27 +0000

Hi Jouni,

Thanks for preparing this. Just some fast reactions:
- slide5-6-7: we may receive a comment that it looks like only end-hosts having same type (TSN, MPLS, IPv6) can be interconnected.
I would propose to add a note, that other combinations as depicted requires further considerations.

- slide8: we have used the MS-PW analogy during our discussions. However it is valid only if PREF is used. 
I would propose to refer on the first bullet only to "PseudoWires" and "IPv6" as the two data plane solution.
A further note could highlight the MS-PW analogy for PREF scenarios.

- slide10-11: I would pair the DetNet flow specific information fields to be transported with the data plane encapsulation fields.
	DetNet flow	Encapsulation fields
	Flow ID:	PW label
	Seq. number: 	CW

- slide14: regarding multicast DetNet flows I would formulate somewhat different. In my view we have considered p2p data plane solutions.
The defined data plane works for DetNet flows having multicast dst-address assuming that the DetNet domain provides p2p connectivity.
We may also receive comments that many DetNet flows are multicast (e.g., TSN flows using IEEE-FRER, etc.) 

Cheers
Bala'zs

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Korhonen, Jouni
Sent: 2017. július 12. 23:29
To: [email-masked]
Subject: [Detnet-dp-dt] DP DT solution draft slides for IETF99

Hi,

- Jouni

---

From: "Korhonen, Jouni" <[email-masked]>
Date: Thu, 13 Jul 2017 09:57:02 +0000

Thanks Balazs. Good input as always. I'll update based on these (and other offline received comments).

- Jouni

> From: Balázs Varga A [mailto:[email-masked]]
> Sent: Thursday, July 13, 2017 12:54 PM
> To: Korhonen, Jouni <[email-masked]>; [email-masked]
> Subject: RE: DP DT solution draft slides for IETF99
> 
> Hi Jouni,
> 
> - slide5-6-7: we may receive a comment that it looks like only end-hosts
> having same type (TSN, MPLS, IPv6) can be interconnected.
> - slide10-11: I would pair the DetNet flow specific information fields to
> be transported with the data plane encapsulation fields.
> - slide14: regarding multicast DetNet flows I would formulate somewhat
> different. In my view we have considered p2p data plane solutions.
> The defined data plane works for DetNet flows having multicast dst-address
> assuming that the DetNet domain provides p2p connectivity.
> Sorry about this taking so long. Please, have a look and flame on..
> There's still time to work on the actual content. However, keep in mind
> that this is mainly an update from last time.
> 
> - Jouni

---

From: "Korhonen, Jouni" <[email-masked]>
Date: Thu, 13 Jul 2017 13:57:09 +0000

An update.. I am still doing the QoS etc part of the deck.

- Jouni

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Thu, 13 Jul 2017 19:39:25 +0200

Hi Jouni,

Thanks for preparing this. Some small comments below:

- Slide 6: I'd remove "native" in "PW-based native DetNet" to be
consistent with the terms used in the draft (alternatively, I'd use
"IPv6-based native DetNet" in slide 7for consistency with "PW-based
native DetNet in slide 6).

- Slides 11 and 12: use the same order for "Flow-ID" and "SeqNum" on
the slides (right hand side)

- Slide 11: though I have no concrete proposal, I think the S-label
could be better introduced (maybe with a figure, also introducing the
(DA-)T-PE and (DA-)S-PE node terminology).

- Slide 14: "already be seen" --> "already been seen"

Thanks,

Carlos

On Thu, 2017-07-13 at 13:57 +0000, Korhonen, Jouni wrote:
> > - slide8: we have used the MS-PW analogy during our discussions.
> > However
> > it is valid only if PREF is used.
> > I would propose to refer on the first bullet only to "PseudoWires"
> > and
> > "IPv6" as the two data plane solution.
> > We may also receive comments that many DetNet flows are multicast
> > (e.g.,
> > TSN flows using IEEE-FRER, etc.)
> > 
> > Cheers
> > Bala'zs
> > 
> > From: Detnet-dp-dt [mailto:[email-masked]] On Behalf
> > Of
> > Korhonen, Jouni
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: "Jouni" <[email-masked]>
Date: Fri, 14 Jul 2017 08:17:12 +0300

Thanks. 

> From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of
> Carlos Jesús Bernardos Cano
> Sent: Thursday, July 13, 2017 20:39 PM
> To: Korhonen, Jouni <[email-masked]>; Balázs Varga A
> <[email-masked]>; [email-masked]
> Subject: Re: [Detnet-dp-dt] DP DT solution draft slides for IETF99
> 
> Hi Jouni,
> 
> consistent with the terms used in the draft (alternatively, I'd use "IPv6-
> based native DetNet" in slide 7for consistency with "PW-based native
> DetNet in slide 6).

Oops. Good catch.

> 
> - Slides 11 and 12: use the same order for "Flow-ID" and "SeqNum" on the
> slides (right hand side)

Ok.

> - Slide 11: though I have no concrete proposal, I think the S-label could
> be better introduced (maybe with a figure, also introducing the (DA-)T-PE
> and (DA-)S-PE node terminology).

Ok. I'll come up with something.

> - Slide 14: "already be seen" --> "already been seen"

Ok.

- Jouni

> > > - slide5-6-7: we may receive a comment that it looks like only end-
> > > hosts having same type (TSN, MPLS, IPv6) can be interconnected.
> > > - slide10-11: I would pair the DetNet flow specific information
> > > fields to be transported with the data plane encapsulation fields.
> > > - slide14: regarding multicast DetNet flows I would formulate
> > > somewhat different. In my view we have considered p2p data plane
> > > solutions.
> > > The defined data plane works for DetNet flows having multicast dst-
> > > address assuming that the DetNet domain provides p2p connectivity.
> > > (e.g., TSN flows using IEEE-FRER, etc.)
> > >
> > > Cheers
> > > Bala'zs
> > >
> > > Of Korhonen, Jouni
> > > There's still time to work on the actual content. However, keep in
> > > mind that this is mainly an update from last time.
> > >
> > > - Jouni
> >

---

From: Jiangyuanlong <[email-masked]>
Date: Fri, 14 Jul 2017 07:55:53 +0000

Hi folks,

I am not sure we need to introduce S-Label in the first place. 
As I remember, we had some consensus that PW label has carried enough information in the f2f discussion happened during the last IETF meeting.
And S-label is regarded redundant for PW. Did I miss something?

Thanks,
Yuanlong

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Jouni
Sent: Friday, July 14, 2017 1:17 PM
To: [email-masked]; 'Korhonen, Jouni'; 'Balázs Varga A'; [email-masked]
Subject: Re: [Detnet-dp-dt] DP DT solution draft slides for IETF99

Thanks. 

> "IPv6- based native DetNet" in slide 7for consistency with "PW-based 

Oops. Good catch.

Ok.

Ok.

- Jouni

> > > To: Korhonen, Jouni <[email-masked]>; 
> > > detnet-dp-dt@ie tf.org
> > > - slide5-6-7: we may receive a comment that it looks like only 
> > > end- hosts having same type (TSN, MPLS, IPv6) can be interconnected.
> > > The defined data plane works for DetNet flows having multicast 
> > > dst- address assuming that the DetNet domain provides p2p connectivity.

---

From: Jiangyuanlong <[email-masked]>
Date: Fri, 14 Jul 2017 08:25:13 +0000

Sorry, I was confused by L-label in the last version and S-Label. But we still need to harmonize the T-Lable with the S-Label.
For example, if we set up a low-latency or contention-free LSP for a detnet flow (between DA-T-PEs or DA-S-PEs), most probably we need some traffic engineered LSPs (i.e., L-LSP as defined in RFC 3270).
Can we regard L-LSP labels on the path to be a T-Label or an S-Label?

Best regards,
Yuanlong

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Jiangyuanlong
Sent: Friday, July 14, 2017 3:56 PM
To: Jouni; [email-masked]; 'Korhonen, Jouni'; 'Balázs Varga A'; [email-masked]
Subject: Re: [Detnet-dp-dt] DP DT solution draft slides for IETF99

Hi folks,

Thanks,
Yuanlong

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Jouni
Sent: Friday, July 14, 2017 1:17 PM
To: [email-masked]; 'Korhonen, Jouni'; 'Balázs Varga A'; [email-masked]
Subject: Re: [Detnet-dp-dt] DP DT solution draft slides for IETF99

Thanks. 

Oops. Good catch.

Ok.

Ok.

- Jouni

---

From: Lou Berger <[email-masked]>
Date: Fri, 14 Jul 2017 06:21:40 -0400

T-label imo.

Lou

On July 14, 2017 4:26:06 AM Jiangyuanlong <[email-masked]> wrote:

> Sorry, I was confused by L-label in the last version and S-Label. But we 
> still need to harmonize the T-Lable with the S-Label.
> For example, if we set up a low-latency or contention-free LSP for a detnet 
> flow (between DA-T-PEs or DA-S-PEs), most probably we need some traffic 
> engineered LSPs (i.e., L-LSP as defined in RFC 3270).
> Jiangyuanlong
> As I remember, we had some consensus that PW label has carried enough 
> information in the f2f discussion happened during the last IETF meeting.

---

From: "Korhonen, Jouni" <[email-masked]>
Date: Fri, 14 Jul 2017 11:22:03 +0000

Another update.

- Jouni

> From: Lou Berger [mailto:[email-masked]]
> Sent: Friday, July 14, 2017 13:22 PM
> To: Jiangyuanlong <[email-masked]>; Jouni
> <[email-masked]>; [email-masked]; Korhonen, Jouni
> <[email-masked]>; 'Balázs Varga A'
> > Sorry, I was confused by L-label in the last version and S-Label. But
> > we still need to harmonize the T-Lable with the S-Label.
> > For example, if we set up a low-latency or contention-free LSP for a
> > detnet flow (between DA-T-PEs or DA-S-PEs), most probably we need some
> > traffic engineered LSPs (i.e., L-LSP as defined in RFC 3270).
> > Jouni
> >> Of Carlos Jesús Bernardos Cano
> >> > > I would propose to add a note, that other combinations as
> >> > > depicted requires further considerations.
> >> > >
> >> > > There's still time to work on the actual content. However, keep
> >> > > in mind that this is mainly an update from last time.
> >> > >
> >> > > - Jouni
> >> >

---

From: Jiangyuanlong <[email-masked]>
Date: Fri, 14 Jul 2017 12:35:50 +0000

Thanks much, Lou. 
It seems that if and only if multiple detnet services are aggregated into a tunnel (T-Label), the S-Label is needed to distinguish them; otherwise, the S-Label is not needed.
Correct?

Cheers,
Yuanlong

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Friday, July 14, 2017 6:22 PM
To: Jiangyuanlong; Jouni; [email-masked]; 'Korhonen, Jouni'; 'Balázs Varga A'; [email-masked]
Subject: Re: [Detnet-dp-dt] DP DT solution draft slides for IETF99

T-label imo.

Lou

---

From: Loa Andersson <[email-masked]>
Date: Fri, 14 Jul 2017 16:43:50 +0200

Folks,

I think this discussion to a large extent is moot.

 From one perspective all labels are T-Labels, sometimes we want to
discuss what these tunnels are there for.

S-Labels indicated that they are carrying some type of service, not
being particular about what type of service, it is just something we
treat as a service.

During the discussion of the of detnet replication and elimination, we
thought it would be good to create an overlay network (L-Labels) we
found that we did not need to name the L-Labels, but they are still
logically there.

> It seems that if and only if multiple detnet services are aggregated into a tunnel (T-Label), the S-Label is needed to distinguish them; otherwise, the S-Label is not needed.

Maybe - are you implying that that we could prohibit multiple detnet
services being aggregated into a tunnel? I think not! S we need the 
concept of an S-Label.

I think that it is good practice to have S-Labels if we have multiple
instances of the same service multiplexed on the same T-Label, right?

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Lou Berger <[email-masked]>
Date: Fri, 14 Jul 2017 10:29:25 -0400

Looks.  Just add page numbers...

Thanks,

Lou

---

From: János Farkas <[email-masked]>
Date: Sat, 15 Jul 2017 23:22:55 +0200

Hi,

Jouni, thank you very much for preparing the slides!
I agree it is good.

just a minor comments.

title page could reflect that this is in fact draft-dt-detnet-dp-sol-01. 
I know that the draft is there at the bottom of many pages, but perhaps 
it'd be better to call out to the title page.
(and data plane solutions design team, not data plane alternatives ;-) )

Thanks,
Janos

---

From: Loa Andersson <[email-masked]>
Date: Sun, 16 Jul 2017 10:49:34 +0200

+1

Jouni, thanks for all the hard work!

/Loa

PS

Can someone help me with github, 20 min hands on maybe. I rad the
instructions but don't really get it :(, some of the language is
not mine.

--

---

From: "Korhonen, Jouni" <[email-masked]>
Date: Sun, 16 Jul 2017 09:23:04 +0000

Ack.

> From: János Farkas [mailto:[email-masked]]
> Sent: Sunday, July 16, 2017 00:23 AM
> To: Lou Berger <[email-masked]>; Korhonen, Jouni
> <[email-masked]>; Jiangyuanlong <[email-masked]>;
> Jouni <[email-masked]>; [email-masked]; 'Balázs Varga A'
> >>>> Sorry, I was confused by L-label in the last version and S-Label.
> >>>> But we still need to harmonize the T-Lable with the S-Label.
> >>>> For example, if we set up a low-latency or contention-free LSP for
> >>>> a detnet flow (between DA-T-PEs or DA-S-PEs), most probably we need
> >>>> some traffic engineered LSPs (i.e., L-LSP as defined in RFC 3270).
> >>>> Of Jiangyuanlong
> >>>> As I remember, we had some consensus that PW label has carried
> >>>> enough information in the f2f discussion happened during the last
> IETF meeting.
> >>>> Of Jouni
> >>>>> From: Detnet-dp-dt [mailto:[email-masked]] On
> >>>>> Behalf Of Carlos Jesús Bernardos Cano
> >>>>> "IPv6- based native DetNet" in slide 7for consistency with
> >>>>> "PW-based native DetNet in slide 6).
> >>>> Oops. Good catch.
> >>>>
> >>>>> - Slides 11 and 12: use the same order for "Flow-ID" and "SeqNum"
> >>>>> on the slides (right hand side)
> >>>> Ok.
> >>>>
> >>>>
> >>>>> - Slide 11: though I have no concrete proposal, I think the
> >>>>> S-label could be better introduced (maybe with a figure, also
> >>>>> introducing the (DA-)T-PE and (DA-)S-PE node terminology).
> >>>>>>> We may also receive comments that many DetNet flows are
> >>>>>>> multicast (e.g., TSN flows using IEEE-FRER, etc.)
> >>>>>>>
> >>>>>>> Cheers
> >>>>>>> Bala'zs
> >>>>>>>