Subject: [Detnet-dp-dt] Fwd: RE: Nits and XML2RFC - that might apply to our draft.

From: Loa Andersson <[email-masked]>
Date: Tue, 5 Sep 2017 12:14:27 +0200

Jouni,

I think this is part of the explanation to the nits we received on
out draft. I have not checked, but it seems reasonable.

/Loa

-------- Forwarded Message --------
Subject: RE: Nits and XML2RFC
Date: Tue, 5 Sep 2017 11:06:42 +0100
From: Adrian Farrel <[email-masked]>
Reply-To: [email-masked]
To: 'Christian Huitema' <[email-masked]>, [email-masked]

Christian,

The "bug" is that xml2rfc now inserts 
"https://datatracker.ietf.org/drafts/current/" and 
"https://trustee.ietf.org/license-info" whereas idnits checks for 
"http://datatracker.ietf.org/drafts/current/" and 
"http://trustee.ietf.org/license-info"

Cheers,
Adrian

> -----Original Message-----
> From: ietf [mailto:[email-masked]] On Behalf Of Christian Huitema
> Sent: 04 September 2017 20:53
> To: [email-masked]
> Subject: Re: Nits and XML2RFC
> 
> 
> 
> On 9/4/2017 12:42 PM, Christian Huitema wrote:
> > I just formatted a draft using xml2rfc and the online tool,
> > https://xml2rfc.tools.ietf.org/. Then I submitted the result for
> > publication. And it was refused because the submission checking tool
> > https://datatracker.ietf.org/submit/ found 4 errors in the copyright and
> > IPR boilerplate. This is weird, because my draft used the xml2rfc option
> > ipr="trust200902". But it seems that the xml2rfc tool and the submission
> > checking tool disagree. I get an interesting message, complaining about
> > errors such as this one: ....
> > As far as I can tell, the only difference between one text and the other
> > are the position of the line breaks. Of course, the line breaks are
> > chosen by the editing tool, and I have no control.
> >
> > Any suggestion on how to fix my draft?
> >
> OK, I managed to fix the submission. My mistake was to submit both a
> text document and an XML document. Since the xml2rfc editor used by the
> submission tool produces a slightly different format than the xml2rfc
> online tool, this generated nits. Probably the results of some recent
> change. Anyhow, I fixed the submission by submitting only the XML
> document. That appeared to be working.
> 
> --
> Christian Huitema

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Jouni" <[email-masked]>
Date: Tue, 5 Sep 2017 13:43:12 +0300

Yeah. The draft is now at secretariat manual posting queue anyway.

- Jouni

> From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Loa
> Andersson
> Sent: Tuesday, September 5, 2017 13:14 PM
> To: [email-masked]
> Subject: [Detnet-dp-dt] Fwd: RE: Nits and XML2RFC - that might apply to
> our draft.
> 
> Jouni,
> 
> I think this is part of the explanation to the nits we received on out
> draft. I have not checked, but it seems reasonable.
> 
> /Loa
> 
> 
> > > https://datatracker.ietf.org/submit/ found 4 errors in the copyright
> > > and IPR boilerplate. This is weird, because my draft used the
> > > xml2rfc option ipr="trust200902". But it seems that the xml2rfc tool
> > > and the submission checking tool disagree. I get an interesting
> > > message, complaining about errors such as this one: ....
> > > As far as I can tell, the only difference between one text and the
> > > other are the position of the line breaks. Of course, the line
> > > breaks are chosen by the editing tool, and I have no control.
> > >
> > text document and an XML document. Since the xml2rfc editor used by
> > the submission tool produces a slightly different format than the
> > xml2rfc online tool, this generated nits. Probably the results of some
> > recent change. Anyhow, I fixed the submission by submitting only the
> > XML document. That appeared to be working.
> >
> > --
> > Christian Huitema
> 
> 
> --
> 
> 
> _______________________________________________
> Detnet-dp-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet-dp-dt

---

From: Jiangyuanlong <[email-masked]>
Date: Wed, 6 Sep 2017 01:20:23 +0000

I think the current document can be sent directly to the Detnet WG mailing list.
A new revision may ensue with further discussions in the WG. 

-----Original Message-----
From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of Jouni
Sent: Tuesday, September 05, 2017 6:43 PM
To: 'Loa Andersson'; [email-masked]
Subject: Re: [Detnet-dp-dt] Fwd: RE: Nits and XML2RFC - that might apply to our draft.

- Jouni

> From: Detnet-dp-dt [mailto:[email-masked]] On Behalf Of 
> Loa Andersson
> Subject: [Detnet-dp-dt] Fwd: RE: Nits and XML2RFC - that might apply 
> to our draft.
> 
> Jouni,
> 
> > > publication. And it was refused because the submission checking 
> > > tool https://datatracker.ietf.org/submit/ found 4 errors in the 
> > > copyright and IPR boilerplate. This is weird, because my draft 
> > > used the xml2rfc option ipr="trust200902". But it seems that the 
> > > xml2rfc tool and the submission checking tool disagree. I get an 
> > > interesting message, complaining about errors such as this one: ....
> > xml2rfc online tool, this generated nits. Probably the results of 
> > some recent change. Anyhow, I fixed the submission by submitting 
> > only the XML document. That appeared to be working.
> >
> > --
> > Christian Huitema
> 
> 
> --
> 
>