Subject: Re: [Detnet] Fwd: I-D Action: draft-korhonen-detnet-telreq-00.txt

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Jun 2015 16:18:23 +0000

Hello Jouni:

Thanks a bunch for posting this!

I read the need of time sync is pervasive.  But do you have cases where replication and elimination would be of use? 
I see a requirement of 10^-9 but then that one is over one hop?

Typo left P4:  architecural 

All the best,

Pascal

> -----Original Message-----
> From: detnet [mailto:[email-masked]] On Behalf Of Jouni Korhonen
> Sent: jeudi 28 mai 2015 21:30
> To: [email-masked]
> Subject: [Detnet] Fwd: I-D Action: draft-korhonen-detnet-telreq-00.txt
> 
> FYI.. a slightly different view to DetNet.
> 
>         Title           : Deterministic networking for radio access networks
>         Author          : Jouni Korhonen
>         Filename        : draft-korhonen-detnet-telreq-00.txt
>         Pages           : 11
>         Date            : 2015-05-28
> 
> Abstract:
>    This document describes requirements for deterministic networking in
>    cellular radio access and transport networks context.  The
>    requirements include time synchronization, clock distribution and
>    ways of establishing time-sensitive streams for both Layer-2 and
>    Layer-3 user plane traffic using IETF protocol solutions.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-korhonen-detnet-telreq/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-korhonen-detnet-telreq-00
> 
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 4 Jun 2015 01:40:24 +0000

Pascal,

Thank you for reading the document. See my comments inline.

> From: detnet [mailto:[email-masked]] On Behalf Of Pascal Thubert
> (pthubert)
> Sent: Tuesday, June 02, 2015 9:18 AM
> To: Jouni Korhonen
> Cc: [email-masked]
> Subject: Re: [Detnet] Fwd: I-D Action: draft-korhonen-detnet-telreq-00.txt
> 
> Hello Jouni:
> 
> I read the need of time sync is pervasive.  But do you have cases where
> replication and elimination would be of use?

The issue with replication really is the traffic volume - you do not want to double your pain you are already having today. If future developments on the radio bring the traffic volumes to sane numbers replication could be useful, since there is no really room for retransmissions or forward error coding schemes that require interleaving.

> I see a requirement of 10^-9 but then that one is over one hop?

That is over one hop.

> Typo left P4:  architecural

ACK. Will fix.

- Jouni