Subject: Re: [Detnet] draft-finn-detnet-architecture-03 comments??

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Fri, 18 Mar 2016 13:27:25 +0000

Hi Norm,

In the clause 4.2.3 The Network Plane

The last paragraph says:
"At the Network plane, relay systems exchange information regarding
   the state of the paths, between adjacent systems and eventually with
   the end systems, andŠ²

In a fully centralized configuration, the relay systems are not obliged to
exchange information between them or with the end systems. This could be
handled by information exchange with the PCE. So I will introduce a ³may²
in the sentence:

"At the Network plane, relay systems may exchange information regarding
   the state of the paths, between adjacent systems and eventually with
the end systems, andŠ²

Do you agree?

Thanks,

Patrick

On 10/03/16 00:29, "detnet on behalf of Norman Finn (nfinn)"
<[email-masked] on behalf of [email-masked]> wrote:

>In our plan from November, we talked about adopting an architecture draft.
>There is a draft for one, and time comment and revise it before the
>deadline for April.  Is it so good there is nothing more to say?  :)  :)
>
>https://www.ietf.org/internet-drafts/draft-finn-detnet-architecture-03.txt
>
>
>‹ Norm
>
>_______________________________________________
>detnet mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/detnet

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 18 Mar 2016 13:48:13 +0000

I'm probably guilty of that piece text and agree with the "may", Patrick.

There are tons of ways this happens even in a centrally controlled network. 
Dome are control plane, really, like UNI (Local management interface) type.
Others are part of the lower layers, like acks/nacks.
Then there's all the variations of OAM. 
What's confusing in this text that we need to improve (that's actually a comment Lou made) Is not to call network layer what control layer happening between the network nodes. Yet we need to differentiate that from the control from the control (southbound) interface with the central controller.

Cheers,

Pascal

> -----Original Message-----
> From: detnet [mailto:[email-masked]] On Behalf Of Patrick
> Wetterwald (pwetterw)
> Sent: vendredi 18 mars 2016 14:27
> To: Norman Finn (nfinn) <[email-masked]>; [email-masked]
> Subject: Re: [Detnet] draft-finn-detnet-architecture-03 comments??
> 
> Hi Norm,
> 
> handled by information exchange with the PCE. So I will introduce a ³may² in
> the sentence:
> 
>    the state of the paths, between adjacent systems and eventually with the
> end systems, andŠ²
> 
> Do you agree?
> 
> Thanks,
> 
> Patrick
> 
>

---

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Mon, 21 Mar 2016 15:54:02 +0000

I agree.  Thanks.