Subject: Re: [Detnet] DetNet Use Cases - Starting the "what is in scope for DetNet" discussion

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Thu, 31 Mar 2016 22:46:46 +0000

Ethan,

Making DetNet work over the Big-I Internet is not one of my goals, at least.  I often use the term “enterprise” for the scope in which I’m interested.

Timekeeping is an essential part of many, probably most, of the applications that also find DetNet useful.  That having been said, so is protection against EMI and electrical power saving. Let’s concentrate DetNet on reliable, on-time delivery of packets.  I’m not even sure that “a way to specify the required accuracy” need be in scope.

— Norm

From: detnet <[email-masked]<mailto:[email-masked]>> on behalf of "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, March 29, 2016 at 12:13 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Detnet] DetNet Use Cases - Starting the "what is in scope for DetNet" discussion

Hi Folks,

I claim that we have brought the DetNet Use Cases draft up to a state where I can say with a straight face “please read this document, it won’t hurt you”. So if you haven’t already done so, please look it over.

https://tools.ietf.org/html/draft-ietf-detnet-use-cases-09

Moving on to the next step, we need to start the discussion on which aspects of the use cases will be within scope of the DetNet work. Or, perhaps it is easier to enumerate which ones are not in scope, at least for a start.

The most obvious first item to decide on is requests to have DetNet work on the open Internet – I think we’re pretty clear that that is “not in scope” because our architecture depends on there being “centralized control” (which may be distributed among multiple network entities, but which together constitute a single point of control). I have also heard this phrased as “corporate networks”. Do we agree on this?

Another example is timekeeping – this will be specified by other existing means, right? The only explicit DetNet Ask for this is in M2M as “Precise time synchronization accuracy (1us)” and I think the intent (as in other use cases) is that the DetNet Ask is for a way to specify the required accuracy, not how to achieve that accuracy.

Anyone else see anything that might not be in scope? I plan to ask this question in the Use Cases part of the IETF session, so if you have any thoughts please send them to the list (or if that doesn’t happen, bring them to the live discussion).

Thanks,
Your faithful Use Cases Editor,
Ethan.

---

From: Rodney Cummings <[email-masked]>
Date: Thu, 31 Mar 2016 23:38:23 +0000

I rarely disagree with Norm, but on this point I'll have to quibble a bit.

I agree that we don't need DetNet to specify how time sync is accomplished. There are plenty of IEEE 1588 techniques (and similar) for that purpose.

I also agree that we should concentrate on reliable, on-time delivery of packets (i.e. worst-case latency).

If I don't know how accurate my time sync is, then how do I know when a packet is delivered on time? If I don't know the reliability of my time sync, how can I reliably measure that packet delivery?

Almost all (if not 100%) of DetNet use cases require time sync at the end systems to some degree of accuracy. I agree that we don't need to address the implementation of that time sync, but the application requirements are needed for time sync (including reliability) just as much as for packet delivery.

From: detnet [mailto:[email-masked]] On Behalf Of Norman Finn (nfinn)
Sent: Thursday, March 31, 2016 5:47 PM
To: Grossman, Ethan A. <[email-masked]>; [email-masked]
Subject: Re: [Detnet] DetNet Use Cases - Starting the "what is in scope for DetNet" discussion

Ethan,

— Norm

From: detnet <mailto:[email-masked]> on behalf of "Grossman, Ethan A." <mailto:[email-masked]>
Date: Tuesday, March 29, 2016 at 12:13 PM
To: "mailto:[email-masked]" <mailto:[email-masked]>
Subject: [Detnet] DetNet Use Cases - Starting the "what is in scope for DetNet" discussion

Hi Folks,

 

 
 
Thanks,