Subject: [Detnet] FW: New Version Notification for draft-zha-detnet-flow-info-model-02.txt

From: zhayiyong <[email-masked]>
Date: Sat, 18 Mar 2017 01:31:59 +0000

Hi All,

Please note that the information model draft has been updated. Changes are:
1. add transport layer information 
2. add traffic type information
3. more elaboration on how to use it with 802.1qcc
4. editorial changes.

Regards,
Yiyong 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, March 13, 2017 6:10 PM
To: zhayiyong; Liang Geng; Jiangyuanlong
Subject: New Version Notification for draft-zha-detnet-flow-info-model-02.txt

A new version of I-D, draft-zha-detnet-flow-info-model-02.txt
has been successfully submitted by Yiyong Zha and posted to the IETF repository.

Name:		draft-zha-detnet-flow-info-model
Revision:	02
Title:		Deterministic Networking Flow Information Model
Document date:	2017-03-13
Group:		Individual Submission
Pages:		15
URL:            https://www.ietf.org/internet-drafts/draft-zha-detnet-flow-info-model-02.txt
Status:         https://datatracker.ietf.org/doc/draft-zha-detnet-flow-info-model/
Htmlized:       https://tools.ietf.org/html/draft-zha-detnet-flow-info-model-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-zha-detnet-flow-info-model-02

Abstract:
   Deterministic Networking (DetNet) provides end-to-end absolute
   delay and loss guarantee to serve real-time applications. DetNet
   is focused on a general approach that use techniques such as 1)
   data plane resources reservation for DetNet flows; 2) providing
   fixed path for DetNet flows; 3)sequentializng, replicating, and
   eliminating duplicate packets transmission [draft-ietf-detnet-
   architecture-00] to guarantee the worst case delay of DetNet flow
   while allow sharing among best effort traffic. Data flow
   information model is important to the DetNet work that it defines
   information be used by flow establishment and control protocols.
   This document describes and DetNet flow information model that
   represents the flow identifier, traffic description information so
   that can make resource reservation and provide differentiate
   service.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Rodney Cummings <[email-masked]>
Date: Mon, 20 Mar 2017 15:39:24 +0000

Thanks Yiyong,

I would like to clarify something about the 802.1 terminology.

802.1Qcc (and its predecessor 802.1Qat) uses the term "StreamID", and 802.1CB uses the term "Stream identification", and those two terms mean very different things. Given that the two terms do not mean that same thing, it was a mistake to use the same words, but... it is what it is.

For DetNet, I think we need to fix that mistake in the terminology.

For StreamID, I would recommend "flow handle" for DetNet, because that describes its usage more precisely. The StreamID is a unique handle that the user's application (i.e. Talker and Listeners) uses to reference the flow's configuration in the network. For example, the Talker/Listener can use the StreamID to ask "Is my flow ready for use?". The StreamID has nothing to do with data packets between Talker and Listener. It is simply a "GUID". In 802.1 standards, we generate the "GUID" using a MAC address followed by a 16 bit unique identifier generated in the Talker. If DetNet choses to use a different technique to generate a unique identifier, that's fine. This "flow handle" concept has nothing to do with the data packets.

For "Stream identification", 802.1CB uses that term to specify the identification of the Stream in data packets. 802.1CB supports the Stream identifications that the I-D below lists in 3.1.1 and 3.1.2, as well as others. For this term, I would recommend "flow identification" for DetNet, which the I-D below uses.

In 3.1.1 of the I-D below states that 802.1Qcc uses MAC address and unique ID as its flow identification. Technically that is incorrect, because 802.1Qcc uses that encoding for StreamID only (the "flow handle"), and that StreamID encoding is unrelated to data packets. For "flow identification", 802.1Qcc uses the same encodings shown in 3.1.1 and 3.1.2. Those "flow identifications" are actually formalized in 802.1CB.

Rodney

> From: detnet [mailto:[email-masked]] On Behalf Of zhayiyong
> Sent: Friday, March 17, 2017 8:32 PM
> To: [email-masked]
> Subject: [Detnet] FW: New Version Notification for draft-zha-detnet-flow-
> info-model-02.txt
> 
> Hi All,
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> The IETF Secretariat
> 
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: zhayiyong <[email-masked]>
Date: Tue, 21 Mar 2017 00:37:10 +0000

Hi Rodney,

Thank you for your clarification. I agree with you that DetNet should differentiate these two concepts. Flow identification is needed for sure, and do we need such "flow handle" mechanism in DetNet (layer 3 network)? 

Regards,
Yiyong

-----Original Message-----
From: Rodney Cummings [mailto:[email-masked]] 
Sent: Monday, March 20, 2017 11:39 PM
To: zhayiyong; [email-masked]
Subject: RE: New Version Notification for draft-zha-detnet-flow-info-model-02.txt

Thanks Yiyong,

Rodney

> Subject: [Detnet] FW: New Version Notification for 
> draft-zha-detnet-flow- info-model-02.txt
> 
> Hi All,
> 
> 3. more elaboration on how to use it with 802.1qcc 4. editorial 
> changes.
> 
> Regards,
> Yiyong
> 
> Subject: New Version Notification for 
> draft-zha-detnet-flow-info-model- 02.txt
> 
>

---

From: Jouni Korhonen <[email-masked]>
Date: Mon, 20 Mar 2017 18:13:25 -0700

Hi,

Data plane design team produced draft has a 'flow-id' within the
encapsulation header for flow identification purposes.

Jouni

Sent from a smart phone.. Mind the typos..

> On Mar 20, 2017, at 17:37, zhayiyong <[email-masked]> wrote:
>
> Hi Rodney,
>