Subject: Re: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-use-cases-19: (with COMMENT)

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 1 Nov 2018 06:28:32 -0500

Hi, Alissa,

On Wed, Oct 31, 2018, 08:14 Alissa Cooper <[email-masked]> wrote:

>
>
> > On Oct 29, 2018, at 1:41 PM, Stewart Bryant <[email-masked]>
> wrote:
> >
> >
> >
> > On 29/10/2018 01:50, Spencer Dawkins at IETF wrote:
> >> Without going back for a quote, he was basically saying he thought more
> tgan one ABSTAIN was a pretty strong signal from the IESG that a document
> should not be published.
> >
> > That was always my understanding when I was on the IESG.
>
> This does not match what is described at <
> https://www.ietf.org/standards/process/iesg-ballots/>, which is the
> guideline I follow. Informational documents require one Yes ballot with no
> Discuss ballots. If we wanted to block publication, someone would need to
> ballot Discuss, or we would all need to ballot something besides Yes,
> including the sponsoring AD.
>
> When I filed my ballot, this document already had one Yes and five No
> Objection ballot positions, so the implication that my Abstain was meant to
> trigger some set of ballots that would block this document seems misplaced.
>

Sure. So my point isn't that ADs who do this are doing anything that's not
allowed in the process (we have Discuss criteria, but no critera for
Comments), but that we're surprising experienced IETF participants,
including one of my most long-serving chairs, and one past two-term RTG AD
(if I understand what Stewart is saying).

Communication is a good thing, I learned in my second marriage ;-) ...

Travel safely.

Spencer

Alissa
> > - Stewart

---

From: "Black, David" <[email-masked]>
Date: Sun, 4 Nov 2018 01:51:29 +0000

HI Alissa,

De-cloaking … I’m the person whom Spencer referred to as “one of our most experienced TSV chairs, who did not understand the meaning of an avalanche of ABSTAINs in the way that you and I understand it” and as I also happen to be the Transport Tech Advisor to the detnet WG, I suppose I should comment …

Going back to <https://www.ietf.org/standards/process/iesg-ballots/>, two reasons are given for a Discuss position:

1.      I am so strongly opposed to the document that I am unwilling to "discuss". (Note that this should be very unusual.)

2.      I oppose this document but understand that others differ and am not going to stand in the way of the others.

My sense from experience is that Abstain was rarely used in the past (e.g., prior to the IESG statement on support documents), and mostly for the first reason, particularly as an escalation of an initial Discuss position that had led to an unproductive discussion with a high heat/light ratio.   When used in the latter fashion, Abstain carries a strong “This document is fundamentally wrong” message about document content along with an overtone of AD frustration with the unproductive discussion.  That tends to be long-remembered by those who have been through such an experience in any role ;-).

Here, it seems that Abstain is being used in a rather different and much less emphatic fashion – based on the comment that the document “has useful content but I'm not convinced of its archival value,” this appears to be a “process” Abstain – i.e., the draft content is ok, but in the AD‘s view, this sort of draft should not be published as an RFC.  That’s a weaker level of concern than a Discuss, in contrast to the other usage, and comes a surprise, at least to me.  IMHO, it’s within reason for the IESG to start using Abstain in this fashion in connection with statement on support documents, but that new practice could have been much better communicated.

Also, Stewart Bryant is definitely correct about publishing support documents as RFCs to provide stable references for other standards bodies – RFC 8394 (from the nvo3 WG) is a recent worked example from May of this year.  That RFC is a requirements document whose requirements led to changes in an IEEE 802 protocol (VDP), and IEEE 802 wanted a stable IETF reference for that requirements input.  In the “credit where credit is due” department, Yizhou Li (RFC co-author), did most of the work across IETF and IEEE 802 to make those VDP changes happen.
Thanks, --David

From: detnet [mailto:[email-masked]] On Behalf Of Alissa Cooper
Sent: Wednesday, October 31, 2018 9:17 AM
To: Spencer Dawkins at IETF
Cc: Lou Berger; Adam Roach; BRUNGARD, DEBORAH A; [email-masked]; IESG; DetNet Chairs; Stewart Bryant; [email-masked]
Subject: Re: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-use-cases-19: (with COMMENT)

[EXTERNAL EMAIL]
Please report any suspicious attachments, links, or requests for sensitive information.

On Oct 29, 2018, at 5:35 PM, Spencer Dawkins at IETF <[email-masked]<mailto:[email-masked]>> wrote:

Hi, Adam,

On Mon, Oct 29, 2018 at 2:02 PM Adam Roach <[email-masked]<mailto:[email-masked]>> wrote:
On 10/29/18 12:41 PM, Stewart Bryant wrote:
>> Without going back for a quote, he was basically saying he thought
>> more tgan one ABSTAIN was a pretty strong signal from the IESG that a
>> document should not be published.
>

It is mine as well, but it only serves as advice. For informational
documents, it has no process significance, since it does not preclude
publication. Basically, if there are a large number of ABSTAINs, it
means that the working group is publishing the document over the
objections of the IESG (unless it uses this advice as an opportunity to
reconsider the request for publication). It is my understanding that the
process is set up exactly to allow this kind of thing to happen.

It's certainly fair game to discuss whether the system *should* be set
up this way, but I can't imagine any realistic changes other than ones
that would actually block publication under such circumstances -- and I
doubt that's where the community wants to take things.

In this particular case, it appears as if you're trying to get an IESG
member to say that she supports publication of a document when that is
not actually true. Given that there is no practical difference in
getting the document published, this pressure seems kind of problematic.

Pronouns are confusing, but since Stewart was replying to me, I'm not sure who "you" is.

But just in case it's me, we're still talking about an Informational document that requires one Yes and no Discusses to publish, no? And our BCP says that Informational documents do not reflect IETF consensus or recommendation, in https://tools.ietf.org/html/rfc2026#section-4.2.2.

So, I know why an AD would ballot DIscuss on an Informational document, but I'm less clear about why ADs ballot Abstains.

I ballot Abstain when my position on the document is consistent with what is described at <https://www.ietf.org/standards/process/iesg-ballots/>, namely "I oppose this document but understand that others differ and am not going to stand in the way of the others.”

Alissa

Of course, we've had conversations about this at least since Stewart was on the IESG. So I'll stop typing, and go back to packing.

Travel safely, all, of course.

Spencer

---

From: Loa Andersson <[email-masked]>
Date: Sun, 4 Nov 2018 09:51:06 +0700

I strongly agree with David and Stewart.
First - starting to use “Abstain” is the dualistic fashion should really have been much better way to E.g.-chairs and to the community in general. I’d say it should be avoided. 
Second - I also find the the group documents together of a wide range of documents to be less than productive. 
I would further say that some documents the are called “support documents” are really key documents e.g. RFC 5654. 
(Yes, that document is PS, but that is only because ITU-T could not reference Informational RFC at that time. 
Third - I expect any documents that a working group requests publication for get a fair review by the IESG. It is not like we are producing unnecessary documents. 

/Loa

Sent from my iPhone

> On 4 Nov 2018, at 08:51, Black, David <[email-masked]> wrote:
> 
> HI Alissa,
>  
> On Oct 29, 2018, at 5:35 PM, Spencer Dawkins at IETF <[email-masked]> wrote:
>  
> Hi, Adam, 
>  
> On Mon, Oct 29, 2018 at 2:02 PM Adam Roach <[email-masked]> wrote:
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: Alissa Cooper <[email-masked]>
Date: Sun, 4 Nov 2018 14:40:08 +0700

Hi David,

> On Nov 4, 2018, at 8:51 AM, Black, David <[email-masked]> wrote:
> 
> HI Alissa, <>
>  
> Going back to <https://www.ietf.org/standards/process/iesg-ballots/ <https://www.ietf.org/standards/process/iesg-ballots/>>, two reasons are given for a Discuss position:

The two reasons given below are for Abstain positions, not Discuss positions.

> Here, it seems that Abstain is being used in a rather different and much less emphatic fashion – based on the comment that the document “has useful content but I'm not convinced of its archival value,” this appears to be a “process” Abstain – i.e., the draft content is ok, but in the AD‘s view, this sort of draft should not be published as an RFC.  That’s a weaker level of concern than a Discuss, in contrast to the other usage, and comes a surprise, at least to me.  

As I mentioned earlier in the thread, my ballot on this document is consistent with the second reason given above for balloting Abstain. I believe the ballot procedures you quote have been in place since 2009. I appreciate that people may read more into the ballots and ballot positions than what is written in them, but all I can do is write in the ballot what I actually mean.

To further illustrate this, it seems to me this effort to get me to change my ballot from Abstain to No Objection (presumably), is to my eye akin to an effort to get someone to change their ballot from No Objection to Yes. That is, neither position prevents the document from being published, but for some reason people want me to have one position rather than the other. Notably, I can’t recall ever seeing anyone try to convince an AD to change from No Objection to Yes. So it’s a bit perplexing to see all of this discussion about changing between two other ballot positions that both have the same effect on the document, namely that they both allow the document to be publishes as-is.

> IMHO, it’s within reason for the IESG to start using Abstain in this fashion in connection with statement on support documents, 

I only had time to look through my own Abstain ballots, and I found the following prior ballots in this vein (note that some of them list similar ballots from other ADs):

January 2015: https://datatracker.ietf.org/doc/rfc7498/ballot/

February 2015: https://datatracker.ietf.org/doc/rfc7547/ballot/

February 2017: https://datatracker.ietf.org/doc/rfc8123/ballot/

April 2017: https://datatracker.ietf.org/doc/rfc8192/ballot/

June 2017: https://datatracker.ietf.org/doc/rfc8248/ballot/

May 2018: https://datatracker.ietf.org/doc/rfc8432/ballot/

So I don’t think it’s accurate to say that this practice “started” with this ballot on draft-ietf-detnet-use-cases, or with the ballots on draft-ietf-tsvwg-rfc4960-errata.

> but that new practice could have been much better communicated.

Fair enough. We got a bit of feedback when we published the statement, and within the IESG I think we agreed that each AD should socialize its existence within our own areas and working groups. Perhaps that decentralized communication has not been as effective as it could be and we need to put in another round of effort to make it more visible.

Alissa

> From: detnet [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Alissa Cooper
> Cc: Lou Berger; Adam Roach; BRUNGARD, DEBORAH A; [email-masked] <mailto:[email-masked]>; IESG; DetNet Chairs; Stewart Bryant; [email-masked] <mailto:[email-masked]>
> On Oct 29, 2018, at 5:35 PM, Spencer Dawkins at IETF <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hi, Adam, 
>  
> On Mon, Oct 29, 2018 at 2:02 PM Adam Roach <[email-masked] <mailto:[email-masked]>> wrote:
> But just in case it's me, we're still talking about an Informational document that requires one Yes and no Discusses to publish, no? And our BCP says that Informational documents do not reflect IETF consensus or recommendation, in https://tools.ietf.org/html/rfc2026#section-4.2.2 <https://tools.ietf.org/html/rfc2026#section-4.2.2>.  
>  
> I ballot Abstain when my position on the document is consistent with what is described at <https://www.ietf.org/standards/process/iesg-ballots/ <https://www.ietf.org/standards/process/iesg-ballots/>>, namely "I oppose this document but understand that others differ and am not going to stand in the way of the others.”
>  
> Alissa
> 
> 
>

---

From: "Black, David" <[email-masked]>
Date: Sun, 4 Nov 2018 14:50:54 +0000

Inline …

Thanks, --David

From: Alissa Cooper [mailto:[email-masked]]
Sent: Sunday, November 4, 2018 2:40 AM
To: Black, David
Cc: Spencer Dawkins at IETF; Lou Berger; Adam Roach; BRUNGARD, DEBORAH A; [email-masked]; IESG; DetNet Chairs; Stewart Bryant; [email-masked]
Subject: Re: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-use-cases-19: (with COMMENT)

[EXTERNAL EMAIL]

On Nov 4, 2018, at 8:51 AM, Black, David <[email-masked]<mailto:[email-masked]>> wrote:

HI Alissa,

[David>] Correct, touche’

Alissa

[David>] The concern is not so much about communication of the statement but rather about setting expectations that some ADs are using Abstain positions to reflect that statement.

Cc: Lou Berger; Adam Roach; BRUNGARD, DEBORAH A; [email-masked]<mailto:[email-masked]>; IESG; DetNet Chairs; Stewart Bryant; [email-masked]<mailto:[email-masked]>

[EXTERNAL EMAIL]

Hi, Adam,

Alissa

Spencer

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 5 Nov 2018 02:41:35 +0000

>> IMHO, it’s within reason for the IESG to start using Abstain in this 
>> fashion in connection with statement on support documents,
>
> I only had time to look through my own Abstain ballots, and I found 
> the following prior ballots in this vein (note that some of them list 
> similar ballots from other ADs):
>
> So I don’t think it’s accurate to say that this practice “started” 
> with this ballot on draft-ietf-detnet-use-cases, or with the ballots 
> on draft-ietf-tsvwg-rfc4960-errata.

Whilst that may be so, that is not so many drafts compared to the number 
that went through the IESG that most of us would have noticed unless we 
were an affected chair or author.

> Fair enough. We got a bit of feedback when we published the statement, 
> and within the IESG I think we agreed that each AD should socialize 
> its existence within our own areas and working groups. Perhaps that 
> decentralized communication has not been as effective as it could be 
> and we need to put in another round of effort to make it more visible.
>
I think the IESG need to revisit both the statement and the 
communitation of the statement and its implications.  I am not convinced 
either of these was widely noted.

Best regards

Stewart

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 5 Nov 2018 10:45:04 +0700

This is not my IETF week to have lots of opinions about what Abstains are,
or are not, and to share those opinions with others, but I do have enough
time to say this.

"Communication is a good thing, as I learned in my SECOND marriage".

I say that often, but don't often follow up with the corollary.

"If I expect someone to work with me, we need to talk before I do things
they don't expect or understand".

Substitute "live with" for "work with", and all of you will know why
Shirley and I are still married, and Helen and I are not.

Make good choices.

Spencer