Subject: [Detnet] Controlling Replication

From: Remous-Aris Koutsiamanis <[email-masked]>
Date: Thu, 15 Nov 2018 17:57:36 +0100 (CET)

Hello,

I have been reading through the material in the DetNet WG in search for a
specific mechanism for controlling replication.
I have not found something very specific, e.g. a header field indicating to
enable replications or to do N replications, until now.
I have found BIER-TE, however, as far as I can tell the replication
decision (to which next hops to forward to) in this case is made beforehand
in the controller, not in each intermediate node.
Would someone be kind enough to either point me in the right direction if
there is such functionality or confirm that there is nothing of this kind
specified (yet).

Kind regards,
Remous-Aris Koutsiamanis
IMT Atlantique, France

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 16 Nov 2018 00:33:23 +0100

Remous-Aris,

We did propose BIER-TE as a possible transport in DetNet, but so far
there was no feedback re. that proposal.  I still think
that BIER-TE would be a great lightweigt transport option, but maybe
there is too little understanding DetNet of its benefits yet in the WG.
Note that BIER-TE would support both unicast/multicast as well as PRF.

Cheers
    Toerless

> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

-- 
---
[email-masked]

---

From: Mach Chen <[email-masked]>
Date: Fri, 16 Nov 2018 00:58:02 +0000

Hi Remous-Aris,

To control where/when to replicate/eliminate is the possibility of the control plane/management plane. The control plane work is not started yet, you can find the YANG-based configuration solution in https://tools.ietf.org/html/draft-ietf-detnet-yang-00 .

BIER-TE like solution is another candidate solution.

Best regards,
Mach

From: detnet [mailto:[email-masked]] On Behalf Of Remous-Aris Koutsiamanis
Sent: Friday, November 16, 2018 12:58 AM
To: [email-masked]
Subject: [Detnet] Controlling Replication

Hello,

I have been reading through the material in the DetNet WG in search for a specific mechanism for controlling replication.
I have not found something very specific, e.g. a header field indicating to enable replications or to do N replications, until now.
I have found BIER-TE, however, as far as I can tell the replication decision (to which next hops to forward to) in this case is made beforehand in the controller, not in each intermediate node..
Would someone be kind enough to either point me in the right direction if there is such functionality or confirm that there is nothing of this kind specified (yet).

Kind regards,
Remous-Aris Koutsiamanis
IMT Atlantique, France

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 16 Nov 2018 04:24:17 +0000

Hello Toerless 

Not to mention OAM. The draft provides all in one a per-packet control of the segments to be traversed and the exploration of the possible trajectories of the replicas. 

As an OAM technique, BIER TE provides a very concise expression for the status of the individual segments. .

With this draft one can automate the enablement of segment to continuously providing redundancy while avoiding bandwidth and energy wastes.

Being concise is critical in wireless but valuable everywhere. BIER as a WG does not need it - we do. But it would be great that they give a stamp of approval for the whole design before they give it back to DetNet - or PAW.

Take care.

Pascal

> Le 16 nov. 2018 à 00:33, Toerless Eckert <[email-masked]> a écrit :
> 
> Remous-Aris,
>

---

From: Remous-Aris Koutsiamanis <[email-masked]>
Date: Fri, 16 Nov 2018 17:55:56 +0100 (CET)

Hello,

thanks Pascal, Toerless, and Mach for the very helpful comments and
pointers.

Just as some context, I was looking for something which can control
replication for my work on draft-koutsiamanis-roll-nsa-extension.
I have looked at BIER-TE and it does look very interesting. I think that
BIER-TE is a different approach in this case, so it makes sense that it
provides no way to do replication control in the network, since everything
is decided in the controller.
I will also look at the YANG-based configuration solution in
https://tools.ietf.org/html/draft-ietf-detnet-yang-00.

Again, thanks a lot.

Kind regards,
Aris

On Fri, Nov 16, 2018 at 5:24 AM Pascal Thubert (pthubert) <
[email-masked]> wrote:

> Hello Toerless
>
> Not to mention OAM. The draft provides all in one a per-packet control of
> the segments to be traversed and the exploration of the possible
> trajectories of the replicas.
>
> With this draft one can automate the enablement of segment to continuously
> providing redundancy while avoiding bandwidth and energy wastes.
>
> Being concise is critical in wireless but valuable everywhere. BIER as a
> WG does not need it - we do. But it would be great that they give a stamp
> of approval for the whole design before they give it back to DetNet - or
> PAW.
>
> Take care.
>
> Pascal
>