Subject: [Detnet] Mirja Kühlewind's Abstain on draft-ietf-detnet-problem-statement-07: (with COMMENT)

From: Mirja Kühlewind <[email-masked]>
Date: Fri, 30 Nov 2018 07:18:01 -0800

Mirja Kühlewind has entered the following ballot position for
draft-ietf-detnet-problem-statement-07: Abstain

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-detnet-problem-statement/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I don't really see the archival value of this doc; it rather reads like an
extended charter. However, that's not a reason to block publication, therefore
I ballot abstain.

One comment on this text in section 3.3:
"indicate the flows and packet sequences in-band with the flows;"
I don't really understand why this is needed or where this requirement comes
from. Is then assumption that in-ordered delivery is needed? However, why would
packets be re-ordered in a detnet system? Also, not all flows might need
ordered delivery; so that might be another flow characteristic which you may
want to configure.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 30 Nov 2018 15:36:48 +0000

Hello Mirja

You are correct: the core service layer function is what we call PREOF, replication, elimination and reordering. For those, secure flow identification and sequencing are needed.

All the best,

Pascal

> -----Original Message-----
> From: Mirja Kühlewind <[email-masked]>
> Sent: vendredi 30 novembre 2018 16:18
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Lou Berger
> <[email-masked]>; Janos Farkas <[email-masked]>; detnet-
> [email-masked]; [email-masked]; [email-masked]
> Subject: Mirja Kühlewind's Abstain on draft-ietf-detnet-problem-statement-07:
> (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> I don't really see the archival value of this doc; it rather reads like an extended
> charter. However, that's not a reason to block publication, therefore I ballot
> abstain.
> 
> from. Is then assumption that in-ordered delivery is needed? However, why
> would packets be re-ordered in a detnet system? Also, not all flows might need