Subject: [Detnet] Proposed update to DetNet OAM requirements

From: Greg Mirsky <[email-masked]>
Date: Mon, 12 Nov 2018 10:01:20 +0700

Dear All,
we've worked with Pascal off-line to address his comments at the meeting.
Attached please find the diff to the working version and its copy. Much
appreciate your comments, questions, and suggestions.

Regards,
Greg

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 12 Nov 2018 03:59:37 +0000

Many thanks Greg:

The main change that I suggested was to consider OAM for the detnet service layer as well as the detnet transport layer. I do not have a solution in mind that can do that for the IP dataplane without instrumenting the packets.
I worked on that topic in the context of wireless, which is extreme in that there is a lot of PREOF going on in order to provide spatial diversity in compensation to the lossiness of the medium.
It is also often constrained so we had to come up with a very concise way to observing the service layer operation.
Finally the radio medium is constrained energy-wise so we wanted to be able to control dynamically the amount of PREOF being used based on its usefulness, and favor the segments that provide the best service at any point of time. Sine this is highly variable, we needed a way to provide a control loop between the OAM observation and the Segment routing signaling.
We found that BIER-TE was an excellent tool for all the above and produced https://datatracker.ietf.org/doc/html/draft-thubert-bier-replication-elimination which was discussed at BIER for a while.
Once BIER agrees that the technology is sound, I think we need to bring it back to where it belongs, ideally DetNet, but if it is too specific for DetNet, then Paw.

Please go through  the draft and let us know;

Pascal

From: Greg Mirsky <[email-masked]>
Sent: lundi 12 novembre 2018 10:01
To: DetNet WG <[email-masked]>; Pascal Thubert (pthubert) <[email-masked]>
Subject: Proposed update to DetNet OAM requirements

Dear All,
we've worked with Pascal off-line to address his comments at the meeting. Attached please find the diff to the working version and its copy. Much appreciate your comments, questions, and suggestions.

Regards,
Greg