Subject: [Detnet] Discussion of New YANG model aligned with DetNet Flow

From: "Don Fedyk" <[email-masked]>
Date: Tue, 18 Feb 2020 18:17:11 -0500

Hi

Monday Feb 17th we had a DetNet meeting discussing the det-net flow yang
model.  

 https://github.com/detnet-wg/draft-ietf-detnet-yang/issues/1

https://github.com/detnet-wg/draft-ietf-detnet-yang/issues/2

This model covers IP and MPLS only. 

It is a new foundation where more functions may need to be added.  

It also reuses Routing (IP) and MPLS yang input and output. 

The model captures unidirectional paths in each direction

On today's call the presentation: 

https://github.com/detnet-wg/draft-ietf-detnet-yang/issues/4

Notes that there is no mapping in the model for a transit node. 

Question 1: It looks like this model does not support a transit node?  

I looked at this this item and the answer is yes that is correct.  

A pure transit node in DetNet is an IP or MPLS node and this is already
covered by existing models.  With no termination of a DetNet
service/application layer there is no DetNet specific controls. 

I'm proposing there is no need for a special transit node YANG for DetNet. 

Question 2: The relay node in this model uses a single service to link a
terminating forwarding sublayer to am forwarding sublayer. 

This was the intent of the model. But I think that this part needs to be
modified.  

There are two ways to address this:

1.	Either provide an optional pointer to a service just as we have with
applications so an incoming service either terminates on an application or
another service.
2.	Expand a single service to link input and output forwarding layers. 

I suggest option 1 is better because the additions for the relay in option 2
would be redundant for a terminating case. It also allows for aggregating
services into a next service hop.  

I will provide an update with a service pointer to address the Service Relay
case.  There are ongoing Monday Meetings if people would like to comment or
contribute. 

Cheers

Don

---

From: "Don Fedyk" <[email-masked]>
Date: Sun, 23 Feb 2020 16:59:49 -0500

For this Monday's Meeting I have put some updated models addressing the
comments. 

As https://github.com/detnet-wg/draft-ietf-detnet-yang/issues/5

Cheers

Don

From: detnet <[email-masked]> On Behalf Of Don Fedyk
Sent: Tuesday, February 18, 2020 6:17 PM
To: 'DetNet WG' <[email-masked]>
Subject: [Detnet] Discussion of New YANG model aligned with DetNet Flow

Hi

Cheers

Don

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Mon, 24 Feb 2020 03:24:49 +0000

Hi Don,

Thank you for preparing for the material. After a quick review about the updated part: Page 10-13, I have some questions:

1.       I notice that the edge node/relay node/transit node are discussed separately. Whether this will influence the structure of YANG Model? For example, based on the node type.

2.       In the blue box of service: what is the difference between “service edge originating” in Page10 and “service relay originating” in Page11. (The same as terminating case)

Best Regards
Xuesong

发件人: detnet [mailto:[email-masked]] 代表 Don Fedyk
发送时间: 2020年2月24日 6:00
收件人: 'DetNet WG' <[email-masked]>
主题: Re: [Detnet] Discussion of New YANG model aligned with DetNet Flow

For this Monday’s Meeting I have put some updated models addressing the comments.
As https://github.com/detnet-wg/draft-ietf-detnet-yang/issues/5

Cheers
Don

From: detnet <[email-masked]<mailto:[email-masked]>> On Behalf Of Don Fedyk
Sent: Tuesday, February 18, 2020 6:17 PM
To: 'DetNet WG' <[email-masked]<mailto:[email-masked]>>
Subject: [Detnet] Discussion of New YANG model aligned with DetNet Flow

Hi

Monday Feb 17th we had a DetNet meeting discussing the det-net flow yang model.

On today’s call the presentation:
https://github.com/detnet-wg/draft-ietf-detnet-yang/issues/4
Notes that there is no mapping in the model for a transit node.

Question 1: It looks like this model does not support a transit node?
I looked at this this item and the answer is yes that is correct.
A pure transit node in DetNet is an IP or MPLS node and this is already covered by existing models.  With no termination of a DetNet service/application layer there is no DetNet specific controls.
I’m proposing there is no need for a special transit node YANG for DetNet.

Question 2: The relay node in this model uses a single service to link a terminating forwarding sublayer to am forwarding sublayer.
This was the intent of the model. But I think that this part needs to be modified.
There are two ways to address this:

  1.  Either provide an optional pointer to a service just as we have with applications so an incoming service either terminates on an application or another service.
  2.  Expand a single service to link input and output forwarding layers.

I suggest option 1 is better because the additions for the relay in option 2 would be redundant for a terminating case. It also allows for aggregating services into a next service hop.

I will provide an update with a service pointer to address the Service Relay case.  There are ongoing Monday Meetings if people would like to comment or contribute.

Cheers
Don

---

From: 유연철 <[email-masked]>
Date: Mon, 24 Feb 2020 08:45:02 +0000

Dear Don,

Thank you for preparing for the material. I have some questions for updated material:
In general, I am not sure the YANG data model you proposed is aligned with the information model. One of the main issues that we discussed in the side meeting of the last IETF was people seemed to have difficulties in seeing how the groups defined in the information model document have been realized in the YANG data model document.

The information model defines three groups; App-flow, DetNet flow, and DetNet service, and it defines a view from overall network perspective. The current YANG model defined in draft-ietf-detnet-yang-04 has a different set of groups (app flows, service sub-layer, forwarding sub-layer, sub-network), and it is for configuring network nodes. The proposed YANG model defines a different set of groups (applications, app-ingress, app-egress, services, fwd-sub-layer-input, fwd-sub-layer-output), but, it is still difficult to see the relationship with the information model clearly.

From P.10 of the ppt, I can see mapping between interface and application ingress/egress is k:1, and application and service has n:1 relation. From the YANG tree, I also noticed that multiple application ingresses/egresses are mapped to a single application, which is not shown in the slide. In the meantime, the slide shows mapping between DetNet flow and service to be m:1, but I cannot find this relationship from the YANG tree. Would you clarify this, first?

Then, it is difficult for me to understand why multiple interfaces are mapped to a single application ingress/egress and why multiple interfaces are mapped to a single forwarding-sub-layers input/output.

Best Regards,
Yeoncheol

출발: detnet <[email-masked]>(Don Fedyk <[email-masked]> 대신)
날짜: 2020년 2월 24일 월요일 오전 7:00
받는 사람: 'DetNet WG' <[email-masked]>
주제: Re: [Detnet] Discussion of New YANG model aligned with DetNet Flow

Cheers
Don

Hi

Cheers
Don