Subject: [Detnet] Tsvart last call review of draft-ietf-detnet-data-plane-framework-04

From: Yoshifumi Nishida via Datatracker <[email-masked]>
Date: Tue, 07 Apr 2020 01:57:41 -0700

Reviewer: Yoshifumi Nishida
Review result: Ready with Nits

This document has been reviewed as part of the transport area review team's
ongoing effort to review key IETF documents. These comments were written
primarily for the transport area directors, but are copied to the document's
authors and WG to allow them to address any issues raised and also to the IETF
discussion list for information.

When done at the time of IETF Last Call, the authors should consider this
review as part of the last-call comments they receive. Please always CC
[email-masked] if you reply to or forward this review.

Summary: Ready with Nits.

This document is well-written as an informational RFC. I don't see any
technical issues related to transport, but it might be better to clarify the
following minor point.

The draft allows DetNet data plane to carry flow ID and sequence number as
metadata. But, aren't there any potential risks for the conflict of the flow ID
or wrap-around of the sequence number? (especially for explicit case) It might
be better to state which module should care if it's out of scope for the draft
or to clarify there is no risk against them.

Thanks,
--
Yoshi

---

From: Balázs Varga A <[email-masked]>
Date: Wed, 15 Apr 2020 15:10:29 +0000

Hi Yoshi,

Many thanks for the review.
Regarding your comment on "conflict of the flow ID or wrap-around of the sequence number".
Yes, these are important aspects in DetNet.

Yes, flow ID must be unique in order to identify packets belonging to the DetNet flow. 
This must be ensured by the control and/or management plane. DetNet WG was re-chartered 
recently to focus on these planes as well. In data plane drafts we have dedicated a section
to collect " Controller Plane (Management and Control) Considerations".

Regarding sequence number, wrap-around events are flow characteristics and network 
dependent. The data plane technology specific documents ensures that the sequence number 
space does not wrap whilst packets are in flight ( see Section 4.1. and 4.2.1 in 
https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls ).

I hope that clarifies your comments.

Many Thanks
Bala'zs

-----Original Message-----
From: Yoshifumi Nishida via Datatracker <[email-masked]> 
Sent: Tuesday, April 7, 2020 10:58 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Tsvart last call review of draft-ietf-detnet-data-plane-framework-04

This document has been reviewed as part of the transport area review team's ongoing effort to review key IETF documents. These comments were written primarily for the transport area directors, but are copied to the document's authors and WG to allow them to address any issues raised and also to the IETF discussion list for information.

When done at the time of IETF Last Call, the authors should consider this review as part of the last-call comments they receive. Please always CC [email-masked] if you reply to or forward this review.

This document is well-written as an informational RFC. I don't see any technical issues related to transport, but it might be better to clarify the following minor point.

The draft allows DetNet data plane to carry flow ID and sequence number as metadata. But, aren't there any potential risks for the conflict of the flow ID or wrap-around of the sequence number? (especially for explicit case) It might be better to state which module should care if it's out of scope for the draft or to clarify there is no risk against them.

Thanks,
--
Yoshi

---

From: Yoshifumi Nishida <[email-masked]>
Date: Mon, 20 Apr 2020 02:05:13 -0700

Hi Balázs,

Thanks for the clarification.
I think it might be good if you can provide simple texts in the draft to
provide these info for references.
--
Yoshi

On Wed, Apr 15, 2020 at 8:10 AM Balázs Varga A <[email-masked]>
wrote:

> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: Tsvart last call review of
> draft-ietf-detnet-data-plane-framework-04
>
> This document has been reviewed as part of the transport area review
> team's ongoing effort to review key IETF documents. These comments were
> written primarily for the transport area directors, but are copied to the
> document's authors and WG to allow them to address any issues raised and
> also to the IETF discussion list for information.
>
> technical issues related to transport, but it might be better to clarify
> the following minor point.
>
> metadata. But, aren't there any potential risks for the conflict of the
> flow ID or wrap-around of the sequence number? (especially for explicit
> case) It might be better to state which module should care if it's out of
> scope for the draft or to clarify there is no risk against them.
>
> Thanks,
> --
> Yoshi
>
>
>
>

---

From: Balázs Varga A <[email-masked]>
Date: Mon, 20 Apr 2020 13:09:42 +0000

Hi Yoshi,
Thanks. Creating the next version is in progress.
It will address your comment.
Cheers
Bala’zs

From: Yoshifumi Nishida <[email-masked]>
Sent: Monday, April 20, 2020 11:05 AM
To: Balázs Varga A <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Tsvart last call review of draft-ietf-detnet-data-plane-framework-04

Hi Balázs,

Thanks for the clarification.
I think it might be good if you can provide simple texts in the draft to provide these info for references.
--
Yoshi

On Wed, Apr 15, 2020 at 8:10 AM Balázs Varga A <[email-masked]<mailto:[email-masked]>> wrote:
Hi Yoshi,

Many Thanks
Bala'zs

-----Original Message-----
From: Yoshifumi Nishida via Datatracker <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, April 7, 2020 10:58 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Tsvart last call review of draft-ietf-detnet-data-plane-framework-04

When done at the time of IETF Last Call, the authors should consider this review as part of the last-call comments they receive. Please always CC [email-masked]<mailto:[email-masked]> if you reply to or forward this review.

Thanks,
--
Yoshi