Subject: Re: [Detnet] Genart last call review of draft-ietf-detnet-data-plane-framework-04

From: Balázs Varga A <[email-masked]>
Date: Wed, 15 Apr 2020 14:44:42 +0000

Hi Christer,
Thanks for your review. Replies/comments inline marked with <BV>.
We are working on an updated version of the draft to incorporate your comments as well.
Thanks
Bala'zs

-----Original Message-----
From: Christer Holmberg via Datatracker <[email-masked]> 
Sent: Sunday, March 15, 2020 11:29 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Genart last call review of draft-ietf-detnet-data-plane-framework-04

Reviewer: Christer Holmberg
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-detnet-data-plane-framework-04
Reviewer: Christer Holmberg
Review Date: 2020-03-15
IETF LC End Date: 2020-03-13
IESG Telechat date: Not scheduled for a telechat

Summary: The document is well written, and almost ready for publication. I have no issues on the technical parts, but I have found some editorial nits in the
Introduction- and Security Considerations sections that I ask the authors to address.

Major issues: N/A

Minor issues: N/A

Nits/editorial comments:

Q1:

The first line of the Introduction says:

“DetNet (Deterministic Networking) provides a capability…”

Please add a reference to DetNet/RFC8655 on first occurance.

<BV> OK, the second sentence refers to RFC8655. First sentence provides a general description.

Q2:

The first line of the 2nd paragraph of the Introduction says:

“This document describes the concepts needed by any DetNet data plane specification…”

What is meant by DetNet data plane specification? The definition of DetNet flows over a specific network technology? Please clarify, or reference if already defined elsewhere.

<BV> Data plane documents focuses how DetNet packets are recognized and served according to DetNet service and forwarding sub-layer functions. The next sentence is intended to clarify that.

Q3:

The 5th paragraph of the Introduction (“DetNet flows may be carried over
network…”) contains text about network topologies that can be used for DetNet flows.

Is the text (all, or part of it) in the paragraph somehow specific to this document, or is it simply repeating things that are defined in RFC 8655? If the paragraph is only repeating stuff, maybe start with “As defined in RFC8655, DetNet flows may be carried…”.

<BV> YES, framework document is inline with RFC8655 and here we are referring to it. I will modify the sentence according to your suggestion.

Q4:

The 6th paragraph of the Introduction says:

“Different application flows (e.g., Ethernet, IP, etc.)…”

The text may it look like the Ethernet, IP etc is the actual application flow.
I assume you mean application flow carried over Ethernet, IP, etc? If so, please modify to make it more clear.

<BV> It is intentionally formulated so. From DetNet edge nodes perspective the received Ethernet frames or IP packets are treated as an app-flow. 
The end-host application data carried over Ethernet, IP are not "touched" by DetNet.

Q5:

The Security considerations say:

“Security considerations for DetNet are described in detail in [I-D.ietf-detnet-security].  General security considerations are described in [RFC8655].”

The sentence is confusing. General security considerations for what? Doesn’t RFC 8655 also describe security considerations for DetNet?

<BV> OK. General security considerations for DetNet were meant here. I will update text to be more specific.

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 15 Apr 2020 21:19:06 +0000

Hi Bala'zs,

Thank you for the reply and clarifications. I still have a question on Q2.

...
    
    Q2:
    
    > <BV> Data plane documents focuses how DetNet packets are recognized and served according to DetNet service and forwarding sub-layer functions. 
    >The next sentence is intended to clarify that.

    The next sentence is fine. It is just a little unclear to me what the definition of DetNet data plane specification actually is. Is it a specification that 
    defines the combination of service sub-layer using protocol X and forwarding sub-layer using protocol Y?

Regards,

Christer

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 16 Apr 2020 11:28:11 +0000

Hi Christer,

No, data plane specification does not cover what protocols are used by service sub-layer and forwarding sub-layer functions.
A data plane specification specifies what headers fields are there in the packet and how to use these header fields for a specific 
purpose. For instance, in case of DetNet, what fields are used to recognize a DetNet flow (flow ID) and how is the sequence number 
encoded and used.

A possible clarification is below (text added in brackets to firs sentence). Does it solves your concern?
OLD:
   This document describes the concepts needed by any DetNet data plane
   specification and provides considerations for any corresponding
   implementation.  It covers the building blocks that provide the
   DetNet service, the DetNet service sub-layer and the DetNet
   forwarding sub-layer functions as described in the DetNet
   Architecture.

NEW:
   This document describes the concepts needed by any DetNet data plane
   specification (i.e., the DetNet-specific use of packet header fields) and 
   provides considerations for any corresponding
   implementation.  It covers the building blocks that provide the
   DetNet service, the DetNet service sub-layer and the DetNet
   forwarding sub-layer functions as described in the DetNet
   Architecture.

Thanks
Bala'zs

-----Original Message-----
From: Christer Holmberg <[email-masked]> 
Sent: Wednesday, April 15, 2020 11:19 PM
To: Balázs Varga A <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Genart last call review of draft-ietf-detnet-data-plane-framework-04

Hi Bala'zs,

...

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 16 Apr 2020 16:46:47 +0000

Hi Bala'zs,

The modified text you suggest addresses my issue.

Thanks!

Regards,

Christer

On 16/04/2020, 14.28, "Balázs Varga A" <[email-masked]> wrote:

    Hi Christer,

    
    NEW:
    
    Thanks
    Bala'zs
    
    -----Original Message-----
    From: Christer Holmberg <[email-masked]> 
    Sent: Wednesday, April 15, 2020 11:19 PM
    To: Balázs Varga A <[email-masked]>; [email-masked]
    Cc: [email-masked]; [email-masked]; [email-masked]
    Subject: Re: Genart last call review of draft-ietf-detnet-data-plane-framework-04
    
    Hi Bala'zs,

    ...

    

    Regards,
    
    Christer

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 23 Apr 2020 16:29:28 -0400

Christer, thanks for your review. Balázs, thanks for your response. I entered a No Objection ballot.

Alissa

> On Apr 16, 2020, at 12:46 PM, Christer Holmberg <christer.holmberg=[email-masked]> wrote:
> 
> Hi Bala'zs,
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art