Subject: [Detnet] Support of FREOF in DetNet MPLS relay nodes as shown in Figure 1 of RFC 8655

From: Jeong-dong Ryoo <[email-masked]>
Date: Thu, 28 May 2020 17:10:51 +0900 (KST)

Dear DetNet experts,

In Sections 4.5.1 and 4.5.2 of DetNet MPLS data plane draft,&nbsp;draft-ietf-detnet-mpls-06, processing of edge and relay nodes is described from the perspective of the service sub-layer.&nbsp;

It seems that current text supports a network scenario that only two edge nodes perform FREOF functions and relay nodes between them are just acting as transit nodes. In other words, the very first figure of DetNet architecture document, RFC 8655, is not supported by current DetNet MPLS data plane draft.&nbsp;

On the other hand, I see the following text from the second paragraph of Section 4.5.1, which describes processing of edge nodes:&nbsp;
“During elimination and the replication process the sequence number of the
DetNet member flow MUST be preserved and copied to the egress DetNet
member flow.”
I am wondering whether the quoted text should apply to relay nodes, not edge nodes, because edge nodes, which add or remove d-CWs and S-Labels, do not have to pass the sequence number outside.&nbsp;

Anyway, in my opinion, Figure 1 of RFC 8655 should be supported in the DetNet MPLS data plane document, and I would like to propose the following text, which reuses current text as much as possible, for Sections 4.5.1 and 4.5.2:&nbsp;
%%% BEGIN %%%

4.5.1. Edge Node Processing

An edge node is responsible for matching ingress packets to the
service they require&nbsp;and encapsulating them accordingly. An edge
node may participate in the packet replication and duplicate packet
elimination.

The DetNet-aware forwarder in the&nbsp;DetNet edge node selects the&nbsp;
egress DetNet member flow segment based on the flow identification.&nbsp;
The mapping of ingress DetNet app-flow to egress DetNet member&nbsp;
flow segment may be statically or dynamically configured.
Additionally, the DetNet-aware forwarder does duplicate frame&nbsp;
elimination based on the sequence number in the d-CW.&nbsp;
The packet replication&nbsp;is also done within the DetNet-aware forwarder.

4.5.2. Relay Node Processing

A DetNet Relay node operates in the DetNet service sub-layer.
For DetNet using MPLS this processing is performed on the S-Label.
A relay node may participate in the packet replication and&nbsp;
duplicate packet elimination.

The DetNet-aware forwarder in the DetNet relay node selects the&nbsp;
egress DetNet member flow segment based on the ingress S-Label.
The mapping of ingress to egress S-Label may be statically&nbsp;
or dynamically configured. Additionally, the DetNet-aware&nbsp;
forwarder does duplicate frame elimination based on the sequence&nbsp;
number in the d-CW. The packet replication is also done within the&nbsp;
DetNet-aware forwarder. During elimination and the replication&nbsp;
process the sequence number of the DetNet member flow MUST be&nbsp;
preserved and copied to the egress DetNet member flow.

%%% End %%%

Please, note that the third paragraph of Section 4.5.1 does not appear in the text proposed above.&nbsp;I think that paragraph should be moved before Section 4.5.1 since it can apply to both edge and relay nodes.

I would appreciate if you can review the proposed text and provide your feedbacks.

Best regards,

Jeong-dong

---

From: Balázs Varga A <[email-masked]>
Date: Fri, 29 May 2020 15:12:36 +0000

Hi Jeong-dong,

Thanks for your fresh eyes. I think this is an editorial issue. The draft contains at many points explicitly that Relay Nodes operate at both sub-layer (service and forwarding).
However it is never too late to make the text clearer, therefore some editorial changes were made on the sections You have referred. Thank You for the review.

Please, check the editorial changes on the Github:
https://github.com/detnet-wg/data-plane-drafts/pull/99/files

UPDATED Text:
4.5.1. Edge Node Processing
An edge node is responsible for matching ingress packets to the
service they require and encapsulating them accordingly. An edge
node may participate in the packet replication and duplicate packet
elimination.

The DetNet-aware forwarder selects the egress DetNet member flow
segment based on the flow identification. The mapping of ingress
DetNet member flow segment to egress DetNet member flow segment may
be statically or dynamically configured. Additionally the DetNet-
aware forwarder does duplicate frame elimination based on the flow
identification and the sequence number combination. The packet
replication is also done within the DetNet-aware forwarder.
4.5.2. Relay Node Processing
A DetNet Relay node operates in the DetNet forwarding sub-layer and
service sub-layer. For DetNet using MPLS forwarding processing is
performed on the F-Label. This processing is done within an extended
forwarder function. Whether an ingress DetNet member flow receives
DetNet specific processing depends on how the forwarding is
programmed. Some relay nodes may be DetNet service aware for certain
DetNet services, while for other DetNet services the node may perform
as unmodified LSRs that only understand how to switch MPLS-TE LSPs,
i.e., as a transit node, see Section 4.4. Again, this is entirely up
to how the forwarding has been programmed.

During elimination and the replication process the sequence number of
the DetNet member flow MUST be preserved and copied to the egress
DetNet member flow. Specifically, a relay node sends the same
sequence number in an outgoing packet of a DetNet member flow that is
received in the corresponding incoming packet of a DetNet compound
flow. This is true whether or not PREOF is performed at the relay
node.

The internal design of a relay node is out of scope of this document.
However the reader’s attention is drawn to the need to make any PREOF
state available to the packet processor(s) dealing with packets to
which the PREOF functions must be applied, and to maintain that state
is such as way that it is available to the packet processor operation
on the next packet in the DetNet flow (which may be a duplicate, a
late packet, or the next packet in sequence.

END of UPDATED Text:

Thanks & Cheers
Bala’zs

From: [email-masked] <[email-masked]>
Sent: Thursday, May 28, 2020 10:11 AM
To: DetNet WG <[email-masked]>
Cc: 'DetNet Chairs' <[email-masked]>; [email-masked]
Subject: Support of FREOF in DetNet MPLS relay nodes as shown in Figure 1 of RFC 8655

Dear DetNet experts,

In Sections 4.5.1 and 4.5.2 of DetNet MPLS data plane draft, draft-ietf-detnet-mpls-06, processing of edge and relay nodes is described from the perspective of the service sub-layer.

It seems that current text supports a network scenario that only two edge nodes perform FREOF functions and relay nodes between them are just acting as transit nodes. In other words, the very first figure of DetNet architecture document, RFC 8655, is not supported by current DetNet MPLS data plane draft.

On the other hand, I see the following text from the second paragraph of Section 4.5.1, which describes processing of edge nodes:

member flow.”

I am wondering whether the quoted text should apply to relay nodes, not edge nodes, because edge nodes, which add or remove d-CWs and S-Labels, do not have to pass the sequence number outside.

Anyway, in my opinion, Figure 1 of RFC 8655 should be supported in the DetNet MPLS data plane document, and I would like to propose the following text, which reuses current text as much as possible, for Sections 4.5.1 and 4.5.2:

%%% BEGIN %%%

service they require and encapsulating them accordingly. An edge

elimination.

The DetNet-aware forwarder in the DetNet edge node selects the

egress DetNet member flow segment based on the flow identification.

The mapping of ingress DetNet app-flow to egress DetNet member

Additionally, the DetNet-aware forwarder does duplicate frame

elimination based on the sequence number in the d-CW.

The packet replication is also done within the DetNet-aware forwarder.

A relay node may participate in the packet replication and

The DetNet-aware forwarder in the DetNet relay node selects the

The mapping of ingress to egress S-Label may be statically

or dynamically configured. Additionally, the DetNet-aware

forwarder does duplicate frame elimination based on the sequence

number in the d-CW. The packet replication is also done within the

DetNet-aware forwarder. During elimination and the replication

process the sequence number of the DetNet member flow MUST be

%%% End %%%

Please, note that the third paragraph of Section 4.5.1 does not appear in the text proposed above. I think that paragraph should be moved before Section 4.5.1 since it can apply to both edge and relay nodes.

Best regards,

Jeong-dong

[https://gov-dooray.com/mail-receipts?img=3431765056546f50-255f338911948417-26398ea52d3696d1-263993826fbe1ade.gif]