Subject: [Detnet] Detnet WG charter ? “QOS and Jumbo frames” over public internet

From: Gyan Mishra <[email-masked]>
Date: Thu, 23 Jul 2020 16:27:26 -0400

Dear Detnet WG

+ PIM & MBONED ( As the ? relates to reliable multicast video delivery over
the internet or 4G/5G RAN backhaul for reliable multicast over mobile
devices as well as simultaneously massive data transfers and how to make
feasible)

I was curious if Detnet as it appears relevant to the charter to provide
reliable voice and video delivery over the public internet.

Their have been many white papers by universities and research institutions
over the years related to how to make end to end QOS possible over the
global internet.

Historically the problem has always been that all providers have their own
QOS policy and its impractical to be able to come up with a standard
queuing standards that all ISPs throughout the hierarchical internet must
follow from Tier 1 down to the broadband carriers so that multicast can
thrive on the internet.

I don’t think it’s impossible and maybe a ubiquitous standard exists exists
that all providers must follow today but I am not aware of one.

The conceptual idea is that in this day and age precluding the concept of
net neutrality or not as that opens up another can of worms - In theory it
seems possible to have a standard way of WRR IPV4 IPV6 dscp based or IPV6
future flow label field to provide end to end QOS guarantees for voice and
video and reliable multicast delivery over the internet.  This would help
UDP RTP multicast tremendously so that I-frame does not get dropped
resulting in buffering issues pervasive and show stopper for best effort
class dscp 0 multicast over the internet.

If a QOS queuing standard does not exist today across the internet which WG
do you think the standard should fall?

I figured I would start with Detnet w/ CC to MBONE and PIM.

Another idea which is orthogonal but related to end to end Jumbo and jumbo
grams over the internet for high speed data transfers end to end.

I stated orthogonal as due to FIFO queuing serialization delays w/o
pipelining architecture QOS WRR and SP queue, voice and video would suffer
from Jumbo - understood.  However if end to end QOS was possible over the
global internet you could in theory essentially have your cake and eat it
to so to speak.  Meaning with QOS voice and video let’s say could sit in EF
and futuristic IPV6 Jumbo grams 4.2G payload bulk transfers could sit in a
separate WRR AF queue end to end across the internet for both flow types.

Kind Regards

Gyan
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: Michael McBride <[email-masked]>
Date: Tue, 28 Jul 2020 03:10:04 +0000

Hi Gyan,

Please take a quick glance at RFC 5740 (NORM) and 3208 (PGM). We had a reliable multicast transport (rmt) wg, now closed, which put out some good rfc’s (https://datatracker.ietf.org/wg/rmt/documents/) which may be a good starting point for future work. Maybe it’s time to revisit this?  Talk to you tomorrow.

mike

From: MBONED <[email-masked]> On Behalf Of Gyan Mishra
Sent: Thursday, July 23, 2020 1:27 PM
To: MBONED WG <[email-masked]>; [email-masked]; [email-masked]
Subject: [MBONED] Detnet WG charter ? “QOS and Jumbo frames” over public internet

Dear Detnet WG

+ PIM & MBONED ( As the ? relates to reliable multicast video delivery over the internet or 4G/5G RAN backhaul for reliable multicast over mobile devices as well as simultaneously massive data transfers and how to make feasible)

I was curious if Detnet as it appears relevant to the charter to provide reliable voice and video delivery over the public internet.

Their have been many white papers by universities and research institutions over the years related to how to make end to end QOS possible over the global internet.

Historically the problem has always been that all providers have their own QOS policy and its impractical to be able to come up with a standard queuing standards that all ISPs throughout the hierarchical internet must follow from Tier 1 down to the broadband carriers so that multicast can thrive on the internet.

I don’t think it’s impossible and maybe a ubiquitous standard exists exists that all providers must follow today but I am not aware of one.

The conceptual idea is that in this day and age precluding the concept of net neutrality or not as that opens up another can of worms - In theory it seems possible to have a standard way of WRR IPV4 IPV6 dscp based or IPV6 future flow label field to provide end to end QOS guarantees for voice and video and reliable multicast delivery over the internet.  This would help UDP RTP multicast tremendously so that I-frame does not get dropped resulting in buffering issues pervasive and show stopper for best effort class dscp 0 multicast over the internet.

If a QOS queuing standard does not exist today across the internet which WG do you think the standard should fall?

Another idea which is orthogonal but related to end to end Jumbo and jumbo grams over the internet for high speed data transfers end to end..

I stated orthogonal as due to FIFO queuing serialization delays w/o pipelining architecture QOS WRR and SP queue, voice and video would suffer from Jumbo - understood.  However if end to end QOS was possible over the global internet you could in theory essentially have your cake and eat it to so to speak.  Meaning with QOS voice and video let’s say could sit in EF and futuristic IPV6 Jumbo grams 4.2G payload bulk transfers could sit in a separate WRR AF queue end to end across the internet for both flow types.

Kind Regards

Gyan
--

[http://ss7.vzw.com/is/image/VerizonWireless/vz-logo-email]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C0bab63d5e18b49bafa6308d82f46e59a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637311328847561602&sdata=iVsgI1D%2BpQqEdF39uRuiCLCoEgd4l3LY31AiBISXJao%3D&reserved=0>

Gyan Mishra

Network Solutions Architect

M 301 502-1347
13101 Columbia Pike
Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Tue, 28 Jul 2020 09:12:43 -0400

I do recall PGM about 15+ years ago  a few vendor implemented it I believe
Cisco & Juniper.  I reviewed the draft for some more talking points for
today's discussion.

Thanks

Gyan

On Mon, Jul 27, 2020 at 11:10 PM Michael McBride <
[email-masked]> wrote:

> Hi Gyan,
>
>
>
> Please take a quick glance at RFC 5740 (NORM) and 3208 (PGM). We had a
> reliable multicast transport (rmt) wg, now closed, which put out some good
> rfc’s (https://datatracker.ietf.org/wg/rmt/documents/) which may be a
> good starting point for future work. Maybe it’s time to revisit this?  Talk
> to you tomorrow.
>
>
>
> mike
>
>
>
>
>
> *From:* MBONED <[email-masked]> *On Behalf Of *Gyan Mishra
> *Sent:* Thursday, July 23, 2020 1:27 PM
> *To:* MBONED WG <[email-masked]>; [email-masked]; [email-masked]
> *Subject:* [MBONED] Detnet WG charter ? “QOS and Jumbo frames” over
> public internet
>
>
>
>
>
> Dear Detnet WG
>
>
>
> + PIM & MBONED ( As the ? relates to reliable multicast video delivery
> over the internet or 4G/5G RAN backhaul for reliable multicast over mobile
> Their have been many white papers by universities and research
> institutions over the years related to how to make end to end QOS possible
> over the global internet.
>
>
>
> I don’t think it’s impossible and maybe a ubiquitous standard exists
> exists that all providers must follow today but I am not aware of one.
>
>
>
> If a QOS queuing standard does not exist today across the internet which
> WG do you think the standard should fall?
>
>
>
> grams over the internet for high speed data transfers end to end..
>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=02%7C01%7Cmichael.mcbride%40futurewei.com%7C0bab63d5e18b49bafa6308d82f46e59a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637311328847561602&sdata=iVsgI1D%2BpQqEdF39uRuiCLCoEgd4l3LY31AiBISXJao%3D&reserved=0>
>
> *Gyan Mishra*
>
> *Network Solutions Architect *
>
>
>
> *M 301 502-1347 13101 Columbia Pike  *Silver Spring, MD
>
>
>

-- 

*Gyan Mishra*