Subject: [Detnet] Robert Wilton's Discuss on draft-ietf-detnet-mpls-11: (with DISCUSS)

From: Robert Wilton via Datatracker <[email-masked]>
Date: Thu, 10 Sep 2020 03:06:59 -0700

Robert Wilton has entered the following ballot position for
draft-ietf-detnet-mpls-11: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Hi,

Thank you for this document.

Hopefully a trivial discuss to resolve ...

4.2.1.  DetNet Control Word and the DetNet Sequence Number

Does this section need to specify the initial value for the sequence number for a new flow?

Regards,
Rob

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 10 Sep 2020 11:35:15 +0100

Hi Rob,

I don’t think so.

Since the protocol is one way and the receiver needs to recover following an outage, by definitition it can cope without an expected start value, which means that the transmitter can start with any value it wants.

Best regards

Stewart

> On 10 Sep 2020, at 11:06, Robert Wilton via Datatracker <[email-masked]> wrote:
>

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 10 Sep 2020 10:54:55 +0000

Hi, exactly. No need to define initial value. Cheers Bala'zs

-----Original Message-----
From: Stewart Bryant <[email-masked]> 
Sent: Thursday, September 10, 2020 12:35 PM
To: Robert Wilton <[email-masked]>
Cc: Stewart Bryant <[email-masked]>; The IESG <[email-masked]>; [email-masked]; DetNet Chairs <[email-masked]>; DetNet WG <[email-masked]>; Ethan Grossman <[email-masked]>
Subject: Re: Robert Wilton's Discuss on draft-ietf-detnet-mpls-11: (with DISCUSS)

Hi Rob,

I don’t think so.

Best regards

Stewart

> email addresses included in the To and CC lines. (Feel free to cut 
> this introductory paragraph, however.)
> 
> 
> Please refer to 
> https://www.ietf.org/iesg/statement/discuss-criteria.html

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 10 Sep 2020 11:15:17 +0000

Hi Balazs, Stewart,

Thanks for the quick responses.

Understood that the transmitter can start with any value.  But probably it would be helpful to add a sentence to explicitly state this?

Regards,
Rob

> From: Balázs Varga A <[email-masked]>
> Sent: 10 September 2020 11:55
> To: Stewart Bryant <[email-masked]>; Rob Wilton (rwilton)
> <[email-masked]>
> Cc: The IESG <[email-masked]>; [email-masked]; DetNet
> Chairs <[email-masked]>; DetNet WG <[email-masked]>; Ethan
> Grossman <[email-masked]>
> Subject: RE: Robert Wilton's Discuss on draft-ietf-detnet-mpls-11: (with
> DISCUSS)
> 
> Cc: Stewart Bryant <[email-masked]>; The IESG <[email-masked]>;
> [email-masked]; DetNet Chairs <[email-masked]>;
> DetNet WG <[email-masked]>; Ethan Grossman <[email-masked]>
> Since the protocol is one way and the receiver needs to recover following
> an outage, by definitition it can cope without an expected start value,
> which means that the transmitter can start with any value it wants.
> 
> Best regards
> 
> Stewart
> 
>

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 10 Sep 2020 12:21:57 +0000

Hi Rob,

OK, it was added to the new version. Just now uploaded.
https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls/

Cheers
Bala'zs

-----Original Message-----
From: Rob Wilton (rwilton) <[email-masked]> 
Sent: Thursday, September 10, 2020 1:15 PM
To: Balázs Varga A <[email-masked]>; Stewart Bryant <[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; DetNet Chairs <[email-masked]>; DetNet WG <[email-masked]>; Ethan Grossman <[email-masked]>
Subject: RE: Robert Wilton's Discuss on draft-ietf-detnet-mpls-11: (with DISCUSS)

Hi Balazs, Stewart,

Regards,
Rob

> Cc: Stewart Bryant <[email-masked]>; The IESG 
> <[email-masked]>; [email-masked]; DetNet Chairs 
> <[email-masked]>; DetNet WG <[email-masked]>; Ethan Grossman 
> <[email-masked]>
> Subject: Re: Robert Wilton's Discuss on draft-ietf-detnet-mpls-11: 
> (with
> DISCUSS)
> 
> Hi Rob,
> 
> I don’t think so.
> 
> Since the protocol is one way and the receiver needs to recover 
> following an outage, by definitition it can cope without an expected 
> start value, which means that the transmitter can start with any value it wants.
> 
> Best regards
> 
> Stewart
> 
> 
> > When responding, please keep the subject line intact and reply to 
> > all email addresses included in the To and CC lines. (Feel free to 
> > cut this introductory paragraph, however.)
> >
> >
> > Please refer to

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 10 Sep 2020 12:57:39 +0000

Hi Bala'zs

Thanks for the quick update/response.

I have cleared the discuss.

Regards,
Rob

> Sent: 10 September 2020 13:22
> To: Rob Wilton (rwilton) <[email-masked]>; Stewart Bryant
> <[email-masked]>
> Understood that the transmitter can start with any value.  But probably it
> would be helpful to add a sentence to explicitly state this?
> 
> Regards,
> Rob
> 
>