Subject: [Detnet] Warren Kumari's No Objection on draft-ietf-detnet-mpls-11: (with COMMENT)

From: Warren Kumari via Datatracker <[email-masked]>
Date: Wed, 09 Sep 2020 12:43:00 -0700

Warren Kumari has entered the following ballot position for
draft-ietf-detnet-mpls-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks to Shwetha for the OpsDir review, it was helpful to me for knowing where
to focus my review.

I think it would be nice if  the document had a bit more text around the (lack
of) issues caused by: "It is important to note that this document differs from
[RFC4448]
   where a sequence number of zero (0) is used to indicate that the
   sequence number check algorithm is not used."

I had to re-read this a few times and then spend some time trying to figure out
what happens with implementations that follow RFC4448; as far as I can tell
nothing bad happens, but having an extra sentence or two reassuring readers of
this would be nice.

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 10 Sep 2020 08:04:28 +0000

Hi Warren,

Many thanks for your review. Regarding your comment:
- PEF (packet elimination function) and POF (packet ordering function) functions expect a 
sequence number space/format as defined in draft-ietf-detnet-mpls. When an edge node 
adds sequence numbers to a DetNet flow according to an implementation that follows 
RFC4448, they may not work properly. 
PEF and POF will recognize (badly) that a packet is missing from the flow (there is a "jump" 
in the sequence number). Actual impact depends on the network scenario, flow 
characteristics, application characteristics, etc.

This is why the note was added.

Thanks & Cheers
Bala'zs

-----Original Message-----
From: Warren Kumari via Datatracker <[email-masked]> 
Sent: Wednesday, September 9, 2020 9:43 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Ethan Grossman <[email-masked]>; [email-masked]; [email-masked]
Subject: Warren Kumari's No Objection on draft-ietf-detnet-mpls-11: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Thanks to Shwetha for the OpsDir review, it was helpful to me for knowing where to focus my review.

I think it would be nice if  the document had a bit more text around the (lack
of) issues caused by: "It is important to note that this document differs from [RFC4448]
   where a sequence number of zero (0) is used to indicate that the
   sequence number check algorithm is not used."

I had to re-read this a few times and then spend some time trying to figure out what happens with implementations that follow RFC4448; as far as I can tell nothing bad happens, but having an extra sentence or two reassuring readers of this would be nice.