Subject: [Detnet] Secdir last call review of draft-ietf-detnet-mpls-over-udp-ip-06

From: Stephen Farrell via Datatracker <[email-masked]>
Date: Thu, 24 Sep 2020 11:15:06 -0700

Reviewer: Stephen Farrell
Review result: Ready

(Sorry for the missed review deadline.)

Other than general doubts about "I'll only use this in one administrative
domain", the only specific thing that concerned me here was that
draft-ietf-detnet-security doesn't seem to include any analysis of detnet/UDP
(and indeed says that detnet runs over IP) and the security considerations
section here is purely by reference. Given that draft-ietf-detnet-security
seems to have done a reasonable job of analysis, it's a pity to not have that
for the detnet/UDP case. All that said, I don't have any concrete problems to
highlight with detnet/UDP, though of course I've not been thinking about this
as $dayjob, so there may be issues there.

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Thu, 24 Sep 2020 20:28:19 +0000

Thanks Stephen. FWIW it isn't too late to add some text to the DetNet Security draft regarding DetNet over UDP, if someone can think up something useful to say. I suppose one could simply mention UDP in the same breath as TCP (implying that the same general security guidelines apply, if that's our stance). 
Any thoughts (from anyone)? 
Thanks,
Ethan (as Editor, DetNet Security draft)

-----Original Message-----
From: detnet <[email-masked]> On Behalf Of Stephen Farrell via Datatracker
Sent: Thursday, September 24, 2020 11:15 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Detnet] Secdir last call review of draft-ietf-detnet-mpls-over-udp-ip-06

Other than general doubts about "I'll only use this in one administrative domain", the only specific thing that concerned me here was that draft-ietf-detnet-security doesn't seem to include any analysis of detnet/UDP (and indeed says that detnet runs over IP) and the security considerations section here is purely by reference. Given that draft-ietf-detnet-security seems to have done a reasonable job of analysis, it's a pity to not have that for the detnet/UDP case. All that said, I don't have any concrete problems to highlight with detnet/UDP, though of course I've not been thinking about this as $dayjob, so there may be issues there.

_______________________________________________
detnet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet