Subject: Re: [Detnet] [Raw] WG adoption poll on draft-mirsky-detnet-ip-oam-03

From: Rick Taylor <[email-masked]>
Date: Fri, 11 Sep 2020 12:58:10 +0000

Hi Greg,

At the IETF-108 there was rough consensus in the room for the split/merge of the OAM documents into DetNet-generic and RAW-specific drafts.

The chairs have been slow in asking for official confirmation on the list, for which I apologise, but here it is:

WG: Do you have any objections to the room-consensus from IETF-108 for the OAM document re-organisation.  Please raise your objections quickly, as silence will be regarded as agreement.

Cheers,

Rick

From: RAW [mailto:[email-masked]] On Behalf Of Greg Mirsky
Sent: 31 August 2020 20:40
To: Pascal Thubert (pthubert)
Cc: Janos Farkas; DetNet WG; [email-masked]; [email-masked]
Subject: Re: [Raw] [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03

Hi Pascal,
thank you for your suggestions. I'll apply the editorial fix in the next update of the draft, hope that is acceptable.
We've discussed your suggestions with the authors draft-theoleyre-raw-oam-support.  Perhaps it might be more appropriate to discuss these topics in the new draft that Lou has recommended at the RAW WG meeting. The work has already started and we are planning to share the first version before IETF-109. Do you think that this is a reasonable approach?
I've added my answers, notes below in-line under GIM>> tag.

Kind regards,
Greg

On Thu, Aug 27, 2020 at 12:43 AM Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Hello Greg:

Please find some review comments below

P4, 1st sentence: Nit; “specified” -> “is specified”

P4 section 3.1: We need to discuss the attack vector whereby the attacker would flood the DetNet Path with forged OAM and consume the available bandwidth
GIM>> Such a scenario is more likely applicable to DetNet in general. If you agree, it will be considered in the new document that describes OAM in DetNet.

P4 section 3.2: We need to elaborate on the OAM behavior if there is a replication point. Also, how it plays with coding.
GIM>> I think that DetNet WG decided that PREOF is supported only in DetNet with MPLS data plane. I agree with you, the document that defines OAM functions specific to PREOF is required.

P5 Section 3: Suggestion to add 2 subsections,

  *   One on the 6TiSCH model that is echoed in the the personal sub of RAW architecture, see https://tools.ietf.org/html/draft-pthubert-raw-architecture-04#section-7, in particular section 7.3.
GIM>> Thank you for your recommendation, will address this topic in the new draft.

  *
  *   One on IPPM and iOAM where the measurement fields are in the packet header, inserted by the source (or encapsulator)
GIM>> Thank you for this question! We will certainly discuss the applicability of the methods to collect on-path telemetry information and transport it for processing in the new DetNet OAM draft (and will add a section on specifics of RAW to draft-theoleyre-raw-oam-support).

  *

Take care,

Pascal

From: detnet <[email-masked]<mailto:[email-masked]>> On Behalf Of Greg Mirsky
Sent: lundi 17 août 2020 01:04
To: Janos Farkas <Janos.Farkas=[email-masked]<mailto:[email-masked]>>
Cc: DetNet WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03

Hi Janos, Lou, et al.,
yes/support adoption as the co-author of the draft.
The draft is on the Informational track as the authors don't see the need to define any new mechanism for OAM in DetNet over IP.

Regards,
Greg

On Fri, Aug 14, 2020 at 8:50 AM Janos Farkas <Janos.Farkas=[email-masked]<mailto:[email-masked]>> wrote:
Hi,

This is start of a three week poll on making
draft-mirsky-detnet-ip-oam-03 a working group document. Please
send email to the list indicating "yes/support" or "no/do not
support".  If indicating no, please state your reservations with the
document.  If yes, please also feel free to provide comments you'd
like to see addressed once the document is a WG document.

The poll ends September 4.

Regards,
Janos and Lou
_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 11 Sep 2020 08:23:37 -0700

Hi Rick,
thank you for the question. The authors of draft-theoleyre-raw-oam-support
are working according to the recommendation the WG expressed at the
IETF-108 meeting. We expect that the new draft in DetNet WG and the updated
document on specifics of OAM in the RAW environment will be ready for
discussions in October.

Regards,
Greg

On Fri, Sep 11, 2020 at 5:58 AM Rick Taylor <[email-masked]>
wrote:

> Hi Greg,
>
>
>
> At the IETF-108 there was rough consensus in the room for the split/merge
> of the OAM documents into DetNet-generic and RAW-specific drafts.
>
>
>
> WG: Do you have any objections to the room-consensus from IETF-108 for the
> OAM document re-organisation.  Please raise your objections quickly, as
> silence will be regarded as agreement.
>
>
>
> Cheers,
>
>
>
> Rick
>
>
>
> *From:* RAW [mailto:[email-masked]] *On Behalf Of *Greg Mirsky
> *Sent:* 31 August 2020 20:40
> *To:* Pascal Thubert (pthubert)
> *Cc:* Janos Farkas; DetNet WG; [email-masked];
> [email-masked]
> *Subject:* Re: [Raw] [Detnet] WG adoption poll on
> draft-mirsky-detnet-ip-oam-03
>
>
>
> Hi Pascal,
>
> thank you for your suggestions. I'll apply the editorial fix in the next
> update of the draft, hope that is acceptable.
>
> We've discussed your suggestions with the
> authors draft-theoleyre-raw-oam-support.  Perhaps it might be more
> appropriate to discuss these topics in the new draft that Lou has
> recommended at the RAW WG meeting. The work has already started and we are
> planning to share the first version before IETF-109. Do you think that
> this is a reasonable approach?
>
> On Thu, Aug 27, 2020 at 12:43 AM Pascal Thubert (pthubert) <
> [email-masked]> wrote:
>
> Hello Greg:
>
>
>
> P4 section 3.1: We need to discuss the attack vector whereby the attacker
> would flood the DetNet Path with forged OAM and consume the available
> bandwidth
>
> GIM>> Such a scenario is more likely applicable to DetNet in general. If
> you agree, it will be considered in the new document that describes OAM in
> DetNet.
>
>
>
> P4 section 3.2: We need to elaborate on the OAM behavior if there is a
> replication point. Also, how it plays with coding.
>
> GIM>> I think that DetNet WG decided that PREOF is supported only in
> DetNet with MPLS data plane. I agree with you, the document that defines
> OAM functions specific to PREOF is required.
>
>
>
>    - One on the 6TiSCH model that is echoed in the the personal sub of
>    RAW architecture, see
>    https://tools.ietf.org/html/draft-pthubert-raw-architecture-04#section-7,
>    in particular section 7.3.
>
>    -
>    - One on IPPM and iOAM where the measurement fields are in the packet
>    header, inserted by the source (or encapsulator)
>
> GIM>> Thank you for this question! We will certainly discuss the
> applicability of the methods to collect on-path telemetry information and
> transport it for processing in the new DetNet OAM draft (and will add a
> section on specifics of RAW to draft-theoleyre-raw-oam-support).
>
>
>    -
>
>
>
> Take care,
>
>
>
> Pascal
>
>
>
> *From:* detnet <[email-masked]> *On Behalf Of *Greg Mirsky
> *Sent:* lundi 17 août 2020 01:04
> *To:* Janos Farkas <Janos.Farkas=[email-masked]>
> *Cc:* DetNet WG <[email-masked]>
> *Subject:* Re: [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03
>
>
>
> Hi Janos, Lou, et al.,
>
> The draft is on the Informational track as the authors don't see the need
> to define any new mechanism for OAM in DetNet over IP.
>
>
>
> Regards,
>
> Greg
>
>
>
> On Fri, Aug 14, 2020 at 8:50 AM Janos Farkas <Janos.Farkas=
> [email-masked]> wrote:
>
> Hi,
>
>
>
> [email-masked]

---

From: Fabrice Theoleyre <[email-masked]>
Date: Fri, 11 Sep 2020 20:17:05 +0200

Dear all, 

Now, the novel RAW draft addresses only wireless challenges, while the detnet draft only focuses on the generic aspects.
Our objective is to reach something stable at the end of the month. 

Regards,
Fabrice

> Le 11 sept. 2020 à 17:23, Greg Mirsky <[email-masked]> a écrit :
> 
> Hi Rick,
> thank you for the question. The authors of draft-theoleyre-raw-oam-support are working according to the recommendation the WG expressed at the IETF-108 meeting. We expect that the new draft in DetNet WG and the updated document on specifics of OAM in the RAW environment will be ready for discussions in October.
> 
> Regards,
> Greg
> 
> On Fri, Sep 11, 2020 at 5:58 AM Rick Taylor <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Greg,
> 
>  
> 
> From: RAW [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Greg Mirsky
> Cc: Janos Farkas; DetNet WG; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> On Thu, Aug 27, 2020 at 12:43 AM Pascal Thubert (pthubert) <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Hello Greg:
> 
>  
> 
> One on the 6TiSCH model that is echoed in the the personal sub of RAW architecture, see https://tools.ietf.org/html/draft-pthubert-raw-architecture-04#section-7 <https://tools.ietf.org/html/draft-pthubert-raw-architecture-04#section-7>, in particular section 7.3.
> One on IPPM and iOAM where the measurement fields are in the packet header, inserted by the source (or encapsulator)
> From: detnet <[email-masked] <mailto:[email-masked]>> On Behalf Of Greg Mirsky
> To: Janos Farkas <Janos.Farkas=[email-masked] <mailto:[email-masked]>>
> Cc: DetNet WG <[email-masked] <mailto:[email-masked]>>
> On Fri, Aug 14, 2020 at 8:50 AM Janos Farkas <Janos.Farkas=[email-masked] <mailto:[email-masked]>> wrote:
> 
> Hi,
> 
>  
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/detnet <https://www.ietf.org/mailman/listinfo/detnet>

---

From: Janos Farkas <[email-masked]>
Date: Fri, 18 Sep 2020 12:51:39 +0000

Hi,

The adoption call is complete.  As always, adoption is a starting point for the solution that the WG will develop on this topic, and normal working group processing of this documents will now commence.

Authors,
Please repost the document as a 00 version, with only the file name and publication date changed.  The file name should  be in the form draft-ietf-detnet-<current-name>.

Please then address the comments received in a follow-up 01 version.

Thank you,
Janos and Lou

From: detnet <[email-masked]> On Behalf Of Janos Farkas
Sent: Friday, August 14, 2020 5:50 PM
To: DetNet WG <[email-masked]>
Subject: [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03

Hi,

Regards,
Janos and Lou