Subject: [Detnet] Alvaro Retana's No Objection on draft-ietf-detnet-ip-over-mpls-07: (with COMMENT)

From: Alvaro Retana via Datatracker <[email-masked]>
Date: Tue, 08 Sep 2020 15:40:11 -0700

Alvaro Retana has entered the following ballot position for
draft-ietf-detnet-ip-over-mpls-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-detnet-ip-over-mpls/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

(1) I may have completely missed the point of this document; what is it?  More
importantly, what is this document specifying?  Why is it on the Standards
Track?

As I see it, this document says that IP flows can be carried over MPLS -- ok,
specifically over DetNet MPLS.  The mapping of IP flows to an MPLS LSP is no
different in DetNet MPLS when compared to "plain" MPLS...nor is it different
for IP vs DetNet IP flows -- from §4.2:

   Mapping of IP to DetNet MPLS is similar for DetNet IP flows and IP
   flows.  The six-tuple of IP is mapped to the S-Label in both cases.
   The various fields may be mapped or ignored when going from IP to
   MPLS.

At best, it seems to me that this document could be Informational.

(2) It looks like this document should be tagged in the Datatracker as (also)
replacing draft-ietf-detnet-dp-sol-ip.

(3) s/both Non-DetNet and DetNet IP packet/both Non-DetNet and DetNet IP packets

---

From: Balázs Varga A <[email-masked]>
Date: Wed, 9 Sep 2020 12:50:11 +0000

Hi Alvaro,

Many thanks for your review. Regarding:
(1) Yes, there are similarities on high level. However, the main differences of mapping to DetNet MPLS (compared to plain MPLS) are that (1) there is a mandatory flow identification (and not the FEC), (2) the d-CW (DetNet Control Word) is mandatory and (3) DetNet specific treatment is needed.
(2) draft-ietf-detnet-dp-sol-ip was replaced primarly by draft-ietf-detnet-ip. But, I see your point, this draft is also related.
(3) Thanks. Corrected.

Thanks & Cheers
Bala'zs

-----Original Message-----
From: Alvaro Retana via Datatracker <[email-masked]> 
Sent: Wednesday, September 9, 2020 12:40 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Ethan Grossman <[email-masked]>
Subject: Alvaro Retana's No Objection on draft-ietf-detnet-ip-over-mpls-07: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

(1) I may have completely missed the point of this document; what is it?  More importantly, what is this document specifying?  Why is it on the Standards Track?

As I see it, this document says that IP flows can be carried over MPLS -- ok, specifically over DetNet MPLS.  The mapping of IP flows to an MPLS LSP is no different in DetNet MPLS when compared to "plain" MPLS...nor is it different for IP vs DetNet IP flows -- from §4.2:

(2) It looks like this document should be tagged in the Datatracker as (also) replacing draft-ietf-detnet-dp-sol-ip.

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 17 Sep 2020 07:39:24 -0700

Bala’zs:

Hi!

Thanks for your reply…but I am still missing the details of what is
specified.  The mandatory points you mention are detailed in the
detnet-mpls document, and I see no explicit procedures on how to do the
mapping, except for the general phrase: "DetNet IP flow over a DetNet MPLS
network MUST map a DetNet IP flow”.

IOW, no specifics of a “take this field and map it there”-type are present.

In any case, these comments are non-blocking…and I defer to Deborah to make
the right decision.

Thanks!

Alvaro.

On September 9, 2020 at 8:50:12 AM, Balázs Varga A (
[email-masked]) wrote:

Hi Alvaro,

Many thanks for your review. Regarding:
(1) Yes, there are similarities on high level. However, the main
differences of mapping to DetNet MPLS (compared to plain MPLS) are that (1)
there is a mandatory flow identification (and not the FEC), (2) the d-CW
(DetNet Control Word) is mandatory and (3) DetNet specific treatment is
needed.
(2) draft-ietf-detnet-dp-sol-ip was replaced primarly by
draft-ietf-detnet-ip. But, I see your point, this draft is also related.
(3) Thanks. Corrected.

Thanks & Cheers
Bala'zs

-----Original Message-----
From: Alvaro Retana via Datatracker <[email-masked]>
Sent: Wednesday, September 9, 2020 12:40 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked];
[email-masked]; Ethan Grossman <[email-masked]>
Subject: Alvaro Retana's No Objection on draft-ietf-detnet-ip-over-mpls-07:
(with COMMENT)

When responding, please keep the subject line intact and reply to all email
addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

(1) I may have completely missed the point of this document; what is it?
More importantly, what is this document specifying? Why is it on the
Standards Track?

As I see it, this document says that IP flows can be carried over MPLS --
ok, specifically over DetNet MPLS. The mapping of IP flows to an MPLS LSP
is no different in DetNet MPLS when compared to "plain" MPLS...nor is it
different for IP vs DetNet IP flows -- from §4.2:

(2) It looks like this document should be tagged in the Datatracker as
(also) replacing draft-ietf-detnet-dp-sol-ip.

(3) s/both Non-DetNet and DetNet IP packet/both Non-DetNet and DetNet IP
packets

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Fri, 18 Sep 2020 21:51:17 +0000

Thanks Alvaro and Ben for all your comments to help improve -
The author team (and I) will work on improving the text – especially the procedures so as to be clear what is needed. PW/MPLS has many variations – all looking alike on “the MPLS wire”. For the solution, that was the goal, to “look like MPLS”. It seems we were not clear on which variation this one needs to get on/off the wire.

Good weekends-
Deborah

From: detnet <[email-masked]> On Behalf Of Alvaro Retana
Sent: Thursday, September 17, 2020 10:39 AM
To: The IESG <[email-masked]>; Balázs Varga A <[email-masked]>
Cc: Ethan Grossman <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Detnet] Alvaro Retana's No Objection on draft-ietf-detnet-ip-over-mpls-07: (with COMMENT)

Bala’zs:

Hi!

Thanks for your reply…but I am still missing the details of what is specified.  The mandatory points you mention are detailed in the detnet-mpls document, and I see no explicit procedures on how to do the mapping, except for the general phrase: "DetNet IP flow over a DetNet MPLS network MUST map a DetNet IP flow”.

In any case, these comments are non-blocking…and I defer to Deborah to make the right decision.

Thanks!

Alvaro.

On September 9, 2020 at 8:50:12 AM, Balázs Varga A ([email-masked]<mailto:[email-masked]>) wrote:
Hi Alvaro,

Thanks & Cheers
Bala'zs

-----Original Message-----
From: Alvaro Retana via Datatracker <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, September 9, 2020 12:40 AM
To: The IESG <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Ethan Grossman <[email-masked]<mailto:[email-masked]>>
Subject: Alvaro Retana's No Objection on draft-ietf-detnet-ip-over-mpls-07: (with COMMENT)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_iesg_statement_discuss-2Dcriteria.html&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=W1Io_KlHfpqjIXG9lzVTh89Bc738dmJ_cReMZjGjVVQ&s=1vpFvNdc2xS4th7vUO1Q591WwM0RUxoHDh9wExKiu1M&e=>
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-detnet-ip-over-mpls/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Ddetnet-2Dip-2Dover-2Dmpls_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=W1Io_KlHfpqjIXG9lzVTh89Bc738dmJ_cReMZjGjVVQ&s=ZJMB2xn1DnKnGa947Og9G22_a2xOU426KxGO5tg0jLA&e=>