Subject: [Detnet] Murray Kucherawy's No Objection on draft-ietf-detnet-security-13: (with COMMENT)

From: Murray Kucherawy via Datatracker <[email-masked]>
Date: Tue, 05 Jan 2021 23:52:50 -0800

Murray Kucherawy has entered the following ballot position for
draft-ietf-detnet-security-13: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-detnet-security/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I found this to be an interesting read.  Once you mentioned aircraft internals,
I was even more into it.

This text in the Abstract caught my eye:

   This document also addresses security considerations specific to the
   IP and MPLS data plane technologies, thereby complementing the
   Security Considerations sections of those documents.

It almost seems appropriate for this one to formally update those if indeed
they were left incomplete.  I realize, however, that's not possible for an
Informational document if the others are Standards Track.

Besides that, some nits:

Section 8.1.8: s/coexistance/coexistence/

In Section 8.1.11, there's an instance of DETNET in all-caps, while it's
"DetNet" everywhere else.

Section 8.1.22, a suggestion:

OLD:

   [...] A strategy used by DetNet
   for providing such extraordinarily high levels of reliability is to
   provide redundant paths that can be seamlessly switched between, all
   the while maintaining the required performance of that system.

NEW:

   [...] A strategy used by DetNet
   for providing such extraordinarily high levels of reliability is to
   provide redundant paths between which traffic can be seamlessly
   switched, all the while maintaining the required performance of that system.

---

From: "Ethan Grossman" <[email-masked]>
Date: Wed, 6 Jan 2021 16:24:28 -0800

Hi Murray,
Thank you for your review, we will incorporate all of your comments as written into the next draft version. 
And yes, this draft is informational whereas the IP and MPLS data plane drafts are both standards track. 
Sincerely,
Ethan (as DetNet Security draft editor)

-----Original Message-----
From: Murray Kucherawy via Datatracker <[email-masked]> 
Sent: Tuesday, January 5, 2021 11:53 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Lou Berger <[email-masked]>
Subject: Murray Kucherawy's No Objection on draft-ietf-detnet-security-13: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

I found this to be an interesting read.  Once you mentioned aircraft internals, I was even more into it.

It almost seems appropriate for this one to formally update those if indeed they were left incomplete.  I realize, however, that's not possible for an Informational document if the others are Standards Track.

Besides that, some nits:

In Section 8.1.11, there's an instance of DETNET in all-caps, while it's "DetNet" everywhere else.

OLD:

NEW: