Subject: Re: [Detnet] Work on 'control plane signaling'

From: Balázs Varga A <[email-masked]>
Date: Tue, 2 Feb 2021 16:53:52 +0000

Hi,

Some possible improvement points for the next version:
1, Fixing terminology:
Current version contains some new terminology. It would be worth to use the already
exiting terminology of DetNet if appropriate and define new term if really needed.

2, Narrowing the scope of the draft:
I think adding a scenario description and a related figure is inevitable. You may consider
a figure similar to Figure 2 in rfc8964 or Figure 1 in draft-ietf-detnet-mpls-over-tsn-05.
Starting with a well-defined scenario could be a good starting point to increase the scope
in later versions. Furthermore it could put in context the current Figure 2. in
draft-trossen-detnet-control-signaling-00.

3, Defining the functionalities / capabilities per DetNet and/or TSN entity:
If a figure is added it is more easy to refer e.g., the signaling protocol peers (both internal
and external ones), signaling domain borders, etc.

Cheers
Bala'zs

From: detnet <[email-masked]> On Behalf Of Dirk Trossen
Sent: Tuesday, December 15, 2020 4:54 PM
To: DetNet WG <[email-masked]>
Subject: [Detnet] Work on 'control plane signaling'

All,

many thanks for the great discussion during last week's interim on our plans to progress the 'control plane signaling' draft.

As we tried to outline in our revised structure (for the next draft update), our intention is to specify the required distributed end-to-end signaling for deterministic networking scenarios, not relying on managed, e.g., centralized, TE methods. With this in mind, we see the combination of RSVP-TE aspects and the interaction between RSVP at L3 and L2 solutions as the core of our contribution, labeled as 'RSVP-detnet' in our slide material. From this perspective, TSN is just one example for said L2 solutions.

Another possible route forward could be to narrow the discussion (and contribution) purely to the L3/L2 interactions between RSVP and specific L2 technologies, such as RAP (for TSN) - this route would lead then to something one could label as 'RSVP-tsn'.

We would like to seek your comments and thoughts on those possible routes. If anybody is interested in joining the efforts, please do let us know.

Best,

Dirk, on behalf of the draft authors

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 2 Feb 2021 16:59:10 +0000

Hi Bala'zs,

Many thanks for those comments which come almost shockingly in time when I'm doing the edit for the next version.

We will try to address those and would much appreciate further comments when the next revision will come out.

Best,

Dirk

From: detnet [mailto:[email-masked]] On Behalf Of Balázs Varga A
Sent: 02 February 2021 17:54
To: DetNet WG <[email-masked]>
Subject: Re: [Detnet] Work on 'control plane signaling'

Hi,

Cheers
Bala'zs

From: detnet <[email-masked]<mailto:[email-masked]>> On Behalf Of Dirk Trossen
Sent: Tuesday, December 15, 2020 4:54 PM
To: DetNet WG <[email-masked]<mailto:[email-masked]>>
Subject: [Detnet] Work on 'control plane signaling'

All,

Best,