Subject: [Detnet] Murray Kucherawy's No Objection on draft-ietf-detnet-mpls-over-tsn-06: (with COMMENT)

From: Murray Kucherawy via Datatracker <[email-masked]>
Date: Wed, 17 Feb 2021 22:12:51 -0800

Murray Kucherawy has entered the following ballot position for
draft-ietf-detnet-mpls-over-tsn-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls-over-tsn/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

This document is "MPLS over IEEE 802.1 Time-Sensitive Networking".  Also on
this telechat: "IEEE 802.1 Time Sensitive Networking over MPLS".  I wonder if
one is just the inverse of the other.

I concur with Alvaro's statement about the IEEE references being normative.

In Section 2.2, "CW" is defined, but the term used in the document is actually
"d-CW".  The terms "DF", "LSR", "PE", "S-PE", and "T-PE" are defined but not
used anywhere.

In Section 4, I can't parse this sentence: "All these functions have to
identify flows those require TSN treatment (i.e., applying TSN functions during
forwarding)."

Section 6 says: "Therefore, it is important that the interface between DetNet
nodes and TSN sub-network are subject to authorization, authentication, and
encryption."  Would references to documents describing those specific TSN
capabilities be useful here?  I'm not sure if those are covered by the
referenced TSN documents.

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 18 Feb 2021 10:36:38 +0000

Hi Murray,

Many thanks for your review. Proposed fixing inline.

Thanks
Bala'zs

-----Original Message-----
From: Murray Kucherawy via Datatracker <[email-masked]> 
Sent: Thursday, February 18, 2021 7:13 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Lou Berger <[email-masked]>
Subject: Murray Kucherawy's No Objection on draft-ietf-detnet-mpls-over-tsn-06: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

This document is "MPLS over IEEE 802.1 Time-Sensitive Networking".  Also on this telechat: "IEEE 802.1 Time Sensitive Networking over MPLS".  I wonder if one is just the inverse of the other.

<Bala'zs> OK.

In Section 2.2, "CW" is defined, but the term used in the document is actually "d-CW".  The terms "DF", "LSR", "PE", "S-PE", and "T-PE" are defined but not used anywhere.

<Bala'zs> Thanks I will fix these.

In Section 4, I can't parse this sentence: "All these functions have to identify flows those require TSN treatment (i.e., applying TSN functions during forwarding)."

<Bala'zs> "These functions" means the TSN functionalities defined in IEEE 802.1. TSN functionalities have to be able to select which frames belong to TSN Streams.

Section 6 says: "Therefore, it is important that the interface between DetNet nodes and TSN sub-network are subject to authorization, authentication, and encryption."  Would references to documents describing those specific TSN capabilities be useful here?  I'm not sure if those are covered by the referenced TSN documents.

<Bala'zs> OK. There are no extra security functionalities defined for TSN Streams. TSN leverages the traffic control and security standards specified by IEEE 802.1. Please see https://1.ieee802.org/security/ for further details.