Subject: [Detnet] Alvaro Retana's No Objection on draft-ietf-detnet-tsn-vpn-over-mpls-06: (with COMMENT)

From: Alvaro Retana via Datatracker <[email-masked]>
Date: Tue, 16 Feb 2021 07:10:53 -0800

Alvaro Retana has entered the following ballot position for
draft-ietf-detnet-tsn-vpn-over-mpls-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-detnet-tsn-vpn-over-mpls/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

The following references should be Normative: I-D.ietf-detnet-security,
IEEE8021CB, IEEE8021Q, IEEEP8021CBdb, RFC8655 and RFC8938.

Some of these references describe TSN, an understanding which is required to
execute normative actions.  Others represent the architecture, framework, and
security considerations for DetNet -- note that other data plane documents use
them normatively as well.

---

From: Balázs Varga A <[email-masked]>
Date: Wed, 17 Feb 2021 13:23:54 +0000

Hi Alvaro,

Many thanks for your review.

I have lots of sympathy with your comment regarding normative references.
That was our starting point as well, when the draft was crafted. It was followed 
by discussions regarding what references should be normative. 
The conclusion was to have references as normative only if there are explicit 
normative statements in the text, so these references were kept informative.

Cheers
Bala'zs

-----Original Message-----
From: Alvaro Retana via Datatracker <[email-masked]> 
Sent: Tuesday, February 16, 2021 4:11 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Lou Berger <[email-masked]>
Subject: Alvaro Retana's No Objection on draft-ietf-detnet-tsn-vpn-over-mpls-06: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

The following references should be Normative: I-D.ietf-detnet-security, IEEE8021CB, IEEE8021Q, IEEEP8021CBdb, RFC8655 and RFC8938.

Some of these references describe TSN, an understanding which is required to execute normative actions.  Others represent the architecture, framework, and security considerations for DetNet -- note that other data plane documents use them normatively as well.

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 17 Feb 2021 08:03:42 -0800

Balazs:

Hi!  How are you?

That is not the criteria that should be used, please take a look at this:
https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/

BTW, one of the reasons I made this comment is because the already approved
Data Plane documents do include these references as Normative.  In any
case, I trust you and the AD to address this consistently.

Thanks!

Alvaro.

On February 17, 2021 at 8:23:56 AM, Balázs Varga A (
[email-masked]) wrote:

I have lots of sympathy with your comment regarding normative references.
That was our starting point as well, when the draft was crafted. It was
followed
by discussions regarding what references should be normative.
The conclusion was to have references as normative only if there are
explicit
normative statements in the text, so these references were kept informative.