Subject: [Detnet] Tsvart last call review of draft-ietf-detnet-mpls-over-tsn-05

From: Kyle Rose via Datatracker <[email-masked]>
Date: Mon, 01 Feb 2021 08:53:15 -0800

Reviewer: Kyle Rose
Review result: Ready with Nits

This document has been reviewed as part of the transport area review team's
ongoing effort to review key IETF documents. These comments were written
primarily for the transport area directors, but are copied to the document's
authors and WG to allow them to address any issues raised and also to the IETF
discussion list for information.

When done at the time of IETF Last Call, the authors should consider this
review as part of the last-call comments they receive. Please always CC
[email-masked] if you reply to or forward this review.

This document is ready with nits.

At a high level, the document describes the relationship between DetNet flows
and the underlying layer 2 network when that network is an IEEE time-sensitive
network, which is interesting because both DetNet and TSN require explicit
routing and resource allocation at different layers.

Two nits:

1. There are numerous and often significant grammatical errors throughout the
document. The working group should perform a scrub of the text to minimize
editorial load on the RFC Editor.

2. Informational documents containing (lowercase, non-authoritative) normative
language should provide clear references to corresponding normative sources for
all such statements. Ideally, to minimize future document updates, replicating
such language in non-authoritative documents is not advisable. That said, you
should consider whether this document is really informational or should instead
be standards-track.

---

From: Balázs Varga A <[email-masked]>
Date: Mon, 8 Feb 2021 20:45:17 +0000

Hi Kyle,
Many thanks for your review. I will consult with the native speaker co-authors to increase grammatical readiness.
Informational vs. standard track was discussed in the WG and concluded to have this document as informational.
Thanks
Bala'zs

-----Original Message-----
From: Kyle Rose via Datatracker <[email-masked]> 
Sent: Monday, February 1, 2021 5:53 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Tsvart last call review of draft-ietf-detnet-mpls-over-tsn-05

Reviewer: Kyle Rose

This document has been reviewed as part of the transport area review team's ongoing effort to review key IETF documents. These comments were written primarily for the transport area directors, but are copied to the document's authors and WG to allow them to address any issues raised and also to the IETF discussion list for information.

When done at the time of IETF Last Call, the authors should consider this review as part of the last-call comments they receive. Please always CC [email-masked] if you reply to or forward this review.

At a high level, the document describes the relationship between DetNet flows and the underlying layer 2 network when that network is an IEEE time-sensitive network, which is interesting because both DetNet and TSN require explicit routing and resource allocation at different layers.

Two nits:

1. There are numerous and often significant grammatical errors throughout the document. The working group should perform a scrub of the text to minimize editorial load on the RFC Editor.

2. Informational documents containing (lowercase, non-authoritative) normative language should provide clear references to corresponding normative sources for all such statements. Ideally, to minimize future document updates, replicating such language in non-authoritative documents is not advisable. That said, you should consider whether this document is really informational or should instead be standards-track.