Subject: [Detnet] Packet Ordering Function (draft-varga-detnet-pof-00.txt)

From: Balázs Varga A <[email-masked]>
Date: Tue, 20 Apr 2021 05:38:49 +0000

Hi,

A draft on Packet Ordering Function (POF) algorithms were uploaded.
Comments and views are highly appreciated.

Thanks
Bala'zs (and the authors)

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Tuesday, April 20, 2021 7:14 AM
To: Balázs Varga A <[email-masked]>; Janos Farkas <[email-masked]>; Balázs Varga A <[email-masked]>; Janos Farkas <[email-masked]>; Stephan Kehrer <[email-masked]>; Stephan Kehrer <[email-masked]>; Tobias Heer <[email-masked]>; Tobias Heer <[email-masked]>
Subject: New Version Notification for draft-varga-detnet-pof-00.txt

A new version of I-D, draft-varga-detnet-pof-00.txt has been successfully submitted by =?utf-8?q?Bal=C3=A1zs_Varga?= and posted to the IETF repository.

Name:		draft-varga-detnet-pof
Revision:	00
Title:		Deterministic Networking (DetNet): Packet Ordering Function
Document date:	2021-04-19
Group:		Individual Submission
Pages:		10
URL:            https://www.ietf.org/archive/id/draft-varga-detnet-pof-00.txt
Status:         https://datatracker.ietf.org/doc/draft-varga-detnet-pof/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-varga-detnet-pof
Htmlized:       https://tools.ietf.org/html/draft-varga-detnet-pof-00

Abstract:
   Replication and Elimination functions of DetNet [RFC8655] may result
   in out-of-order packets, which may not be acceptable for some time-
   sensitive applications.  The Packet Ordering Function (POF) algorithm
   described herein enables to restore the correct packet order when
   replication and elimination functions are used in DetNet networks.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Mohammadpour Ehsan <[email-masked]>
Date: Tue, 20 Apr 2021 10:02:04 +0000

Hello Balàzs,

Thanks for starting a draft of POF. While reading the algorithm, I saw the parameter “POFTakeAnyTime”, where a received packet is forwarded  after no packet was received packet for the duration POFTakeAnyTime. 

I wonder about the need of this parameter. Can’t the POF function and algorithm work only with “POFMaxDelay”, since a packet is stored at the latest for POFMaxDelay? 
As written in the draft, POFTakeAnyTime must by larger than POFMaxDelay. Also at the POF point, it should incorporate the interspacing between the packets that might change significantly inside the network (comparing to source) due to the queuing delays and delay variations among the paths.

Best,
Ehsan

> On 20 Apr 2021, at 07:38, Balázs Varga A <balazs.a.varga=[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 20 Apr 2021 13:01:47 +0000

Hi Ehsan,

Thanks for the comment. Right, “POFTakeAnyTime” has a special role.
It does not impact POF under normal circumstances. “POFTakeAnyTime”
allows to deal with some failure scenarios affecting the state of the POF
functionality. For example, when all paths of member flows fail for a while.

Cheers
Bala'zs

-----Original Message-----
From: Mohammadpour Ehsan <ehsan.mohammadpour=[email-masked]> 
Sent: Tuesday, April 20, 2021 12:02 PM
To: Balázs Varga A <[email-masked]>
Cc: [email-masked]
Subject: Re: [Detnet] Packet Ordering Function (draft-varga-detnet-pof-00.txt)

Hello Balàzs,

Best,
Ehsan

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 23 Apr 2021 18:03:52 -0700

Hi Balazs,
thank you for the well-designed mechanism of one of the key DetNet
functions.
I have a scenario and would appreciate your consideration if you think it
is a plausible one:

   - assume that POFLastSent = 100
   - a packet with seq_num = 103 is received and placed into the buffer for
   the duration of POFMaxDelay
   - next received packet has seq_num = 102. It is also moved into the
   buffer for the duration of POFMaxDelay
   - finally, before all delayed packets transmitted out of the buffer, a
   packet with seq_num = 101 is received and is forwarded right away
   - the delay timer expires on the packet with seq_num=103. It is
   forwarded and  POFLastSent = 103
   - next, the delay timer expires on the packet with seq_num=102. It, in
   turn, is forwarded and  POFLastSent = 102
   - from now, based on my understanding of the described POF algorithm,
   every packet will be delayed even if there are no re-ordered packets. For
   example, the sequence of arriving packets is as 104, 105, 106, ...

Much appreciate your opinion if the scenario, i.e., a sequence like 100,
103, 102, 101, is a realistic one.

Regards,
Greg

On Mon, Apr 19, 2021 at 10:39 PM Balázs Varga A <balazs.a.varga=
[email-masked]> wrote:

> To: Balázs Varga A <[email-masked]>; Janos Farkas <
> [email-masked]>; Balázs Varga A <[email-masked]>;
> Janos Farkas <[email-masked]>; Stephan Kehrer <
> [email-masked]>; Stephan Kehrer <[email-masked]>;
> Tobias Heer <[email-masked]>; Tobias Heer <[email-masked]>
> A new version of I-D, draft-varga-detnet-pof-00.txt has been successfully
> submitted by =?utf-8?q?Bal=C3=A1zs_Varga?= and posted to the IETF
> repository.
>
> URL:
> https://www.ietf.org/archive/id/draft-varga-detnet-pof-00.txt
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-varga-detnet-pof
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
>

---

From: Stephan Kehrer <[email-masked]>
Date: Mon, 26 Apr 2021 09:25:26 +0000

Hi Greg,

Looking at the scenario you describe I think packets arriving in the order 100, 103, 102, 101 cannot happen due to an error on the transmission path if you are using only two paths. They might happen if the sender is failing and sends out the packets in the wrong order to begin with or if you are using more than two paths for redundancy and have failures on multiple transmission paths in a very specific order.
That being said, even then the transmission order 100, 101, 103, 102 should not be something you get from the POF in my opinion. If the packets are arriving and are buffered the way you describe, I think the following is what should happen (changes to what you had in your mail marked in red):

  *   POFLastSent = 100
  *   a packet with seq_num = 103 is received and placed into the buffer for the duration of POFMaxDelay
  *   next received packet has seq_num = 102. It is also moved into the buffer for the duration of POFMaxDelay
  *   finally, before all delayed packets transmitted out of the buffer, a packet with seq_num = 101 is received and is forwarded right away. This sets POFLastSent = 101.
  *   the packet with seq_num=102 is forwarded because it now fulfills the condition ‘OR its seq_num becomes equal to"POFLastSent + 1"’. This sets POFLastSent = 102.
  *   the packet with seq_num=103 is forwarded because it now fulfills the condition ‘OR its seq_num becomes equal to"POFLastSent + 1"’. This set POFLastSent = 103.
  *   Packets arriving after that are forwarded without delay if they are next in sequence, and delayed if they are out of sequence as described in the POF algorithm.
Regards,
Stephan
--
Mit freundlichen Grüßen | With kind regards

Stephan Kehrer | Senior Architect – CTO Office | Hirschmann Automation and Control GmbH
Stuttgarter Straße 45-51 | 72654 Neckartenzlingen | Germany
Phone: +49 7127 14 - 1035 | Mobile: +49 152 28813002 | Fax: +49 7127 14 - 1600
[email-masked]<mailto:[email-masked]> | www.beldensolutions.com<http://www.beldensolutions.com/> | www.blog.beldensolutions.com<http://www.blog.beldensolutions.com/>

Hirschmann Automation and Control GmbH, Neckartenzlingen
Register Court: Stuttgart, Trade Register No.: HRB 225927
VAT No.: DE 814 212 604
Managing Director: Brian Anderson, Wolfgang Schenk, Brian Lieser

Von: detnet <[email-masked]> Im Auftrag von Greg Mirsky
Gesendet: Samstag, 24. April 2021 03:04
An: Balázs Varga A <balazs.a.varga=[email-masked]>
Cc: [email-masked]
Betreff: [EXTERNAL] Re: [Detnet] Packet Ordering Function (draft-varga-detnet-pof-00.txt)

External Message:Use caution before opening links or attachments
Hi Balazs,
thank you for the well-designed mechanism of one of the key DetNet functions.
I have a scenario and would appreciate your consideration if you think it is a plausible one:

  *   assume that POFLastSent = 100
  *   a packet with seq_num = 103 is received and placed into the buffer for the duration of POFMaxDelay
  *   next received packet has seq_num = 102. It is also moved into the buffer for the duration of POFMaxDelay
  *   finally, before all delayed packets transmitted out of the buffer, a packet with seq_num = 101 is received and is forwarded right away
  *   the delay timer expires on the packet with seq_num=103. It is forwarded and  POFLastSent = 103
  *   next, the delay timer expires on the packet with seq_num=102. It, in turn, is forwarded and  POFLastSent = 102
  *   from now, based on my understanding of the described POF algorithm, every packet will be delayed even if there are no re-ordered packets. For example, the sequence of arriving packets is as 104, 105, 106, ...
Much appreciate your opinion if the scenario, i.e., a sequence like 100, 103, 102, 101, is a realistic one.

Regards,
Greg

On Mon, Apr 19, 2021 at 10:39 PM Balázs Varga A <balazs.a.varga=[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thanks

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, April 20, 2021 7:14 AM
To: Balázs Varga A <[email-masked]<mailto:[email-masked]>>; Janos Farkas <[email-masked]<mailto:[email-masked]>>; Balázs Varga A <[email-masked]<mailto:[email-masked]>>; Janos Farkas <[email-masked]<mailto:[email-masked]>>; Stephan Kehrer <[email-masked]<mailto:[email-masked]>>; Stephan Kehrer <[email-masked]<mailto:[email-masked]>>; Tobias Heer <[email-masked]<mailto:[email-masked]>>; Tobias Heer <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-varga-detnet-pof-00.txt

Name:           draft-varga-detnet-pof
Revision:       00
Title:          Deterministic Networking (DetNet): Packet Ordering Function
Document date:  2021-04-19
Group:          Individual Submission
Pages:          10
URL:            https://www.ietf.org/archive/id/draft-varga-detnet-pof-00.txt<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-varga-detnet-pof-00.txt__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWdzZ8c98$>
Status:         https://datatracker.ietf.org/doc/draft-varga-detnet-pof/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-varga-detnet-pof/__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWJABOkBc$>
Htmlized:       https://datatracker.ietf.org/doc/html/draft-varga-detnet-pof<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-varga-detnet-pof__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWE_vUf0k$>
Htmlized:       https://tools.ietf.org/html/draft-varga-detnet-pof-00<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-varga-detnet-pof-00__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKW2P84vhs$>

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<https://urldefense.com/v3/__http:/tools.ietf.org__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWhEGXwQU$>.

The IETF Secretariat

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/detnet__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWTJ53qCw$>

**********************************************************************
DISCLAIMER:
Privileged and/or Confidential information may be contained in this message. If you are not the addressee of this message, you may not copy, use or deliver this message to anyone. In such event, you should destroy the message and kindly notify the sender by reply e-mail. It is understood that opinions or conclusions that do not relate to the official business of the company are neither given nor endorsed by the company. Thank You.

---

From: Jeong-dong Ryoo <[email-masked]>
Date: Mon, 26 Apr 2021 18:50:59 +0900 (KST)

Hi,

In order to describe the operation a little bit more clearly, how about the following modification:
OLD:
o If (seq_num &lt;= POFLastSent + 1)
&nbsp; &nbsp;* Then the packet is forwarded and "POFLastSent" is updated
&nbsp; &nbsp; &nbsp; (POFLastSent = seq_num).
&nbsp; * Else the received packet is buffered until a predefined time
&nbsp; &nbsp; &nbsp; ("POFMaxDelay") elapses OR its seq_num becomes equal to
&nbsp; &nbsp; &nbsp; "POFLastSent + 1".
NEW:
o If (seq_num &lt;= POFLastSent + 1)
&nbsp; &nbsp;* Then the packet is forwarded and "POFLastSent" is updated
&nbsp; &nbsp; &nbsp; (POFLastSent = seq_num).
&nbsp; * Else the received packet is buffered.
o &nbsp;A buffered packet is forwarded from the buffer&nbsp;
&nbsp; &nbsp; when its seq_num becomes equal to "POFLastSent +1," OR&nbsp;
&nbsp; &nbsp; a predefined time ("POFMaxDely") elapses.&nbsp;

Best regards,

Jeong-dong

&nbsp;

-----Original Message-----
From: "Stephan Kehrer" &lt;[email-masked]&gt;
To: "Greg Mirsky" &lt;[email-masked]&gt;;
Cc: "[email-masked]" &lt;[email-masked]&gt;;
Sent: 2021-04-26 (월) 18:26:05 (UTC+09:00)
Subject: Re: [Detnet] Packet Ordering Function (draft-varga-detnet-pof-00.txt)

Hi Greg,
&nbsp;
Looking at the scenario you describe I think packets arriving in the order 100, 103, 102, 101 cannot happen due to an error on the transmission path if you are using only two paths. They might happen if the sender is failing and sends out the packets in the wrong order to begin with or if you are using more than two paths for redundancy and have failures on multiple transmission paths in a very specific order.
That being said, even then the transmission order 100, 101, 103, 102 should not be something you get from the POF in my opinion. If the packets are arriving and are buffered the way you describe, I think the following is what should happen (changes to what you had in your mail marked in red):
POFLastSent = 100a packet&nbsp;with&nbsp;seq_num = 103 is received and placed into the buffer for the duration of&nbsp;POFMaxDelaynext received packet has seq_num = 102. It is also moved into the buffer for the duration of&nbsp;POFMaxDelayfinally, before all delayed packets transmitted out of the buffer, a packet with seq_num = 101 is received and is forwarded right away.&nbsp;This sets POFLastSent = 101.the packet with seq_num=102 is forwarded because it now fulfills the condition ‘OR its seq_num becomes equal to"POFLastSent + 1"’. This sets POFLastSent = 102.the packet with seq_num=103 is forwarded because it now fulfills the condition ‘OR its seq_num becomes equal to"POFLastSent + 1"’. This set POFLastSent = 103.Packets arriving after that are forwarded without delay if they are next in sequence, and delayed if they are out of sequence as described in the POF algorithm.Regards,
Stephan
--
Mit freundlichen Grüßen | With kind regards
&nbsp;
Stephan Kehrer&nbsp;| Senior Architect –&nbsp;CTO Office&nbsp;| Hirschmann Automation and Control GmbH
Stuttgarter Straße 45-51 | 72654 Neckartenzlingen | Germany
Phone: +49 7127 14 - 1035 | Mobile: +49 152 28813002 | Fax: +49 7127 14 - 1600
[email-masked] mailto:[email-masked]&nbsp;| www.beldensolutions.com http://www.beldensolutions.com/ | &nbsp;www.blog.beldensolutions.com http://www.blog.beldensolutions.com/
&nbsp;
Hirschmann Automation and Control GmbH, Neckartenzlingen
Register Court: Stuttgart, Trade Register No.: HRB 225927
VAT No.: DE 814 212 604
Managing Director: Brian Anderson, Wolfgang Schenk, Brian Lieser
&nbsp;
&nbsp;
&nbsp;
Von: detnet &lt;[email-masked]&gt; Im Auftrag von&nbsp;Greg MirskyGesendet: Samstag, 24. April 2021 03:04An: Balázs Varga A &lt;balazs.a.varga=[email-masked]&gt;Cc: [email-masked]: [EXTERNAL] Re: [Detnet] Packet Ordering Function (draft-varga-detnet-pof-00.txt)

&nbsp;

Hi Balazs,

assume that&nbsp;POFLastSent = 100a packet&nbsp;with&nbsp;seq_num = 103 is received and placed into the buffer for the duration of&nbsp;POFMaxDelaynext received packet has seq_num = 102. It is also moved into the buffer for the duration of&nbsp;POFMaxDelayfinally, before all delayed packets transmitted out of the buffer, a packet with seq_num = 101 is received and is forwarded right awaythe delay timer expires on the packet with seq_num=103. It is forwarded and &nbsp;POFLastSent = 103next, the delay timer expires on the packet with seq_num=102. It, in turn, is forwarded and &nbsp;POFLastSent = 102from now, based on my understanding of the described POF algorithm, every packet will be delayed even if there are no re-ordered packets. For example, the sequence of arriving packets is as 104, 105, 106, ...Much appreciate your opinion if the scenario, i.e., a&nbsp;sequence like 100, 103, 102, 101, is a realistic one.

&nbsp;

Regards,

Greg

&nbsp;
On Mon, Apr 19, 2021 at 10:39 PM Balázs Varga A &lt;balazs.a.varga=[email-masked] mailto:[email-masked]&gt; wrote:

Hi,A draft on Packet Ordering Function (POF) algorithms were uploaded.Comments and views are highly appreciated.ThanksBala'zs (and the authors)-----Original Message-----From: [email-masked] mailto:[email-masked] &lt;[email-masked] mailto:[email-masked]&gt;Sent: Tuesday, April 20, 2021 7:14 AMTo: Balázs Varga A &lt;[email-masked] mailto:[email-masked]&gt;; Janos Farkas &lt;[email-masked] mailto:[email-masked]&gt;; Balázs Varga A &lt;[email-masked] mailto:[email-masked]&gt;; Janos Farkas &lt;[email-masked] mailto:[email-masked]&gt;; Stephan Kehrer &lt;[email-masked] mailto:[email-masked]&gt;; Stephan Kehrer &lt;[email-masked] mailto:[email-masked]&gt;; Tobias Heer &lt;[email-masked] mailto:[email-masked]&gt;; Tobias Heer &lt;[email-masked] mailto:[email-masked]&gt;Subject: New Version Notification for draft-varga-detnet-pof-00.txtA new version of I-D, draft-varga-detnet-pof-00.txt has been successfully submitted by =?utf-8?q?Bal=C3=A1zs_Varga?= and posted to the IETF repository.Name:           draft-varga-detnet-pofRevision:       00Title:          Deterministic Networking (DetNet): Packet Ordering FunctionDocument date:  2021-04-19Group:          Individual SubmissionPages:          10URL:            &nbsp;https://www.ietf.org/archive/id/draft-varga-detnet-pof-00.txt https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-varga-detnet-pof-00.txt__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWdzZ8c98$Status:         https://datatracker.ietf.org/doc/draft-varga-detnet-pof/ https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-varga-detnet-pof/__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWJABOkBc$Htmlized:       https://datatracker.ietf.org/doc/html/draft-varga-detnet-pof https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-varga-detnet-pof__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWE_vUf0k$Htmlized:       https://tools.ietf.org/html/draft-varga-detnet-pof-00 https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-varga-detnet-pof-00__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKW2P84vhs$Abstract:   Replication and Elimination functions of DetNet [RFC8655] may result   in out-of-order packets, which may not be acceptable for some time-   sensitive applications.  The Packet Ordering Function (POF) algorithm   described herein enables to restore the correct packet order when   replication and elimination functions are used in DetNet networks.Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at &nbsp;tools.ietf.org https://urldefense.com/v3/__http:/tools.ietf.org__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWhEGXwQU$.The IETF Secretariat_______________________________________________detnet mailing [email-masked] mailto:[email-masked]://www.ietf.org/mailman/listinfo/detnet https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/detnet__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWTJ53qCw$

DISCLAIMER:
Privileged and/or Confidential information may be contained in this message. If you are not the addressee of this message, you may not copy, use or deliver this message to anyone. In such event, you should destroy the message and kindly notify the sender by reply e-mail. It is understood that opinions or conclusions that do not relate to the official business of the company are neither given nor endorsed by the company. Thank You.
_______________________________________________ detnet mailing list [email-masked] https://www.ietf.org/mailman/listinfo/detnet

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 27 Apr 2021 09:14:36 +0000

Hi Greg/Stephan/Jeong-dong,

Thanks for the question and the clarifications.
More clear definitions are always better, so we will update the text in the next version. :--)))
Thanks for the proposal, it is identical from operation perspective, but better structured.

Cheers
Bala’zs

From: detnet <[email-masked]> On Behalf Of Jeong-dong Ryoo
Sent: Monday, April 26, 2021 11:51 AM
To: Greg Mirsky <[email-masked]>; Stephan Kehrer <[email-masked]>
Cc: [email-masked]
Subject: Re: [Detnet] Packet Ordering Function (draft-varga-detnet-pof-00.txt)

Hi,

In order to describe the operation a little bit more clearly, how about the following modification:
OLD:
o If (seq_num <= POFLastSent + 1)
   * Then the packet is forwarded and "POFLastSent" is updated
      (POFLastSent = seq_num).
  * Else the received packet is buffered until a predefined time
      ("POFMaxDelay") elapses OR its seq_num becomes equal to
      "POFLastSent + 1".
NEW:
o If (seq_num <= POFLastSent + 1)
   * Then the packet is forwarded and "POFLastSent" is updated
      (POFLastSent = seq_num).
  * Else the received packet is buffered.
o  A buffered packet is forwarded from the buffer
    when its seq_num becomes equal to "POFLastSent +1," OR
    a predefined time ("POFMaxDely") elapses.

Best regards,

Jeong-dong

-----Original Message-----
From: "Stephan Kehrer" <[email-masked]<mailto:[email-masked]>>
To: "Greg Mirsky" <[email-masked]<mailto:[email-masked]>>;
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>;
Sent: 2021-04-26 (월) 18:26:05 (UTC+09:00)
Subject: Re: [Detnet] Packet Ordering Function (draft-varga-detnet-pof-00.txt)

Hi Greg,

  *   POFLastSent = 100

Regards,

Stephan

--

[email-masked]<mailto:[email-masked]> | www.beldensolutions.com<https://protect2.fireeye.com/v1/url?k=dda0719d-823b489d-dda03106-86fc6812c361-f1d5901748d6ff9a&q=1&e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&u=http%3A%2F%2Fwww.beldensolutions.com%2F> |  www.blog.beldensolutions.com<https://protect2.fireeye.com/v1/url?k=ac4b5d7d-f3d0647d-ac4b1de6-86fc6812c361-52ac3550d649b5b3&q=1&e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&u=http%3A%2F%2Fwww.blog.beldensolutions.com%2F>

VAT No.: DE 814 212 604

Von: detnet <[email-masked]<mailto:[email-masked]>> Im Auftrag von Greg Mirsky
Gesendet: Samstag, 24. April 2021 03:04
An: Balázs Varga A <balazs.a.varga=[email-masked]<mailto:balazs.a.varga=[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Betreff: [EXTERNAL] Re: [Detnet] Packet Ordering Function (draft-varga-detnet-pof-00.txt)

Hi Balazs,

Regards,

Greg

Hi,

Thanks

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, April 20, 2021 7:14 AM
To: Balázs Varga A <[email-masked]<mailto:[email-masked]>>; Janos Farkas <[email-masked]<mailto:[email-masked]>>; Balázs Varga A <[email-masked]<mailto:[email-masked]>>; Janos Farkas <[email-masked]<mailto:[email-masked]>>; Stephan Kehrer <[email-masked]<mailto:[email-masked]>>; Stephan Kehrer <[email-masked]<mailto:[email-masked]>>; Tobias Heer <[email-masked]<mailto:[email-masked]>>; Tobias Heer <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-varga-detnet-pof-00.txt

Name: draft-varga-detnet-pof
Revision: 00
Title: Deterministic Networking (DetNet): Packet Ordering Function
Document date: 2021-04-19
Group: Individual Submission
Pages: 10
URL:  https://www.ietf.org/archive/id/draft-varga-detnet-pof-00.txt<https://protect2.fireeye.com/v1/url?k=42292fb7-1db216b7-42296f2c-86fc6812c361-b79213ba824e6d93&q=1&e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-varga-detnet-pof-00.txt__%3B%21%21B_EDKQmmvsU%217vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWdzZ8c98%24>
Status: https://datatracker.ietf.org/doc/draft-varga-detnet-pof/<https://protect2.fireeye.com/v1/url?k=984afd7a-c7d1c47a-984abde1-86fc6812c361-4962d489008d8450&q=1&e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-varga-detnet-pof%2F__%3B%21%21B_EDKQmmvsU%217vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWJABOkBc%24>
Htmlized: https://datatracker.ietf.org/doc/html/draft-varga-detnet-pof<https://protect2.fireeye.com/v1/url?k=dc12b981-83898081-dc12f91a-86fc6812c361-3b1b6f2cbe6ba5d4&q=1&e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-varga-detnet-pof__%3B%21%21B_EDKQmmvsU%217vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWE_vUf0k%24>
Htmlized: https://tools.ietf.org/html/draft-varga-detnet-pof-00<https://protect2.fireeye.com/v1/url?k=4f1f906c-1084a96c-4f1fd0f7-86fc6812c361-e3caef04ecbf73ab&q=1&e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Ftools.ietf.org%2Fhtml%2Fdraft-varga-detnet-pof-00__%3B%21%21B_EDKQmmvsU%217vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKW2P84vhs%24>

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at  tools.ietf.org<https://protect2.fireeye.com/v1/url?k=b5f8187c-ea63217c-b5f858e7-86fc6812c361-e7ee7fdcad2e1824&q=1&e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&u=https%3A%2F%2Furldefense.com%2Fv3%2F__http%3A%2Ftools.ietf.org__%3B%21%21B_EDKQmmvsU%217vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWhEGXwQU%24>.

The IETF Secretariat

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet<https://protect2.fireeye.com/v1/url?k=8e77ce7d-d1ecf77d-8e778ee6-86fc6812c361-964a3c25b2c843c4&q=1&e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&u=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdetnet__%3B%21%21B_EDKQmmvsU%217vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWTJ53qCw%24>

________________________________
DISCLAIMER:
Privileged and/or Confidential information may be contained in this message. If you are not the addressee of this message, you may not copy, use or deliver this message to anyone. In such event, you should destroy the message and kindly notify the sender by reply e-mail. It is understood that opinions or conclusions that do not relate to the official business of the company are neither given nor endorsed by the company. Thank You.
_______________________________________________ detnet mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/detnet
[https://gov-dooray.com/mail-receipts?img=46735a78512b3456-255f338911948417-29933195d91dcdf2-2993342e89cf2491.gif]

---

From: Jeong-dong Ryoo <[email-masked]>
Date: Tue, 27 Apr 2021 18:34:24 +0900 (KST)

Hi Bala'zs,

Thank you for your email.
Yes, it is the same operation.

Cheers,

Jeong-dong

-----Original Message-----
From: "Balázs Varga A" &lt;balazs.a.varga=[email-masked]&gt;
To: "Jeong-dong Ryoo" &lt;[email-masked]&gt;; "Greg Mirsky" &lt;[email-masked]&gt;; "Stephan Kehrer" &lt;[email-masked]&gt;;
Cc: "[email-masked]" &lt;[email-masked]&gt;;
Sent: 2021-04-27 (화) 18:15:10 (UTC+09:00)
Subject: Re: [Detnet] Packet Ordering Function (draft-varga-detnet-pof-00.txt)

From: detnet &lt;[email-masked]&gt; On Behalf Of&nbsp;Jeong-dong RyooSent: Monday, April 26, 2021 11:51 AMTo: Greg Mirsky &lt;[email-masked]&gt;; Stephan Kehrer &lt;[email-masked]&gt;Cc: [email-masked]: Re: [Detnet] Packet Ordering Function (draft-varga-detnet-pof-00.txt)

&nbsp;
Hi,

&nbsp;

OLD:

NEW:

&nbsp;

Best regards,

&nbsp;

Jeong-dong

&nbsp;

&nbsp;

&nbsp;

&nbsp;

&nbsp;

-----Original Message-----

From: "Stephan Kehrer" &lt;[email-masked] mailto:[email-masked]&gt;

To: "Greg Mirsky" &lt;[email-masked] mailto:[email-masked]&gt;;

Cc: "[email-masked] mailto:[email-masked]" &lt;[email-masked] mailto:[email-masked]&gt;;

&nbsp;

Hi Greg,
&nbsp;
Looking at the scenario you describe I think packets arriving in the order 100, 103, 102, 101 cannot happen due to an error on the transmission path if you are using only two paths. They might happen if the sender is failing and sends out the packets in the wrong order to begin with or if you are using more than two paths for redundancy and have failures on multiple transmission paths in a very specific order.
That being said, even then the transmission order 100, 101, 103, 102 should not be something you get from the POF in my opinion. If the packets are arriving and are buffered the way you describe, I think the following is what should happen (changes to what you had in your mail marked in red):
POFLastSent = 100a packet&nbsp;with&nbsp;seq_num = 103 is received and placed into the buffer for the duration of&nbsp;POFMaxDelaynext received packet has seq_num = 102. It is also moved into the buffer for the duration of&nbsp;POFMaxDelayfinally, before all delayed packets transmitted out of the buffer, a packet with seq_num = 101 is received and is forwarded right away. This sets POFLastSent = 101.the packet with seq_num=102 is forwarded because it now fulfills the condition ‘OR its seq_num becomes equal to"POFLastSent + 1"’. This sets POFLastSent = 102.the packet with seq_num=103 is forwarded because it now fulfills the condition ‘OR its seq_num becomes equal to"POFLastSent + 1"’. This set POFLastSent = 103.Packets arriving after that are forwarded without delay if they are next in sequence, and delayed if they are out of sequence as described in the POF algorithm.Regards,
Stephan
--
Mit freundlichen Grüßen | With kind regards
&nbsp;
Stephan Kehrer&nbsp;| Senior Architect –&nbsp;CTO Office&nbsp;| Hirschmann Automation and Control GmbH
Stuttgarter Straße 45-51 | 72654 Neckartenzlingen | Germany
Phone: +49 7127 14 - 1035 | Mobile: +49 152 28813002 | Fax: +49 7127 14 - 1600
[email-masked] mailto:[email-masked] | &nbsp;www.beldensolutions.com https://protect2.fireeye.com/v1/url?k=dda0719d-823b489d-dda03106-86fc6812c361-f1d5901748d6ff9a&amp;q=1&amp;e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&amp;u=http://www.beldensolutions.com/ | &nbsp; www.blog.beldensolutions.com https://protect2.fireeye.com/v1/url?k=ac4b5d7d-f3d0647d-ac4b1de6-86fc6812c361-52ac3550d649b5b3&amp;q=1&amp;e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&amp;u=http://www.blog.beldensolutions.com/
&nbsp;
Hirschmann Automation and Control GmbH, Neckartenzlingen
Register Court: Stuttgart, Trade Register No.: HRB 225927
VAT No.: DE 814 212 604
Managing Director: Brian Anderson, Wolfgang Schenk, Brian Lieser
&nbsp;
&nbsp;
&nbsp;
Von: detnet &lt;[email-masked] mailto:[email-masked]&gt; Im Auftrag von&nbsp;Greg MirskyGesendet: Samstag, 24. April 2021 03:04An: Balázs Varga A &lt;balazs.a.varga=[email-masked] mailto:balazs.a.varga=[email-masked]&gt;Cc: &nbsp;[email-masked] mailto:[email-masked]: [EXTERNAL] Re: [Detnet] Packet Ordering Function (draft-varga-detnet-pof-00.txt)

&nbsp;

Hi Balazs,

&nbsp;

Regards,

Greg

&nbsp;

Hi,A draft on Packet Ordering Function (POF) algorithms were uploaded.Comments and views are highly appreciated.ThanksBala'zs (and the authors)

-----Original Message-----
From: [email-masked] mailto:[email-masked] &lt;[email-masked] mailto:[email-masked]&gt;
Sent: Tuesday, April 20, 2021 7:14 AM
To: Balázs Varga A &lt;[email-masked] mailto:[email-masked]&gt;; Janos Farkas &lt;[email-masked] mailto:[email-masked]&gt;; Balázs Varga A &lt;[email-masked] mailto:[email-masked]&gt;;
 Janos Farkas &lt;[email-masked] mailto:[email-masked]&gt;; Stephan Kehrer &lt;[email-masked] mailto:[email-masked]&gt;; Stephan Kehrer &lt;[email-masked] mailto:[email-masked]&gt;;
 Tobias Heer &lt;[email-masked] mailto:[email-masked]&gt;; Tobias Heer &lt;[email-masked] mailto:[email-masked]&gt;
Subject: New Version Notification for draft-varga-detnet-pof-00.txt

Name: draft-varga-detnet-pof
Revision: 00
Title: Deterministic Networking (DetNet): Packet Ordering Function
Document date: 2021-04-19
Group: Individual Submission
Pages: 10
URL: 
&nbsp;https://www.ietf.org/archive/id/draft-varga-detnet-pof-00.txt https://protect2.fireeye.com/v1/url?k=42292fb7-1db216b7-42296f2c-86fc6812c361-b79213ba824e6d93&amp;q=1&amp;e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&amp;u=https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-varga-detnet-pof-00.txt__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWdzZ8c98$
Status: 
https://datatracker.ietf.org/doc/draft-varga-detnet-pof/ https://protect2.fireeye.com/v1/url?k=984afd7a-c7d1c47a-984abde1-86fc6812c361-4962d489008d8450&amp;q=1&amp;e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&amp;u=https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-varga-detnet-pof/__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWJABOkBc$
Htmlized: 
https://datatracker.ietf.org/doc/html/draft-varga-detnet-pof https://protect2.fireeye.com/v1/url?k=dc12b981-83898081-dc12f91a-86fc6812c361-3b1b6f2cbe6ba5d4&amp;q=1&amp;e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&amp;u=https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-varga-detnet-pof__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWE_vUf0k$
Htmlized: 
https://tools.ietf.org/html/draft-varga-detnet-pof-00 https://protect2.fireeye.com/v1/url?k=4f1f906c-1084a96c-4f1fd0f7-86fc6812c361-e3caef04ecbf73ab&amp;q=1&amp;e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&amp;u=https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-varga-detnet-pof-00__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKW2P84vhs$

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at

&nbsp;tools.ietf.org https://protect2.fireeye.com/v1/url?k=b5f8187c-ea63217c-b5f858e7-86fc6812c361-e7ee7fdcad2e1824&amp;q=1&amp;e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&amp;u=https://urldefense.com/v3/__http:/tools.ietf.org__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWhEGXwQU$.

The IETF Secretariat

_______________________________________________
detnet mailing list
[email-masked] mailto:[email-masked]
https://www.ietf.org/mailman/listinfo/detnet https://protect2.fireeye.com/v1/url?k=8e77ce7d-d1ecf77d-8e778ee6-86fc6812c361-964a3c25b2c843c4&amp;q=1&amp;e=5dd3eaf7-6baf-4f90-b030-71c3c708325b&amp;u=https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/detnet__;!!B_EDKQmmvsU!7vmDpLfsfmmLuG9tQHwCrsPqlNqL_fA88lGK7awH9s4iu2A-gZ-KVq6uPhKWTJ53qCw$

DISCLAIMER:

Privileged and/or Confidential information may be contained in this message. If you are not the addressee of this message, you may not copy, use or deliver this message to anyone. In such event, you should destroy the message and kindly
 notify the sender by reply e-mail. It is understood that opinions or conclusions that do not relate to the official business of the company are neither given nor endorsed by the company. Thank You.

_______________________________________________ detnet mailing list
[email-masked] mailto:[email-masked] 
https://www.ietf.org/mailman/listinfo/detnet https://www.ietf.org/mailman/listinfo/detnet

&nbsp;