Subject: [Detnet] PALS meeting IETF 111

From: Stewart Bryant <[email-masked]>
Date: Fri, 23 Jul 2021 12:28:26 +0100

The agenda for the joint PALS/MPLS meeting is shown below.

This meeting is focused on Meta/Ancillary data in MPLS packets - how we know it is there and how we carry it.

This is both formal reporting of the progress on the MPLS Open Design Team and a working session to progress the work.

The MPLS open design team keeps a log of its work here

https://trac.ietf.org/trac/mpls/wiki/MPLSOpenDT

- Stewart

Revised Joint WG Session Agenda for IETF 111: ¶
5 min - Chairs’ intro - Andy MALIS
20 min - MPLS Open DT summary and status - Stewart BRYANT
In-stack Indicators
3.1 FAI MSPL I-D: Kireeti (10 mins)
3.2 draft-bryant-mpls-aux-data-pointer-00 <http://tools.ietf.org/html/draft-bryant-mpls-aux-data-pointer-00>: Stewart (10 mins)
3.3 draft-song-mpls-eh-indicator <http://tools.ietf.org/html/draft-song-mpls-eh-indicator>: Haoyo (5 mins)

Meta-data Encoding Options:
4.1 15 min - MPLS Extension Header: Enabling Extensible In-Network Services - Haoyu SONG
draft-song-mpls-extension-header <http://tools.ietf.org/html/draft-song-mpls-extension-header> draft-andersson-mpls-eh-architecture <http://tools.ietf.org/html/draft-andersson-mpls-eh-architecture> draft-andersson-mpls-eh-label-stack-operations <http://tools.ietf.org/html/draft-andersson-mpls-eh-label-stack-operations>

Objective: Recap the solution proposal with some updates based on the DT meeting discussion.

4.2 10 mins - GDF encodings - Jeffrey
35 min - Discussion - all
5 min - Chairs’ summary - Stewart BRYANT

---

From: Haoyu Song <[email-masked]>
Date: Sat, 24 Jul 2021 23:54:55 +0000

Hi Stewart,

A quick question. Where should we submit the meeting slides? Thanks!

Haoyu

From: mpls <[email-masked]> On Behalf Of Stewart Bryant
Sent: Friday, July 23, 2021 4:28 AM
To: [email-masked]
Cc: mpls <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: [mpls] PALS meeting IETF 111

https://trac.ietf.org/trac/mpls/wiki/MPLSOpenDT<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fmpls%2Fwiki%2FMPLSOpenDT&data=04%7C01%7Chaoyu.song%40futurewei.com%7C19cae2c38faa48e4bd0e08d94dcd13df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637626365478409910%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=S%2FX9p23z%2FB8gC6K5yuWpAqgfl0YvzEN2Sd2oL2Nfu0Y%3D&reserved=0>

- Stewart

  1.  5 min - Chairs' intro - Andy MALIS
  2.  20 min - MPLS Open DT summary and status - Stewart BRYANT
  3.  In-stack Indicators
3.1 FAI MSPL I-D: Kireeti (10 mins)
3.2 draft-bryant-mpls-aux-data-pointer-00<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-bryant-mpls-aux-data-pointer-00&data=04%7C01%7Chaoyu.song%40futurewei.com%7C19cae2c38faa48e4bd0e08d94dcd13df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637626365478419867%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=JgekbcHbAmZKCHoy8XGzF%2FVZg74lRg%2BvotI4X9zXdaA%3D&reserved=0>: Stewart (10 mins)
3.3 draft-song-mpls-eh-indicator<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-song-mpls-eh-indicator&data=04%7C01%7Chaoyu.song%40futurewei.com%7C19cae2c38faa48e4bd0e08d94dcd13df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637626365478419867%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=8J%2BprMDEKogeY4%2FXAtdgT9QrsAN7jxzMHxmAE%2FVTkDQ%3D&reserved=0>: Haoyo (5 mins)

  1.  Meta-data Encoding Options:
4.1 15 min - MPLS Extension Header: Enabling Extensible In-Network Services - Haoyu SONG
draft-song-mpls-extension-header<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-song-mpls-extension-header&data=04%7C01%7Chaoyu.song%40futurewei.com%7C19cae2c38faa48e4bd0e08d94dcd13df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637626365478429827%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=bnikRLRP5bBC4L1upLYrU92KGGBe3W3qWp2NG4oGT%2BI%3D&reserved=0> draft-andersson-mpls-eh-architecture<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-andersson-mpls-eh-architecture&data=04%7C01%7Chaoyu.song%40futurewei.com%7C19cae2c38faa48e4bd0e08d94dcd13df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637626365478429827%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=OPw%2BP7KPODsc499%2FEUSWvn3NewZx6gdMM85uA0weHl0%3D&reserved=0> draft-andersson-mpls-eh-label-stack-operations<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-andersson-mpls-eh-label-stack-operations&data=04%7C01%7Chaoyu.song%40futurewei.com%7C19cae2c38faa48e4bd0e08d94dcd13df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637626365478429827%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=%2Be3JC3X944vbnyI7PDYf6Yj2sgSxa1ea7X%2FAoW902FM%3D&reserved=0>

  1.  35 min - Discussion - all
  2.  5 min - Chairs' summary - Stewart BRYANT

---

From: David Sinicrope <[email-masked]>
Date: Mon, 26 Jul 2021 10:41:10 -0400

Hi All,

Sorry for the slow response, I was on vacation last week.

I see that the agenda below is posted, thanks!

I'll send a notice for slides in a minute or two.

-Dave

On 7/23/21 7:28 AM, Stewart Bryant wrote:
> This is both formal reporting of the progress on the MPLS Open Design 
> Team and a working session to progress the work.
>
> <https://trac.ietf.org/trac/mpls/wiki/MPLSOpenDT>
>
> - Stewart
> *
> *
> *Revised Joint WG Session Agenda for IETF 111:**¶*
>
>  1. 5 min - Chairs’ intro - Andy MALIS
> 3.2 draft-bryant-mpls-aux-data-pointer-00 
> <http://tools.ietf.org/html/draft-bryant-mpls-aux-data-pointer-00>: 
> Stewart (10 mins)
> 3.3 draft-song-mpls-eh-indicator 
> <http://tools.ietf.org/html/draft-song-mpls-eh-indicator>: Haoyo (5 mins)
>
>  4. Meta-data Encoding Options:
>
> draft-song-mpls-extension-header 
> <http://tools.ietf.org/html/draft-song-mpls-extension-header>draft-andersson-mpls-eh-architecture 
> <http://tools.ietf.org/html/draft-andersson-mpls-eh-architecture> 
> draft-andersson-mpls-eh-label-stack-operations 
> <http://tools.ietf.org/html/draft-andersson-mpls-eh-label-stack-operations>
>
>  5. 35 min - Discussion - all
>  6. 5 min - Chairs’ summary - Stewart BRYANT
>
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 26 Jul 2021 10:44:04 -0400

Dave,

I just sent you my final slides. Look at the version of the agenda in my
slides, I replaced two of the placeholders with actual draft names. I
suggest updating the online agenda to match.

Thanks,
Andy

On Mon, Jul 26, 2021 at 10:41 AM David Sinicrope <[email-masked]>
wrote:

> This is both formal reporting of the progress on the MPLS Open Design Team
> and a working session to progress the work.
>
> *Revised Joint WG Session Agenda for IETF 111:** ¶*
>
>    2. 5 min - Chairs’ summary - Stewart BRYANT
>
>
>

---

From: David Sinicrope <[email-masked]>
Date: Mon, 26 Jul 2021 11:09:28 -0400

Done. https://datatracker.ietf.org/doc/agenda-111-pals/

I'll upload slides next..

Dave

On 7/26/21 10:44 AM, Andrew G. Malis wrote:
> Dave,
>
> I just sent you my final slides. Look at the version of the agenda in 
> my slides, I replaced two of the placeholders with actual draft names. 
> I suggest updating the online agenda to match.
>
> Thanks,
> Andy
>
>
> On Mon, Jul 26, 2021 at 10:41 AM David Sinicrope 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi All,
>
>>     This meeting is focused on Meta/Ancillary data in MPLS packets -
>>     how we know it is there and how we carry it.
>>
>>     This is both formal reporting of the progress on the MPLS Open
>>     Design Team and a working session to progress the work.
>>