Subject: [Detnet] OAM terms

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 6 Jul 2021 14:02:23 +0000

Dear all

There's a need in the DetNet OAM framework and in the RAW architecture/framework to agree on definitions that can be used on both sides to mean the same thing. At the DetNet OAM call today, we agreed to work on that issue before cut off and publish aligned documents.

As a starting point, please find below the current text in the RAW document, largely based on a mix of RFC 6291 ans Greg's sentences in the previous thread on this subject; you'll note the 2 original terms for reverse OAM and Limited OAM that need more refining.

Fire at will!

Pascal

   AOM:  OAM stands for Operations, Administration, and Maintenance, and
      covers the processes, activities, tools, and standards involved
      with operating, administering, managing and maintaining any
      system.  This document uses the terms Operations, Administration,
      and Maintenance, in conformance with the IETF 'Guidelines for the
      Use of the "OAM" Acronym in the IETF' [RFC6291] and the system
      observed by the RAW OAM is the Track.

   Active OAM:  Active OAM uses specially constructed test packets
      crafted to observe a particular Track, subTrack, or Segment of a
      Track.

   In-Band OAM:  An active OAM packet is considered in-band in the
      monitored Track when it traverses the same set of links and
      interfaces receiving the same QoS and PAREO treatment as the data
      flows that are injected in the Track.

   Out-of-Band OAM:  An active OAM packet is out-of-band if its datapath
      is topologically the same as of that of the Track, subTrack or
      Segment being observed, but the QoS or PAREO treatment is
      different (e.g., lower CoS).

   Limited OAM:  An active OAM packet is a Limited OAM packet when it is
      observes the RAW operation over a node, a segment, or a subTrack
      of the Track, though not from Ingress to Egress.  It is injected
      in the datapath and extracted from the datapath around the
      particular function or subnetwork (e.g., around a relay providing
      a service layer replication point) that is being tested.

   Reverse OAM:  A Reverse OAM packet is an Out-of-Band OAM packet that
      traverses the Track from West to East and North-South in one of
      either direction, to capture and report OAM measurements upstream.

---

From: Fabrice Theoleyre <[email-masked]>
Date: Wed, 7 Jul 2021 08:11:14 +0200

Hi Pascal,

Thanks for taking this initiative.

>  
>    [OAM]:  OAM stands for Operations, Administration, and Maintenance, and
>    In-Band OAM:  An active OAM packet is considered in-band [for] the
>       interfaces, [and if the OAM packets receive] the same QoS and PAREO treatment as the data
>    Limited OAM:  An active OAM packet is a Limited OAM packet when it [is]

[FT] I modified directly the text for typos / direct reformulations  [modif]

>       either direction, to capture and report OAM measurements upstream.

[FT] Shall we consider also the case where each intermediary hop reports directly and autonomously the control information to the OAM source? To my mind, saying that an OAM packet collects everything may be quite restrictive, and we may not be able to address all the cases. 

[FT] in that case, Reverse OAM: a reverse OAM packet is an Out-of-Band OAM packet that reports OAM measurements from intermediary routers to the OAM source. 

My 2 cents,
Fabrice

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 7 Jul 2021 09:30:00 +0000

Hello Fabrice,

Please see below!

From: detnet <[email-masked]> On Behalf Of Fabrice Theoleyre
Sent: mercredi 7 juillet 2021 8:11
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: [email-masked]; Balázs Varga A <[email-masked]>; Black, David <[email-masked]>; Janos Farkas <[email-masked]>; [email-masked]; DetNet WG <[email-masked]>
Subject: Re: [Detnet] OAM terms

Hi Pascal,

> [FT] I modified directly the text for typos / direct reformulations  [modif]

[PT]  many thanks, I applied

> [FT] Shall we consider also the case where each intermediary hop reports directly and autonomously the control information to the OAM source? To my mind, saying that an OAM packet collects everythi…

[PT]  great point,  what about

    A Reverse OAM packet is an Out-of-Band OAM packet that traverses the Track
    from egress to ingress on the reverse direction, to capture and  report OAM
    measurements upstream. The collection may capture all information along the
    whole Track, or it may only learn select data across all, or only a
     particular subTrack, or Segment of a Track.

[PT]  Well, the PSE may be distributed and learn from incoming reverse OAM at any point in the network.

Keep safe;

Pascal

---

From: Fabrice Theoleyre <[email-masked]>
Date: Wed, 7 Jul 2021 14:47:03 +0200

Hi Pascal, 

>      particular subTrack, or Segment of a Track.
[FT] Yes, it’s generic now (to my mind)

> [PT]  Well, the PSE may be distributed and learn from incoming reverse OAM at any point in the network.  

[FT]: yes, +1,  OAM source is a specific case.

Fabrice

---

From: Dangjuanna <[email-masked]>
Date: Thu, 8 Jul 2021 02:23:37 +0000

Hi Pascal,

Please see below.

From: detnet [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: 2021年7月6日 22:02
To: DetNet WG <[email-masked]>; [email-masked]
Cc: Fabrice Theoleyre <[email-masked]>; Black, David <[email-masked]>; [email-masked]; Balázs Varga A <[email-masked]>; Janos Farkas <[email-masked]>
Subject: [Detnet] OAM terms

Dear all

There’s a need in the DetNet OAM framework and in the RAW architecture/framework to agree on definitions that can be used on both sides to mean the same thing. At the DetNet OAM call today, we agreed to work on that issue before cut off and publish aligned documents.

As a starting point, please find below the current text in the RAW document, largely based on a mix of RFC 6291 ans Greg’s sentences in the previous thread on this subject; you’ll note the 2 original terms for reverse OAM and Limited OAM that need more refining.

Fire at will!

Pascal

[DJ] I am not sure what scenarios this technology will be used in? What role does it play?

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 9 Jul 2021 16:21:01 +0000

Hello Juanna

One example I when the measured data is pulled from a controller. Another would be to traverse the graph through a path that is not the data path, e.g., if the links of the deta path are dedicated, or if the grapf is traversed from egress to ingress. Either way I believe that we are talking about capturing metrics that are already stored in nodes as opposed to following the packet flows to observe the treatment of individual packets.

Keep safe;

Pascal

From: Dangjuanna <[email-masked]>
Sent: jeudi 8 juillet 2021 4:24
To: Pascal Thubert (pthubert) <[email-masked]>; DetNet WG <[email-masked]>; [email-masked]
Cc: Fabrice Theoleyre <[email-masked]>; Black, David <[email-masked]>; [email-masked]; Balázs Varga A <[email-masked]>; Janos Farkas <[email-masked]>
Subject: RE: OAM terms

Hi Pascal,

Please see below.

From: detnet [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: 2021年7月6日 22:02
To: DetNet WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Fabrice Theoleyre <[email-masked]<mailto:[email-masked]>>; Black, David <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Balázs Varga A <[email-masked]<mailto:[email-masked]>>; Janos Farkas <[email-masked]<mailto:[email-masked]>>
Subject: [Detnet] OAM terms

Dear all

Fire at will!

Pascal