Subject: [Detnet] The new d-ACH format

From: Greg Mirsky <[email-masked]>
Date: Wed, 10 Nov 2021 05:14:11 -0800

Dear All,
Bala'zs has presented the new d-ACH (DetNet Associated Channel Header)
format at the DetNet WG meeting. Earlier this week, the new d-ACH format
was presented at joint PALS, MPLS, and DetNet meeting and received several
positive comments. At the DetNet WG meeting, it was proposed to integrate
the technical part, the new format of d-ACH
<https://datatracker.ietf.org/doc/html/draft-varga-detnet-service-sub-layer-oam-01#page-6>
into
the draft-ietf-detnet-mpls-oam
<https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls-oam/>.
Please, respond with the indication of your support or no support for the
proposed update of the WG document.

Regards,
Greg (as the Editor of draft-ietf-detnet-mpls-oam)

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 16 Nov 2021 12:54:37 -0800

Dear All,
I hope you've recovered from the IETF-112 (timing on the West Coast was
brutal).
Please share your thoughts, comments, and questions about the proposed new
format of d-ACH and whether you support including it and updating
draft-ietf-detnet-mpls-oam.

Regards,
Greg

On Wed, Nov 10, 2021 at 5:14 AM Greg Mirsky <[email-masked]> wrote:

> <https://datatracker.ietf.org/doc/html/draft-varga-detnet-service-sub-layer-oam-01#page-6> into

---

From: "Yangfan(Fan,IP Standards)" <[email-masked]>
Date: Wed, 17 Nov 2021 10:26:13 +0000

Hi Greg,

Regarding the new d-ACH format, I have a few questions to share, hopefully trigger more discussions.

1)       I feel we need more specifications of Node ID.  Using 20 bits to indicate a Node in MPLS data plane, can I deduce it is an MPLS label? In any MPLS data planes except SR-MPLS, there is no definition to use a label to identify a node. If we want a format generic for all MPLS data planes, I wonder whether node id is a good indicator? Whether 20 bits is enough?

2)       I also noticed there is a session ID, but is only 4 bit length, which I believe is way too short. Moreover, whether originator node ID and session ID are duplicated here to identify an OAM session. To dig deeper, DetNet OAM should be stateless or stateful?

3)       if we plans to take advantages of CFM y.1731 mechanisms,  level and flags are necessary but the length also needs further considerations.

Looking forward to further discussions.

Regards,
Fan

From: detnet [mailto:[email-masked]] On Behalf Of Greg Mirsky
Sent: Wednesday, November 17, 2021 4:55 AM
To: DetNet WG <[email-masked]>
Cc: DetNet Chairs <[email-masked]>
Subject: Re: [Detnet] The new d-ACH format

Dear All,
I hope you've recovered from the IETF-112 (timing on the West Coast was brutal).
Please share your thoughts, comments, and questions about the proposed new format of d-ACH and whether you support including it and updating draft-ietf-detnet-mpls-oam.

Regards,
Greg

On Wed, Nov 10, 2021 at 5:14 AM Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:
Dear All,
Bala'zs has presented the new d-ACH (DetNet Associated Channel Header) format at the DetNet WG meeting. Earlier this week, the new d-ACH format was presented at joint PALS, MPLS, and DetNet meeting and received several positive comments. At the DetNet WG meeting, it was proposed to integrate the technical part, the new format of d-ACH<https://datatracker.ietf.org/doc/html/draft-varga-detnet-service-sub-layer-oam-01#page-6> into the draft-ietf-detnet-mpls-oam<https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls-oam/>.
Please, respond with the indication of your support or no support for the proposed update of the WG document.

Regards,

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 17 Nov 2021 15:54:14 -0800

Hi Fan,
thank you for your comments and questions. Please find my notes in-lined
below tagged GIM>>,

Regards,
Greg

On Wed, Nov 17, 2021 at 2:26 AM Yangfan(Fan,IP Standards) <
[email-masked]> wrote:

> 1)       I feel we need more specifications of Node ID.  Using 20 bits to
> indicate a Node in MPLS data plane, can I deduce it is an MPLS label? In
> any MPLS data planes except SR-MPLS, there is no definition to use a label
> to identify a node. If we want a format generic for all MPLS data planes, I
> wonder whether node id is a good indicator? Whether 20 bits is enough?
>
GIM>> I agree that the DetNet WG will have more discussions on the
definition of the Node ID field. I am looking forward to your participation
in these discussions.

> 2)       I also noticed there is a session ID, but is only 4 bit length,
> which I believe is way too short. Moreover, whether originator node ID and
> session ID are duplicated here to identify an OAM session. To dig deeper,
> DetNet OAM should be stateless or stateful?
>
GIM>> Session ID field is only a tentative name. Would it help if we mark
it Reserved?

> 3)       if we plans to take advantages of CFM y.1731 mechanisms,  level
> and flags are necessary but the length also needs further considerations.
>
GIM>> It is not clear if DetNet OAM could benefit from re-using some
principles of Y.1731/CFM as the latter doesn't provide special support for
the Service sub-layer.

> *From:* detnet [mailto:[email-masked]] *On Behalf Of *Greg Mirsky
> *Sent:* Wednesday, November 17, 2021 4:55 AM
> *To:* DetNet WG <[email-masked]>
> *Cc:* DetNet Chairs <[email-masked]>
> *Subject:* Re: [Detnet] The new d-ACH format
>
>
>
> Dear All,
>

---

From: "Yangfan(Fan,IP Standards)" <[email-masked]>
Date: Thu, 18 Nov 2021 02:26:54 +0000

Hi Greg,

I agree we need a thoroughly discussion to this new d-ACH format. Let’s continue the discussion in biweekly OAM meetings.  And I’d be very happy to involve myself more on this work.
One more comment to OAM meetings, maybe it is good to share the meeting minutes in WG after each call, could be short but nice. I can do it as I propose it and doesn’t bring burdens to others.
Besides, I strongly encourage people to join this helpful meeting to progress DetNet OAM as we have already reached many common understandings on OAM requirements in previous months.

Regards,
Fan

From: detnet [mailto:[email-masked]] On Behalf Of Greg Mirsky
Sent: Thursday, November 18, 2021 7:54 AM
To: Yangfan(Fan,IP Standards) <[email-masked]>
Cc: DetNet WG <[email-masked]>; DetNet Chairs <[email-masked]>
Subject: Re: [Detnet] The new d-ACH format

Hi Fan,
thank you for your comments and questions. Please find my notes in-lined below tagged GIM>>,
Regards,
Greg

On Wed, Nov 17, 2021 at 2:26 AM Yangfan(Fan,IP Standards) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

1)       I feel we need more specifications of Node ID.  Using 20 bits to indicate a Node in MPLS data plane, can I deduce it is an MPLS label? In any MPLS data planes except SR-MPLS, there is no definition to use a label to identify a node. If we want a format generic for all MPLS data planes, I wonder whether node id is a good indicator? Whether 20 bits is enough?
GIM>> I agree that the DetNet WG will have more discussions on the definition of the Node ID field. I am looking forward to your participation in these discussions.

2)       I also noticed there is a session ID, but is only 4 bit length, which I believe is way too short. Moreover, whether originator node ID and session ID are duplicated here to identify an OAM session. To dig deeper, DetNet OAM should be stateless or stateful?
GIM>> Session ID field is only a tentative name. Would it help if we mark it Reserved?

3)       if we plans to take advantages of CFM y.1731 mechanisms,  level and flags are necessary but the length also needs further considerations.
GIM>> It is not clear if DetNet OAM could benefit from re-using some principles of Y.1731/CFM as the latter doesn't provide special support for the Service sub-layer.

Regards,
Fan

From: detnet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Greg Mirsky
Sent: Wednesday, November 17, 2021 4:55 AM
To: DetNet WG <[email-masked]<mailto:[email-masked]>>
Cc: DetNet Chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] The new d-ACH format

Dear All,

Regards,
Greg

Regards,

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 18 Nov 2021 07:29:17 -0800

Hi Fan,
thank you for helping progress the DetNet OAM work.

I have a couple of questions for the group:

   - Do you agree that the proposed d-ACH is a good and needed solution for
   the Service sub-layer OAM?
   - Do you support it being included in draft-ietf-detnet-mpls-oam and
   then discussed as a part of the WG document?

Regards,
Greg

On Wed, Nov 17, 2021 at 6:26 PM Yangfan(Fan,IP Standards) <
[email-masked]> wrote:

> Hi Greg,
>
>
>
> I agree we need a thoroughly discussion to this new d-ACH format. Let’s
> continue the discussion in biweekly OAM meetings.  And I’d be very happy to
> involve myself more on this work.
>
> One more comment to OAM meetings, maybe it is good to share the meeting
> minutes in WG after each call, could be short but nice. I can do it as I
> propose it and doesn’t bring burdens to others.
>
> Besides, I strongly encourage people to join this helpful meeting to
> progress DetNet OAM as we have already reached many common understandings
> on OAM requirements in previous months.
>
>
>
> Regards,
>
> Fan
>
>
>
>
>
>
>
>
>
> *Sent:* Thursday, November 18, 2021 7:54 AM
> *To:* Yangfan(Fan,IP Standards) <[email-masked]>
> *Cc:* DetNet WG <[email-masked]>; DetNet Chairs <[email-masked]>

---

From: Gyan Mishra <[email-masked]>
Date: Sat, 20 Nov 2021 10:58:00 -0500

Hi Greg / Authors & WG

Responses in-line

I agree with taking  individual document d-ACH new proposal for d-ACH for
service sub layer OAM presented and had positive feedback on the solution.

https://datatracker.ietf.org/doc/html/draft-varga-detnet-service-sub-layer-oam-01#page-6

Combing to WG document

https://datatracker.ietf.org/doc/html/draft-ietf-detnet-mpls-oam-05

Responses in-line

Many Thanks!

Gyan

On Thu, Nov 18, 2021 at 10:29 AM Greg Mirsky <[email-masked]> wrote:

>    - Do you agree that the proposed d-ACH is a good and needed solution
>    for the Service sub-layer OAM?   Gyan> Support
>
>
>    then discussed as a part of the WG document?  Gyan> Support
>
>
       Once combined we can continue to progress and update as WG document
and address any WG concerns related to field size details mentioned by Fan
in the d-ACH.

>> 1)       I feel we need more specifications of Node ID.  Using 20 bits
>> to indicate a Node in MPLS data plane, can I deduce it is an MPLS label? In
>> Please share your thoughts, comments, and questions about the proposed
>> new format of d-ACH and whether you support including it and updating
>> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*