Subject: [Detnet] New Liaison Statement, "New liaison to ITU-T SG13"

From: Liaison Statement Management Tool <[email-masked]>
Date: Tue, 23 Nov 2021 14:23:36 -0800

Title: New liaison to ITU-T SG13
Submission Date: 2021-11-23
URL of the IETF Web page: https://datatracker.ietf.org/liaison/1765/

From: Scott Mansfield <[email-masked]>
To: [email-masked]
Cc: Deterministic Networking Discussion List <[email-masked]>,Lou Berger <[email-masked]>,Scott Mansfield <[email-masked]>,John Scudder <[email-masked]>,Martin Vigoureux <[email-masked]>,Alvaro Retana <[email-masked]>,János Farkas <[email-masked]>
Response Contacts: Lou Berger <[email-masked]>,János Farkas <[email-masked]>
Technical Contacts: 
Purpose: For information

Referenced liaison: LS on Work items related to deterministic communication in ITU-T SG13 (https://datatracker.ietf.org/liaison/1753/)

Body: Dear Colleagues,

 The Internet Engineering Task Force (IETF) Deterministic Networking (DetNet) Working Group (WG) appreciates your liaison statement informing us about your work. We would like to take the opportunity to inform you about our work and share some of our observations on the work referenced in your Liaison https://datatracker.ietf.org/liaison/1753/.

 For those not familiar with the IETF DetNet WG, a description of its charter cand be found at https://datatracker.ietf.org/wg/detnet/about/. The WG defines technology for Internet Protocol (IP) and Multiprotocol Label Switching (MPLS) networks to achieve bounded latency, including upper and lower bound, i.e., bounded packet delay variation (sometimes referred to as jitter), bounded loss, and high availability/reliability. The DetNet WG collaborates with the IEEE 802.1 Time-Sensitive Networking (TSN) Task Group (TG) to define a common architecture for both Layer 2 and Layer 3.

 As a Layer 3 routed technology, one of the benefits of DetNet is that it provides desired deterministic characteristics at a larger scale than TSN. We would also like to point out that the way of working in the WG is evolutionary, from addressing more tractable problems towards more complex problems. We would like to inform you that the first phase of DetNet standards is mature, the majority have been published, see: https://datatracker.ietf.org/wg/detnet/documents/.  Considering your interest on large scale networks, we note the WG has already begun work on addressing larger scale networks. For example, see https://datatracker.ietf.org/meeting/interim-2021-detnet-01/session/detnet and https://datatracker.ietf.org/meeting/112/session/detnet.

 Upon reading your documents, we think that DetNet has technology solution components for many of the requirements you describe in your documents. However, we note that DetNet work appears to not be reflected  in either ITU-T Y.3113 or the Draft Recommendations attached to your liaison. Draft Recommendation ITU-T Y.IMT2020-jg-lsn references the use of the time-stamping function of RTP, UDP and TCP, implying the use case is IP packets, whereas the statement in this Draft (and ITU-T Y.3113) says, "Routing and upper layer functions lie outside the scope of this Recommendation". It is not clear if this solution is targeted to IP networks. As we have explained above, the DetNet WG is chartered by the IETF to provide bounded latency solutions for IP networks.

 The definition of domain (3.2.2 in ITU-T Y.3113 and ITU-T Y.IMT2020-fa-lg-lsn) cites RFC 8655, "Deterministic Networking Architecture". However, this definition of domain is different than RFC 8655, which focuses on the capabilities of the nodes, not their administrator. The definition of "large scale" in the provided documents is  "16 or more relay nodes". It is not clear where the number 16 is derived as a definition of a large-scale network. Please note that the DetNet WG defined solutions have no specific node count limitations and are support networks with more than 16 hops.

 We note that ITU-T Y.IMT2020-jg-lsn relies on a solution published in a Journal, and timestamping each packet of data flows. We suggest consulting IETF experts in the Timing over IP Connection and Transfer of Clock (tictoc) WG. We also note other relevant work in ITU-T SG15/Q13, IEEE 1588, IEEE 802.3, and IEEE 802.1.

As the IETF's Liaison statement to ITU-T-TSAG (https://datatracker.ietf.org/liaison/1677/) expressed, if the intent of this work covers IETF technologies, requirements or proposals, it is requested for solution work to be discussed in IETF before any work in other SDOs. The success of standardization efforts is dependent on collaboration among the SDOs, as opposed to duplication of efforts and multiple diverging solutions, which will not benefit the industry.

 The DetNet WG is interested in addressing the needs of the industry. If there are specific questions about DetNet or certain aspects that you consider as gaps to meet your requirements, we encourage your participants to bring those questions and discussion points directly to the DetNet WG. We are also always open to organize meetings for discussions about DetNet. We look forward to seeing DetNet being adopted by your members to support your specifications and we welcome all interested parties to join our efforts.
Attachments:

No document has been attached

---

From: "TSB SG13 Secretariat, ITU" <[email-masked]>
Date: Wed, 24 Nov 2021 11:57:23 +0000

Dear Scott,

Thanks for your email.

We acknowledge receipt of the liaison and it will be considered at the upcoming meeting.

Best,
Shaba

-----Original Message-----
From: Liaison Statement Management Tool <[email-masked]> 
Sent: mardi, 23 novembre 2021 23:24
To: TSB SG13 Secretariat, ITU <[email-masked]>
Cc: János Farkas <[email-masked]>; Alvaro Retana <[email-masked]>; Deterministic Networking Discussion List <[email-masked]>; John Scudder <[email-masked]>; Lou Berger <[email-masked]>; Martin Vigoureux <[email-masked]>; Scott Mansfield <[email-masked]>; [email-masked]
Subject: New Liaison Statement, "New liaison to ITU-T SG13"

From: Scott Mansfield <[email-masked]>
To: [email-masked]
Cc: Deterministic Networking Discussion List <[email-masked]>,Lou Berger <[email-masked]>,Scott Mansfield <[email-masked]>,John Scudder <[email-masked]>,Martin Vigoureux <[email-masked]>,Alvaro Retana <[email-masked]>,János Farkas <[email-masked]> Response Contacts: Lou Berger <[email-masked]>,János Farkas <[email-masked]> Technical Contacts: 
Purpose: For information

Body: Dear Colleagues,