Subject: [Detnet] liaison response to ITU-T SG13 LS217

From: Janos Farkas <[email-masked]>
Date: Fri, 12 Nov 2021 14:09:38 +0000

WG,
As we discussed this week, we suggest responding to the liaison we received from ITU-T SG13: https://datatracker.ietf.org/liaison/1753/.
Several of us worked on an initial draft proposal as contributors, see below.
Please review and comment.
Regards,
János and Lou

Dear Colleagues,
The Internet Engineering Task Force (IETF) Deterministic Networking (DetNet) Working Group (WG) appreciates your liaison statement informing us about your work. We would like to take the opportunity to inform you about our work and share some of our observations on the work referenced in your Liaison https://datatracker.ietf.org/liaison/1753/.
For those not familiar with the IETF DetNet WG, a description of its charter cand be found at https://datatracker.ietf.org/wg/detnet/about/. The WG defines technology for Internet Protocol (IP) and Multiprotocol Label Switching (MPLS) networks to achieve bounded latency, including upper and lower bound, i.e., bounded packet delay variation (sometimes referred to as jitter), bounded loss, and high availability/reliability. The DetNet WG collaborates with the IEEE 802.1 Time-Sensitive Networking (TSN) Task Group (TG) to define a common architecture for both Layer 2 and Layer 3.
As a Layer 3 routed technology, one of the benefits of DetNet is that it provides desired deterministic characteristics at a larger scale than TSN. We would also like to point out that the way of working in the WG is evolutionary, from addressing more tractable problems towards more complex problems. We would like to inform you that the first phase of DetNet standards is mature, the majority have been published, see: https://datatracker.ietf.org/wg/detnet/documents/.  Considering your interest on large scale networks, we note the WG has already begun work on addressing larger scale networks. For example, see https://datatracker.ietf.org/meeting/interim-2021-detnet-01/session/detnet and https://datatracker.ietf.org/meeting/112/session/detnet.
We note that DetNet work appears to not be reflected  in either ITU-T Y.3113 or the Draft Recommendations attached to your liaison. Draft Recommendation ITU-T Y.IMT2020-jg-lsn references the use of the time-stamping function of RTP, UDP and TCP, implying the use case is IP packets, whereas the statement in this Draft (and ITU-T Y.3113) says, "Routing and upper layer functions lie outside the scope of this Recommendation". It is not clear if this solution is targeted to IP networks. As we have explained above, the DetNet WG is chartered by the IETF to provide bounded latency solutions for IP networks.
The definition of domain (3.2.2 in ITU-T Y.3113 and ITU-T Y.IMT2020-fa-lg-lsn) cites RFC 8655, "Deterministic Networking Architecture". However, this definition of domain is different than RFC 8655, which focuses on the capabilities of the nodes, not their administrator. The definition of "large scale" in the provided documents is  "16 or more relay nodes". It is not clear where the number 16 is derived as a definition of a large-scale network. Please note that the DetNet WG defined solutions have no specific node count limitations and are support networks with more than 16 hops.
We note that ITU-T Y.IMT2020-jg-lsn relies on a solution published in a Journal, and timestamping each packet of data flows. We suggest consulting IETF experts in the Timing over IP Connection and Transfer of Clock (tictoc) WG. We also note other relevant work in ITU-T SG15/Q13, IEEE 1588, IEEE 802.3, and IEEE 802.1.
As the IETF's Liaison statement to ITU-T-TSAG (https://datatracker.ietf.org/liaison/1677/) expressed, if the intent of this work covers IETF technologies, requirements or proposals, it is requested for solution work to be discussed in IETF before any work in other SDOs. The success of standardization efforts is dependent on collaboration among the SDOs, as opposed to duplication of efforts and multiple diverging solutions, which will not benefit the industry. We welcome all interested parties to join our efforts.

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 13 Nov 2021 04:08:16 +0100

Janos:

Thanks a lot for the writeup.

I find this liaison exchange standalone cumbersome
and most likely not very useful by by itself. You found
a couple of technical points and gave them a few more pointers,
but will that affect anything on their side ? (btw.: i don't
have access to Y.3113, so i can't judge what you wrote, but
i am sure its correct)

Maybe a bit tongue in cheek, but fundamentally honest:

" Thank you for your liaison. Upon reading your documents, we
  think that DetNet has technology solution compoments for
  many of the requirements you describe in your documents.
  We look forward to see DetNet being adopted by your members
  with the help of your specifications.
  
  If there more specific questions about DetNet and/or
  gaps you identify in it to meet your requirements, we encourage
  your participants to bring those questions and discussion points
  directly to the DetNet WG. We are also always open to look into
  organizing workshops for a more structured ToI and/or discussion
  about DetNet. "
  
In other words: why not market/explain DetNet to them and/or have them tell
us what we're missing. For example upon scanning their
documents i saw them discussing an aggregation function/component,
which Pascal also is interested in. So it might be useful for
more DetNet folks to identify if anything theyve written can serve
as additiona evidence for gaps we have.

And wrt to Toi: Last time we had good overview
of DetNet was in Bangalore (joint meeting with TSN), so not a bad time to think having
a similar event again.

And doing it virtually might actually reach
more people than in-person, especially when we do it on IETF
webex and make it easy to attend. As i said, there is likely a
larger research community out there working on TSN that we might
attract as well if we spend a bit of time upfront to market
the event to researchers and are careful with the timing so
its useful for such type of attendees.

Cheers
    Toerless

> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

-- 
---
[email-masked]

---

From: Janos Farkas <[email-masked]>
Date: Mon, 15 Nov 2021 22:44:20 +0000

Hi Toerless,

Thank you for the suggestions!
I've incorporated them in the updated version below, please see the 4th and the last paragraphs. 

I've downloaded Y3113 from: https://www.itu.int/rec/T-REC-Y.3113-202102-I.

I understand the not to be lost too much in details approach. However, I think it is good to point to a couple of specifics.

Cheers,
Janos

-------------------------------------
Dear Colleagues,

Upon reading your documents, we think that DetNet has technology solution components for many of the requirements you describe in your documents. However, we note that DetNet work appears to not be reflected  in either ITU-T Y.3113 or the Draft Recommendations attached to your liaison. Draft Recommendation ITU-T Y.IMT2020-jg-lsn references the use of the time-stamping function of RTP, UDP and TCP, implying the use case is IP packets, whereas the statement in this Draft (and ITU-T Y.3113) says, "Routing and upper layer functions lie outside the scope of this Recommendation". It is not clear if this solution is targeted to IP networks. As we have explained above, the DetNet WG is chartered by the IETF to provide bounded latency solutions for IP networks.

We note that ITU-T Y.IMT2020-jg-lsn relies on a solution published in a Journal, and timestamping each packet of data flows. We suggest consulting IETF experts in the Timing over IP Connection and Transfer of Clock (tictoc) WG. We also note other relevant work in ITU-T SG15/Q13, IEEE 1588, IEEE 802.3, and IEEE 802.1.
As the IETF's Liaison statement to ITU-T-TSAG (https://datatracker.ietf.org/liaison/1677/) expressed, if the intent of this work covers IETF technologies, requirements or proposals, it is requested for solution work to be discussed in IETF before any work in other SDOs. The success of standardization efforts is dependent on collaboration among the SDOs, as opposed to duplication of efforts and multiple diverging solutions, which will not benefit the industry. 

The DetNet WG is interested in addressing the needs of the industry. If there are specific questions about DetNet or certain aspects that you consider as gaps to meet your requirements, we encourage your participants to bring those questions and discussion points directly to the DetNet WG. We are also always open to organize meetings for discussions about DetNet. We look forward to seeing DetNet being adopted by your members to support your specifications and we welcome all interested parties to join our efforts.

-----Original Message-----
From: Toerless Eckert <[email-masked]> 
Sent: Saturday, November 13, 2021 4:08 AM
To: Janos Farkas <[email-masked]>
Cc: DetNet WG <[email-masked]>
Subject: Re: [Detnet] liaison response to ITU-T SG13 LS217

Janos:

I find this liaison exchange standalone cumbersome and most likely not very useful by by itself. You found a couple of technical points and gave them a few more pointers, but will that affect anything on their side ? (btw.: i don't have access to Y.3113, so i can't judge what you wrote, but i am sure its correct)

  
  
In other words: why not market/explain DetNet to them and/or have them tell us what we're missing. For example upon scanning their documents i saw them discussing an aggregation function/component, which Pascal also is interested in. So it might be useful for more DetNet folks to identify if anything theyve written can serve as additiona evidence for gaps we have.

And wrt to Toi: Last time we had good overview of DetNet was in Bangalore (joint meeting with TSN), so not a bad time to think having a similar event again.

And doing it virtually might actually reach more people than in-person, especially when we do it on IETF webex and make it easy to attend. As i said, there is likely a larger research community out there working on TSN that we might attract as well if we spend a bit of time upfront to market the event to researchers and are careful with the timing so its useful for such type of attendees.

Cheers
    Toerless

--
---
[email-masked]

---

From: Janos Farkas <[email-masked]>
Date: Thu, 18 Nov 2021 10:16:58 +0000

Hi,

I think the latest version below is good to be sent.
Please let us know if you have further comments or any objections.
If no objections on the list until November 22, then we will send the liaison response (so that they receive it in time for their upcoming plenary).

Regards,
Janos

-----Original Message-----
From: detnet <[email-masked]> On Behalf Of Janos Farkas
Sent: Monday, November 15, 2021 11:44 PM
To: Toerless Eckert <[email-masked]>; DetNet WG <[email-masked]>
Subject: Re: [Detnet] liaison response to ITU-T SG13 LS217

Hi Toerless,

Cheers,
Janos

-----Original Message-----
From: Toerless Eckert <[email-masked]> 
Sent: Saturday, November 13, 2021 4:08 AM
To: Janos Farkas <[email-masked]>
Cc: DetNet WG <[email-masked]>
Subject: Re: [Detnet] liaison response to ITU-T SG13 LS217

Janos:

  

Cheers
    Toerless

--
---
[email-masked]

---

From: Janos Farkas <[email-masked]>
Date: Tue, 23 Nov 2021 12:25:20 +0000

Hi,

We have not received any further comments. We are moving on and sending the latest version copied here.

Regards,
Janos

-----Original Message-----
From: detnet <[email-masked]> On Behalf Of Janos Farkas
Sent: Thursday, November 18, 2021 11:17 AM
To: DetNet WG <[email-masked]>
Cc: [email-masked]; Scott Mansfield <[email-masked]>
Subject: Re: [Detnet] liaison response to ITU-T SG13 LS217

Hi,

Regards,
Janos

-----Original Message-----
From: detnet <[email-masked]> On Behalf Of Janos Farkas
Sent: Monday, November 15, 2021 11:44 PM
To: Toerless Eckert <[email-masked]>; DetNet WG <[email-masked]>
Subject: Re: [Detnet] liaison response to ITU-T SG13 LS217

Hi Toerless,

Cheers,
Janos

-----Original Message-----
From: Toerless Eckert <[email-masked]> 
Sent: Saturday, November 13, 2021 4:08 AM
To: Janos Farkas <[email-masked]>
Cc: DetNet WG <[email-masked]>
Subject: Re: [Detnet] liaison response to ITU-T SG13 LS217

Janos:

  

Cheers
    Toerless

--
---
[email-masked]