Subject: Re: [Detnet] PREOF signaling

From: <[email-masked]>
Date: Tue, 15 Feb 2022 16:53:13 +0800 (CST)

Hi Pascal,

Thanks for your work!
I suggest the consensus about the IPv6 HBH extensions need be corresponded with 6MAN WG.
In my opinion, your draft could be discussed from two seperate parts including DetNet Redundancy Information Option and DetNet Path Options.
For DetNet Redundancy Information Option, it solves the same issue with draft-varga-detnet-ip-preof. Use cases and detailed procedures could be provided especially for the extended parameters. 
For DetNet Path Options, it is inspired to propose the path-oriented forwarding for DetNet, but other than Path-ID carried in packets, we need more detailed mechanisms.
I am not sure if I understand it right or no, I suggest to divide the draft into two drafts discussing the Redundancy and Path separately.

Best Regards,
Quan

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 17 Feb 2022 10:59:41 +0000

Hello Quan

We chatted between authors and though we agree that there are 2 parts, we believe that it is premature to split. 

This might be done in the WG process of the draft if/when the WG approves the work. Effectively DetNet has a history of splitting documents, and we think the group needs to decide what remains and how to structure it. 
At the moment, what we mostly we want is the adoption of the broad idea to define a DetNet native IPv6 signaling.

Agreed for the use cases and detailed procedures. Then again, we have ample time to do that with more brains on it as a WG effort vs. the limited author set.

Keep safe;

Pascal

> -----Original Message-----
> From: [email-masked] <[email-masked]>
> Sent: mardi 15 février 2022 9:53
> To: Pascal Thubert (pthubert) <[email-masked]>
> Cc: [email-masked]
> Subject: Re:[Detnet] PREOF signaling
> 
> Hi Pascal,
> 
> Thanks for your work!
> In my opinion, your draft could be discussed from two seperate parts
> including DetNet Redundancy Information Option and DetNet Path Options.
> For DetNet Redundancy Information Option, it solves the same issue with
> draft-varga-detnet-ip-preof. Use cases and detailed procedures could be
> provided especially for the extended parameters.
> For DetNet Path Options, it is inspired to propose the path-oriented
> forwarding for DetNet, but other than Path-ID carried in packets, we need
> more detailed mechanisms.
> I am not sure if I understand it right or no, I suggest to divide the
> draft into two drafts discussing the Redundancy and Path separately.
> 
> Best Regards,
> Quan