Subject: [dhcwg] doubt regarding DHCPREQUEST

From: "venkat devarajan" <[email-masked]>
Date: Tue, 09 Oct 2001 17:24:07 +0530

Hi ,
I am Venkat working in Sun Microsystems.
I have a doubt regarding the DHCPREQUEST message broadcast.

Doubt:
Why is a DHCPREQUEST for Address Reuse or an lease time extension broadcast 
to all other servers ? could it not be sent to that dhcp server alone that 
provided the client with the ip adrress ?

Regards,
Venkat

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

_______________________________________________
dhcwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Tue, 09 Oct 2001 13:11:59 -0400

The first DHCPREQUEST, sent at T1, is unicast to the server that provided 
the IP address to the client.  If the client doesn't hear from that server 
by time T2, the client broadcasts its DHCPREQUEST to find any available server.

- Ralph Droms

At 05:24 PM 10/9/2001 +0530, venkat devarajan wrote:
>Why is a DHCPREQUEST for Address Reuse or an lease time extension 
>broadcast to all other servers ? could it not be sent to that dhcp server 
>alone that provided the client with the ip adrress ?
>
>Regards,
>Venkat
>