Subject: RE: [dhcwg] doubt regarding DHCPREQUEST

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Tue, 9 Oct 2001 08:36:04 -0500

The client may well not have an address of sufficient scope it can use to communicate with the server.

If the server and client are on the same link, then sure the link local address could be used (and in this case the server could send the client the unicast option in the Advertise).

However, if the server is off-link, then the client can't communicate with the server directly. Also, if you have multiple relays, won't it be useful to be able to use the one that is up in case one fails?

Also, remember that IPv6 uses a lot of multicasting (no broadcasting) and hence only those systems that are playing a DHCP role will receive these packets. So, the cost of multicasting them is not very high.

- Bernie Volz

-----Original Message-----
From: venkat devarajan [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 7:54 AM
To: [email-masked]
Subject: [dhcwg] doubt regarding DHCPREQUEST

Hi ,
I am Venkat working in Sun Microsystems.
I have a doubt regarding the DHCPREQUEST message broadcast.

Doubt:
Why is a DHCPREQUEST for Address Reuse or an lease time extension broadcast 
to all other servers ? could it not be sent to that dhcp server alone that 
provided the client with the ip adrress ?

Regards,
Venkat

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

_______________________________________________
dhcwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "venkat devarajan" <[email-masked]>
Date: Tue, 09 Oct 2001 21:52:50 +0530

Hi
does the client not know the server's IpAddress when getting a DHCPACK   
/DHCPOFFER ? i am referring to the 'siaddr' field in the dhcp packet 
structure .
Regrads,
Venkat

>From: "Bernie Volz (EUD)" <[email-masked]>
>To: "'venkat devarajan'" <[email-masked]>, [email-masked]
>Subject: RE: [dhcwg] doubt regarding DHCPREQUEST
>Date: Tue, 9 Oct 2001 08:36:04 -0500
>
>If the server and client are on the same link, then sure the link local 
>address could be used (and in this case the server could send the client 
>the unicast option in the Advertise).
>
>However, if the server is off-link, then the client can't communicate with 
>the server directly. Also, if you have multiple relays, won't it be useful 
>to be able to use the one that is up in case one fails?
>
>Also, remember that IPv6 uses a lot of multicasting (no broadcasting) and 
>hence only those systems that are playing a DHCP role will receive these 
>packets. So, the cost of multicasting them is not very high.
>
>- Bernie Volz
>

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Tue, 9 Oct 2001 11:50:32 -0500

Actually, I had DHCPv6 on my brain when I responded. You're asking about DHCP for IPv4.

When a client doesn't yet have a lease on the address, it must broadcast since it has no valid source address. Also, the broadcast serves to indicate to other servers that they were not selected by the client and can 'release' the address that they temporarily allocated and offered to the client.

When a client has an address, the specification says it is unicast (RFC 2131):

  o DHCPREQUEST generated during RENEWING state:

      'server identifier' MUST NOT be filled in, 'requested IP address'
      option MUST NOT be filled in, 'ciaddr' MUST be filled in with
      client's IP address. In this situation, the client is completely
      configured, and is trying to extend its lease. This message will
      be unicast, so no relay agents will be involved in its
      transmission.  Because 'giaddr' is therefore not filled in, the
      DHCP server will trust the value in 'ciaddr', and use it when
      replying to the client.

"This message will be unicast".

- Bernie

-----Original Message-----
From: venkat devarajan [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 12:23 PM
To: [email-masked]
Subject: RE: [dhcwg] doubt regarding DHCPREQUEST

Hi

---

From: "Mark Llacuna" <[email-masked]>
Date: Fri, 12 Oct 2001 08:08:28 -0700

:-----Original Message-----
:From: Bernie Volz (EUD) [mailto:[email-masked]]
:Sent: Tuesday, October 09, 2001 9:51 AM
:To: 'venkat devarajan'; [email-masked]
:Subject: RE: [dhcwg] doubt regarding DHCPREQUEST

:Actually, I had DHCPv6 on my brain when I responded. You're asking about
DHCP for IPv4. 
:When a client doesn't yet have a lease on the address, it must broadcast
since it has no valid source address. Also, the :broadcast serves to
indicate to other servers that they were not selected by the client and can
'release' the address that they :temporarily allocated and offered to the
client.
:When a client has an address, the specification says it is unicast (RFC
2131): 
:  o DHCPREQUEST generated during RENEWING state: 
:      'server identifier' MUST NOT be filled in, 'requested IP address' 
:      option MUST NOT be filled in, 'ciaddr' MUST be filled in with 
:      client's IP address. In this situation, the client is completely 
:      configured, and is trying to extend its lease. This message will 
:      be unicast, so no relay agents will be involved in its 
:      transmission.  Because 'giaddr' is therefore not filled in, the 
:      DHCP server will trust the value in 'ciaddr', and use it when 
:      replying to the client. 
:"This message will be unicast". 

My understanding is that this is the general behavior of a DHCP client.
There are, however, special client implementations (proxy clients) that
unicast lease renewals to a relay agent and not directly to the DHCP
server.

Also, I don't think RFC 2131 makes it an absolute requirement that
lease renewals (before T2) have to be unicast directly to the server.
Therefore, servers should also accommodate lease renewals with the
'giaddr' filled in and respond accordingly, that is, back to the relay
agent.

I remember there was a thread about this issue a long time ago, but
the link I had to that thread no longer exists or may have been already
moved.

Mark

:- Bernie 
:-----Original Message----- 
:From: venkat devarajan [mailto:[email-masked]] 
:Sent: Tuesday, October 09, 2001 12:23 PM 
:To: [email-masked] 
:Subject: RE: [dhcwg] doubt regarding DHCPREQUEST 
:
:
:Hi 
:does the client not know the server's IpAddress when getting a DHCPACK   
:/DHCPOFFER ? i am referring to the 'siaddr' field in the dhcp packet 
:structure . 
:Regrads, 
:Venkat 
:>From: "Bernie Volz (EUD)" <[email-masked]> 
:>To: "'venkat devarajan'" <[email-masked]>, [email-masked] 
:>Subject: RE: [dhcwg] doubt regarding DHCPREQUEST 
:>Date: Tue, 9 Oct 2001 08:36:04 -0500 
:> 
:>The client may well not have an address of sufficient scope it can use to 
:>communicate with the server. 
:> 
:>If the server and client are on the same link, then sure the link local 
:>address could be used (and in this case the server could send the client 
:>the unicast option in the Advertise). 
:> 
:>However, if the server is off-link, then the client can't communicate with

:>the server directly. Also, if you have multiple relays, won't it be useful

:>to be able to use the one that is up in case one fails? 
:> 
:>Also, remember that IPv6 uses a lot of multicasting (no broadcasting) and 
:>hence only those systems that are playing a DHCP role will receive these 
:>packets. So, the cost of multicasting them is not very high. 
:> 
:>- Bernie Volz 
:> 
:>-----Original Message----- 
:>From: venkat devarajan [mailto:[email-masked]] 
:>Sent: Tuesday, October 09, 2001 7:54 AM 
:>To: [email-masked] 
:>Subject: [dhcwg] doubt regarding DHCPREQUEST 
:> 
:> 
:>Hi , 
:>I am Venkat working in Sun Microsystems. 
:>I have a doubt regarding the DHCPREQUEST message broadcast. 
:> 
:>Doubt: 
:>Why is a DHCPREQUEST for Address Reuse or an lease time extension
broadcast 
:>to all other servers ? could it not be sent to that dhcp server alone that

:>provided the client with the ip adrress ? 
:> 
:>Regards, 
:>Venkat 
:> 
:>_________________________________________________________________ 
:>Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

:> 
:> 
:>_______________________________________________ 
:>dhcwg mailing list 
:>[email-masked] 
:>http://www1.ietf.org/mailman/listinfo/dhcwg 
:
:
:_________________________________________________________________ 
:Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp 
:
:
:_______________________________________________ 
:dhcwg mailing list 
:[email-masked] 
:http://www1.ietf.org/mailman/listinfo/dhcwg