Subject: Re: [dhcwg] Query on DHCP client with multiple host

From: "Bhaskar S" <[email-masked]>
Date: Thu, 5 Sep 2002 10:59:18 -0700

Hi Ryan,

Thanks for the info.

I would like to seek more clarification on using DHCP along with VLAN. Here
I mean to say that I have to use DHCP to allocate IP addresses to each of
the VLAN interfaces, assuming that DHCP server is connected to one of the
VLAN interfaces. Is this possible?

It seemed difficult to me because the DHCP requesting IP address for an
interface would be sent only on that interface?

Thanks in advance.

Regards,
Bhaskar S.

Regardomg
----- Original Message -----
From: "Ryan Scripps"
To: "Bhaskar S"
Sent: Thursday, September 05, 2002 8:33 AM
Subject: Re: [dhcwg] Query on DHCP client with multiple host

> My interpretation is that a DISCOVER must be sent from
> each interface since they could each be on a different
> network.
>
> VLANs do not alter the functionality of DHCP.  You
> must ensure that each VLAN has a DHCP server or relay
> agent in it somewhere, however.  Clients on one VLAN
> typically must route to another VLAN, therefore DHCP
> DISCOVERs will not be carried across VLANs.  Your
> switches may allow a single port to trunk VLANs to a
> single host which could have interfaces for all
> available VLANs.
>
> Best of luck,
> Ryan Scripps
>
> --- Bhaskar S wrote:
> > Hi,
> >
> > The DHCP RFC says:
> >
> > "A client with multiple network interfaces must use
> > DHCP through each
> > interface independently to obtain configuration
> > information parameters for
> > these seperate interfaces."
> >
> > Does the above statement mean that DISCOVER message
> > for getting IP
> > address for a particular interface should be sent
> > only on that interface or
> > does it mean that the DISCOVER message has to be
> > sent on each of
> > the interfaces available on the node ?
> >
> > Also I would like links which would give how to
> > configure DHCP in a VLAN
> > environment.
> >
> > Thanks in advance.
> >
> > Regards,
> > Bhaskar S.
> >
> >
>
>
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Finance - Get real-time stock quotes
> http://finance.yahoo.com

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ryan Scripps <[email-masked]>
Date: Mon, 9 Sep 2002 11:33:09 -0700 (PDT)

(This is probably beginning to go outside the scope of
this discussion group, but...)

The details of a VLAN configuration can differ by
vendor.  Simply stated, each VLAN will need to have a
either a DHCP server of DHCP relay on it.  I am most
familiar with Cisco stuff and have typically seen a
router card added to a switch chassis. This router
card has &#34;interfaces&#34; (all in software) for
each network and can act as router between VLANs and
also as a DHCP relay (Cisco calls it a &#34;helper
address&#34;).  A DHCP broadcast will not be carried
across VLANs in any implementation of VLANs that I
have seen.

I have heard of some (presumably very complex)
implementations where switch ports are shunted to a
default VLAN with a DHCP server on it.  When the DHCP
server assigns an address, the DHCP server kicks off a
script file which dynamically reconfigures the
client's switch port with the correct VLAN assignment.

Good luck,
Ryan Scripps

--- Bhaskar S &lt;[email-masked]&gt; wrote:
&gt; Hi Ryan,
&gt; 
&gt; Thanks for the info.
&gt; 
&gt; I would like to seek more clarification on using
&gt; DHCP along with VLAN. Here
&gt; I mean to say that I have to use DHCP to allocate
IP
&gt; addresses to each of
&gt; the VLAN interfaces, assuming that DHCP server is
&gt; connected to one of the
&gt; VLAN interfaces. Is this possible?
&gt; 
&gt; It seemed difficult to me because the DHCP
&gt; requesting IP address for an
&gt; interface would be sent only on that interface?
&gt; 
&gt; Thanks in advance.
&gt; 
&gt; Regards,
&gt; Bhaskar S.
&gt; 
&gt; Regardomg
&gt; ----- Original Message -----
&gt; From: &#34;Ryan Scripps&#34;
&gt; To: &#34;Bhaskar S&#34;
&gt; Sent: Thursday, September 05, 2002 8:33 AM
&gt; Subject: Re: [dhcwg] Query on DHCP client with
&gt; multiple host
&gt; 
&gt; 
&gt; &gt; My interpretation is that a DISCOVER must be
sent
&gt; from
&gt; &gt; each interface since they could each be on a
&gt; different
&gt; &gt; network.
&gt; &gt;
&gt; &gt; VLANs do not alter the functionality of
DHCP.  You
&gt; &gt; must ensure that each VLAN has a DHCP server
or
&gt; relay
&gt; &gt; agent in it somewhere, however.  Clients on
one
&gt; VLAN
&gt; &gt; typically must route to another VLAN,
therefore
&gt; DHCP
&gt; &gt; DISCOVERs will not be carried across VLANs. 
Your
&gt; &gt; switches may allow a single port to trunk
VLANs to
&gt; a
&gt; &gt; single host which could have interfaces for
all
&gt; &gt; available VLANs.
&gt; &gt;
&gt; &gt; Best of luck,
&gt; &gt; Ryan Scripps
&gt; &gt;
&gt; &gt; --- Bhaskar S wrote:
&gt; &gt; &gt; Hi,
&gt; &gt; &gt;
&gt; &gt; &gt; The DHCP RFC says:
&gt; &gt; &gt;
&gt; &gt; &gt; &#34;A client with multiple network
interfaces must
&gt; use
&gt; &gt; &gt; DHCP through each
&gt; &gt; &gt; interface independently to obtain
configuration
&gt; &gt; &gt; information parameters for
&gt; &gt; &gt; these seperate interfaces.&#34;
&gt; &gt; &gt;
&gt; &gt; &gt; Does the above statement mean that
DISCOVER
&gt; message
&gt; &gt; &gt; for getting IP
&gt; &gt; &gt; address for a particular interface
should be
&gt; sent
&gt; &gt; &gt; only on that interface or
&gt; &gt; &gt; does it mean that the DISCOVER message
has to be
&gt; &gt; &gt; sent on each of
&gt; &gt; &gt; the interfaces available on the node ?
&gt; &gt; &gt;
&gt; &gt; &gt; Also I would like links which would
give how to
&gt; &gt; &gt; configure DHCP in a VLAN
&gt; &gt; &gt; environment.
&gt; &gt; &gt;
&gt; &gt; &gt; Thanks in advance.
&gt; &gt; &gt;
&gt; &gt; &gt; Regards,
&gt; &gt; &gt; Bhaskar S.
&gt; &gt; &gt;
&gt; &gt; &gt;
&gt; &gt;
&gt; &gt;
&gt; &gt;
__________________________________________________
&gt; &gt; Do You Yahoo!?
&gt; &gt; Yahoo! Finance - Get real-time stock quotes
&gt; &gt; http://finance.yahoo.com
&gt; 
&gt; _______________________________________________
&gt; dhcwg mailing list
&gt; [email-masked]
&gt; https://www1.ietf.org/mailman/listinfo/dhcwg