Subject: Re: [Dhcpv6bis] Welcome to the "Dhcpv6bis" mailing list

From: Michael Richardson <[email-masked]>
Date: Mon, 25 Nov 2013 16:51:05 -0500

Hi, thanks for adding me.

A github was also discussed?

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: Andrew Yourtchenko <[email-masked]>
Date: Tue, 26 Nov 2013 00:02:21 +0100 (CET)

> A github was also discussed?

+1 for github - it's then very easy to work with the changes.

--a

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 25 Nov 2013 23:55:21 +0000

Did you get my "hello" email to the list that mentioned the github? 

- Bernie (from iPad)

> On Nov 25, 2013, at 6:02 PM, "Andrew Yourtchenko (ayourtch)" <[email-masked]> wrote:
> 
> 
> 
> _______________________________________________
> Dhcpv6bis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcpv6bis

---

From: Michael Richardson <[email-masked]>
Date: Mon, 25 Nov 2013 21:01:44 -0500

> Did you get my "hello" email to the list that mentioned the github?

No, I don't think I did, I think maybe I was added after, or maybe I didn't
confirm in time.  I guess the list is archived.

Aha: http://www.ietf.org/mail-archive/web/dhcpv6bis/current/msg00000.html

My github is https://github.com/mcr314.

https://github.com/dhcwg/rfc3315bis

---

From: Marcin Siodelski <[email-masked]>
Date: Tue, 26 Nov 2013 07:27:41 +0100

Bernie,

Thanks for adding me. Here is my github: https://github.com/msiodelski

Marcin

---

From: Andrew Yourtchenko <[email-masked]>
Date: Tue, 26 Nov 2013 10:38:41 +0100 (CET)

After looking for it, indeed it was there but in the far corner tucked by 
my mailer. Fixed now. Thanks a lot!

I'm https://github.com/ayourtch/

--a

---

From: Michael Richardson <[email-masked]>
Date: Wed, 27 Nov 2013 12:44:49 -0500

Hi.
I forked the git repo, since I don't have push permissions yet.

I loaded the file into xxe and saved it under the new name rfc3315bis.xml.
I added a Makefile that I have kicking around. It runs xml2rfc.
Can we agree to use the newer python based one rather than the tcl one?

To make xxe happy, added rfc2929.dtd to the directory.  If we need
additional references which are not available, they could go into "src"
subdir. (xml2rfc 2.x also caches things nicely, you can work offline)

I've pushed it to my forked copy, and issued a pull.

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 27 Nov 2013 18:38:32 +0000

We may have to wait for Tomek to return from vacation to add the permissions. (So next week.)

I thought he sent me something about this, but I haven't found that email and haven't found anything to set permissions in the github.

Personally, I always use the online xml2rfc (xml.resource.org) rather than installing anything - so much less maintenance work. So, whatever it uses is what I would recommend using. I'm not sure what Tomek used to generate the .txt from the .xml.

Tomek also indicated that there are still things that need to be done (such as cleaning up the references to use the dtd). Note that before test changes occur, we should basically have .txt versions of the rfcs that matches the 'real' ones (excepting minor formatting differences). I did a compare using the tools.ietf.org diff and Tomek has gotten very close (though I haven't studied it in detail).

I don't think Tomek has done anything for RFC 3633 yet (and that may less critical to get 'exact').

We should have a discussion sometime next week(?) once Tomek is back to figure out the next set of goals (with dates and assignments). I will discuss with Tomek on Monday and can set up a WebEx for us.

Please let me know what time zone you're generally in so I can try to pick a reasonable time:

Tomek		- UT + 1h
Bernie		- UT - 5h (US EST)

I'll add a page to the github to track this once I get a bunch of responses.

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Michael Richardson
Sent: Wednesday, November 27, 2013 12:45 PM
To: [email-masked]
Subject: Re: [Dhcpv6bis] Welcome to the "Dhcpv6bis" mailing list

Hi.

To make xxe happy, added rfc2929.dtd to the directory.  If we need additional references which are not available, they could go into "src"
subdir. (xml2rfc 2.x also caches things nicely, you can work offline)

---

From: [email-masked]
Date: Wed, 27 Nov 2013 20:05:50 -0500

Bernie Volz (volz) <[email-masked]> wrote:
    > Personally, I always use the online xml2rfc (xml.resource.org) rather
    > than installing anything - so much less maintenance work. So, whatever
    > it uses is what I would recommend using. I'm not sure what Tomek used
    > to generate the .txt from the .xml.

I don't know what it uses, but I'll check...
http://xml.resource.org/cgi-bin/xml2rfc-version
says version 2.4.3.

    > Tomek also indicated that there are still things that need to be done
    > (such as cleaning up the references to use the dtd). Note that before
    > test changes occur, we should basically have .txt versions of the rfcs
    > that matches the 'real' ones (excepting minor formatting
    > differences). I did a compare using the tools.ietf.org diff and Tomek
    > has gotten very close (though I haven't studied it in detail).

I agree with getting it right.
I made a number of changes to bring it closer.  The figure changes are
important, otherwise, the tool has the right to word wrap the ascii art.

    > We should have a discussion sometime next week(?) once Tomek is back to
    > figure out the next set of goals (with dates and assignments). I will
    > discuss with Tomek on Monday and can set up a WebEx for us.

    > Tomek - UT + 1h Bernie - UT - 5h (US EST)

I'm also -5h.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [