Subject: [Dhcpv6bis] Agenda for dhcpv6bis meeting on 2014-01-22

From: Tomek Mrugalski <[email-masked]>
Date: Mon, 20 Jan 2014 19:43:13 +0100

Folks,
Here's an agenda for upcoming Wednesday, Jan 22nd meeting
8:00 EST (14:00 CET, 21:00 CST). Bernie sent out meeting invitation in a
separate mail.

1. Confirm that XML for 3315 is done.
One outstanding issue are the cross-references. Bernie said he'll look
at that. So this is likely to be a very quick item.

2. Confirm that XML for 3633 is done.
Same as above, except we won't need cross-references as the text will
end up being copied over to 3315bis, so its references will need to be
tweaked anyway.

3. Get over the list of RFCs we want to merge.
Tomek will send out a list of candidates. We'll decide for each of them
what to do:
a) reference only
b) copy minimal text (e.g. UUID duid type) and reference the RFC/I-D
c) skip completely

4. Discuss authorship
The problem is with the number of authors. RFC Editor recommends to not
have more than 5 authors
(http://www.rfc-editor.org/policy.html#policy.authlist). This is a soft
limit, so we can go over if needed, but going for full list (6 original
3315 authors + 5 new ones) will likely not be acceptable. Bernie
proposed (and Tomek agrees) to go with the list of DHCPv6bis team
members and thank 3315 authors in acknowledgement section. We will also
want to thank some people that reported errata or issues.

5. Decide on next steps
Proposal:

- go over reported issues in the tracker. Segregate them into:
  a) obvious/easy to do => apply them before merge
  b) widely supported, but harder to do => apply them after merge
  c) contentious => leave them for discussion on DHC WG

- apply/close issues marked as a)
- upload new revision
- merge
- upload new revision
- apply/close issues makred as b)
- request adoption in DHC
- discuss issues from c) group on DHC WG, get consensus on them,
  apply or reject on a per case basis
- WGLC once all issues are closed

6. Go over reported issues in issue tracker and split into groups.

We'll likely to assign owner to each issue. Such owner will be
responsible for dealing with the issue (and lead any discussions that
may emerge).

7. Any other business

It seems that the majority of the time spent on the meeting will be
about going through the issues in issue tracker. Please take a look at
them prior to the meeting, if possible.

Folks, keep in mind that this is very late meeting for Sheng, so please
keep the non-essential stuff to minimum.

Bernie & Tomek

---

From: Tomek Mrugalski <[email-masked]>
Date: Mon, 20 Jan 2014 19:49:15 +0100

Oops,

Forgot about one extra item:

X. Come up with the merge 3633/3315 strategy.
This looks like a too big task for a single person, so we'll probably
try to split this work among two volunteers. Haven't given much thought
about how to do this, but each person being responsible for moving
roughly a half of the 3633 sections seems like a good idea.

Tomek

---

From: Michael Richardson <[email-masked]>
Date: Tue, 21 Jan 2014 13:20:05 -0500

> want to thank some people that reported errata or issues.

Let's establish a subsection clearly for 3315.
Operationally, we need to have at least one name on the official author list
who can easily post new revisions, and I think that right now, that's
Bernie Volz (probably has to update his email tho)

    > c) contentious => leave them for discussion on DHC WG

We are doing this as a group?  shared screen?

    > them prior to the meeting, if possible.

I think that I've missed/forgotten the link to the issue tracker, I find
nothing at:
   http://trac.tools.ietf.org/wg/dhc/trac/report/1

once we post the -00 as a WG document, we'll have a category for isssues, but
where are the issues being kept right now?

Maybe it was in github? Nope.

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 21 Jan 2014 18:23:41 +0000

That email address is a valid one for me. Though I do plan to change it once we update the author information.

Issues are at http://trac.tools.ietf.org/group/dhcpv6bis/report/1.

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Michael Richardson
Sent: Tuesday, January 21, 2014 1:20 PM
To: [email-masked]
Cc: Tomek Mrugalski
Subject: Re: [Dhcpv6bis] Agenda for dhcpv6bis meeting on 2014-01-22

Let's establish a subsection clearly for 3315.
Operationally, we need to have at least one name on the official author list who can easily post new revisions, and I think that right now, that's Bernie Volz (probably has to update his email tho)

    > them prior to the meeting, if possible.

I think that I've missed/forgotten the link to the issue tracker, I find nothing at:
   http://trac.tools.ietf.org/wg/dhc/trac/report/1

once we post the -00 as a WG document, we'll have a category for isssues, but where are the issues being kept right now?

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 22 Jan 2014 14:48:14 +0000

Andrew:

We assigned you to work with Michael on X:

"X. Come up with the merge 3633/3315 strategy.
This looks like a too big task for a single person, so we'll probably try to split this work among two volunteers. Haven't given much thought about how to do this, but each person being responsible for moving roughly a half of the 3633 sections seems like a good idea."

This is to PLAN the merge (what terminology to use, i.e. Requesting Router = DHCPv6 Client for PD) and what will need to be updated in RFC 3315 (new sections to add, sections to update, etc.). Note also that stateful issues draft changes some PD related items so be mindful of this (though those are not yet 'approved').

If you are not comfortable with this, let us know and we can assign someone else.

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
Sent: Monday, January 20, 2014 1:49 PM
To: [email-masked]
Subject: Re: [Dhcpv6bis] Agenda for dhcpv6bis meeting on 2014-01-22

Oops,

X. Come up with the merge 3633/3315 strategy.
This looks like a too big task for a single person, so we'll probably try to split this work among two volunteers. Haven't given much thought about how to do this, but each person being responsible for moving roughly a half of the 3633 sections seems like a good idea.

Tomek

On 20.01.2014 19:43, Tomek Mrugalski wrote:
> 8:00 EST (14:00 CET, 21:00 CST). Bernie sent out meeting invitation in 
> a separate mail.
> 
> Tomek will send out a list of candidates. We'll decide for each of 
> them what to do:
> a) reference only
> The problem is with the number of authors. RFC Editor recommends to 
> not have more than 5 authors 
> (http://www.rfc-editor.org/policy.html#policy.authlist). This is a 
> soft limit, so we can go over if needed, but going for full list (6 
> original
> members and thank 3315 authors in acknowledgement section. We will 
> also want to thank some people that reported errata or issues.
> 
> 5. Decide on next steps
> Proposal:
> 
> Folks, keep in mind that this is very late meeting for Sheng, so 
> please keep the non-essential stuff to minimum.
> 
> Bernie & Tomek
> 

_______________________________________________
Dhcpv6bis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcpv6bis

---

From: "Leaf Yeh" <[email-masked]>
Date: Thu, 23 Jan 2014 09:58:33 +0800

BV > This is to PLAN the merge (what terminology to use, i.e. Requesting
Router = DHCPv6 Client for PD) and what will need to be updated in RFC 3315
(new sections to add, sections to update, etc.). Note also that stateful
issues draft changes some PD related items so be mindful of this (though
those are not yet 'approved').

I could be the additional volunteer to build a new list of terminology for
DHCPv6bis.

Best Regards,
Leaf

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Bernie Volz
(volz)
Sent: Wednesday, January 22, 2014 10:48 PM
To: Andrew Yourtchenko (ayourtch); [email-masked]
Subject: Re: [Dhcpv6bis] Agenda for dhcpv6bis meeting on 2014-01-22

Andrew:

"X. Come up with the merge 3633/3315 strategy.
This looks like a too big task for a single person, so we'll probably try to
split this work among two volunteers. Haven't given much thought about how
to do this, but each person being responsible for moving roughly a half of
the 3633 sections seems like a good idea."

This is to PLAN the merge (what terminology to use, i.e. Requesting Router =
DHCPv6 Client for PD) and what will need to be updated in RFC 3315 (new
sections to add, sections to update, etc.). Note also that stateful issues
draft changes some PD related items so be mindful of this (though those are
not yet 'approved').

If you are not comfortable with this, let us know and we can assign someone
else.

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Tomek
Mrugalski
Sent: Monday, January 20, 2014 1:49 PM
To: [email-masked]
Subject: Re: [Dhcpv6bis] Agenda for dhcpv6bis meeting on 2014-01-22

Oops,

X. Come up with the merge 3633/3315 strategy.
This looks like a too big task for a single person, so we'll probably try to
split this work among two volunteers. Haven't given much thought about how
to do this, but each person being responsible for moving roughly a half of
the 3633 sections seems like a good idea.

Tomek