Subject: [Dhcpv6bis] Agenda for Dallas IETF-92 DHC WG 3315bis session

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 17 Mar 2015 17:24:15 +0000

Hi:

We need to pull together an agenda for this ~60 min slot we have in the DHC WG session regarding the RFC3315bis work.

Does anyone have any suggestions or issues they would like to discuss.

A rough initial outline might be:

-          Current status (adopted by WG, what's been done, what's outstanding)

-          Open Issues (review tickets and decide which ones to discuss - these should be ones with issues)

-          Short term goals (next steps)

-          Overall plan for document (i.e., what are target dates for finishing up work)

For the open issues, please nominate tickets that you feel are worthy of some discussion.

Does anyone volunteer to lead this (either to develop the agenda and/or to lead the presentation/discussion)?

-          Bernie

---

From: Tomek Mrugalski <[email-masked]>
Date: Sun, 22 Mar 2015 11:53:58 -0500

Here's the proposed bis agenda. We'll discuss those issues as part of
the DHC meeting, Thursday 13:00-15:00 in Far East room.

1. 3315bis adoption (ticket to dhcpv6bis or to dhc list?)
2. stateful issues update (IESG approved, tickets unblocked, apply #59,
   #60, #61, #62, #63, #64, #65, #66, #85 now?)
3. (#142) restructure sections 18,19,20. Decided in January to do it.
   Let's talk about how to do it.
4. Tickets review:

C (consensus needed) category:
- #144: clarify unknown option handling
- #131: proper way to tell the client to NOT renew? Set T1 to infinity
  or valid lifetime? How to gently expire a lease (more frequent
  renewals)
- #139: Do we want a list of mandatory options?
- #81: Should protocol options be included in ORO? Need to clarify which
  options are protocol options (also follow-up #18)
- #18: is ORO mandatory?
- #68: prefix length of the assigned address (/64 vs /128)
- #82: Way for clients to request specific lifetime (zeroed
  iaaddr/iaprefix)
- #114: clarify what hint means? (in B category, but it's pretty
  important, especially the prefix hint case)
- #86: DHCPv6 authentication for Inf-Request (clarify with Jinmei, what
  the conflict is about)
- #91: DHCPv6 authentication: Key Consistency (confirm with Jinmei that
  the proposed solution is ok)
- #140: Common working for NoAddrAvail, NoPrefixAvail
- #70: validating IAADDRs

5. If time permits, let's go over B tickets.

Tomek will cover the general overview and tickets #144, #131, #139, #81,
Bernie will take #18, #68, #82, #114 and Marcin will take #86, #91, #140
and #70. Please send the slides to Tomek.

Tickets are available in our issue tracker:
http://tools.ietf.org/group/dhcpv6bis/

Cheers,
Tomek

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sun, 22 Mar 2015 23:26:23 +0000

Tomek:

Here's my proposed slides for my assigned ticket items. Feel free to edit. We can review in the context of all the slides sometime before posting.

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
Sent: Sunday, March 22, 2015 12:54 PM
To: [email-masked]
Subject: [Dhcpv6bis] Updated agenda for Dallas IETF-92 DHC WG 3315bis session

Here's the proposed bis agenda. We'll discuss those issues as part of the DHC meeting, Thursday 13:00-15:00 in Far East room.

1. 3315bis adoption (ticket to dhcpv6bis or to dhc list?) 2. stateful issues update (IESG approved, tickets unblocked, apply #59,
   #60, #61, #62, #63, #64, #65, #66, #85 now?) 3. (#142) restructure sections 18,19,20. Decided in January to do it.
   Let's talk about how to do it.
4. Tickets review:

Tomek will cover the general overview and tickets #144, #131, #139, #81, Bernie will take #18, #68, #82, #114 and Marcin will take #86, #91, #140 and #70. Please send the slides to Tomek.

Cheers,
Tomek

_______________________________________________
Dhcpv6bis mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcpv6bis

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 23 Mar 2015 00:04:34 +0000

Tomek:

Do we want to do a 1.a about where the document stands at present? Perhaps you were planning to use Slide 2 from http://www.ietf.org/proceedings/91/slides/slides-91-dhc-4.pdf? And move ADOPT up?

The sad news is that not that much happened since IETF-91 on the document itself, but now that stateful-issues has advanced, we can being the work of merging 3315/3633/stateful-issues updates and also #142 (restructuring section 18, 19, 20).

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
Sent: Sunday, March 22, 2015 12:54 PM
To: [email-masked]
Subject: [Dhcpv6bis] Updated agenda for Dallas IETF-92 DHC WG 3315bis session

Cheers,
Tomek

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 23 Mar 2015 00:25:14 +0000

FYI - For what did happen in terms of open/closed tickets, report is at http://trac.tools.ietf.org/group/dhcpv6bis/timeline?from=2015-03-22&daysback=120&authors=&ticket=on&update=Update.

Looks like since IETF-91, we closed 15 tickets: #125, #117, #118, #124, #94, #107, #119, #134, #122, #58, #143, #14, #123, #126, #73 (there was also #129, but that was a dummy ticket for the "due date test"). But, we opened 16 new ones (128 - 144).

I guess more happened than I recalled!!

- Bernie

-----Original Message-----
From: Bernie Volz (volz) 
Sent: Sunday, March 22, 2015 8:05 PM
To: 'Tomek Mrugalski'; [email-masked]
Subject: RE: [Dhcpv6bis] Updated agenda for Dallas IETF-92 DHC WG 3315bis session

Tomek:

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
Sent: Sunday, March 22, 2015 12:54 PM
To: [email-masked]
Subject: [Dhcpv6bis] Updated agenda for Dallas IETF-92 DHC WG 3315bis session

Cheers,
Tomek

---

From: Marcin Siodelski <[email-masked]>
Date: Mon, 23 Mar 2015 18:55:04 -0500

I attached slides for ticket #86 and #70. I didn't prepare the slide for 
#91 as I don't see any issue which would require WG consensus on this 
one. Also, Bernie's and Michael's comments suggest that they don't see 
any issue.

I also didn't create the slide for #140 because it is a problem which we 
have already discussed on one of the RFC3315bis team calls and we have 
agreed on the solution. Also, it is not technical problem but rather a 
problem concerning editorship.

I think it would be good to review the slides together before posting.

Marcin